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Facet Modeling 

Using Facet Modeling 

About Facet Modeling 

Facet modeling involves: 

• Importing point sets obtained by scanning the object. 

• Correcting errors in the point set geometry that may have resulted due to the 
limitations of the scanning devices used. 

• Creating a wrap and correcting errors. For example, removing unwanted 
triangles, creating sharp edges, and filling concave areas. 

• Creating a faceted geometry and editing it with a variety of commands to refine 
and perfect the faceted surface. 

Note: To use Facet Modeling, you must have the Pro/SURFACE and 
Reverse_Engineering licenses. 

 

The Facet Modeling Workflow 

A typical facet modeling session would progress in this fashion: 

• Point handling 

o Import the point set using Insert > Facet Feature and importing a .pts, 
.acs, .vtx, or .ibl file 

o Eliminate erroneous data such as points lying outside the required 
geometry 

o Add additional point sets into the same feature 

o Delete points if required 

o Minimize noise 

o Sample points to clean data and also reduce the computation time 

o Create a wrap from the point set 

• Wrap handling 

o Remove triangles by propagating through the surface in a selected area or 
until the point density changes 

o Remove webs that are generated in open spaces in the model while 
creating a wrap from a point set 

o Remove triangles in a straight line throughout the model, similar to drilling 
a hole 



Facet Modeling - Help Topic Collection 

2 

o Add a single layer of triangles to a selected area of geometry 

o Fill any concave parts of the geometry that you select 

o Fill areas that require additional volume in order to define edges that may 
have been blurred during scanning 

• Facet handling 

• Delete facets that are not required 

• Reduce the number of triangles without compromising surface continuity or 
detail 

• Fill gaps that may have been introduced during the scanning process 

• Improve the faceted geometry by reducing facet size 

• Smooth the polygonal surface by changing the coordinates of the vertices in 
an iterative manner 

• Reverse the orientation of two facets that share an edge 

• Add facets by splitting an existing facet or by selecting three open vertices 
and creating a new facet 

To Create a Facet Feature 

1. Click File > New to open a Pro/ENGINEER part. 

2. Click Insert > Facet Feature. The Open dialog box opens. 

3. Select the file that you want to open and click Open. The Import Options dialog 
box opens. 

4. Select the coordinate system to be used as a reference for inserting the part. 

5. Select the required units from the Units box. 

6. Click OK. Pro/ENGINEER displays the Facet Modeling toolbar. 

Selecting Entities in Facet Modeling 

Pro/ENGINEER provides you with various tools to enable the selection of entities. 
Depending on the Facet Modeling phase that you are working on and the tool that 
you use, you can select points, vertices, edges, or facets. 
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Selecting Entities Using Marquee Selection 

The following selection marquees are available to you from the system toolbar. 

Selection 
Marquee 

Selection 

 Selects points, triangles, or facets that completely lie inside 
the rectangular marquee. 

 Selects points, triangles, or facets that partially or completely 
lie inside the rectangular marquee. 

 Selects points, triangles, or facets that completely lie inside 
the polygon. 

 
Selects points, triangles, or facets through which the stroke of 
the paintbrush traverses. 

 
Selects points, triangles, or facets that completely lie inside 
the elliptical marquee. 

Changing the Selection Preferences 

1. Click Edit > Select > Preferences. The Selection Preferences dialog box 
opens. 

o To change the paintbrush thickness, change the Region Style to 
Paintbrush. Change the value of Thickness as required. 

o You can change the selection marquee from the system toolbar as well as 
from the Selection Preferences dialog box.  

Note: To select entities across a box (equivalent to the  marquee), 
select Rectangular Marquee from the Region Style list and click the 
Include items crossing the region boundary check box. 

o Optionally, click the Preselection highlighting check box to highlight a 
facet over which you place the pointer. 

o Optionally, click the Select visible facets only check box to select facets 
using any selection marquee or method that are visible in the current view. 
If you do not select this option, even those facets that are inside the 
selected marquee but are not visible in the current view are selected. 

2. Click OK. 

Selection of Entities in Different Phases of Facet Modeling 

In addition to the marquee selection, you can select entities in different phases of 
Facet Modeling using these methods: 
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Facet Modeling 
Phase 

Selection 
Command 

Selection 

Points 
 

Reverses the selection of points 
that you select using any of the 
selection marquees. 

Wrap 
 

Selects triangles with a length 
equal to or more than the specified 
length. (You can select triangles 
using this command in both Coarse 
and Fine Tuning phases.)  

Facet 
 

Selects facets with a length equal 
to or more than the specified 
length.   

Facet  Reverses the selection of facets 
that you select using any of the 
selection marquees or selection 
methods. 

 

 

Creating a Facet Feature 

The next tables shows the different files that you can use in the Facet Modeling 
environment, and the results of importing them using Insert > Shared Data > 
From File or Insert > Facet Feature. 

Type of 
File 

 

Insert > Shared Data > From 
File 

Insert > Facet 
Feature 

.pts The Points menu appears. The Points menu 
appears. 

 

.vtx The Points menu appears. The Points menu 
appears. 

 

.acs The Points menu appears. The Points menu 
appears. 
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Type of 
File 

Insert > Shared Data > 
From File 

Insert > Facet 
Feature 

.ibl 

 

The Points menu appears. The Points menu 
appears. 

 

.igs 

 

Only the datum points are read 
and any extra geometry 
present is ignored. 

The Points menu 
appears. 

 

.vda 

 

The file is read as datum 
points. 

The Points menu 
appears. 

 

.stl 

 

The facet feature is displayed 
as is. Use Edit Definition to 
see the Facets menu. 

The Facets menu 
appears. 

 

.wrl 

 

The facet feature is displayed 
as is. Use Edit Definition to 
see the Facets menu. 

The Facets menu 
appears. 

 

.asc 

 

The facet feature is displayed 
as is. Use Edit Definition to 
see the Facets menu. 

The Facets menu 
appears. 

 

 

Point Handling 

About the Points Phase 

This phase involves: 

• Importing the scanned file into your Pro/ENGINEER part. 

• Specifying the coordinate system as a placement reference for the imported data. 

• Using the commands available from the Points menu to modify the point set. 
This enables you to: 

o Eliminate erroneous data. 

o Sample points to reduce the computation time. 

o Reduce noise, that is, reduce deviation of points using statistical methods. 

o Fill gaps or holes in the model. 



Facet Modeling - Help Topic Collection 

6 

 

The Points Menu 

The Points menu in Facet Modeling provides the following point handling tools: 

• Reverse Selection—Reverses the selection of points. 

• Hide Selected—Suppresses the display of selected points. 

• Unhide All—Displays all the hidden points. 

• Filter—Graphically filters points in the point set. 

• Crop Selected—Deletes all the points outside a selected region. 

• Delete Selected—Deletes all the points inside a selected region. 

• Delete Outliers—Deletes points that appear offset from the main point set. 

• Reduce Noise—Moves points to the locations as determined using statistical 
methods. 

• Sample—Creates a sample of the points and helps produce an accurate wrap 
model with fewer points and less computation time. 

• Fill Hole—Fills gaps and holes in the model by adding new points. 

• Add—Allows you to add another point set to the existing point set and merge the 
two. This is useful when you want to close an open surface and create an object 
with a closed volume. 

• Save—Allows you to save the point data to a .pts file. 

• Wrap—Creates a wrap or a triangulated mesh. 

To Reverse the Selection of Points 

Click  or Points > Reverse Selection. 

The selection of points is discarded and the points that were not previously selected 
are selected and highlighted. 

To Turn the Display of Points On or Off 

1. Select the points that you want to hide. 

2. Click  or Points > Hide Selected. The selected points are hidden. 

3. To display all the previously hidden points, click  or Points > Unhide All. 

To Filter Points 

1. Select a value from the list on the toolbar to graphically filter the points. 
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For example, if you select 50%, the number of points are graphically reduced to 
50 percent of the original point set. 

Note: To revert to the original point set, select 100% in the list.  

2. Click OK. 

To Crop Selected Points 

1. Select the region that you want to retain. Hold down the CTRL key to select 
multiple regions. 

2. Click  or click Points > Crop Selected. The points outside the selected 
region are deleted. 

To Delete Selected Points 

1. Select the region from which you want to delete the points. Hold down the CTRL 
key to select multiple regions. 

2. Click  or click Points > Delete Selected. The points inside the selected 
region are deleted. 

To Delete Points Lying Outside the Point Set 

1. Click  or click Points > Delete Outliers. The Delete Outliers dialog box 
opens. 

2. Type a value for Sensitivity. 

To differentiate between the points lying outside the point set and the legitimate 
data points, specify a value between 0 and 1. A lower sensitivity value means 
Pro/ENGINEER selects points farther from the point set, while a higher value 
means Pro/ENGINEER selects points closer to the point set. 

3. If required, click Preview. The points that lie outside the point set are 
highlighted. 

4. Click OK. 

About Reducing Noise 

Due to the limitations of scanning devices, the points in the scanned data may 
deviate from their original location. This deviation is the noise in the point set. 

The Reduce Noise command uses statistical methods to determine the correct 
location for the points and moves the points to that location. Based on the level of 
noise or deviation of points in the point set, you can choose the level of noise 
reduction. 
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To Reduce Noise 

1. Click  or click Points > Reduce Noise. The Reduce Noise dialog box opens. 

2. Select the region for reducing noise. Hold down the CTRL key to select multiple 
regions. 

3. Select the noise reduction method. 

o Free-form—Reduces noise with respect to the surface curvature if the 
point set represents a freeform or organic shape. 

o Mechanical—Retains sharp corners and edges if the point set represents a 
mechanical or prismatic shape. 

4. Specify the smoothness level depending on the level of noise in the point set. You 
can select from Low, Medium, and High. 

5. Click OK. 

To Delete Points by Sampling 

1. Select a point set area to sample. 

Note: If you do not select an area, points are deleted by sampling from the 
entire point set. 

2. Click  or click Points > Sample. The Sample dialog box opens. 

3. Select the method of sampling. 

o Random Sample—Randomly removes the specified percentage of points 
from the point set. 

In the Sample Percentage box, type a value for a percentage of the 
original points that you want to keep. 

o Uniform Sample—Removes points from the point set uniformly. This is 
done by dividing the point set's model space into equal-sized cubes and 
deleting all but one point from each cube. 

In the Spacing box, type a value for the edge length of the cube. You can 
also click the selection arrow and select two points from the point set to 
determine the size of the cube. 

Note: A large cube size means that fewer points are retained from the 
point set whereas a small cube size retains more points. 

o Sample by Curvature—Removes points from the point set  depending on 
the surface curvature at that point.  

More points in the areas of high curvature are retained to maintain the 
accuracy in that area of the surface. Fewer points in the regions with less 
curvature or flat regions are retained as these regions require less detail.  
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In the Sample Percentage box, type a value for a percentage of the 
original points that you want to keep. 

4. Click OK. 

To Fill Holes in the Point Set 

1. Select the points in the point set surrounding the gap that you want to fill. 

2. Click  or click Points > Fill Hole. 

The Fill Hole command inserts points in the holes or gaps in the selected area of 
the point set based on the density and curvature of the surrounding points.  

Note:  

o If you do not select the area while using this command, points are inserted 
in all the gaps or holes. 

o If the region with holes is smooth and continuous, you can get good results 
after using this command.  

o The results of this command depend on the orientation of the model. 

Example: Filling Holes in the Point Set 

The next figure shows a point set with a hole. 
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The next figure shows the result of the Fill Hole command. 

 

Note: To adjust the point density in the hole that was filled, select that area and use 
the Sample command. 

To Add Point Set Data to the Existing Data 

1. Click  or click Points > Add. The Open dialog box opens. 

2. Select a points file. 

3. Select a coordinate system as a reference for the point set insertion. The point 
set is added to the existing point set. The two point sets are merged as a single 
point set for further point set operations. 

Note: Use sampling to delete points that may overlap after the addition of the point 
set. 

To Save Points 

1. Click  or click Points > Save. The Save Points dialog box opens. 

2. In the File Name box, type the file name. 

3. In the Format box, specify the file format in which to save the file. 

Wrap Handling 

About the Wrap Phase 

After you have modified the point set using the Points menu, you can wrap the point 
set to create a triangulated model, also called a wrap, and edit the wrap to: 
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• Remove unwanted triangles. 

• Reveal any underlying geometry. 

A wrap can consist of both closed and open surfaces that, in turn, consist of 
triangles, edges, and vertices. 

As all the points in the point set are used to create a wrap, all the geometric 
information including internal structures is maintained. 

The Wrap phase can be divided into two types of editing operations: 

• Coarse tuning—The coarse tuning operations are more automated and less 
precise and enable you to rapidly modify the model. 

• Fine tuning—The fine tuning operations are less automated but provide a finer 

and more detailed control for editing the model. Click  or Wrap > Fine 
Tune to make the fine tuning operations available. 

To Return to the Point Phase 

1. Click  or Wrap > Return to Point Phase to return to the point phase from 
the wrap phase. You are prompted to confirm that you want to return to the point 
phase. 

2. Click Yes to return to the point phase.  

Coarse Tuning 

The Wrap Menu 

The Wrap menu in Facet Modeling provides the following wrap handling commands: 

• Select by Length—Selects facets with an edge of length greater than or equal to 
the specified value. 

• Push Shallow—Removes triangles by propagating through the selected area. 

• Shoot Through—Deletes triangles in a straight line throughout the selected 
area. This is done in a manner similar to drilling a hole. 

• Push Deep—Removes triangles by propagating through the model until the point 
density changes. 

• Remove Webs—Removes triangles generated in the open spaces of the original 
point set while creating the wrap. 
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Example: A Wrap Created from a Point Set 

The next figure shows a point set inserted from a file. 

 

The next figure shows a wrap created from the point set. 
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To Use the Select by Length Command 

1. Click  or click Wrap > Select by Length. The Select by Length dialog box 
opens. 

2. In the Length box, type a value for the length of the facet edge. 

Optionally,  

o Click the arrow button on the Select by Length dialog box. 

o Select any two facet vertices. 

The distance between the selected facet vertices is calculated and the 
calculated value is displayed in the Length box. 

3. Click OK. The facets that have an edge of length equal to or greater than this 
Length value are selected and highlighted. 

To Use the Push Shallow Command 

1. Select a set of triangles. 

2. Click  or click Wrap > Push Shallow. 

The Push Shallow command removes selected triangles and exposes the 
underlying triangles. 
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Example: Using the Push Shallow Command 

The next figure shows a point set. 

 

The next figure shows a wrap created from this point set using the Wrap command. 
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The next figure shows the usage of the Push Shallow command to reveal the 
underlying geometry. 

 

To Use the Shoot Through Command 

1. Click  or click Wrap > Shoot Through. 

2. Select a set of triangles.  

The Shoot Through command removes triangles in a straight line throughout 
the wrap in a manner similar to drilling a hole. The direction in which the hole is 
drilled is based on the orientation of the model. In addition to the selection area, 
other internal structures may be removed. The operation propagates through the 
model until a change in point density is reached. 
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Example: Using the Shoot Through Command 

The next figure shows a wrap model. 

 

The next figure shows the wrap model after using the Shoot Through command. 

 

To Use the Push Deep Command 

1. Select a set of triangles. 

2. Click  or click Wrap > Push Deep. 
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The Push Deep command removes all the triangles that match the point density 
of the selected triangles by propagating through the model until the point density 
changes. This command also removes the internal structures that have the same 
point density. 

This command is similar to the Push Shallow command, but the depth of 
propagation is greater. 

About Webs 

When you create a wrap from a point set, triangles may get created in the originally 
open spaces in the model. These triangles are called webs. These webs are formed 
internally or between parts of the model where open space exists. The Remove 
Webs command removes these triangles and tetrahedrons. 

To Remove Webs 

1. Select a set of triangles. 

2. Click  or click Wrap > Remove Webs. 

The Remove Webs dialog box opens. Type the following values: 

o Min. Edge Length—Selects triangles based on the length of their edges.  

The web triangle edges are longer than those on the actual model. You can 
select a minimum value for the edge length that is longer than the edge 
length of the actual model triangles. Adjusting the length selects triangles 
with a length greater than the specified value. 

o Min. Angle Deviation—Uses the mathematical normals that extend from 
the surface to calculate the angle between the normal and the triangles. 

The angle values of the model triangles are lower than those of the web 
triangles. This enables you to specify a minimum angle to distinguish 
between the model triangles and the web triangles. 

To effectively remove webs, adjust both these parameters. The Remove Webs 
command removes webs that meet at least one of the criteria. 

For the removal of webs to be effective, you need not select all the triangles, as 
this operation propagates through the model in a manner similar to the Push 
Deep command. 

3. Click OK. 

Note: The web removal operation does not consider the distribution of points, and, 
therefore, cannot distinguish between webs and gaps in the wrap. 
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Example: Removing Webs 

The next figure shows a wrap created from a point set. While creating the wrap, 
webs are created in the open spaces in the model.  
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The next figure has the webs removed using the Remove Webs command. 

 

Fine Tuning 

The Fine Tune Menu 

The Fine Tune menu in Facet Modeling provides the following wrap handling 
commands: 

• Select By Length (Fine Tune)—Selects facets with an edge of length greater 
than or equal to the specified value. 

• Push Shallow (Fine Tune)—Removes only the selected triangles and reveals 
the underlying region. 

• Shoot Through (Fine Tune)—Deletes triangles in a straight line throughout the 
selected area in a manner similar to drilling a hole. 

• Remove Webs (Fine Tune)—Removes triangles generated in the open spaces 
of the original point set while creating the wrap. 
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• Fill Edges—Adds volume over the selected facets of the model to define sharp 
features that may have been blurred during the scanning operation. 

• Fill Up—Adds volume to the concave parts of the selected area of the model. 

• Fill Layer—Adds a single layer of volume to the selected area of the model. 

To Use the Fine Tune - Select by Length Command 

1. Click  or click Fine Tune > Select by Length. The Select by Length dialog 
box opens. 

2. In the Length box, type a value for the length of the facet edge. 

Optionally,  

o Click the arrow button on the Select by Length dialog box. 

o Select any two facet vertices. 

The distance between the selected facet vertices is calculated and the 
calculated value is displayed in the Length box. 

3. Click OK. The facets that have an edge of length equal to or greater than this 
Length value are highlighted. 

Example: Selecting Facets by Length 

The next figure shows a wrap created from a point set. 
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The next figure shows the facets selected by specifying the length of an edge. 

 

To Use the Fine Tune - Push Shallow Command 

1. Select a set of triangles. 

2. Click  or click Fine Tune > Push Shallow. 

The Push Shallow command removes only the selected triangles and exposes 
the underlying geometry. 

To Use the Fine Tune - Shoot Through Command 

1. Click  or click Fine Tune > Shoot Through. 

2. Select a set of triangles. 

The Shoot Through command removes triangles in a straight line throughout 
the wrap in a manner similar to drilling a hole. The direction in which the hole is 
drilled is based on the orientation of the model. 
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The difference between the coarse and fine tune Shoot Through commands is 
the level of propagation. The coarse Shoot Though command removes 
structures based on the point density. The fine tune Shoot Through command 
removes only those polygons that are intersected by the selection area. 

To Use the Fine Tune - Remove Webs Command 

1. Select a set of triangles. 

2. Click  or click Fine Tune > Remove Webs. 

The Remove Webs dialog box opens. Type the following values: 

o Min. Edge Length—Selects polygons based on the length of the triangle 
edges.  

The web triangle edges are longer than those on the actual model. You can 
select a minimum value for the edge length that is longer than the edge 
length of the actual model triangles. Adjusting the length selects triangles 
with a length greater than the specified value. 

o Min. Angle Deviation—Uses the mathematical normals that extend from 
the surface to calculate the angle between the normal and the triangles. 

The angle values of the model triangles are lower than those of the web 
triangles. This enables you to specify a minimum angle to distinguish 
between the model triangles and the web triangles. 

To effectively remove webs, adjust both these parameters. The Remove Webs 
command removes webs that meet at least one of the criteria. 

For the removal of webs to be effective, you need not select all the triangles, as 
this operation propagates through the model in a manner similar to the Push 
Deep command. 

3. Click OK. 

Note: The web removal operation does not consider the distribution of points, and, 
therefore, cannot distinguish between webs and gaps in the wrap. 

To Fill an Area by Adding Facets along the Edge 

1. Select a set of triangles. 

2. Click  or click Fine Tune > Fill Edges. 

The Fill Edges command fills edges by adding polygons to the selected area. 
This command is useful to define the sharp features of a model such as edges 
that may have been blurred during scanning. 

To Fill a Concave Area by Adding Facets 

1. Select a set of triangles. 
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2. Click  or click Fine Tune > Fill Up. 

The Fill Up command adds triangles to the concave parts of the selected area. 
Repeat the procedure until the selected area is filled. 

To Fill an Area by Adding a Layer of Facets 

1. Select a set of triangles. 

2. Click  or click Fine Tune > Fill Layer. 

Note: This command may add structures that look like spikes. To avoid the 
addition of such structures, select small regions of the model for adding layers. 

Facet Handling 

About the Facets Phase 

When you bring a model into the Facets phase, you can remove the internal 
structures and edit the model with a variety of commands to refine and perfect the 
faceted surface. 

Most of the commands in this phase change the coordinates of the existing points or 
add new points. Therefore, the faceted geometry differs from the original point set. 

If you must retain the original point set, do not use the editing operations in the 
Facets phase. 

The Facets Menu 

The Facets menu in Facet Modeling provides the following facet handling 
commands: 

• Select By Length—Selects facets with an edge of length greater than or equal 
to the specified value. 

• Select Connected Components—Highlights all the facets in the subset of a 
facet feature connected to the selected facet. 

• Reverse Selection—Discards the current selection of the facets and selects 
facets that were not previously selected. 

• Delete—Deletes selected facets. 

• Fill Hole—Fills gaps in the faceted geometry such that the faceted surface is 
continuous. 

• Clean—Cleans the faceted geometry by creating sharp edges or by making the 
surface smooth. 

• Decimate—Reduces the number of facets. 
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• Refine—Improves the shape of the facet model by increasing the density of 
facets and optionally moving facet vertices. 

• Relax—Makes the faceted surface smooth by changing the coordinates of the 
facet vertices in an iterative manner. 

• Offset—Offsets an entire faceted model or a subset of a facet feature. 

• Trim—Trims the faceted surface by using a datum plane. 

• Symmetry Plane—Creates a symmetry plane for the entire faceted model. 

• Make Manifold—Creates a manifold representation of the faceted surface. 

• Add Facet—Adds facets to the facet geometry by using the specified vertices. 

• Flip Edge—Reverses the orientation of two facets. 

• Split Edge—Adds facets by splitting the selected facet edge. 

To Select Connected Components 

1. Click  or Facets > Select Connected Components. 

2. Select a facet from the faceted model. Facet Modeling highlights all the facets in 
the subset of a facet feature connected to the selected facet.  

 

To Select Facets by Length 

1. Click  or click Facets > Select by Length. The Select by Length dialog box 
opens. 

2. In the Length box, type a value for the length of the facet edge. 

Optionally,  

o Click the arrow button on the Select by Length dialog box. 

o Select any two facet vertices. 

The distance between the selected facet vertices is calculated and the 
calculated value is displayed in the Length box. 

3. Click OK. The facets that have an edge length equal to or greater than the 
Length value are highlighted. 

To Reverse the Selection of Facets 

Click  or Facets > Reverse Selection. 

The selection of previously selected facets is cancelled and the facets that were not 
selected earlier are now selected and highlighted. 
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To Select Visible Facets Only 

Click  or Edit > Select > Preferences > Select Visible Facets Only, to 
select only visible facets.  You cannot select hidden facets. 

To select both visible and hidden facets, click  again. 

To Delete the Selected Facets 

1. Select facets for deletion using the selection marquee or using the Select by 
Length command. 

2. Click  or click Facets > Delete. The selected facets are deleted. 

To Fill Holes in the Faceted Geometry 

1. Click  or click Facets > Fill Hole. The Fill Holes dialog box opens. 

2. Under Fill Type, select one of the following fill types: 

o Curvature—Adds facets such that the surface curvature is maintained. 

o Flat—Fills the hole but does not maintain the surface curvature. 

3. Under Holes To Fill, select one of the following options: 

o Smaller than—Use the slider to set the size of the holes to be selected. 
Pro/ENGINEER selects the holes based on percentage of the model size that 
you specify using the slider. 

o All—Selects all holes with open facet edges. 

o Select—Allows you to select open facet edges for the holes to be filled. 

Click  and select the open facet edges. 

4. If required, click Preview to see a preview of the filled holes in the faceted 
surface. 

5. If required, click Undo to discard the changes that you made.  

6. Click OK. The gaps or holes in the faceted surface are filled. 
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Example: Using the Fill Hole Command 

The next figure shows a faceted surface with a hole in it. 

 

The next figure shows the faceted surface after using the Fill Hole command from 
the Facets menu. 
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About Cleaning the Faceted Geometry 

The Clean command uses a shape-correction algorithm. Using this command 
corrects the triangle of the faceted data. Cleaning the faceted geometry makes the 
polygonal surface conform to the shape decided by the original point set. This 
command removes dents, smoothes cylindrical sections, or sharpens edges 
depending on the mode you choose. 

To Clean the Faceted Geometry 

1. Click  or click Facets > Clean. Select the region for cleaning. If you do not 
select the region, the operation is performed on the entire model. 

The Clean dialog box opens. 

2. Select the mode for cleaning the facet geometry. 

Free-form—Cleans and smoothes the surface geometry with respect to the 
surface curvature if the faceted surface represents a freeform or organic shape. 

Mechanical—Retains sharp corners and edges while cleaning the geometry if the 
faceted surface represents a mechanical or prismatic shape. 

3. Click OK. 

Example: Cleaning the Faceted Geometry 

The next figure shows a faceted surface before using the Clean command. 
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The next figure shows the faceted surface after using the Clean command with the 
Free-form option. 

 

The next figure shows the faceted surface before using the Clean command with the 
Mechanical option. 
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The next figure shows the faceted surface after using the Clean command with the 
Mechanical option. 

 

 

To Decimate Facets 

1. Click  or click Facets > Decimate. The Decimate dialog box opens. 

2. In the Percentage To Keep box, type a value for the percentage of original 
points that you want to retain. 

3. To fix the boundary of decimated facets with respect to the surrounding facets 
after decimation, click the Fix Boundary check box. This is useful when the 
boundary consists of corners or feature lines that you want to retain. 

4. Click OK. The Decimate command enables you to reduce the number of 
triangles without compromising the surface integrity or detail. 
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Example: Using the Decimate Command 

The next figure shows a faceted surface and the facets selected for decimation. 

 

The next figure shows the selected facets after using the Decimate command with a 
reduction to 60 per cent of the original number of facets. 
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The next figure shows the selected facets after using the Decimate command with a 
reduction to 25 per cent of the original number of facets.  

 

About Refining the Faceted Geometry 

The Refine command improves the surface of the facet model by making the mesh 
denser by subdividing the existing facets. This results in an increased number of 
facets in the selected area. Using this command results in a more detailed and 
smoother selected region. 

To Refine the Faceted Geometry 

1. Select the area for refining using the selection marquee or using the Select by 
Length command. 

Note: If you do not select the area, the Refine command subdivides the entire 
faceted surface. 

2. Click  or click Facets > Refine. The Refine dialog box opens. 

3. Select a Refinement Algorithm: 

3X Subdivision—Replaces every existing triangle in the selected area with three 
triangles. 

4X Subdivision—Replaces every existing triangle in the selected area with four 
triangles. 

4. Click the Move Points check box to adjust the position of vertices to 
accommodate the increased number of triangles and produce a smoother surface. 

5. Click the Fix Boundary check box to ensure that the boundary edges and sharp 
edges are not moved. This is useful when the boundary consists of corners or 
feature lines that you want to retain. 
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6. Click OK. 

Example: Refining the Faceted Geometry 

The next figure shows a faceted surface. 
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The next figure shows the region selected for using the Refine command. 
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The next figure shows the faceted surface after using the Refine command to 
replace every triangle with four triangles in the selected region. 

 

About Relaxing the Faceted Geometry 

The Relax command smoothes the surface by moving the coordinates of the facet 
vertices. This process is iterative. 

More iterations mean a smoother surface, but too many iterations significantly 
change the original scanned data. 

To Relax the Faceted Geometry 

1. Select the area for smoothing using the selection marquee or using the Select 
by Length command. 

Note: If you do not select an area, the Relax command smoothes the entire 
faceted surface. 

2. Click  or click Facets > Relax. The Relax dialog box opens. 

3. In the Iterations box, type a value for the number of times the operation should 
be performed. You can also use the spin control to adjust the value. 
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4. In the Strength box, type a value for the amount of relaxation to be performed. 
This value must be between zero and one. 

Note: In general, there is a balance between the relaxation, or smoothing, and 
the shrinkage of the model. Increasing the Strength increases the amount of 
smoothing at the expense of additional shrinkage and thus loss of finer details. 

5. Click the Fix Boundary check box to ensure that the boundary edges and sharp 
edges are not moved. This is useful when the boundary consists of corners or 
feature lines that you want to retain. 

6. Click OK. 

Example: Relaxing the Faceted Geometry 

The next figure shows a faceted surface. 
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The next figure shows the faceted surface after a relaxation of facets using the 
Relax command. 

 

To Offset Facets 

1. Select a subset of a facet feature or an entire facet model. 

2. Click  or Facets > Offset. The Offset dialog box opens. 

3. Specify a value for Offset Value. The default is 1.000. 

Note: To reverse the direction of the offset, enter a negative value. 

4. Click the Maintain Mesh check box to maintain the existing mesh of triangulated 
facets while offsetting the facet model. 

5. Click the Thicken check box to add thickness to the facet model. This thickness 
is equal to the value specified for Offset Value. 

For example, if the Thicken check box is not selected, only the facet subset or 
model is offset by the specified Offset Value. If the Thicken check box is 
selected, then the facet subset or model is offset by the specified Offset Value 
and sidewalls are created. 

6. If required, click Preview to preview the offset of the subset of the facet feature 
or model. 

7. Click OK to offset the subset of the facet feature or model. 

To Trim Facets 

1. Click  or Facets > Trim. The Trim dialog box opens. 
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2. Select a datum plane.  

3. If required, click  to flip or reverse the direction of the trim. 

4. If required, click Preview to preview the trimmed faceted surface. 

5. Click OK to trim the faceted surface. 

 

To Create a Symmetry Plane 

1. Click  or Facets > Symmetry Plane. The Plane dialog box opens. 

2. If required, under References, click  and select a Coordinate System, 
Origin Point, and Direction for the symmetry plane. 

3. If required, under Origin Point Coordinates, specify values for X Coordinate, 
Y Coordinate, and Z Coordinate. 

4. If required, specify values for Direction Angular Dimensions.  

Note: YOZ, XOZ, and XOY represent the angular dimensions between the Y and 
Z, X and Z, and X and Y directions, respectively. 

5. If required, click  to preview the symmetry plane.  

6. If required, click  to discard changes made in the Plane dialog box. You 
can specify new values for Coordinate System, Origin Point, Direction, 
Origin Point Coordinates, and Direction Angular Dimensions again. 

7. Click OK. The symmetry plane is generated for the entire faceted surface. 

 

About Manifold Representations of Faceted Geometry 

You can create manifold models of the faceted surfaces in Facet Modeling. You can 
work with both open and closed manifold models. 

Manifold representations of a model have all the triangles connected continuously by 
their edges except for boundary edges.  

Closed-manifold objects bound volume whereas open-manifold objects do not. 

If a point set represents a closed object, the Wrap ( ) command creates a closed 
object. However, noise in the scan data can result in a wrap model that is not closed 
or contains nonmanifold edges, that is, some triangles in the model are not 
connected continuously by their edges. 
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To Create a Manifold Representation of the Faceted Geometry 

1. Click  or click Facets > Make Manifold. The Make Manifold dialog box 
opens. 

2. Select the type of manifold representation to create. 

Open—Creates a representation of the model where all the triangles are 
connected continuously by their edges except for boundary edges. This 
representation is created even if the wrap model does not bound volume. 

Closed—Creates a representation of the model where all the triangles are 
connected continuously by their edges except for boundary edges. This 
representation is created only if the wrap model bounds volume. 

3. Click OK. 

To Add Facets to the Faceted Geometry 

1. Click  or click Facets > Add Facet. 

2. Select three vertices of the existing facets in such a way that the triangle they 
form does not overlap or intersect any existing facets. The three selected vertices 
should create a triangle in an open space in the model. A new facet is created 
using these vertices. 

Example: Adding Facets to the Faceted Geometry 

The next figure shows a faceted surface with a gap in it. 
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The next figure shows facets added in this gap. 

 

To Reverse the Orientation of Two Facets 

1. Click  or click Facets > Flip Edge. 

2. Select an edge shared by two facets. 

The two facets form a quadrangular area. This command replaces one diagonal of 
this area with the other, changing the orientation of the two facets. 

Example: Reversing the Orientation of Two Facets 

The next figure shows two facets that share an edge. 
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The next figure shows the same facets after reversing their orientation using the Flip 
Edge command. 

 

To Add Facets by Splitting a Facet Edge 

1. Click  or click Facets > Split Edge. 

2. Select a facet edge shared by two facets. 

The edge is split into two parts and a facet is added on either side of the edge by 
dividing each of the two facets into two. 
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Example: Adding Facets by Splitting a Facet Edge 

The next figure shows two facets that have a common edge. 

 

The next figure shows the common edge as well as the facets split in two using the 
Split Edge command. 

 

About Copying Facet Features 

You can create a copy of a facet feature and manipulate it as required. The new or 
copied facet feature becomes the active facet feature. Copying a facet feature and 
offsetting the copied facets helps in preserving the original facets. 
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To Copy a Facet Feature 

1. Select the facet feature that you want to copy. 

2. Click  or Edit > Copy. 

3. Click  or Edit > Paste. 

4. Select a coordinate system. This coordinate system acts as a reference for 
placing the copied facet feature. 

5. Click OK. A copy of the facet feature is created. 
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