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Session one: Scalextric4Schools Challenge 
Scalextric4Schools is an exciting Design – Make – Race challenge developed by PTC™ 
and Hornby™ with support from Root Solutions™.  Many companies and organizations 
support the challenge. 
Full information including guides, rules and links to order components and track can be 
downloaded from www.scalextric4schools.org  
 
Introduction 
The PTC Scalextric4Schools challenge provides students with Creo Parametric 3D 
software to model their own designs for 1:32 scale racing cars. Many schools will have 
equipment to manufacture their cars but if not, partner schools and organizations will 
manufacture components and ship to the team. Details are on the web site at 
www.scalextric4schools.org. 
A combination of track testing and simulation using the advanced tools in Creo 
Parametric will help you understand the physics of car performance and redesign your car 
to make it faster. 
In certain regions, PTC organizes official competitions where teams compete to become 
champions. 
 
Prior learning 
This tutorial assumes you are already familiar with Creo Parametric and comfortable 
creating parts, assemblies and testing movement using kinematic motion. 
If you are not confident about these techniques you should complete the Primer and 
Advanced Primer.  These can be downloaded here: www.ptcschools.com. 
To help you get the most from Creo Parametric, PTC provides teachers and students with 
access to Precision LMS, a virtual learning environment with over 400 hours of self-paced 
tutorials covering all of the tools and techniques available in Creo Parametric. 
 
 
The slot car challenge was originally developed by 
design & technology teachers David Eyre and Chris 
Jarman. The cars you see on the right and on the 
next page were created by them and their students. 

 

http://www.scalextric4schools.org/
http://www.scalextric4schools.org/
http://www.ptcschools.com/
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Scale models 
Most slot cars are designed to a scale of 1:32 which 
means the model of a car 12 feet (4 metres) long in real 
life will be 4.5 inches (12.5 cm) long. 
The Design guide booklet shows how to transfer your 
own sketches into Creo Parametric and trace around 
them to create the shape of your very own slot car. 

The design challenge 
Can you design and make a slot car based around a 
standard chassis?   
Models should be to a scale of 1:32 and must comply with 
the rules for the competition. 
This tutorial and companion documents will prepare you 
for the challenge. 

 
 

After designing and making your car you can test it on any 
analogue Scalextric track. 
Schools can buy sets of parts and a special track layout 
for this challenge at heavily discounted prices.  Details on: 
www.scalextric4schools.org  

 
 
Baseline for car performance 
An important part of design development is to establish a ‘benchmark’ against which you 
can measure how quick your design is. 
With help from your teacher, you will be shown how to model, make, assemble, set-up and 
test a standard car shape to establish a benchmark for future design improvement.   
The ‘Make – Assemble - Setup’ booklet will help you get the car working smoothly and 
efficiently.   
You should then use scientific methods to carry out ‘fair tests’ to quantify the performance 
of the standard car, establishing the benchmark.   
Later you will carry out the same experiments on your own designs to measure any 
improvements in performance. 
 
  

http://www.scalextric4schools.org/
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Overview 
Chassis 
This inline chassis layout is used for the 
Creo Parametric tutorial that follows. A 
number of flat parts are slotted together and 
a single screw holds everything together. 
This allows components to be swapped and 
changes to be made very easily.   
Design for maintenance is very important 
part of product development. 
 

 
 

Body 
High quality realistic body shapes are made 
possible using CNC machining to create a 
mold. 
The mold can then be used to vacuum form 
thin shells from thermoplastic sheet. 
 

 
 

 
Outline 
The instructions that follow will teach you 
how to use Creo Parametric to create a 
hatchback body shape for a slot car. 
 

 
 
The starting point is a Creo Parametric part 
with half the base modeled and wheel arch 
cutouts.   
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You will insert a series of features that form 
the body mold which is then exported for 
manufacture. 

 
 

 
Additional features will be added to convert 
the mold into a finished car body. 

 
 

 With symmetrical designs it’s good 
practice to model half of the car 
body and mirror the shape late in 
the modeling process.  Any 
asymmetric details like driver, 
steering wheel, windshield wipers 
and exhaust pipes can be added 
after the mirror feature. 
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Task1: Configuring Creo Parametric 
Expert/overview 
PTC provides scripts to configure Creo Parametric for units of measurement and drawing 
standards.  Refer to the install instructions to configure Creo Parametric for mm, kg and 
seconds. 
 

Task 2: Download the model files 
Expert/overview 
We provide models you can download to use as a starting point 
1. Go to www.scalextric4schools.org: 

• On the right of the home page click Get Started: 
 
2. Expand the Download Curriculum and CAD Models section: 

• Click on F3 Hatchback Creo Parametric  2.0: 
• Save the file where you store documents: 
• Right click on the zipped folder and select Extract All. 

 

 There may be occasions when it would be useful to see a completed version of an 
exercise.  We provide completed versions of most activitie by adding a Z_ prefix to 
the filename.   These files appear at the bottom of a list of files sorted 
alphabetically. 

 For example, the completed body mold exercise is named Z_BODY.PRT 

   

http://www.scalextric4schools.org/
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Task 3: Setting the working directory 
Expert/overview 
When modeling using Creo Parametric you will create many different files in numerous 
formats and there will be occasions when Creo Parametric creates files for you. It is 
important that all these files can be found later and the easiest way to ensure this is to set 
the working directory before you start modeling. 

  Always Set working directory before you start each Creo Parametric modeling 
session. 

 

 
1. Getting started: 

• Start Creo Parametric. 
• From the Home tab, Data group, click Select Working 

Directory  . 
• In the Select Working Directory dialog box navigate to the 

folder 2013_S4S_Car folder. 
• Click OK to set the folder as the working directory. 

 
 

2. Open an assembly 

• From the Quick Access toolbar or 
the Home tab, click Open . 

• In the File Open dialog box, 
double click 
2013_S4S_HATCH.ASM 

 

 
 

  You will see a completed Scalextric4Schools car in the graphics screen. 
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3. Hide datum features 

• From the In Graphics toolbar, click the Datum Display 
Filters  list and disable the display of all datum 
features. 

 

 
 

 
 

What have you learned? 

• Overview of the Scalextric4Schools F3 car. 

• Aware of Creo modeling the car body. 

• Configure Creo for units of measurement. 

• Download library files. 

• Setting working directory. 

• Open files. 

• Datum visibility. 

• Advantages of mirroring geometry. 

• Multiple select (Ctrl key to add/remove selections). 

• Edge references. 
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Task 4: Exploring Creo Parametric   
Expert/overview 
This section will show or remind you how to manipulate and position models in the 
graphics area.  You will also hide and unhide components in the assembly. 
 
1. Spinning the model 

• Move the mouse cursor into the graphics 
area, hold down the middle mouse button 
and move the mouse. 

 

• As you move the mouse, the model will spin 
around the Spin Center  .   

 

 
 

   If the Spin Center is turned off, the model spins around the mouse cursor position. 
 

 
 
2. Zoom the model 

• Move the mouse cursor over a part of the 
model and, without clicking, rotate the 
middle mouse wheel. 

 
 

 

 
 

   The zoom function uses the mouse cursor as the fixed position while zooming. 
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3. Refit the model 

• If the model disappears, there is a 
button to refit the model in the 
modeling window. 

• From the In Graphics toolbar, click on 

Refit . 
 
The model will automatically zoom to fit into 
the graphics area.  

 
 
4. Saved Views 
You may also want to return to a view of the car 
the correct way up. 

• From the In Graphics toolbar, click  

Named Views    and select Trimetric 
from the drop-down menu. 

 
 

5. Hiding and Unhiding 

• In the model tree, right click on 
Z_BODY.PRT, and from the pop-up menu, 
select Hide. 

 
The body will disappear. 

  

 
 

• In the model tree, right click on 
BODY.PRT and from the pop-up menu 
select Unhide. 

This part will be developed first as a mold 
and then as the finished body. 
At the moment BODY.PRT occupies the 
same space as the chassis base and is 
shown here highlighted in green. 
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 Along the centerline of the car you will see a drawing for a hatchback car.   
 This will be used as a guide when drawing the side profile of the car. Later in this 

tutorial you will be shown how to add your own design sketches to the model. 
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Task 5: Prepare for modeling 
Expert/overview 
You will open the file BODY.PRT, move the Insert Here flag then add features to create 
the mold shape.  
 
1. Opening a part from an assembly 

• In the model tree right click on BODY.PRT and from 
the pop-up menu, select Open. 

 

 
 

The model tree displays the features that were used to create the part. 
 
Several new features need to be inserted before the CHASSIS CORNERS feature. 
2. Inserting new features 

• In the model tree, drag the  
Insert Here flag above the CHASSIS_CORNERS 
feature. 

The model tree will look like this with the wheel arch cut 
outs and corner rounds disappearing from the model.  

 

 
 

  The small black squares next to the features below the red arrow in the model tree 
indicate the features are now ‘suppressed’ and not being included in the model. 
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What have you learned? 

• Viewing the model – Rotate, zoom and spin center. 

• Hide and unhide parts in the model tree. 

• Inserting features in the model tree. 
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Task 6: Body profile 
Expert/overview 
The body profile shown below will be extruded from an internal sketch located on the 
FRONT datum plane.   
The sketched profile uses straight lines to trace the car outline and references the TOP 
datum plane and the ends of the CHASSIS_BASE extrusion. 

 
 
1. Begin extrusion 
You will start an extrusion and then select the FRONT datum plane as your sketching 
plane. 

• From the Model tab, Shapes group, click Extrude  . 
 

The Extrusion dashboard will appear across the top of the modeling window. 

 
 

• In the model tree, select the FRONT datum plane as the location for the sketch. 
 
The Sketch tab will open across the top of the Creo Parametric screen. 

 

• From the In Graphics toolbar click Sketch View . 
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 To help with the next step we have provided red lines you can trace over plus 
dimensions if you want to fully constrain the sketch. 

  
 
2. Sketching the body profile 

• In the Sketcher toolbar start the Line Chain  tool. 
• Draw the shape shown here by left clicking at each X starting with number one and 

finishing back at the same point.  When drawing the roof line, make sure there is an 
‘H’ visible showing this line will be constrained to be horizontal. 

 
• When you finish drawing the shape, click the middle mouse button twice to complete 

the sketch. 
 

  Initially your sketch should look like this with dimensional constraints. Creo 
Parametric has added these grey ‘weak’ dimensions. Don’t worry if yours are not 
the same as these at the moment. 

 

 

 The sketch for a simple extrusion should contain a continuous outline with no 
breaks or overlaps. If the sketch is a closed loop, Creo Parametric will shade the 
outline as shown in the previous illustration.  
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Sketch diagnostics 
If your sketch is not shaded, Creo Parametric provides 
diagnostic tools in the Inspect group of the Sketcher toolbar to 
help find errors. 

 
 
Cause Cure 

• Profile not shaded The Highlight Closed Loops tool should be active by default 
and shades closed outlines of lines.  If an outline will not shade, 
use the other diagnostic tools to find and correct errors.   

• Open ends Use the Highlight Open Ends  diagnostic tool to find these, 
the open end will have a red dot clearly visible. 

• Gaps - Lines that 
do not meet 
properly 

The Highlight Open Ends tool  will also identify very small 
gaps with two red dots close together.  Zoom in on each pair of 
red dots to find the gap, delete the line that is too short and 
redraw it closing the gap. 

• Coincident lines - 
Lines drawn on 
top of each other 

Use the Overlapping Geometry tool  to find overlapping 
lines.  The double line and the line either side will be highlighted 
in red.  Click on the middle one of the red lines and delete it.  

Repeat the  diagnostic tool as many times as necessary to 
find each duplicate line. 
If you accidentally delete a line that is not a duplicate, use  
Undo  or Ctrl + Z to restore the last line deleted. 

• Extended lines  Use the Highlight Open Ends tool  to find extended lines.  

Zoom in on each extended line and use the trim tool  to 
delete the extended part of the line. 

• Stray lines The Highlight Open Ends  diagnostic tool will help you find 
these. Look inside and outside the profile for red dots and delete 
the stray lines. 

 
If these techniques do not work use Undo  or Ctrl + Z multiple times to remove all lines 
and sketch the profile again. 
 
Revising the dimensioning scheme 
There are 3 types of sketch dimension; 

• Weak - colored light blue, these are created automatically by Creo Parametric.  
They report sizes in the sketch but allow changes to be made including letting you 
drag lines and points. 
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• Strong – these dimensions are darker blue in color.  Geometry controlled by 
strong dimensions can still be dragged on screen. 

• Locked – these dimensions are brown in color. Geometry controlled by locked 
dimensions cannot be changed by dragging on screen.  Locked dimension can be 
changed by double clicking and typing a different value. 

 
 
Lips at the front and rear of the 
body shell are needed to locate it 
accurately on the chassis.   
 
Dimensions will be added to the 
sketch to specify 2mm lips and 
Creo Parametric will automatically 
sort out the other dimensions. 

 
 

 
3. Adding a dimension 
Dimensions are added by left clicking on the two extents of the dimension then middle 
clicking to locate the dimension text. 

• Zoom in on one end of the car profile. 

• In the sketcher toolbar, Dimension group, click the Normal  tool. 
 

• Select the vertical edge of the base extrusion 
at X1. 

• Select the end point of the sketched line at X2. 
• Middle click at X3 to place the dimension 

value. 
• Type 2 and press Enter. 

 
 

The dimension changes from light blue to darker blue denoting it is now a strong 
dimension. To ensure the sketch is not over-constrained, Creo has removed one of the 
weak dimensions. 
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 This is a major strength of Creo Parametric. It constantly manages dimensions to 
fully specify the sketch. 

 
 
4. Adding another dimension 

• Create another 2mm dimension at the opposite end of the sketch. 

• In the Sketcher toolbar, activate the One by One  selection tool. 
 
5. Locking dimensions 
Dimensions you do not want to change can be “locked”. 

• From the In Graphics toolbar click Refit . 
• Select one of the 2mm dimensions. 
• Right click and from the pop-up menu, select Lock. 
• Click in a blank region of the graphics area to deselect the dimension. 

 
The dimension will change color to brown to show it is now locked. 

• Lock the other 2mm dimension as shown below 
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Drag lines to change shape 
When you added the 2mm dimensions, other lines 
may have moved and no longer follow the shape 
of the image underneath. Lines that are not 
constrained with locked dimensions can be 
dragged. 
6. Moving sketched lines 

• Click to select a node between two lines and 
then drag to re-align the node with the car 
shape. 

• Continue moving nodes until the sketch 
matches the car profile image. 

 
 

 If the sketch changes shape unexpectedly, use the Undo  button or Ctrl + Z. 
 
 
Fully constrained sketch 
Product designers are mostly concerned with shape and proportion so dragging the nodes 
until the shape is how they want it would probably be sufficient. 
Engineers don’t like anything left to chance and would probably lock all the dimensions.  
You can do this too by following the dimensions on the image. 

 
 
7. Complete the extrude 

• Once you are happy with your sketched shape, check that it is still shaded and that 
there is a horizontal constraint H on the roof. 

• From the In Graphics toolbar, Saved Views list   select Trimetric. 
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• When finished sketching, in the Close 
group, click OK . 

 
The Sketcher tab will close revealing the 
Extrude tab. 

 
 

8. Setting extrude options 

• Change the depth option to Extrude to Selected . 

 
 

• Click to select the side surface of the 
base extrusion, shown outlined in 
green to the right. 

• In the dashboard, click Complete 

Feature  to complete the 
extrusion. 

• From the Quick Access toolbar click 
Save . 

 
A new Extrude entry will appear in the 
model tree and the body will display as 
shown below.  
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9. Hiding the profile image 
We no longer need the car image so it can be hidden 
from view. 

• Click the View tab 
• In the Model Display group click Images 

The Images toolbar opens. 
 

 
• Open the Imported Images drop-down menu 
• Select Side Elevation.jpg 
• Click  Hide and the Side elevation image will 

be hidden. 
• Click OK to close the Images toolbar 
• From the Quick Access toolbar click Save . 

 
 

What have you learned? 

• Sketcher – toolbar, sketch plane, line chain, drag geometry. 

• Sketcher constraints – adding references to existing geometry. 

• Sketcher diagnostics – closed loops, open ends, overlapping geometry. 

• Dimensions – normal, weak, strong, locked, adding and changing. 

• Extrusion – add material, depth controls. 

• Model view – trimetric, sketch view 
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Task 7: Side taper 
Expert/overview 
Looking from the front of the car, the side needs to be tapered.   
This will be done by drawing a diagonal line on the RIGHT 
datum plane referenced from the roof to the point where the 
hood/bonnet meets the side of the car. 
The sketch will be extruded, removing material Through all in 
both directions.  

 
 

1. Start an Extrude 

• In the Model tab, Shapes group, start the Extrude  
tool. 

• In the model tree, select the RIGHT datum plane as the 
sketch plane. 

Creo Parametric will enter sketch mode with the sketch tab 
open across the top of the screen. 

• From the In Graphics toolbar, click Sketch View . 
 

 
2. Sketching with references 
Open loop sketches can be used to remove material but lines must extend beyond the 
model or attach to the edges of the model. Sketch references allow us to do this and can 
be created “on the fly”. 

• From the Sketching group, Line Types drop-down menu, select Line Chain . 
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3. Creating references “on-the-fly”. 

• Move the mouse cursor over the top edge of the model 
and hold down the Alt key on the keyboard. 

• Click to create a line reference along the top surface.  
• Release the Alt key to see the reference. 

 
A dashed reference line will appear across the top of the model.  
 

 
 

 

• Move the point of the mouse 
cursor arrow precisely over 
the front corner of the 
hood/bonnet, hold down the 
Alt key and click to create a 
point reference.  

• Release the Alt key and a 
very small light blue “Point 
reference” x will appear.  

 
 

 
4. Drawing the cut line 
The Line Chain  tool should still be active. 

• Draw the diagonal line shown here making sure the ends 
snap to the references you have just created. 

• Middle mouse button twice to cancel the Line Chain  
tool. 

• If necessary drag the top of the line along the reference 
until it is angled as shown here on the right. 

 
 

• When finished sketching, from the 
Close group, click OK . 

• From the In Graphics toolbar, click 
Named Views  and from the drop-
down menu, select Trimetric. 
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5. Changing extrude settings 

• In the Extrude tab, change the choices to those shown below. 
• Ensure that Extrude as Solid X1 has been selected. 
• Click Blind and select Through All X2 from the drop-down menu. 
• Click Remove Material X3. 

 
 

• Change the options so that material is 
removed through the entire model 

• In the dashboard, click the Options 
tab to open the drop-down panel. 

• Change the Side 2 option to extrude 
Through All. 

• Make sure the purple arrow is pointing 
away from the model. 

 

 
 

 

6. Complete the extrude feature and save 
your work. 

• Click Complete Feature  to 
complete the feature. 

The side of the car body will now be angled. 
 

• From the Quick Access toolbar, click 
Save . 
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What have you learned? 

• Sketcher – toolbar, sketch plane, line chain, drag geometry. 

• Sketcher constraints – adding references to existing geometry. 

• Extrusion – dashboard, remove material, depth controls. 

• Model view – trimetric, sketch view. 
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Task 8: Rounds 
Expert/overview 
Three rounds will be added to the edges 
arrowed in the order 30mm, 8mm then 5mm  
 

 
 

1. Adding a round feature: 

• From the Model tab, Engineering 
group, click Round  from the Round 
Types drop-down menu. 

• Click to select the edge shown in 
green. 

• In the Round tab, change the radius to 
30 and press Enter. 

• Click Complete Feature  to finish 
the round feature.  

 
2. Adding more rounds: 

• From the Model tab, Engineering 
group, click Round from the Round 
Types drop-down menu.   

• Hold down the Ctrl key and select 
each of the edges shown here in 
green. 

• In the Round tab, change the radius to 
8 and press Enter. 

• Click Complete Feature  to finish 
the round feature. 
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• Add another Round feature of 5 mm 
radius to the edge shown in green. 

 
 

 
 

 Creo Parametric continues the round along all edges that are tangential. 
 

• From the Quick Access toolbar, click Save . 
 
 

What have you learned? 

• Round feature. 

• Multiple select (Ctrl key to add/remove selections). 

• Edge references. 
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Task 9: Complete the mold 
Expert/overview 
To complete the mold you will move the Insert here flag down one feature in the model 
tree and then mirror the model about the FRONT datum plane. 
 
1. Resume a feature 

• In the model tree, drag the  Insert Here flag below 
the CHASSIS_CORNERS feature. 

The corners of the base extrusion will now be rounded. 

 
 

 
 

 

• From the In Graphics toolbar, click the 
Datum Display Filters list  and enable 
only the display of datum planes. 

 
 

 
2. Mirror the model 

• In the model tree, click on BODY.PRT to 
select it. 

• In the Model tab, Editing group, click 
Mirror . 

• In the model tree or the graphics area, 
select the FRONT datum plane as the 
mirror axis. 
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3. Complete the feature and save your work. 

• From the In Graphics toolbar, click the 
Datum Display Filters list  and disable 
the display of all datum features. 

• Click Complete Feature  to complete 
the mirror feature. 

• Click Save . 
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Task 10: Model properties 
Expert/summary 
While the shape of the body mold is complete, we still need to specify Balsa as the 
material it will be made of together with the name of the part, who modeled it and the 
project it is part of. 
 
1. Editing model properties 

• Click File > Prepare > Model Properties. 
• In the Model Properties dialog box, next to Materials click change. 

 

 
 

• In the Materials dialog box, select Wood_balsa.mtl. 
• Click Assign  and then click OK.  

 
Creo Parametric will apply this material to the model. 

 

 
 

 This will not alter the external appearance of the part. It has changed the 
density/mass and physical properties of the model so that measurements and 
analyses report accurate results. 
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The next step is to assign parameters to the part. 
 
2. Assigning model parameters 

• From the Model Properties dialog 
box, click change next to 
Parameters. 

• From the Parameters dialog box, in 
the Value column: 

• Next to DESCRIPTION, type 
S4S_BODY 

• Next to PROJECT type 
SCALEXTRIC4SCHOOLS. 

• Next to MODELLED_BY type your 
name.  

• Click OK to close the Parameters 
dialog box. 

• Click Close to close the Model 
Properties dialog box. 

• Click Save . 
 

 

What have you learned? 

• Model properties – assigning material properties, description, project and 
modeled_by properties to a model. 

• Measurement and analyses – awareness of material properties and they affect 
measurements and analyses. 

• Saving your work. 
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Task 11: STL file for machining 
The most common file format used to transfer 3D shapes to machining software is STL.  
The companion document ‘Make - assemble - setup’ booklet contains a full description of 
the STL file format, post processing and CNC machining. 
 
Expert/summary 
Here you will be show how to export an STL file of your model configured for a fine mesh 
surface. 
1. Exporting an STL file. 

• Click File > Save As… > Save a Copy and, in the 
Save a Copy dialog box, change the Type to 
Stereolithography (*.stl). 

 
The default filename uses the part name with an .stl 
extension. 

• Click OK to save your model as BODY.STL 
 
2. Defining the mesh size. 

• In the Export STL dialog box, change the Chord 
Height value to 0 (zero). 

 

 
 

: Creo Parametric will enter the smallest practical value for Chord Height.  The 
resulting number is based on the size and complexity of the part. 

 

• Accept the other defaults and click OK to create the STL file and close the dialog 
box. 

 
The display will change to show the faceted 
surface of the STL file. 
3. Check your work and repaint your 

model: 

• Zoom in to a curved corner to see the 
triangular surfaces created by the STL 
conversion. 

• From the In Graphics, toolbar click on 

Repaint   to repaint the screen and 
return to the parametric model. 

 
 



Creo  2.0  Scalextric4Schools 

PTC – www.ptc.com www.scalextric4schools.org page 36 of 90 

 

: A description of the machining process can be found in the accompanying  
‘Make – assemble – setup’ document. 

 
 

What have you learned? 

• .Awareness that STL is an industry standard format for manufacturing files. 

• Awareness that STL conversion creates a quilt of triangular facets on the 
surfaces of a model. 

• Understanding that facet size is controlled using the “Chord Height” variable. 
 
Homework one – Car performance 

• Before the next session read through the section Car performance in the Design 
Guide booklet for this project. 
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Session two: Physics of car performance 
Task 1: Review homework. 
Based on your homework task, your teacher will help the group create a list of key physics 
principles affecting car performance.  These will be useful later when re-designing your 
car. 

 
Task 2: Review design factors 
In design teams you will create a set of bullet points to guide the development of your car 
design. 
 
Competitions 
You will be racing other students or teams and to make sure competition is fair a set of 
rules have been created. Rules for the Scalextric4Schools Challenge are published on the 
www.scalextric4schools.org  web site. 
Next you will be shown how to convert your paper sketches into a 3D CAD model, then 
how to make changes to existing parts and finally learn about alternative 3D modeling 
features. 
 
Homework 2: Design sketches 

• Refer to the Design guide for detailed instructions on sketching ideas for body 
shapes. 

 
Homework 3: Hornby the company 

• Read through the ‘Hornby the company’ section of the ‘Design guide’ for this 
project.   

You will be asked questions on this at the start of the next session. 
 

  

http://www.scalextric4schools.org/
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Session three: Modify Creo Parametric models 
Outline 
During this session you will learn how to modify existing designs, correct some of the faults 
that can occur and hear about other 3D modeling tools. 
 

Task 1: Hornby the company 
Your teacher will ask the class to show their knowledge of Hornby, one of the foremost 
companies in the world designing and manufacturing slot cars. 
 

Task 2: Dealing with failed features 
This example shows changes to the body mold profile and how this makes the subsequent 
Round feature fail.  Read through this so that you will know what is happening when 
failures occur. 
In the diagrams below, the body profile has been edited changing it from a hatchback to a 
sedan/saloon. 
 
Before After 

  
 

When it was created, the round features 
shown on the right referenced the five 
edges across the car.  
The round feature is ‘child’ to the five 
‘parent’ edges.   
 

 
 

When changes were made to the profile 
sketch, an extra edge was created at the 
base of the rear window. 
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The round cannot work out which of the new edges to 
use so the round feature and others below have failed.   
Creo Parametric reports modeling failures with a 
drop-down message like the one below. 

 
 
Edit Definition allows us to correct the errors. 
 

 
 

Here Edit Definition was used to re-open the Round 2 
feature in the model tree. The Sets tab is where edge 
references and radii are recorded. 
Scrolling down the references list revealed one failed 
edge reference ( ) and two ambiguous edge references 
shown in yellow ( ). 

 
The failed entries are removed by right clicking on each 
one and, from the pop-up menu choosing Remove. 
New edges are then added by holding down Ctrl and 
selecting the new edges.   
The Round feature is then completed by clicking 
Complete Feature .  
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Correcting the parent edges in the first failed Round has 
resulted in the lower failures being resolved automatically. 

 
 
Creo Parametric is now able to regenerate the model 
successfully. 

 
 

:  Making changes to complex models may generate several failed features that 
should be corrected before continuing to model. 

 
 

What have you learned? 

• Aware of Hornby the company, its history and products. 

• Causes of regeneration failure. 

• Introduced to Parent - Child relations. 

• Editing a Round feature – Edit Definition, removing and replacing failed 
references. 
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Task 3: Reverting to a previous version of a part 
We shouldn’t need to mention the importance of saving your work regularly! 
When a part or assembly is created in Creo Parametric, a 
number is added after the file extension. 
Each time you make changes to a part or assembly and 
save, another new file is created with the number 
incremented.  Here is an example where the base part was 
saved sixteen times during development. 
If changes to a model go seriously wrong you can close 
the part, erase the model from memory and then open a 
previous version. 

 

1. From the Quick Access toolbar, 
click Open . 

• In the Type drop-down list, 
select Part (*.prt) 

• In the Tools drop-down list 
select All Versions. 

You will now be able to see all the 
versions of each file. 
2. Select one of the earlier versions 

of BODY.PRT and click the 
Preview button. 

A preview of the earlier version is 
shown and can be opened.  

 

 
Homework three – Competition rules 

• Take a copy of the competition rules home with you.  They are available on the 
challenge web site - www.scalextric4schools.org   

• Read through them carefully.   

• Read through again looking for opportunities to design a car that will be quick 
around the track.   

• Write down a list of the top five things you think will make a car quick.   

• Bring the list with you to the start of the next session. 
You now have some of the knowledge to design your own car.   

What have you learned? 

• Creo Parametric creates numbered copies when files are saved. 

• How to view and open previous versions can be opened. 

• Aware of competition rules. 
  

http://www.scalextric4schools.org/
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Extension one: Alternative modeling strategies 
If you found the Creo Parametric modeling easy so far, you may want to know about a 
few other 3D features and modeling strategies that could be used to create a car body. 
 
 

Blend 
Sometimes called loft this uses cross sections that 
Creo joins up to create a solid or surface.   All sections 
must contain the same number of lines 
Precision LMS - Advanced Modeling. 
 

 
 

 

Variable section sweep 
A very powerful tool that uses a single cross section 
sketch projected along one or more control curves to 
create a variable cross-section surface or solid.  
Precision LMS - Advanced Modeling. 

 
 

Warp 
The warp feature is a collection of tools that allow 
existing shapes to be distorted in a very ‘organic’ way.  
There are no sketches involved; instead, frames 
surround the affected area while points and edges on 
a mesh are pushed and pulled to change the model. 
Precision LMS – Advanced Modeling. 

 
 
Homework – Change request 
When a commercial product requires modifying the design team agrees to a change 
request.  This is similar to a product specification and lists the changes needed. 
Your task is to create a ‘change request’ listing the modifications needed to change the 
standard car body design to match your revised design. You will need your change 
request in the next session.   

 Use your experience of the model tree to help you order your list of changes.  
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Session four: Own design 
You now have sufficient experience to model your own body.  However you may find the 
following design guidance helpful 
From previous homework you should have several sketch ideas for car shapes drawn on 
templates.   
 

 
You should also have a ‘change request’ list of modifications to make. 
 

Task 1: Preparing your drawings 
1. Scanning images 

• Choose one of your design sketches.  
• Use a scanner to capture your drawings into the computer.  Create two images of the 

car like the ones shown below.   
 
 

 
 

 Car_name_side.png  Car_name_front.png 
 

• Name the files Car_name_side.png and Car_name_front.png, saving them in the 
directory where the Scalextric4Schools Creo models are saved. 

  

133mm 27mm 
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Task 2: Tracing over Images 
Creo Parametric allows you to insert and scale images as a reference to trace over. In the 
following task we will use images named SKETCH_SIDE.png and SKETCH_FRONT.png.   
You should use the images you have drawn. scanned and saved. 
1. Opening a start part. 

• From the Quick Access toolbar, click 
Open  and select the part 
BODY_TRACE.PRT. 

• Drag the  Insert here flag between the 
CHASSIS_BASE and 
CHASSIS_CORNERS features. 

 
 

2. Adding an image 

• From the View tab, Model Display group, select Images from the Model Display drop-
down menu. 

 
 

• From the Image group, click Add 
. 

• In the model tree, select the FRONT 
datum plane. 

• In the Open dialog box, browse to the 
working directory, select  
SKETCH_SIDE.PNG and click Open. 

2. Refit the model in the graphics area. 

• If necessary, from the In Graphics 
toolbar click Refit . 

You can now see that the image placed on 
the FRONT datum plane 
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The sketch you have just placed needs to be scaled and positioned. 
3. Scaling the image 

• From the In Graphics toolbar, click Named Views  and select FRONT from the drop-
down menu. 

• From the Images tab, Fit group, click Fit and select  Horizontal radio button. 
• Drag the red dots until the vertical limit lines align with the ends of the chassis. 
• Double click the dimension, type 133 and press Enter. 

 
The image will be rescaled to 133 mm wide while maintaining the image aspect ratio.  An 
alternative dimension you could use is the wheelbase which is 78.5 mm. 

 
4. Repositioning the image 

• From the Fit group, click Fit to deselect the Fit tool. 
• In the graphics area, drag the image aligning the top of the chassis in the image with the 

top of the chassis model. 
 
The image below shows the image correctly aligned with chassis base in the model. 

 
 

 Take a look at the other options in the Images dashboard including altering the 
transparency of the image. 

 
When you are happy with the scale and location of your image, from the Close group, click OK 
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• Repeat the process in order to place 
the SKETCH_FRONT.PNG image on 
the RIGHT datum plane. 

• If necessary, rotate the image by 90 
degrees. 

• Edit the horizontal width to be 27mm. 
 
Your instructor/teacher will now help you 
create a Creo Parametric model of your 
design of car. 
 

 

 
Homework four – CNC machining 
Research CNC machining and write a description of: 

• How a 3D CAD model is transferred to the computer controlling the machine tool. 

• How the machine tool software creates instructions for the machine. 

• How the machine removes material. 

• The advantages of CNC machining. 

• The disadvantages of CNC machining. 
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Session five: Machining 
The Make-Assemble-Setup guide contains a detailed description of taking the Creo 
Parametric model of the body mold through to the machined vacuum forming mold. 
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Homework five – Parts design and manufacture 
Would it be cool to spend your working day recreating the latest dream cars as Scalextric 
models?   Interested in how it’s done?  Read the section about Darren in the ‘Design 
Guide’. 
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Session six: Car assembly 
The Make-Assemble-Setup guide contains a detailed section on how to assemble the 
chassis for this project. 
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Session seven: Testing, analysis and simulation 
Simulating car performance 
In the past, designers and engineers would build 
real prototypes to test their designs.  They were 
tested and the results used to make 
improvements. It could take months even years 
to build physical prototypes and testing could be 
hazardous to the operator. 
The prototype to the right was the forerunner of 
the Harrier /AV8B ‘jump’ jet. The air intake ‘cuffs’ 
are evidence of significant changes made as a 
result of testing and before production started. A 
prototype harrier crashed at the Farnborough air 
show in front of large crowds. 

 
www.wikepedia.org 

 
 

A major advantage of computer modeling 
is the ability to test and evaluate virtual 
designs in 3D. This reduces the time and 
material costs of making physical 
prototypes. 
Analysis tools in 3D modeling software 
are developing all the time and the 
following tests have been developed for 
Creo Parametric models of Scalextric 
cars.  

 
Creo Parametric has extensive measurement and analysis tools and these can be used 
to evaluate the virtual model to assess how well it might perform before making and testing 
a physical prototype.  There are obvious benefits in doing this including faster 
development of design variations and reduced cost of materials and manufacture. 
The analyses covered here include: 
Static measurements: 

• Mass and center of gravity (C of G) 

• Frontal area 
 
Dynamic analyses: 

• The effect of center of gravity on lateral stability 

• Acceleration in a straight line 
 
Creo Parametric models 
Several simulations have been created based on the standard car model.  These should 
help you learn about the science and math of movement and help you understand how to 
design a faster and more efficient car. 

http://www.wikepedia.org/
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The Creo Parametric models for these analyses can be downloaded from the challenge 
web site at: www.scalextric4schools.org  
 

Task 1: Mass/C of G measurement 
The mass of a design will have a major impact on acceleration.  A lighter car will 
accelerate faster than a heavy car providing the wheels do not spin.  Most racing formulae 
restrict the mass of a car usually with a lower limit to make sure designers do not reduce 
the mass to the point that the structure is not strong enough to protect the driver. 
 
1. Getting started 

• If necessary, start Creo 
Parametric. 

• Set the Working Directory to the 
location for your tutorial models. 

2. Opening an assembly: 

• From the Home tab or Quick 
Access toolbar, click Open  

• Select 2013_S4S_ANALYSIS.ASM 
and click Open. 

3. Analyzing the mass properties: 

• From the Analysis tab, Model 
Report group, select Mass 
Properties from the Mass 
Properties types drop-down menu. 

• In the Mass Properties dialog box 
click Compute  to run the 
analysis. 

The dialog box now shows the mass 
properties and coordinates for the center 
of gravity. 

 
 

In this example the mass is reported as 9.5142 e-02 KILOGRAM which is 95 g. 
While the Mass Properties are displayed in the 
dialog box, the model will display two sets of 
coordinates.  The XYZ coordinate system at 
the center of the rear axle is the default for the 
assembly and is used as a reference to report 
the center of gravity for the entire model.  

• Rotate and zoom the model to examine 
where the C of G is located. 

• From the Mass Properties dialog box 
click  to cancel and close the Mass 
Properties dialog box. 

 

 

http://www.scalextric4schools.org/
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4. Close the model and erase parts from memory. 

• DO NOT save the model. 
• From the Quick Access toolbar, click Close. 
• From the Home tab, Data group, click Erase Not Displayed. 

 
You may want to try out some of the following items. 
Mass 

• Open Z_BODY.PRT. 

• Check the material e.g. plastic_hips.mtl and note it’s density. 

• Carry out mass measurement. 

• Change material to polyethylene – and note its density. 

• Carry out another mass measurement. 

• Compare the results and densities between the two models. 

• What would be the effect of using one of the following materials? 
o acetal, acrylic, nylon, polycarbonate. 

• You may need to look on the web for the densities of some of these materials. 
www.matweb.com  
 
Design hint: Reduce the mass of your car by removing material where it is not needed.  
Move heavy components as low as possible and reduce the overall height of the car as 
much as possible. 
 
Density 

• Find the density of a material by experiment 

• Predict the impact on performance of using the new material. 

• Make the changes to your model then take measurements of mass. 

• Interpret the results in terms of performance. 

• Use your conclusions to prompt further changes to your design. 
 

  

http://www.matweb.com/
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Task 2: Frontal area 
A key factor in car performance is the size of the “hole” the car makes as it travels through 
the air.  The term “frontal area” is used to describe this and Creo Parametric has a 
Shadow tool that we can use to measure frontal area. 
 
Shadow analysis 
1. Opening the shadow analysis model. 

• From the Quick Access toolbar or the Home tab, click 
Open . 

• Select 2013_S4S_ANALYSIS.ASM 
• In the model tree, right click on the Fill_1 feature and 

click unhide from the floating menu. 
2. Shadow analysis 

• From the Analysis tab, Inspect Geometry group, select 
Shadow from the Inspect Geometry drop-down menu. 

• Select the purple surface behind the car. 
• In the Shadow dialog box, select the Model field and, in 

the model tree, select 2013_S4S_ANALYSIS.ASM 
• In the Shadow dialog box, select the Direction field and 

then select the surface behind the car.  
 

• Click on the magenta arrow in the graphics area to reverse the direction for 
projection. 

You are now seeing the shadow on the surface behind the car. The dialog box will show 
the area of the shadow and the percentage of the surface that the shadow fills. 
This analysis shows the size of the hole that the car is making in the air as it travels along. 

  
• Click  to close the Shadow dialog box. 
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3. Closing the model and erasing parts from memory: 

• DO NOT save the model. 

• From the Quick Access toolbar click Close  . 

• From the Home tab, Data group, click Erase Not Displayed  . 
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Task 3: Center of gravity and stability 
Center of gravity is an imaginary location where all the mass of an object can be 
considered to act.  The position of the center of gravity will determine how well the car will 
go around corners. 
 
Cornering 
The slot guide steers the front of the car round the corner while friction between the rear 
wheels and the track keeps the car from sliding or spinning.  Analyses have been provided 
for you to experiment with. 
 
Effect of C of G on cornering 
Remember the cartoon in the Design 
Guide showing a bus being tilted on a 
platform until it falls over?   
Here is the real thing. The test for double 
decker buses in London was a 28 degree 
tilt.  All four tires must remain in contact 
with the platform at this angle. 
Notice the sloping wall to catch the bus if 
it begins to tilt! 

http://www.20thcenturylondon.org.uk/ 

 
 

An assembly has been created with the 
standard car ‘hinged’ to the track by the 
edge of the tire. Using the mechanism 
module in Creo Parametric, gravity is 
applied and the track is gradually tilted.   
When gravity acting at the center of 
gravity falls outside the wheelbase the 
model tips over.  
 

 
 

From this we can infer a tall car will be more likely to topple over so we will analyze the 
design by gradually tipping the track until the car falls over.  The track angle gives an 
accurate guide to how stable a car will be. 
1. Starting Creo and setting the working directory: 

• If necessary, start Creo Parametric. 
• From the Home tab, Data group, click Select Working Directory . 
• Navigate to the folder 2013_S4S_Car. 
• Click OK to set the folder as the working directory. 

 

http://www.20thcenturylondon.org.uk/
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2. Opening the analysis model: 

• From the Quick Access toolbar or the 
Home tab, click Open . 

• Select C_OF_G_TILT.ASM and click 
Open. 
 

 
 

You will be looking at the front of the car sitting on a section of track. 
 

3. Running an analysis: 

• From the Applications tab, Motion group, select 
Mechanism. 

• In the Mechanism tree on the left side of the screen, 
expand the ANALYSES sub-heading. 

• Right click on C_OF_G_TILT (DYNAMICS) and, select 
Run from the pop-up menu. 

The analysis applies gravity to the model and then runs the 
servo motor which tilts the track. 

 
 

4. Play back the analysis 

• Once the analysis has finished, expand the 
PLAYBACKS sub-heading. 

• Right click on the C_OF_G_TILT playback feature 
and, select Play from the pop-up menu,. 

• Use the playback controls to view the analysis. 
• Pause the movement at the instant the car begins to 

tip. 
 

 
 
5. Taking measurements from the model: 

• From the Analysis tab, Measure group, select Angle 
form the Measure drop-down menu. 

• In the model tree click ASM_TOP, hold Ctrl and then 
select the underside of the track. 
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• Record the angle shown in the graphics area 
next to the track. 

 
6. Close the model 

• From the Quick Access toolbar, click Close 
. 

• From the Home tab, Data group, click Erase 

Not Displayed .  
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Task 4: Acceleration 
1. Starting Creo and setting the working directory: 

• If necessary, start Creo Parametric. 
• From the Home tab, Data group, click Select Working Directory. 
• Navigate to the folder 2013_S4S_Car. 
• Click OK to set the folder as the working directory. 

 
2. Opening the analysis model: 

• Open the assembly ACCELERATION.ASM. 
• Zoom to view the model like this. 

 

  
 
3. Running the analysis: 

• From the Applications tab, Motion group select 
Mechanism. 

• In the Mechanism tree, expand the ANALYSES 
sub-heading. 

• Right click on ACCELERATION (DYNAMICS) 
and select Run from the pop-up menu. 

 

 
 

4. Playing back the analysis 

• Once the analysis has finished, expand the 
PLAYBACKS sub-heading, right click the 
ACCELERATION feature and click Play from the 
pop-up menu. 

• Use the playback controls to view the analysis. 
• While the playback is running rotate and zoom 

the model to inspect the behavior more closely.  
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Task 5: Coefficient of friction 
A cam connection links each of the rear wheels of the car to the track surface.  These cam 
connections contain properties for coefficient of restitution and friction.   
To make the analysis realistic it is important that the correct values are used for these 
properties. The next step is to find the coefficient of friction between the tires and the 
surface of the track.  
 
Coefficient of friction is an empirical 
value and therefore can only be found 
by experiment. In the picture shown to 
the right, the car is being pulled along 
the track using a force meter. 
The experiment came up with a pulling 
force of 0.053 Newtons 
 

 

Example 
Mass of Slot car=0.085 kg 
 Weight = Mass x gravity 
 Weight = 0.085 x 9.81 
 Weight (FN) = 0.083 Newtons 
 
 Pulling force (Ff) = 0.053 Newtons 
 

Your calculations 
Mass of Slot car=       kg 
 Weight = Mass x gravity 
 Weight =      x 9.81 
 Weight (FN) =         Newtons 
 
 Pulling force (Ff) =         Newtons 
 

Coefficient of Friction (µ) 
 Ff = µ x FN 
 0.053 = µ x 0.083 
 0.053 = µ 
 0.083 
 0.64 = µ 

Coefficient of Friction (µ) 
 Ff = µ x FN 
  = µ x  
           = µ 
  
  =µ 

 
Design guide: Increase tire friction, reduce bearing friction. 
  

Mass (m) Pulling force (Ff) 

Weight (FN) 
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5. Changing the analysis 

• In the mechanism tree, expand the 
CONNECTIONS sub-heading and then the 
CAMS sub-heading. 

• Click on Cam Follower 1 (ACCELERATION) 
and, select Edit Definition from the pop-up 
menu. 

• In the Cam-Follower… connection definition 
dialog box, click the Properties tab. 

• Enter the value you have derived for coefficient 
of friction into the two fields shown outlined in 
red. 

  
• Click OK to finish editing  the cam follower connection definition. 

 
6. Re-run the analysis. 

• Run the ACCELERATION (DYNAMICS) analysis again and use the playback 
controls to examine the results of the new analysis.   

 
7. Conclusions 

• Explain any differences in the two analyses. 
 
Design hint: Match gearing to each track.  For example, you may want low gearing for 
acceleration on tight, twisty circuits or high gearing for high speed circuits.   
 
Aim:  The motor should be running at maximum rpm at fastest part of circuit. 
 
Design guide:  Tires with sharp edges are less likely to slide but may suddenly ‘dig in’ 
making the car roll out of the slot.  A crashed car loses lots of time so enthusiasts radius 
the edges of the rear tires to stop them digging in allowing the car to slide or drift around 
corners. 
 
Further analyses/simulations 
Here are other analyses Creo Parametric would allow you to apply to your design.   

• Gearing - Change the gear ratio and re-run the acceleration analysis. 

• Cornering static – For C of G stability but with the tires free to slip on the track 
surface. 

• Cornering dynamic – All points of contact assembly connection allows the slot 
guide to release and shows the car tumbling off the track.  See video 
Scalextric4Schools-W5.wmv 
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• Hill climb – For acceleration but with the track at increasing angles until the driving 
wheels spin or the car tips over backwards. 

 Setting up analyses from scratch is an advanced technique. Detailed guidance can 
be found in Precision LMS courses on mechanism dynamics. 

 

 
 
Teachers and instructors using Creo 
Parametric can register to use PTC 
University – Precision LMS, a 
comprehensive range of online 
tutorials covering most of the features 
in this software.  
Once registered, your instructor can 
allow students to access the 
materials. 
This is an excellent way for you to 
learn Creo Parametric from the 
professionals.  
 

 
 

Each unit of material is organized into  

• Concept – The learning goals of the unit including animated images and audio-
visual presentation. 

• Demonstration – An on-screen video recording with commentary by an expert user 
of Creo Parametric. This can be paused and replayed as often as you like.  Where 
appropriate there are Creo Parametric files you can download and work with 
alongside the tutorials. 

• Procedure – Step by step text tutorial with animated illustrations explaining every 
action, dialog box and menu picks. 

 
Homework 
Have you ever thought about industrial designer as a career and what you would have to 
study to become one?  Read how Victoria became a designer, the subjects she studied at 
school and the work she did at university to land a job at Hornby designing the Scalextric 
cars you can buy in toy stores around the world.  
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Session eight: Presentation preparation 
Outline 
By the end of this session you will have started creating an electronic presentation 
showing how your design was developed.  Make sure you structure your presentation with 
evidence for all sections in the competition rules. 
To help you we will show you how to convert your body mold into a body shell and add it to 
an assembly.  Rendering the finished car will provide one of the images you will need for 
your presentation. 
 
Starter 
Your teacher will ask you questions about the career of product designer and the 
education route to become one. 
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Task 1: CAD modeling the vacuum formed body 
Outline 
Adding features to convert the body mold into a body shell is straightforward and involves 
re-instating the model tree and making changes to the order of features 
 
Convert mold to body shell 
Expert/Overview 
The following section will teach you how to convert 
the body mold into a body shell.  This involves: 

• Moving the Insert here flag above the mirror 
feature. 

• Shelling the half mold outside by 2 mm with 
the underside and center faces removed. 

• Move the Insert here flag to the bottom of 
the model tree.  

 
 
The result will be a body shell representing the 
vacuum formed component needed to complete 
the assembly. 
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 After adding features to convert your mold into a body, at any time can switch 
between the two by suppressing additional features as shown below. 

 
 

Model tree Model view 

 
 

 

 

 

 

Suppressed 
Features 
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Step by Step 
1. Getting started. 

• If necessary, start Creo Parametric.  
• Set the Working Directory to where 

your Scalextric4Schools models are 
stored. 

2. Making a copy of your mold part 

• Open the body mold you created 
previously. 

• Click File > Save As > Save a 
Copy. 

• In the Save a Copy dialog box, New 
Name field, type 
BODY_SHELL.PRT and click OK.   

• Close BODY.PRT 
• Erase Not Displayed 
• Open BODYSHELL.PRT. 

 

 
 

3. Moving the “Insert Here” flag: 

• In the model tree, drag the Insert 
here flag above the mirror feature. 

 

 
 

4. Adding a shell feature: 

• From the Model tab, Engineering group, click Shell . 

• In the Shell tab, change the Thickness X1 to 2 and click X2 Change Direction , 
to shell the model externally. 
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When the shell is external, the orange 
preview will be visible outside the model. 

 
 

• Rotate the model so you can see the 
center and bottom faces. 

• Hold CTRL and select the bottom 
and center faces of the model.  

These surfaces will be shown removed 
from the shelled shape. 

 
 

• In the Shell tab click Complete 

Feature . 
 

 
 

 
5. Move the “Insert Here” flag to 

reinstate features. 

• In the model tree, drag the Insert 
Here flag to the bottom of the model 
tree. 

 
This reinstates the features in the model. 
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The model will regenerate, mirroring the 
extra features. You should now have a 
symmetrical car body with wheel arches. 
 

• Save your model. 
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Task 2: Part properties 
While the shape of the body is complete, we still need to record other details to form a 
complete description of the part including a description, the project it forms part of, who 
created it and the material it is made of. 
 
1. Applying material 

properties 

• Click File > Prepare > 
Properties. 

• Next to the Materials 
entry, click change. 

 

 
 

• In Materials dialog box, 
select Plastic_HIPS 
and click Assign   

• If you see a message 
asking if you want to 
convert units, click OK. 

• Click OK in the 
Materials dialog box to 
close it.  

 
Creo Parametric has applied 
this material to the body. 
 

 
 

 For accurate analysis you should research the properties of actual vacuum 
forming sheets you will be using, create a new material definition and apply this to 
your model. 
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Part properties 
The next step is to assign non-geometric parameters to the part. 
The Model Properties dialog box 
should still be open. 
2. Adding text parameters 

• Next to Parameters click 
Change. 

• In the Parameter dialog box, fill 
in the values for 
DESCRIPTION, PROJECT 
and MODELLED_BY. 

• Click OK in the Parameters 
dialog box. 

• In the Model Properties dialog 
box, click Close. 

• Save your model and close the 
window. 

 

 the material parameter has been entered 
automatically. 

 

 
You should now be comfortable using Creo Parametric to model a body shape ready for 
when you design your own car shape. 
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Task 3: Add body shell to the assembly 
1. Getting started: 

• Open the model 
2013_S4S_HATCH.ASM  

• Hide any mold or body components 
that may be visible. 

 
2. Adding a new component to the 

assembly:  
 

• From the Model tab, 
Component group, click 
Assemble  to add a new 
part. 

• In the Open dialog box select 
BODYSHELL.PRT and click 
Open. 

  
 

 
The part will appear in the model window 
attached to your cursor. 

• Move the mouse until the body shell is 
close to where it needs to be placed. 

• Click to place the part temporarily. 

 

 
 

 
The mouse cursor will be released 
from the part and the 3D Dragger 
will appear.  
If the body is not close to its final 
position, use the dragger arrows to 
move it close but with a small gap 
as shown here.  

 



Creo  2.0  Scalextric4Schools 

PTC – www.ptc.com www.scalextric4schools.org page 71 of 90 

Three pairs of surfaces will each 
be linked with a Coincident 
assembly constraint. 
3. Create the first assembly 

constraint: 

• Click to select the top surface 
of the chassis base at X1. 

• Click the inside surface of the 
front step on the body at X2. 

As the mate constraint is applied, 
the body will move until the 
selected surfaces are coincident. 
 

 
 

4. Create a second assembly 
constraint 

• Use the Dragger to move the 
body shell slightly forward of 
its final position. 

• Select the front face of the 
chassis at X1. 

• Select the vertical face inside 
the front of the body at X2. 

The body will move rearwards to 
mate the two surfaces creating 
another Coincident constraint. 

 
 

5. Adding a third assembly 
constraint. 

• Use dragger to move the 
body to the side, leaving a 
gap so that it is easier to 
select the final pair of 
surfaces. 

• Select the side of the chassis 
at X1. 

• Select the inside face of the 
body side at X2. 
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The body will move sideways and 
change to a yellow color to show that 
it is now Fully Constrained.  
Labels show the type and position of 
the assembly constraints. 
 

 
 

The Placement tab at the bottom edge 
of the Assembly dashboard is where 
the constraints and surface selections 
are recorded.  You can edit the 
constraints in the Placement tab. 

• In the assembly dashboard, click 
Complete Assembly  to 
finish adding the body to the 
assembly. 

• Save your model, Close the 
Window and Erase Not 
Displayed. 
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Extensions 
 
By creating additional features, you can 
make your model more realistic. 
 
Extrude sketches a small depth removing 
material to create recesses for windows. 
 

 
 

 
Project a sketch onto the car surfaces and 
then “Sweep” a small circle along the 
projected spline.   
This technique has been used here to 
create a “shut” line around the headlight. 

 
 

 
Homework six - Industrial designer 
The job of product designer is well paid and varied.  If you would like to know more about 
becoming a designer you may be interested in the story of Victoria, one of the Scalextric 
designers.  Her story is in the ‘Design Guide’ for this project. 
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Session nine: Visualizing 
Creo Parametric has a wide range of powerful tools for presenting your design. 
 
Rendered CAD model 
Creo Parametric is supplied with a set of 
fully featured rendering tools allowing you 
to create a photo-realistic image of your 
design. 
In this section you will be taught how to 
apply textures and graphics to parts and 
present them as finished image. 

 
 
Key principles 
The Advanced Rendering Extension (ARX) module in Creo Parametric is very powerful 
with many adjustments to the room environment such as materials, lighting and reflections 
possible. 
This session will provide a brief overview and hands-on experience of just a few features, 
enough to produce a final rendered image of your slot car assembly. 
The sequence you will work through is: 

• Apply an appearance to the surface of your car body 

• Apply a logo graphic to surfaces on your car body 

• Open your slot car assembly 

• Define initial render settings 

• Load a scene definition 

• Position the model in the room 

• Change the view of your model 

• Try a draft render 

• Make any adjustments. 

• Perform the final render 

• Save the rendered image 
 

 Making changes to the features of a model that has appearances and decals 
applied can lose them. Delay rendering your model until you are happy it won’t 
need any changes to the shape. 
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Task 1: Applying textures 
Applying appearances is very 
straightforward and Creo 
Parametric comes with a comprehensive 
library of material appearances. 
1. Getting started: 

• If necessary, start Creo Parametric  
• Open BODYSHELL.PRT. 

 
 

2. Applying an appearance to the model. 

• From the Render tab, Appearance group, open 
the Appearance Gallery drop-down menu. 

• In the Library section X1, select a category of 
material appearances.   

To the right, a library of spray painted textures is shown.  

• In the library section of the Appearance Gallery 
drop-down menu, click ADV-PAINT-SPRAY.DMT 
at X2 to open the list of spray painted 
appearances. 

• Select one of the colors shown in the Library 
section.   

  
When a selection is made, the drop down menu will 

close, the mouse cursor will change to a paintbrush  
and, the Select dialog box will open in the top right of 
the screen. 

• Select BODYSHEL.PRT at the top of the model 
tree. 

• You can either middle-click or, click OK in the 
Select dialog box to finish applying the 
appearance. 
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The model will be colored with the new 
appearance on all surfaces. 

• Save your model, Close the Window and 
Erase Not Displayed. 
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Task 2: Sponsorship and logos 
In motor sport it is common to sell advertising space on cars.  The cost to sponsors 
depends on how visible the spaces are to spectators and TV coverage.  Which surfaces of 
your car do you think will be worth the most? 
The following organizations already sponsor this challenge with curriculum, branding and 
resources.  The competition rules dictate you must have their logos on your car at the 
sizes shown. 
  
Global sponsors 

  
16mm x 6mm 18mm x 4mm 

 

 

12mm x 8mm  

 
Regional sponsors – UK 

 
 

10mm x 10mm 
 

12mm x 14mm 
 

  
18mm x 5mm 

 
18mm x 8mm 

 

 
 

18mm x 9mm 18mm x 5mm 
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Regional sponsors - Australia 

 
 

12mm x 12mm 
 

12mm x 12mm 
 

 
 

10mm x 14mm 
 

12mm x 8mm 
 

 

 

13mm x 7mm  

 
Regional sponsors – North America 

Add here Add here 
12mm x 12mm 

 
12mm x 12mm 

 
 
Are they all the same size?  The logos are all different proportions so how would you 
measure the amount of space each one has.  Would you include the white spaces? 
What mathematical techniques could you use to measure the area of each logo?   
Sponsors will want proof their logos are the correct size. 
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Creating a decal from a logo 
Where logos are not rectangular it’s important to make the background color transparent. 
In this example the white background obscures the teal color on the body. 

 
 

 

 
You will need a bit map file of an image with an alpha channel layer of the masked area.   
A guide to editing an image using Paint Shop Pro is available at:  
http://www.axialis.com/tutorials/tutorial-misc002.html  
 
 
 
This example uses a PNG format 
image of the PTC Logo. 
 

 
 
 

 
After conversion, the surrounding 
‘transparent’ or masked area is shown 
as a checker board in the editing 
software.  
 
The checker board pattern shows where the transparency will apply around the lettering. 
Two versions of the PTC logo are available for you to practice with 

• PTC_LOGO_ON_WHITE.PNG 
• PTC_LOGO_GRAY_ALPHA.PNG 

 

  

 

http://www.axialis.com/tutorials/tutorial-misc002.html
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Task 3: Applying a decal 
Expert/Overview 
Applying a decal to a model is straightforward. 

• A material texture is applied to the model. 
• A copy of the material texture is made and the decal applied to this copy. 
• The new material texture with the decal is applied to selected surfaces on the 

model.  
• The decal placement is altered to rotate and position the decal. 

 
1. Getting started 

• Start Creo Parametric. 
• Set Working Directory to where your models are 

saved. 
• Open BODYSHELL.PRT. 
• If it is needed, a file named BODY_RENDER.PRT is 

available for this exercise. 

 

 One of the standard Creo Parametric textures has 
been applied to the body and the default gray textures 
to the windows. 

 
 
2. From the Render tab, Appearance group, open the 

Appearance Gallery drop-down list and click 
Appearances Manager at X1. 

 

 
 

Appearances Manager is where you add, delete and modify material appearances for your 
model.  You will make a copy of the texture that has been applied to the model then add a bit 
map image to the new texture. 
The Model section of the dialog box lists the materials that have already been applied to the 
model.  
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3. Making a copy of a texture 

• Right click on the Teal model 
appearance at X1 and, click Copy to 
My Appearances from the drop-down 
menu. 

The new material will be listed in the My 
Appearances section. 

• Right click on the new appearance and 
click New from the pop-up menu. 

 

 
 
 

• Type a new name at X1 for the material 
using a name which identifies the parent 
texture and the decal used. 

 
4. Adding a decal 

• Click to open the Map tab. 
• In the Decal drop-down list at X2 select 

Image.  
• Click on the white square at X3.  
• In the Open dialog box, Common 

Folders list, click Working Directory 
and from the list of files, select 
PTC_LOGO_APLPHA.png. 

• Click Open. 
 
5. Saving Appearances 
You must save the new list of appearances to 
make sure the new texture is available next 
time the model is opened. 

• In the Appearances Manager, click File 
> Save As… 

• From the Common Folders list select 
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Working Directory and click OK.    
• In the Save dialog box, click to select 

the Working Directory then click OK to 
save the list of appearances in the 
model. 

• Close the Appearance Manager. 
 
The appearance with the PTC logo can now be applied wherever the decal is required.  
 
6. Apply the new decal texture 

• From the Render tab, open the 
Appearance Gallery and select the 
texture with the logo you just created. 

The Appearance Gallery will close 
automatically and the screen cursor 
changes to a paint brush. 

• Move the mouse cursor over the 
surface you want the logo to appear 
on and click to select it. 

• Middle click to finish applying the 
appearance to the model. 

• Save your model. 

 
 

 
When an appearance with decal is first applied to the model it is highly unlikely it will be 
scaled or positioned correctly.  Creo Parametric provides tools to refine the size and 
orientation of decals. 
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7. Scale and position the decal 

• Open the Appearance Gallery drop-down menu. 
• Click Edit Model Appearances. 
• Near the top of the dialog box at X1, click on the 

Eye Dropper  and use it to select the decal 
surface to be edited. 

• In the Model Appearance Editor dialog box, click on 
the Map tab. 

• In the Decal section click on  at X3 to open the 
Edit Decal Placement dialog box. 

 
 

 
 

• In the Edit Decal placement dialog box, Copies 
section, select Single X1. 

• Use the Repeat spin wheels at X2 to scale the 
decal and the Position spin wheels at X3 to move 
and/or rotate the decal. 

• When you are happy with the decal placement, click 
OK in the Decal Placement dialog box and click 
Close in the Model Appearances Editor dialog box. 

8. Repeat the scale and position steps on each decal 
surface. 

 
9. Save the model. 
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Task 4: Final render 
1. Getting started. 

• If necessary, start Creo Parametric. 
• Set the working directory to where you files are stored. 
• Open 2013_S4S_HATCH.ASM. 

 
2. Adding a scene 

• From the Render tab, Scene group, click Scene . 
• In the Scenes dialog box, scroll in the Scene Gallery 

section to find the photolux-studio-hard scene and 
double click to apply it to the model. 

• Select the Save scene with model option X1  
 
A ‘Scene’ stores information about several aspects of the 
render including the size and shape of the room, textures on 
room surfaces, lighting and special effects. 
 

3. Aligning the floor with the model. 

• In the Scenes dialog box, select the Room tab at X2. 

 
 

• Click on Align Floor  at X1 to snap the floor to the 
model. 

If you rotate the model you will see the floor has attached 
itself to the bottom of the slot guide. We want it to be just 
touching the wheels. 

• Drag the Floor spin wheel at X2 to move the floor up.  If 
needed, type in numbers for fine adjustment. 

 
• Click Close to finish with the Scenes dialog box. 
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4. Adding perspective 

• From the Render tab, Perspective group click 

Perspective . 
• Click the small arrow next to the Perspective group 

and select Perspective Settings from the drop-
down menu. 

• Move the Eye Distance slider to see how this 
changes the amount of perspective. 

• When you are satisfied with the perspective settings, 
click OK to close the Perspective dialog box. 

Photographers will recognize the effect which is similar to 
the distortion caused by lenses of different focal length. 
 

 
 

 
5. Positioning the model: 

• Spin and zoom the model to position 
the car how you want to see it. 

 

 
 
6. Quick render: 

• From the Render tab, Render group 
select Render Window . 

 
Why do you think a tea pot has been used 
for this tool?   
Depending on the speed of your PC, the 
render may take a little while.  
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7. Higher quality render: 

• When you are happy with the overall appearance of 

your model, click Render Setup  and change the 
Quality to Maximum. 

• Close the Render Setup dialog box and render the 
model again. 

This may take some time but the result should be much 
more realistic. 

 

 

Try out different settings. 
Here the Scene was changed to Photolux- 
studio_soft, the floor was reset to the 
bottom of the tires and the quality was 
increased to maximum. 
If you want to find out more about render 
settings your teacher has access to a more 
detailed guide. 
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Graphic design 
Professional racing teams have full-time 
designers working on car graphics, promotional 
materials and branding. 
The base color schemes on full scale cars is 
spray painted. 
Company logos, text and images are then 
applied using vinyl decals/stickers.   
 

 

 

 
Many schools have computer controlled vinyl 
cutters.   
This would work fine for go-faster stripes and 
large text but fine detail is not easy to create 
and apply using knife cut vinyl. 
 

Water -slide transfer material is ideal for putting 
detail on your car bodies.  Simply print your graphics 
on the sheet, cut round the graphic, soak in warm 
water, then slide the graphic on to the model.   
It works best on flat surfaces or ones with a single 
curvature. 
Available from Magic Touch - 
http://www.themagictouch.co.uk/transfer/dct.htm  
 

 

 
  

http://www.themagictouch.co.uk/transfer/dct.htm
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Session ten: Races 
Track 
The Scalextric4Schools track layout was designed specifically by Scalextric with tight 
curves and fast straights to test cars and drivers to the limit. 

 
 
The track pack comes with two speed controllers and a power supply can be purchased 
online with education discount. www.scalextric4schools.org. 
A Creo Parametric model of the Challenge track layout is available to download on the 
challenge web site.  
 
You can also download the track design in 
the format used by Scalextric ‘Track 
Designer software.   
Scalextric ‘Track Designer’ software can be 
downloaded free from the Scalextric web 
site at www.scalextric.com. 
 

 
 
When testing your cars, make sure you carry out ‘fair tests’.  Your instructor/teacher will be 
able to explain this and help you use testing to identify aspects of your design you could 
modify and improve. 
In certain regions competitions will be organized by PTC, Scalextric or their partners using 
the Scalextric4Schools ‘Sport’ track layout. 

http://www.scalextric4schools.org/
http://www.scalextric.com/
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Session eleven: Presentation 
This is an opportunity for your team to present the story of your design, how it developed 
and how well it performs. 
 
Good luck! 
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Appendix: Car design template 
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