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About This Guide
The Windchill Workgroup Manager for Creo Illustrate Administrator’s
and User’s Guide describes how to configure and use Creo Illustrate with
Windchill Workgroup Manager.
This guide is designed to provide the information you need in an easy-to-use
format. General scenarios and specific Creo Illustrate examples are intended to
provide useful recommendations as you work with Windchill Workgroup Manager.
The information in this chapter details how the guide is set up, its content flow, and
summarizes the content, and intended audience, for each chapter.

Guide Structure
The contents of this guide are presented in sequential order so that, should you
read the guide from cover-to-cover, you get the full, comprehensive view of
Windchill Workgroup Manager and its interaction with Creo Illustrate. However,
each chapter is written in standalone sections that are intended to be read and
understood on their own. Sections are not dependent upon other areas of the guide
for understanding a concept or task, so the time you spend reading the guide should
be more efficient. If you want to learn more information on a particular subject,
hyperlinks are available in most sections to take you to related subjects.

Guide Content Flow
The guide begins with the installation process and the necessary steps to register
Creo Illustrate with Windchill Workgroup Manager and connect to the Windchill
server. The next chapter presents the basics of Windchill Workgroup Manager,
explaining what it is and how it relates to Creo Illustrate.
The next chapter discusses details of using the product data management actions
that are available to Creo Illustrate users with the Windchill Workgroup Manager,
and that chapter is followed by a discussion of advanced user techniques, such as
working with external references and resolving conflicts.
Toward the end of the guide are more reference-oriented chapters. The next
chapter explains how to set up preferences on the server and the client. This
chapter is beneficial to both administrators and users. The final chapter presents
administration and configuration information for administrative users.
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Where to Start
This section describes where to start using the guide. If you have limited or
no experience with Windchill, you should start with the Overview and the
Using Workspaces chapters, which describe the system architecture and basic
Windchill concepts. If you have previous experience with Windchill, and feel very
comfortable working with it, you can start with the Getting Started chapter, to
reacquaint yourself with familiar PDM actions.
The intended audience is described as follows.
•

Novice — No or little Windchill experience

•

Experienced — Experienced with Windchill and understands product data

management concepts
•

Administrator — Experienced with configuring Windchill

The following table can be used to quickly understand what audience the chapters
in this guide are intended.
Chapter
How to Use This Guide

User
Definition
Describes guide contents, Novice, Experienced
purpose, navigation,
access to online help,
related documentation and
technical support.

Installing Windchill
Workgroup Manager
Windchill Workgroup
Manager Overview

Describes installing the
client.
Describes
Windchill Workgroup
Manager system
architecture.
Describes connecting to
Windchill, registering
servers and CAD
applications, workspaces.
Describes using PDM
actions.
Describes working with
Families, External
References, Drawings,
and managing cache.

Getting Started with

PDM Actions
Advanced Techniques
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Novice, Experienced,
Administrator
Novice, Experienced

Novice, Experienced,
Administrator

Novice, Experienced
Experienced
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Chapter
Client and Server
Preferences
Administration and
Configuration

Definition
Describes setting up
preferences on the client
and server.
Describes configuring the
CAD application with
Windchill, and Windchill
management

User
Novice, Experienced,
Administrator
Administrator

Related Documentation
Documentation related to this products is available under Windchill Workgroup
Manager for Creo Illustrate in the Windchill Workgroup Manager Help Center.
If documentation is not installed on your system, see your system administrator.

Technical Support
Contact PTC Technical Support through the PTC website, or by phone, email, or
fax if you encounter problems using this product or the product documentation.
For complete details, see the PTC Customer Service Guide. You can find this guide
under Contacting Technical Support on the PTC Technical Support page:
http://www.ptc.com/support/index.htm
You must have a Service Contract Number (SCN) before you can receive technical
support. If you do not have an SCN, contact the PTC Maintenance Department
using the instructions found in the PTC Customer Service Guide or on the PTC
Technical Support page.

Documentation for PTC Products
You can access PTC documentation using the following resources:
•

Windchill Help Center—The Windchill Help Center is an online knowledge

base that includes a comprehensive index of all Windchill documentation. You
can browse the entire Windchill documentation set, or use the search capability
to perform a keyword search. To access the help center, you can:
○ Click any help icon

in Windchill

○ Select Help ▶ Windchill Help Center from the Quick Links menu at the top
right of any Windchill page
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○ Use the following link to access all PTC help centers:
https://www.ptc.com/appserver/cs/help/help.jsp
•

Reference Documents Website—The Reference Documents website is a library

of all PTC guides:
http://www.ptc.com/appserver/cs/doc/refdoc.jsp
A Service Contract Number (SCN) is required to access the PTC documentation
from the Reference Documents website. For more information on SCNs, see the
PTC Technical Support page:
http://www.ptc.com/support/index.htm

Comments
PTC welcomes your suggestions and comments on its documentation. To submit
your feedback, you can:
•

Send an email to documentation@ptc.com. Include the name of the application
and its release number with your comments. If your comments are about a
specific help topic or book, include the title.

•

Click the PTC help center feedback icon
in the upper right of a Windchill
Help Center topic and complete the feedback form. The help topic title is
automatically included with your feedback.
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This section describes how to install and configure, and uninstall the
Windchill Workgroup Manager client software.
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Overview
In addition to the Windchill Workgroup Manager client software installation is the
Windchill Workgroup Manager server installation.
The Windchill Workgroup Manager client software must connect to a Windchill
server that includes the Windchill Workgroup Manager server installation.
The Windchill Workgroup Manager server installation is typically performed by
a Systems Administrator. This procedure is performed using the PTC Solutions
Installer and is documented in the Windchill Installation and Configuration Guide
and in the Windchill Help Center under Installation and Upgrade.
Other mandatory server installation steps after installing the
Windchill Workgroup Manager server installation are “Configuring the Worker,”
and the “Post-Install Configuration of the Worker on Windows” sections in
the Windchill System Administrator's Guide in order to create the system-level
environment variables noted in the section.
•

The system environment variable for the PTC Virtual File System (VFS), that
is installed during the Windchill Workgroup Manager client installation, is
PTC_VFS_INTALL_DIR. This variable allows the user to install VFS at the
specified location for the Windchill Workgroup Manager client software.
Note
If you do not set the above variable, then during the
Windchill Workgroup Manager client software installation, VFS
will install at the default location “C:\ProgramFiles\PTC\VFS,” rather than
the specified Windchill Workgroup Manager client software location.

•

Other system environment variables must be set before installing the
Windchill Workgroup Manager client software:
○ PTC_VFS_ROOT=<any local directory>
○ PTC_WLD_ROOT=<any local directory>
Note
If you do not set the above variables, then during the
Windchill Workgroup Manager client software installation, the folders “.ws”
and “.vfs” are created under <local drive>\<Users>\<user>\.wwgm. If the
“.wwgm” folder becomes created under the network drive, it will cause a
conflict.

Refer to the Windchill System Administrator's Guide, available at the PTC
Document Reference Site for more information.

10
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Installation and Configuration Steps
Follow the procedures in this section to:
•

Upgrade an existing Windchill Workgroup Manager client software installation

•

Install Windchill Workgroup Manager client software for the first time.

Upgrading From a Prior Release of Windchill Workgroup Manager
Follow the steps below to upgrade your current client installation.
1. Verify that all files are checked in. (IMPORTANT! To prevent data loss, all
files must be checked in before you continue.)
2. Launch the Windchill Workgroup Manager client with administrator logon.
3. Unregister Creo Illustrate and all the registered
Windchill Workgroup Manager applications.
Note
See Unregistering an Application on page 23 for instructions.
4. Exit the Windchill Workgroup Manager client.
5. Stop the PTC VFS Controller service. Then uninstall the Windchill Virtual File
System (VFS) software. See Stopping the PTC VFS Controller Service and
Uninstalling Windchill Virtual File Service (VFS) on page 24.
6. Uninstall the existing Windchill Workgroup Manager client. See Uninstalling
Windchill Workgroup Manager Client on page 24.
7. Delete the remaining Windchill Workgroup Manager files and folders. See
Deleting Windchill Workgroup Manager Files and Folders on page 25.
8. Install the new version to the required location. See Installing the Windchill
Workgroup Manager Client and Windchill Virtual File System (VFS) on page
16.
9. Register the Creo Illustrate application. See Registering an Application on
page 21.
10. Register and connect to a Windchill server. See Registering the Windchill
Server on page 20.
11. Set the Connect to Windchill option in Creo Illustrate.
Installing Windchill Workgroup Manager Client For the First Time
This section describes the process for installing and getting
Windchill Workgroup Manager operational on a local computer.

Installation and Configuration
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The PTC Virtual File System (VFS) installation component is installed during the
Windchill Workgroup Manager client. VFS is necessary in order to browse to PTC
Places where you can perform various Windchill PDM actions, in addition to the
Windchill PDM Actions that can be performed from within Creo Illustrate.
Note
The installation of the Windchill Workgroup Manager client with the PTC Virtual
File System component requires administrative privileges.
1. After the Windchill Workgroup Manager server installation and configuration
is completed, install the Windchill Workgroup Manager client in one of the
following ways:
Install Windchill Workgroup Manager client software as follows:
a. Download Windchill Workgroup Manager Client installer to your local
computer. Install Windchill Workgroup Manager client. See Installing the
Windchill Workgroup Manager Client and Windchill Virtual File System
(VFS) on page 16.
b. Install Windchill Workgroup Manager client using the redistributable
installer. See Redistributable Windchill Workgroup Manager Client
Installer on page 12.
Note
The Windchill Workgroup Manager client installation includes the PTC Virtual
File System installation. You must install the Windchill Workgroup Manager
client on your local drive. Do not install it on a network drive.
2. Configure the Virtual File System to allow access to PTC Places. See
Configuring the Windchill Virtual File System on page 19.
3. Register the Creo Illustrate application. See Registering an Application on
page 21.
4. Register and connect to a Windchill server. See Registering the Windchill
Server on page 20.

Redistributable Windchill Workgroup Manager
Client Installer
The Windchill Workgroup Manager Client can be downloaded for redistribution
rather than installed from the server. This feature will allow users to download
the installer without starting the install process. Administrators can then copy the
installation to a network location where it can be installed on multiple machines or
installed through a software deployment tool.
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1. Access the Software Downloads page from the Windchill Quick Links
drop-down list.
2. Select Windchill Workgroup Manager. The Installing Windchill Workgroup
Manager Client page launches.
3. Select Creating a redistributable Windchill Workgroup Manager installer.

4.

A new window will open to create the redistributable installation. Follow
the steps on the web page and enter the applicable information for each of
the fields.
•

Enter a location to output the installation image.

•

Ensure you have JRE 6.0, if not install or update to that version.

•

Download the ClientInstaller.jar file to a location on your local file system.

•

Enter the location to the local ClientInstaller.jar file.

•

Enter the path to the java executable file.

•

Select the Operating System used to build the image.

•

Enable build logging, if desired.

The above will enable you to create the redistributable installation. There
is also an option to create this install to be a silent deployment. The silent
deployment option will install with no UI or user inputs needed. The inputs will

Installation and Configuration
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be provided from the values provided in the fields. These fields will be stored in
a silent.properties file. Continue to the next step, to create a silent deployment.

5. Checking the Create image for silent (background) deployment box will display
the following fields to enter details about the client machines the Windchill
Workgroup Manager will be installed on.
Note
If “Installation Directory”, “Shortcuts Directory”, and “Path to the installer
image from deployment machine” are left blank, the default install locations
and the Java Virtual Machine supplied with the installer will be used).
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•

Select the Operating System of the machines the client will be deployed on.

•

Provide the path to the installation directory.

•

Provide the path to the shortcuts directory where application shortcuts
will be created.

•

Provide the path to the installer image accessible from the deployment
machine.

•

Provide the path to the java executable on the deployment machine.

6. Once you completed all required inputs, open a command prompt window and
copy the text under the Launch command: section into the command line. Run
the command to create the installer image.

7. The silent install portion is now complete. The silent install can be launched
using silent.bat located in <Install Directory>\CLIENT directory,
The installer is now created under the directory specified as the output location.
You may copy the installer to any location accessible from the client machines to
install the Windchill Workgroup Manager.

Installation and Configuration
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•

Normal install — The installation can be launched by running <output
directory>\CLIENT\setup.vbs

•

Silent non-user installation — If you entered details to create a silent
installation script, the silent installation can be launched using <output
dir>\CLIENT\silent.bat. This will install using the settings entered in the web
page above (stored in the silent.properties file) to perform the installation
silently with no user interface and without prompting the user for input. This
can be run either by end users or used by a software deployment tool to roll
out software to user machines.

Installing the Windchill Workgroup Manager Client
and Windchill Virtual File System (VFS)
After the system administrator has installed and configured
the Windchill Workgroup Manager server, download the
Windchill Workgroup Manager client installer to your local computer.
The Windchill Virtual File System (VFS) installs as part of the
Windchill Workgroup Manager client installation.
Use the following procedure to download the installer and install the client and
VFS.
Note
The Windchill Workgroup Manager client installation includes the PTC Virtual
File System installation. You must install the Windchill Workgroup Manager client
on your local drive. Do not install it on a network drive.
1. Access the Software Downloads page from the Windchill Quick Links
drop-down list.
2. Select Windchill Workgroup Manager. The Installing Windchill Workgroup
Manager Client page launches.
Note
If your Windchill System Administrator installed
Windchill Workgroup Manager support for more than one application, the
Installing Windchill Workgroup Manager Client page displays a link to
the Administrator's and User's guide for each of the supported Windchill
Workgroup Managers. You may want to save one or more of these guides
to your local computer before you start the installation process. To save
the guides, select the appropriate link to open its related PDF. Save the file
to your local computer. To save another guide, select the appropriate link
to open the desired PDF.
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3. Select Start Installation. The Windchill Workgroup Manager client installer
launches on your local computer and the installation process begins. The first
panel that appears is the PTC panel, indicating the language selected by the
System Administrator during the CD-to-server installation.
Note
If the installer does not start, select Troubleshooting Windchill Workgroup
Manager Client Installation and follow the troubleshooting instructions.
4. Select the appropriate language and select OK. The Before You Begin panel
appears.
5. Select Next. The Select Directory panel appears.
6. In the Select Directory panel, keep the default directory, or browse to the
desired installation directory on your computer, and select Next. A confirmation
window appears if the directory selected as the installation directory does not
exist on your local computer.
7. Select Yes to confirm that the client installation directory is correct. If it is not
correct, select No and browse to the appropriate directory.
8. Select Next to continue. For both Windows and Solaris, the Choose Shortcut
Folder panel appears.

Installation and Configuration
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9. Choose a shortcut directory and select Next. The Review Settings panel appears.

10. Review the install settings you just selected. Click Back to make corrections;
otherwise, select Install. The installation process begins.
The Installing Windchill Workgroup Manager panel displays a
progress bar to indicate the status of the installation. After the
Windchill Workgroup Manager client is installed, the Windchill Virtual System
(VFS) installation begins.
Note
Select Cancel to stop the installation.
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11. Once the installation is complete, the Installation Complete panel appears.

12. Select Done. The Windchill Workgroup Manager client and VFS are now
installed on your computer.

Configuring the Windchill Virtual File System
After the Windchill Workgroup Manager client is installed, the PTC Virtual File
System (VFS) executable file, PtcVfs.msi becomes located in the \wgm\installer
directory.
The PTC Virtual File System (VFS) installation component is necessary in order to
browse to PTC Places where you can perform various Windchill PDM actions,
in addition to the Windchill PDM Actions that can be performed from within
Creo Illustrate.
1. After the Windchill Workgroup Manager client and VFS installation is
complete, configure PTC Places.
a. Locate PTC Places Options in the control panel of your local machine.
Right-click to open PTC Places, or double-click on the file to open it.
b. In the PTC Places tab, set the folder location to the server accessible from
PTC Places. For example,
D:\User Profiles\<username>\PTC Places

Installation and Configuration
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c. The Server Registration tab isn’t used to register a Windchill server. Leave
this option blank.
Note
Server registration is performed from Windchill Workgroup Manager Server
Manager. See Registering a Server on page for additional information.
d. The Application Manager tab contains the updated applications values
as soon as the application is registered or unregistered from the
Windchill Workgroup Manager client. Do not attempt to update the
information contained in this tab because this option does not apply to
the VFS installation.

Registering the Windchill Server
Before Creo Illustrate can connect to Windchill, you must register a Windchill
server to the application and select a Windchill workspace.
After registration, you can run Creo Illustrate, click Connect to Windchill, and then
manage your illustration files in the selected workspace.
Caution
If you do not register a Windchill server to Creo Illustrate, you will not be able to
connect to Windchill from Creo Illustrate.
Use the following steps to register a Windchill server.
1. Access the Server Management utility in one of the following ways:
•

From an active Windchill Workgroup Manager session, select
Tools ▶ Server Management. The Server Management window opens.

•

From Creo Illustrate, click Configuration
open the Server Management window.

in the Windchill ribbon to

2. Select Server ▶ Register New Server. The Register New Server window opens.
3. Specify the server name to appear in the Name field.
Note
It is recommended that all users in a company register the server using the
same name.
4. Enter the Windchill server codebase URL. (You can get this information from
your Windchill administrator.)
5. Select Check to validate the server location is complete and valid.
6. Enter the user name and password in the Authentication window.
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7. Select the workspace you want Creo Illustrate to use from the workspace list.
Note
A default workspace already exists for each Windchill product that you
have access to. If you want to create new, additional workspaces, click
Workspace ▶ New to create a new one. This option is only available when the
server is registered and has been given primary importance.
8. Select Close.
9. Select Server ▶ Set as Primary Server. This enables Creo Illustrate to connect
to the specified Windchill server and use the selected workspace.
Note
Once registered, the server and workspace are listed in the Folder Navigator.

Registering an Application
The operating system-specific components for integration with all supported
applications and their versions are automatically installed with the
Windchill Workgroup Manager client. For example, if your installation is on
a machine running Windows XP, all the application integration components for
Windows XP are installed, except those that were specifically excluded by the
system administrator during the CD-to-Server installation.
Your Creo Illustrate application must be registered with the
Windchill Workgroup Manager client before it can be used with
Windchill Workgroup Manager. It is possible to register several different
applications at the same time, but only one version of each at a time. If there are
no applications registered with the Windchill Workgroup Manager client at startup
(typically the first startup after installation), the client automatically launches
the Application Management utility so that Creo Illustrate can be registered with
the client.
When you first initialize Windchill Workgroup Manager, no applications are
registered. You choose from a list, or have Windchill Workgroup Manager browse
for an application in the Application Management utility. If you have already
registered an application, you can use the Application Management utility to add
others.
Use the following procedure to register Creo Illustrate with
Windchill Workgroup Manager.
1. Access the Windchill Workgroup Manager Application Management utility in
one of the following ways:
a. Select the Tools menu from Windchill Workgroup Manager.
Installation and Configuration
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b. Launch Windchill Workgroup Manager using the Workgroup
icon in Creo Illustrate. Select the Tools menu from
Windchill Workgroup Manager.

Manager

2. From the Tools menu, select Application Management. The Application
Management utility lists all of the applications that your system administrator
has made available.
3. If the application you want registered with Windchill Workgroup Manager is
listed, select the application — in this case, Creo Illustrate 1.0 and click
Register.
4. Once the application has been located, the Register an Authoring Application
window Register button becomes gray. Click Close.
5. If the Creo Illustrate application you want to register cannot automatically be
found on your hard drive, the following error message appears. “Automatic
registration failed. Please register the authoring application manually.” Click
OK.
a. From the Register an Authoring Application window, select
Creo Illustrate 1.0 and click Register Manually.
b. Click Find to signal Windchill Workgroup Manager to locate the
application.
Once the application has been located, the Register an Authoring
Application window Register button becomes gray. Click Close.
c. If Windchill Workgroup Manager cannot automatically find the application,
the Attributes section displays in the Register an Authoring Application
window. Enter the Startup Command and Install Directory manually and
click OK.
6. Applications registered with Windchill Workgroup Manager appear in the
Application Management window. Click on Creo Illustrate 1.0. to verify it
with Windchill Workgroup Manager.
7. The verification credentials for the application appear under the Description in
the Application Management window.

Setting the Connect to Windchill Option in Creo
Illustrate
Before you can use the Windchill PDM actions in Creo Illustrate you must set the
Connect to Windchill option from the Windchill ribbon in Creo Illustrate.
In Creo Illustrate, click the Windchill ribbon Connect to Windchill

22
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Unregistering an Application
This section describes how to unregister an application, like Creo Illustrate, with
Windchill Workgroup Manager, and how to do so.
Note
Exit your authoring application before trying to remove it from the Application
Manager. Windchill Workgroup Manager will not remove an application if it is
running.
1. In the Windchill Workgroup Manager window, click Tools ▶ Application
Management. The system opens the Application Management window.
2. In the Application Management window, select the application you want to
remove. In this case, select Creo Illustrate 1.0.
3. Click Applications ▶ Remove or right click the application and select Remove.
The system unregisters the selected application with Windchill.
4. Click Close to exit the Application Management utility.

Uninstalling Windchill Workgroup
Manager Client
This section contains the necessary steps to properly uninstall Windchill
Workgroup Manager client and other related files and directories.
When upgrading from a previous version of Windchill Workgroup Manager, the
following must be performed in chronological order:
1. Verify that all files are checked in. (IMPORTANT! To prevent data loss, all
files must be checked in before you continue.)
2. Launch the existing Windchill Workgroup Manager client with administrator
logon.
3. Unregister Creo Illustrate and all the registered
Windchill Workgroup Manager applications.
Note
See Unregistering an Application on page 23 for instructions.
4. Exit Windchill Workgroup Manager client.
5. Stop the PTC VFS Controller Service and Uninstall the Windchill Virtual File
Service (VFS). See Stopping the PTC VFS Controller Service and Uninstalling
Windchill Virtual File Service (VFS) on page 24.
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6. Uninstall the existing Windchill Workgroup Manager client with administrator
logon. See Uninstalling Windchill Workgroup Manager Client on page 24.
7. Delete the remaining Windchill Workgroup Manager files and folders. See
Deleting Windchill Workgroup Manager Files and Folders on page 25.
To install Windchill Workgroup Manager client, see step 8 in the Installation and
Configuration Steps on page 11.

Stopping the PTC VFS Controller Service and
Uninstalling Windchill Virtual File System (VFS)
If you are upgrading from a previous Windchill Workgroup Manager, you must
first stop the PTC VFS Controller service and then uninstall Windchill Virtual File
System (VFS) before uninstalling the Windchill Workgroup Manager Client.
1. To stop the PTC VFS Controller service:
a. Go to the Control Panel in Windows.
b. Select Administrative Tools ▶ Services.
c. From Services (Local), select PTC VFS Controller.
d. Select Stop the service.
2. To uninstall Windchill Virtual File System (VFS):
a. Go to the Control Panel in Windows.
b. Select Add or Remove Programs.
c. Select Windchill Virtual File System and click Remove.

Uninstalling Windchill Workgroup Manager Client
If you are upgrading from a previous Windchill Workgroup Manager, you must
first stop the PTC VFS Controller service and then uninstall Windchill Virtual File
System (VFS) before uninstalling the Windchill Workgroup Manager Client.
There are three methods that allow you to uninstall Windchill Workgroup Manager.
•

Start menu (Windows only) – select the uninstall icon.

•

Add or Remove Programs (Windows only) – select Windchill Workgroup
Manager and select Remove .

•

The following procedure:
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1. Navigate to <Windchill Workgroup Manager Install
Directory>\installer\uninstall.
2. Double-click the file Uninstall Windchill Workgroup
Manager.exe.
Note
On UNIX the file name is
Uninstall_Windchill_Workgroup_Manager.
The Uninstall panel appears.
Select Uninstall. The Uninstall Windchill Workgroup Manager Status panel
appears.
3. When the uninstall is complete, the Uninstall Complete panel appears.
Select Done.
There are instances where the uninstall fails. This is caused by an issue in
InstallAnywhere. If your uninstall fails, then complete the following procedure:
1. Navigate to Program Files\Zero G Registry and delete the file
.com.zerog.registry.xml.
Note
On UNIX, the file is located in the user home directory.
2. Reinstall Windchill Workgroup Manager into the same directory as the original
installation.
3. Rerun the uninstall program documented in this section.

Deleting Windchill Workgroup Manager Files and
Folders
After you have uninstalled the Windchill Workgroup Manager client, delete the
following Windchill Workgroup Manager files and folders.
Delete the Windchill Workgroup Manager files and folders from the following
locations:
1. The Cache directory <PTC_WF_ROOT>, if set.
2. The directory and files in the Application registry location,
<APPDATA>\PTC\ProENGINEER\Wildfire,
or,
The .wf and .wwgm directories and files that are created under a location.
3. The directory and files in the Application registry location,
<APPDATA>\PTC\ProENGINEER\Wildfire.
Installation and Configuration
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4. The Virtual File System (VFS) Cache directory <PTC_VFS_ROOT>, if set
or,
The /wwgm directory that is created under <User Profile Location>
5. The Workspace Local Directory (WLD) <PTC_WLD_ROOT>
6. The Application registry location <APPDATA>\PTC\Windchill Workgroup
Manager>
or,
The <PTC_WGM_ROOT>, if set.
7. Clear the Java plug-in cache.
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This section is intended for novice and experienced users. It provides a general
overview of Windchill Workgroup Manager, its architecture, and a typical first-use
scenario.
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What is Windchill Workgroup Manager?
Windchill Workgroup Manager provides a common client application that allows
you to manage data generated by Creo Illustrate in Windchill. A typical user of
Windchill Workgroup Manager can manage the design process in a controlled,
collaborative manner within the Windchill environment.
The Windchill Product Data Management (PDM) actions, such as check in
and check out, can be initiated from the Windchill Workgroup Manager client
application, via the embedded Windchill ribbon in Creo Illustrate. The Windchill
ribbon is active when the authoring application is registered with Windchill and
the Windchill preference is set in Creo Illustrate.
Windchill Workgroup Manager connects your authoring application with Windchill
to provide the data management and life cycle management capabilities offered
by Windchill PDMLink, Pro/INTRALINK, Arbortext Content Manager, and
ProjectLink. Accessing data through Windchill Workgroup Manager provides the
same consistent set of core features that are available when accessing Windchill
through a standard internet browser. Examples of this are opening files from an
authoring application supported by Windchill Workgroup Manager, such as a
Creo Illustrate file.
In addition to Creo Illustrate, Windchill Workgroup Manager common
framework supports authoring applications, such as Arbortext IsoDraw,
AutoCAD, SolidWorks, CoCreate, Mathcad and CATIA V5. With
Windchill Workgroup Manager, you only need to launch one authoring application
in order to work with any of your company’s supported applications and Windchill.
For example, if you use Creo Illustrate for one project and SolidWorks for another,
once you open Windchill Workgroup Manager, you can easily switch between the
two applications.
Windchill Workgroup Manager supports two modes: standalone and connected.
•

Standalone (not connected to Creo Illustrate) –
Windchill Workgroup Manager can be launched on its own, so that you can
access your data stored in the Windchill database or in your private working
area (workspace) without having to start Creo Illustrate. This also allows
you access to Windchill through the Windchill Workgroup Manager HTML
browser.

•

Connected (connected to Creo Illustrate) – Windchill Workgroup Manager can
be launched with Creo Illustrate so the two are connected.
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The Windchill Workgroup Manager interface is automatically presented in
Creo Illustrate once the following conditions are set:
•

Windchill Workgroup Manager client is installed.

•

Creo Illustrateis registered with Windchill.

•

The Connect to Windchill toggle button is selected on the Windchill ribbon.

The Windchill Workgroup Manager user interface is exited, the Windchill ribbon
becomes grayed out and control of the authoring application is returned to the user.
The Windchill ribbon remains in the Creo Illustrate application as long as the
authoring application remains registered with the Windchill server.
Information on transactions performed by Windchill Workgroup Manager is
available from the Windchill Workgroup Manager client message area. The
following graphic illustrates information messages in the message area of an
Creo Illustrate file example.

A pop-up window displays when Windchill Workgroup Manager is minimized,
or an action is initiated from Creo Illustrate. The graphic below shows as pop-up
window containing information notifying a user of actions that have succeeded.

More detailed transaction information is also available from the event
console, accessed directly from the Windchill ribbon Event Manager
button in Creo Illustrate, or from the Event Management
Windchill Workgroup Manager client.

icon in the

In addition to Windchill Workgroup Manager for Creo Illustrate documentation
found in this section, also refer to online help in the Using Windchill Workgroup
Manager ▶ Understanding Windchill Objects and PDM Concepts in the
Windchill Workgroup Manager Help Center to learn about the various Windchill
objects and PDM concepts.

Windchill Workgroup Manager Overview
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Windchill Workgroup Manager PDM
System Architecture
The basic architecture of Windchill Workgroup Manager Product Data
Management (PDM) system is comprised of the following:
•

The authoring application (e.g. Creo Illustrate).

•

The Windchill Workgroup Manager client, which connects the authoring
application and Windchill.

•

A workspace on the server.

•

The Windchill database.

The following graphic illustrates the Windchill Workgroup Manager architecture.

Once the Windchill Workgroup Manager client is installed, your application has
been registered, and you’ve connect to a Windchill server, you can begin working
with your data you can begin working with your data.
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Initial
Windchill Workgroup Manager Scenario
The Windchill Workgroup Manager application must first be installed on the
same computer as the Creo Illustrate client. The client software is downloaded
from the Windchill server. The first time you use Windchill Workgroup Manager,
after installation, you need to perform the following basic configuration before
you can start using it.
•

Set one of the registered Windchill servers as the primary server.

•

Create and select a workspace as your active workspace.

This basic configuration is discussed below.
1. Configure server importance. Before you can manage any Creo Illustrate files in
Windchill, you need to give one of your registered servers primary importance.
Primary importance means that Windchill Workgroup Manager and
Creo Illustrate recognize and communicate with the Windchill server that is
managing the data. Use the following steps to give a server primary importance.
a. From Windchill Workgroup Manager, select Tools ▶ Server Manager and
right-click the wanted registered server node. Select Set as Primary Server.
or
b. From the Windchill ribbon in Creo Illustrate, click the Configuration
button. Right-click the wanted registered server node and select Set as
Primary Server. You can also register a new server and set it as the primary
server.
2. Select a workspace. Select an area in Windchill to manage your working data.
This working area is called a workspace. You can select a default workspace
on Windchill, or create your own.
Note
You may want to create several workspaces to manage the different projects
on which you are currently working.
This workspace is private to you and is used to interface with your
Creo Illustrate dynamic documents (illustrations). When you work in this
workspace, your files are not visible to others until they are checked in to a
Windchill server. Once checked in to Windchill, these files are available to
others.
3. Create data and save it to your workspace. Once registered with
Creo Illustrate, Windchill Workgroup Manager simultaneously starts when
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Creo Illustrate starts. When you create a drawing an Creo Illustrate illustration
and save it to your workspace, and it is saved locally.
4. When you are ready to share an Creo Illustrate file with others, you can either:
a. From your workspace in Windchill Workgroup Manager, select Check
In/Auto
or Check In/Custom
.
or
b. From Creo Illustrate, select Check In

or Custom Check In

.

Note
Check In/Auto
automatically checks in the Creo Illustrate file to server
side active workspace.
Check In/Custom
allows you to select the location (server-side active
workspace, or a different server-side workspace).

Client and Server Architecture of
Windchill Workgroup Manager
Windchill Workgroup Manager has a client-server architecture. The following
components reside on an end user's workstation:
•

The authoring application (i.e., Creo Illustrate) that is registered with
Windchill Workgroup Manager.

•

The workspace local directory – the local cache folders connected to the
workspace located on the Windchill server.

•

Windchill Workgroup Manager application that communicates between the
authoring application and the Windchill server.

The following components reside on the Windchill server:
•

Windchill database.

•

Server-side workspace.

The workspace consists of two components:
•

Server-side workspace.

•

Workspace local directory that stores the physical files so they can be accessed
by the authoring application.
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The next diagram shows the main components of the
Windchill Workgroup Manager.

Windchill Workgroup Manager
Capabilities
This section introduces the concept of the workspace, and provides a general
overview of the commonly used Product Data Management (PDM) functions.
Windchill Workgroup Manager is used to manage your data in Windchill, so it is
controlled by revision and managed through its life cycle. This helps ensure data
integrity is maintained.

Managing Data Through the Workspace
Your data is managed through a workspace that is split between the client and the
server. These workspace components are:
•

workspace local directory – client-side cache for files currently being worked
on.

•

server–side workspace – a user's private working area which is synchronized
with the files in the workspace local directory.

The workspace local directory is a cache area on the client computer through
which the authoring application (i.e., Creo Illustrate) can access and modify your
data. When you have completed work on this data, but don't want it to be shared,
you upload it to the server-side workspace, located on the server. The server-side
workspace is also a private area, and is accessible only by you. The server-side
workspace is used to store your current work-in-progress, allowing you to save
data from, and retrieve data to, your authoring application. Once you are ready to
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share this data with others, you check it in to the commonspace also located on the
Windchill server. The difference is that the commonspace is viewable to anyone
who has access to it; typically, your team members.
To learn about workspaces, refer to Using Windchill Workgroup
Manager ▶ Understanding Windchill Objects and PDM Concepts ▶ About
Workspaces in the Windchill Workgroup Manager Help Center.

Common PDM Actions
When you work connected to a Windchill server (the server you have given
primary importance) in an active workspace, PDM actions become available in
your authoring application (i.e., Creo Illustrate) to help you manage your data
in Windchill.
All files remain in your control until you are ready to share them with others. Use
either Save or Save As from the Creo Illustrate File menu to save any changes
you have made to a drawing. Then use Check In/Auto
to move your files to
the server-side workspace where they can be accessed by others, or choose use
Check In/Custom
to move your files to a server-side active workspace or the
Windchill Cabinet where they can be accessed by others.
Note
Synchronize ensures the contents of the workspace local directory cache are the

same as the contents in the server-side workspace. The command is only available
through the Windchill Workgroup Manager workspace browser.
The Check Out
function enables the person who performs the checkout to
modify the data being checked out. Once checked out, the file cannot be modified
by anyone else. The file can be viewed by others, but can only be modified by
the checkout owner. This exercise of checking in and checking out ensures data
integrity is maintained because the file is always controlled through Windchill.
PDM actions available from within Creo Illustrate are documented under Windchill
Workgroup Manager Integrations ▶ Windchill Workgroup Manager for Creo Illustrate
Administrator’s and User’s Guide in the Windchill Workgroup Manager Help

Center.
PDM actions available from the Windchill Workgroup Manager client are
documented in Working with Windchill PDM Actions on page 53.
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This section is intended for novice and experienced users, as well as administrators
who may want to learn more about using Windchill Workgroup Manager. This
chapter covers actions such as registering a server and registering an authoring
application. It also covers navigators, workspaces and viewing objects. For more
experienced users, this chapter can be used to review the basic elements before
getting started with Windchill Workgroup Manager.
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About Windchill Workgroup Manager
This section provides information about using Windchill Workgroup Manager to
manage your Creo Illustrate illustrations with Windchill.
You can run Windchill Workgroup Manager in stand-alone mode,
where Creo Illustrate only becomes available when certain commands
are given, or in full-client mode, where Creo Illustrate is connected to
Windchill Workgroup Manager.
This chapter discusses the following:
•

Registering Windchill servers.
Note
Server registration is the first step you take to get started with
Windchill Workgroup Manager, and is one that you always return to
when you need to set up another server and workspace. When you access
a server or workspace, it is made visible through an HTML page in
Windchill Workgroup Manager.

•

Registering Creo Illustrate with Windchill.

•

Windchill PDM actions available from Creo Illustrate and
Windchill Workgroup Manager.

•

TheWindchill Workgroup Manager HTML browser and navigators.

•

Workspace management, including, activating and deactivating a workspace.

•

Viewing Creo Illustrate files.

Initiating the
Windchill Workgroup Manager
Windchill Workgroup Manager can run in stand-alone mode, or concurrently with
Creo Illustrate. Once you have installed Windchill Workgroup Manager to your
desktop, and registered Creo Illustrate with Windchill, the choice is yours as to
how you want to initiate Windchill Workgroup Manager. Detailed information can
be found in the Windchill Workgroup Manager Client PDM Actions chapter.

Running Concurrently with Creo Illustrate
In most cases, you work in Windchill Workgroup Manager concurrently with
Creo Illustrate. This mode allows you to easily interact between Creo Illustrate and
Windchill. Once you have registered with Windchill Workgroup Manager and
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selected the Connect to Windchill toggle button on the Windchill tab ribbon,
Windchill Workgroup Manager launches automatically when Creo Illustrate is
initiated if Windchill Workgroup Manager is running.

Running Standalone from the Desktop
There may be occasions where it is more convenient to run
Windchill Workgroup Manager alone, and not connected to Creo Illustrate. For
example, you may want to check out files from Windchill Workgroup Manager,
which does not necessitate being connected to Creo Illustrate.
When working in stand-alone mode, Windchill Workgroup Manager provides
access to the Windchill server, and the workspaces available to you. You can
check out files to your hard drive and change attributes, or perform non-file-based
operations. These updated files can be uploaded to Windchill once Creo Illustrate is
connected to Windchill and Windchill Workgroup Manager is invoked.
You can invoke Windchill Workgroup Manager using the icon in your
Start menu, or from your desktop. Additionally, users can invoke
Windchill Workgroup Manager through the Home/Bin/uwgm_client.bat
file.

About the
Windchill Workgroup Manager User
Interface
This section describes the Windchill Workgroup Manager HTML browser.
The Windchill Workgroup Manager user interface is presented as
a series of HTML pages accessible through your Web browser.
Windchill Workgroup Manager browser is similar to Microsoft’s Internet Explorer.
The next graphic displays the Windchill Workgroup Manager browser toolbar.

The following commands appear on the Windchill Workgroup Manager browser
menu bar:
•

Back

•

Forward

•

Stop

– Select to go to the previous page in the browser's history list.
– Select to go to the next page in the browser's history list.
– Select to stop loading the current page.
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•

Refresh

– Select to refresh the current page.

•

Home

•

Save

– Select to save the current browser contents as a file.

•

Print

– Select to print the contents of the current browser page.

•

– Select to view the favorites (bookmarks) you have set
in Windchill Workgroup Manager.

•

History Navigator

•

Address Box

– Select to open the user-defined home page.

Favorites Navigator

– Select to view the browser history.
– Select to enter a URL, then select Go

to open the Web page.
Note
The Windchill Workgroup Manager HTML browser is the only browser that
supports the connection between your authoring application and a Windchill
server. Accessing the Windchill server in an external Internet Explorer or Mozilla
browser will not create connectivity between Creo Illustrate and Windchill.

Using Windchill Workgroup Manager
The Windchill Workgroup Manager HTML user interface supports
the connectivity between Creo Illustrate and Windchill. You register
Windchill servers that are designated to contain the data you work with.
Windchill Workgroup Manager allows connections to multiple Windchill servers.
One server is always set as primary, and any additional servers that you register are
considered secondary servers. The next graphic illustrates how a primary server
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and secondary servers connect with Windchill Workgroup Manager. In addition to
authoring applications, like Creo Illustrate, Windchill Workgroup Manager also
supports CAD applications.

Primary and Secondary Servers
Windchill Workgroup Manager allows you to simultaneously browse to multiple
Windchill servers. However, it is necessary to designate one server as the primary
server.
The primary server acts as the default location for all storage and retrieval using
the PDM functions performed with Windchill. When it is required that you work
in another server, you set it as primary through the Server Manager option on
the Windchill Workgroup Manager Tools menu, right-click and select Set as
Primary in the Folder Navigator, or from the Windchill ribbon Configuration
icon in Creo Illustrate.

Secondary servers are typically used for backing up data, for libraries, or for
sharing data with other users that do not have access to your primary server (for
instance Windchill ProjectLink servers that are placed on a different part of the
company network, such as outside the company’s firewall), or test servers. For
example, you could create a project on your company’s Windchill server, and then
invite suppliers to share this data. You would not set this server as primary. This
secondary server gives your suppliers the ability to read and write to that project.
Getting Started with Windchill Workgroup Manager
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Working with Windchill Servers
This section explains how you work with Windchill servers in
Windchill Workgroup Manager.
To create the connection to a Windchill server, you register the Windchill server
and select a workspace. At this point, if you want to work on this server, you set it
as the primary server.
Once registered, the server and workspace are listed in the Folder Navigator.

Using the Server Management Utility
To register and manage servers in Windchill Workgroup Manager, use the Server
Management utility. To access the Server Management utility, select Tools ▶ Server
in the Windchill
Management, or from Creo Illustrate, click Configuration
ribbon to open the Server Management window. For information on how to register
a Windchill server, refer to Registering the Windchill Server on page 20.
Tip
After you have registered a server, you can access the Server Management window
from the Folder Navigator by right-clicking the server or the workspace node.
The Server Management window has three menus:
•

File

Opens the Save Server Management Settings File window, and allows you
to save a Servers Configuration File (FLD) to a common folder, or server,
workspace.
•

Server

Allows you to register a new server or edit an existing server.
•

Workspace

Allows you to create a new workspace.
There are two tabs available from the Server Management window:
•

Servers

•

Cache

The Servers tab allows you to view the server name(s) and register, edit server
name and delete the server.
•
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Displays the registered servers and their online or offline status. Also displays
<NO SERVER> which, when set as primary, disables all PDM actions in the
authoring application.
Note
You may want to use this option when you want to restore all the basic
behaviors of the authoring application without having to unregister any
Windchill servers.
The registered servers can be viewed from the Server Management window.
•

The Cache tab shows you how much disk space is used by the workspace
local directory cache per server or workspace, allows you to clear the cache,
and provides access to the Cache Management tools. For more information on
cache, refer to the Managing Cache section.

Connecting to a Server
To create the connection to a Windchill server, you register a server and select a
workspace. At this point, if you want to work on this server, you set it as the
primary server.
Once registered, the server and workspace are listed in the Folder Navigator.

Using the Server Tab
The Server tab on the Server Management window contains three sections:
Servers, Server Active Workspace, and Description.
•

Servers - Lists the servers that are registered with

Windchill Workgroup Manager. You can right-click a server and register
another server, set it as primary (if it is not already), and edit the server name.
•

Server Active Workspace - Lists the workspaces on the selected server. To list

available workspaces on any registered server, select a server from the Servers
list. Use the workspace commands to do the following:
○ New
Creates a new workspace on the primary server.
○ Activate
Activates a workspace on a secondary server, or activates a workspace
and sets it as primary.
○ Delete
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Deletes the server.
•

Description - Describes the server name, location and primary active workspace

name.

Using the Application Management Utility
Use the Application Management utility to register or unregister Creo Illustrate with
Windchill Workgroup Manager. To access the Application Management utility,
select Tools ▶ Application Management from Windchill Workgroup Manager, or
launch Windchill Workgroup Manager in Creo Illustrate using the Windchill ribbon
Workgroup Manager

icon and then select Tools ▶ Application Management.

Registering Creo Illustrate
Creo Illustrate must be registered with Windchill Workgroup Manager. When
you first initialize Windchill Workgroup Manager, no applications are registered.
You choose from a list, or have Windchill Workgroup Manager browse for
an application in the Application Manager. If you have already registered an
application, you can use the Application Management utility to add others.
For information on how to register Creo Illustrate with
Windchill Workgroup Manager, refer to Registering an Application on page 21.

Unregistering Creo Illustrate
A use scenario for unregistering Creo Illustrate with
Windchill Workgroup Manager is when you are upgrading to a new version
of Windchill Workgroup Manager. For information on how to unregister
Creo Illustrate with Windchill Workgroup Manager, refer to Unregistering
an Application on page 23.

About Navigators
Windchill Workgroup Manager has four navigational tools available that allow you
to easily access and manage your work. With these tools, you can browse servers
and workspaces, manage your Personal Favorites folder, and view the history of
the HTML pages you have accessed. You can also create and save a full search
of your Windchill documents.
The following navigator tools are located on the browser window ribbon:
•

Folder Navigator

•

Favorites navigator
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– Select to manage folders.
– Select to manage favorites.
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•

History navigator

– Select to manage Web history.

•

Search navigator

– Select to perform and manage file searches.

Folder Navigator
This section describes the Folder Navigator, which is located on the left-hand panel
in Windchill Workgroup Manager. The Folder Navigator is an expandable tree that
displays the registered and primary active servers, contexts and workspaces.
The next graphic illustrates the Folder Navigator.

You can browse Windchill servers and workspaces connected to your computer
in the Folder Navigator. The Folder Navigator is useful for quickly accessing
and managing your Windchill data. Select the folder navigator
icon to open
the Folder Navigator. From here, you can access the Server Registry window to
register new servers or manage your cache. In the Folder Navigator window, you
browse different servers and workspaces, set a server as the primary one through
which you work with Windchill, and activate its workspace. You can also expand
or collapse your folder directory, and navigate directly to your Windchill cabinets
and workspaces. Once set, the primary server and active workspace are indicated
by the primary server icon
, and the active workspace
icon. As you navigate
the Folder Navigator window and select a server or workspace, the contents appear
in the browser so that you can work on them.
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To move directly to your primary server or active workspace click one of the
following icons located at the top of the Folder Navigator.
— Moves directly to the registered server.
— Moves directly to the primary, active workspace.

Favorites Navigator
The Favorites navigator is useful for bookmarking Web sites you visit frequently.
Click

to open the Favorites navigator.

The following graphic displays the Favorites navigator panel.

Here, you manage your Personal Favorites folder by adding, renaming, or deleting
links to HTML pages represented in the browser. You can add to the list of
favorites by accessing a site in the browser and clicking Add in the Favorites
navigator. You can also organize your favorites by name, location, last visited,
created on, and number of visits by clicking Organize in the Favorites navigator.
You can also add bookmarks by editing the wtcad.ini file and adding a name
and address for the favorite in the format:
; add my own url GOOGLE=http://www.google.com/

Adding a Location to Your Favorites
1. Go to a site or directory you want to save to Favorites. The
Windchill Workgroup Manager browser displays the page you want to save.
2. Do one of the following:
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•

Right-click within the Windchill Workgroup Manager browser and click
Add to Favorites on the shortcut menu.

•

Select add to favorites

icon at the top of the Favorites navigator.
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3. In the Add Favorite window, select a folder in which you want to save the
favorite, or create a new folder.
4. Select OK.

Organizing Favorites
You can add, rename, delete, and move favorites in the Favorites navigator.
1. Select the favorites navigator
2. Select the organize
Organize window opens.
3.

icon.
icon at the top of the Favorites navigator. The

Select the following options:
•

Create folder.

•

Rename.

•

Delete.

4. To show information about folders, select View Info at the bottom of the
window.
5. Select Close.
To reorder favorites in the Favorites navigator, drag an item to a new location.

History Navigator
The History navigator is useful for returning quickly to HTML pages that you
found particularly helpful, but are not entered in the Favorites navigator. Select
the history navigator
icon to open the History navigator, and display what you
have opened in the browser.
The following graphic displays the History navigator window.

The view can be filtered by Date, Site, Most Visited, or By Order Visited Today. If
you want to clear all these sites, select Clear.
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Search Navigator
This section provides an overview of the Search navigator, and how to search for
an object and open it in Creo Illustrate. It explains the workflow when using saved
searches, and also for adding an object to the workspace.
The Search navigator is used to search for files located in Windchill. You can
search using criterion used before (a saved search), or through a customized
search. The Search navigator is useful for searching on basic criteria, advanced
criteria, and complex Windchill searches. Search results display in a narrow table
below the Search navigator, and in a wide table view in the browser window,
which displays more detailed information about the search result.
The Search navigator displays results for registered, primary servers only. When
there is no registered, primary server, the Search navigator is not available.
Select the search
icon to open the Search navigator. The Search navigator
allows you to search for parts and dynamic documents on a registered, primary
server. All searches can be saved for future use. For example, to perform a basic
search in the Search navigator, specify the criteria and select Search. If you want
to save this search, select Save This Search.
You can search by several criteria. For example, you can search for parts created
in any supported CAD or authoring application, Owner application, Dynamic
Document type, Dynamic Document sub-type, Check out by, Created by, Updated
by, Updated on, and Organization ID. The search results are returned in a Search
Results table that lists the name, number, context, version, organization, state, last
updated, created on, and authoring application. You can select a part or dynamic
document from the results table, and apply a Windchill action, such as Check Out,
to it. Once you have specified your search criterion and performed a search, you
can use the Save This Search button on the Search navigator to save the search
for future use. Saved searches can be made available to others by adding specific
groups once the Save This Search button has been activated. An administrator
enables the Mark as Global Search and Set Scope of Global Search check boxes in
order to set up Saved Searches.
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The Search user-interface depends upon the type of user performing the search. A
typical user sees the following window.

An administrator sees the next window.

To perform more advanced searches, select the Advanced Search link on the
Search navigator.
Use the following procedure to create an advanced search.
1. Select Advanced Search.
2. Identify the Context for the search. The default context is the Product, Library,
or Project associated to the active workspace.
3. Identify the type of dynamic document to search for.
4. (optional) Identify the date range to search.
5. Select the criteria in the Search For field.
6. Set the operator for the criteria (equals, not equal to, between).
7.

Set the value for the criteria, including any wildcards.
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8. Apply the criteria by choosing the Add button. The criteria is added to a list
where it may be selected for edit or removal.
9. Add another criterion.
10. Repeat steps 6 through 9 for each desired criterion.
11. When criteria setting is complete, set whether the search results will “Match
All Criteria” on the list, or any criteria on the list.
12. Select Search. Results are presented in a list beneath the search criteria and
also in the main browser window.
From the search results under the Advanced Search criteria you may:
•

Select the open in Creo Illustrate
icon to open the file in Creo Illustrate (this
command is only available if Creo Illustrate is registered).

•

Select the Name link to view the information page for the selected object in the
main browser window where you can see detailed information related to that
object, and perform actions on that object.

From the search results in the main browser window, you may either access the
information page or choose an action to perform on the object from the drop-down
list (such as Add to Workspace or Check Out). If you want to save an object from
the narrow search results table, select the object link to display its information
page in the browser window.
If you prefer to perform a complete search of Windchill, access the Full Search link.
This opens a page in the browser and allows you to browse the commonspace and
search in detail. For more information on search, refer to the Windchill online help.

Accessing Workspaces
This section describes the concept of accessing the workspace and the local
workspace directory.
Windchill Workgroup Manager provides you with a private area on the Windchill
server for managing your work while working with other designers. This
area is called the workspace. The workspace allows you to track and change
multiple objects and perform data management operations from within the
authoring application user interface. The workspace enables designers to operate
independently while recording and tracking concurrent activities to assist in
product design decisions.
The primary purpose of the workspace is to allow designers to work freely on
design development and changes without impacting data in the database until they
are ready to expose their design or changes to the rest of the design community
by checking in to the commonspace.
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As a Windchill user, you typically check out or download design information from
the Windchill server to your workspace to modify or view it. Checkout reserves
the object on the server, so that no one but you can modify the design (although
other users can still access the data on a read-only basis). When you are finished
modifying a design and you want to share the modification with other users, you
perform a check-in operation. The check-in operation uploads your modified
design to the Windchill server and releases the object on the server allowing other
users to access and modify the data further. The process of checking out and
checking in (reserving and releasing) data helps you to maintain the integrity
of your data.
It is through the workspace that the Windchill server connects to Creo Illustrate.
The Creo Illustrate application session and the workspace are linked such that
information that is modified in Creo Illustrate can be seen from Windchill.
Tip
The Windchill system can create multiple workspaces. This is useful if you are
working on several projects at one time because it allows you to create a workspace
for each of your projects and segregate your design data by project affiliation.

Accessing Service Information Manager
and Service Parts
If you have Service Information Manager and Service Parts installed, you can
access the Service Information Manager and Service Parts functionality to add,
edit, and delete illustrations to a Parts List or to add, edit, and delete illustrations
in the active workspace or commonspace for Service Information Manager and
Service Parts.
A workspace is a private area on the Windchill server for managing your work
while working with other Windchill users. This area is called the workspace.
The workspace allows you to track and change multiple objects and perform data
management operations from within Creo Illustrate and from the workspace. The
workspace enables Windchill users to operate independently while recording and
tracking concurrent activities to assist in the production of a service manual or
parts catalog.
The primary purpose of the workspace is to allow Windchill users to work freely
in the commonspace without impacting data in the database until they are ready to
expose their illustrations to the rest of the Windchill community by checking in
the illustration to the active workspace.
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As a Windchill user, you typically open, check out, or download an illustration
from the Windchill server to your workspace, when Creo Illustrate is connected to
Windchill, to modify or view it in Creo Illustrate. Checkout reserves the object on
the server, so that no one but you can modify the illustration (although other users
can still access the data on a read-only basis). When you are finished modifying an
illustration and you want to share the modification with other users, you perform a
check-in operation. The check-in operation uploads your modified illustration to
the Windchill server and releases the object on the server allowing other users to
access and modify the illustration further. During check in you have the option
of picking a folder location, or browsing to a product ASPS location. You can
also provide an optional check in comment. The process of checking out and
checking in (reserving and releasing) data helps you to maintain the integrity of
your illustration.
It is through the workspace that the Windchill server connects to Creo Illustrate.
The Creo Illustrate application session and the workspace are linked such that
information that is modified in Creo Illustratecan be seen from Windchill.
Tip
The Windchill system can create multiple workspaces. This is useful if you are
working on several projects at one time because it allows you to create a workspace
for each of your projects and segregate your design data by project affiliation.
For more information about the Windchill PDM actions you can perform from
within Creo Illustrate, refer to the Windchill Workgroup Manager Help Center under
Using Windchill Workgroup Manager ▶ Authoring Applications ▶ Creo Illustrate.
For more information about Windchill PDM actions you can perform from the
Windchill workspace, refer to Working with Windchill PDM Actions on page 53,
and Windchill PDM Actions in Service Information Manager and Service Parts
on page 71 , or from the Windchill Workgroup Manager Help Center under Windchill
Workgroup Manager Integrations ▶ Windchill Workgroup Manager for Creo Illustrate
Administrator’s and User’s Guide ▶ Working with Windchill PDM Actions.

For more information about Service Information Manager and Service Parts,
refer to the Windchill Help Center under Specialized User Capabilities ▶ Service
Information Manager.

Viewing Windchill Objects
Windchill objects are viewed through the workspace in Windchill, so that you can
easily keep track of what you are working on. Once objects are checked in, they
are visible through the folders menu in the commonspace. The commonspace
is the area accessible to others who have permission to it, such as other project
team members.
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Once you save an illustration in Creo Illustrate, it appears in your private
workspace in Windchill. To access this workspace, click the primary workspace
node in the Windchill Workgroup Manager Folder Navigator. The HTML user
interface displays the models you have saved. The workspace view can be
customized through the Custom Table view in Windchill.
Because dynamic documents in a workspace can differ from the commonspace
version, Windchill Workgroup Manager can present a workspace information
page and a commonspace information page. The information page called from
the workspace presents the workspace-relevant information. (Even though you
can bring parts and end-objects into a workspace, they are commonspace objects
only, and therefore only have commonspace information pages.) From the
workspace, select the information
icon to present an information page for the
workspace version of an object. Select the information
icon for an object in
the commonspace accesses the information page for the commonspace version
of the object.

Workspace Management Actions
This section describes the concept of managing workspaces, and includes
switching between existing workspaces and creating new ones.
You work in a private area in Windchill called a workspace. To interact with
Creo Illustrate, a workspace must be set as active on the primary Windchill server.
This can be done from the Server Manager window, which is accessed from the
Windchill Workgroup Manager Tools menu, or by right clicking on the workspace
node in the Folder Navigator. The primary, active workspace
icon indicates that
the server and workspace is active and connected to the primary Windchill server.
When you want to switch and work in another workspace, you activate that
workspace and set it as primary either from the Tools menu or the Folder Navigator.
If you need to create a new workspace, access the Workspaces menu from the
Server Manager in Windchill Workgroup Manager. This menu allows you to create
a new workspace, edit its name, or delete it.
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To populate your workspace, use the Save or Save As commands from
Creo Illustrate after you have created illustrations. This puts the dynamic document
into the primary, active workspace, and saves it to the workspace local directory.
Note
From the File menu in Windchill, the Save As command saves file content in HTML
format to a local drive.
Note
Modified parts are overwritten automatically in the workspace local directory
when you open a corresponding assembly in any other location. If you open a part
outside the workspace local directory and if any of its dependents exist in the
workspace local directory, the following message displays:
“The local workspace already contains file(s) with the same name that will be
over-written by this operation. Press Yes to backup (*.wbk) these files in the local
workspace.”
If you select Yes, then backup files are created in the workspace local directory,
and the original files are overwritten. If you select No, then the original files are
overwritten and no backups are created.
You can also remove a worksheet from a workspace through the File ▶ Remove
action.
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Accessing the Windchill Workgroup Manager Help Center........................................... 54
Windchill PDM Actions .............................................................................................. 55
Working with Information System Manager and Service Parts...................................... 66

This section contains the Windchill Product Data Management (PDM) actions that
are initiated from Windchill when Creo Illustrate is:
•

Installed on the same computer as the Windchill Workgroup Manager client, is
registered to that client, and connected to the Windchill server.
or,

•

Installed on the same computer as the Windchill Workgroup Manager client, is
registered to that client, connected to the Windchill server, and when Service
Information Manager and Service Parts are installed.
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Accessing the Windchill Workgroup
Manager Help Center
The Windchill Workgroup Manager Help Center includes help for the
Windchill Workgroup Manager for Creo Illustrate.
You can access the Windchill Workgroup Manager Help Center as follows:
From
Creo Illustrate

Do the Following
In the Creo Illustrate Windchill ribbon,
click Connect to Windchill. After
Creo Illustrate connects to Windchill, click

Windows and mixed user interface

File ▶ Help ▶ Windchill Workgroup Manager
Help.
Windchill ▶ Windchill Workgroup Manager
Help

or,
Windows classic user interface

Help ▶ Windchill Workgroup Manager Help
Windchill WGM ▶ HELP

The Windchill Workgroup Manager Help Center provides
help for the Windchill Workgroup Manager user interface,
the Windchill Workgroup Manager help, workspace, and all
Windchill Workgroup Manager-integrated applications (including Creo Illustrate).
The Windchill Workgroup Manager Help Center also contains the complete
Windchill Workgroup Manager for Creo Illustrate Administrator’s and User’s
Guide. It covers:
•

Installing, configuring, and getting started with
Windchill Workgroup Manager for Creo Illustrate.

•

Working with Windchill PDM Actions in Creo Illustrate.

•

Setting Windchill Workgroup Manager client, server, and Creo Illustrate
preferences.

•

Performing Windchill Workgroup Manager for Creo Illustrate administrative
tasks.

You can also download the Windchill Workgroup Manager for Creo Illustrate
Administrator’s and User’s Guide from the Windchill Support Center page
on the PTC WEB site. (Click the Reference Documents link and search for
Windchill Workgroup Manager.)
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Windchill PDM Actions
Before working with Windchill PDM Actions, ensure that the following
requirements have been completed:
1. The Windchill Workgroup Manager client for Creo Illustrate must be installed
and configured on your machine in order to access and perform Windchill
PDM Actions from within Creo Illustrate and from the Windchill Workgroup
Manager. The PTC Virtual File System (VFS) is automatically installed during
the installation of Windchill Workgroup Manager client.
Note
If you have not installed and configured the Windchill Workgroup Manager
client for Creo Illustrate, refer to the installation chapter in the Windchill
Workgroup Manager for Creo Illustrate Administrator’s and User’s Guide for
instructions on how to install the Windchill Workgroup Manager Client.
2. PTC Virtual File System must be configured on your machine in order to
access PTC Places. Ensure that you have set up and configured the PTC Virtual
File System before working with Windchill PDM actions.
Note
Refer to the Installation chapter in the Windchill Workgroup Manager for Creo
Illustrate Administrator’s and User’s Guide for instructions on how to install
and configure the PTC Virtual File System.
3. Ensure that PTC Places is your default directory when you are connected to
Windchill and have an active Creo Illustrate session.
a. Confirm that PTC Places is your default directory by clicking the Look in
location from File ▶ Open in Creo Illustrate. The PTC Places directory
should appear one level up from the “workspace” default directory.
Note
PTC Places are locations within the Windchill server.
b. If your default view in the Look in directory points elsewhere, refer to
the Installation chapter in the Windchill Workgroup Manager for Creo
Illustrate Administrator’s and User’s Guide for help in making PTC Places
the default directory.
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Note
If PTC Places is not your default directory when you are connected to
Windchill and have an active Creo Illustrate session, you will not be able to
perform Windchill PDM Actions. Refer to the Installation chapter in the
Windchill Workgroup Manager for Creo Illustrate Administrator’s and
User’s Guide for instructions on how to set PTC Places to be your default
directory.
4. If you want to add, edit, and delete illustrations in a Parts List, or add, edit,
and delete illustrations in the Service Parts active workspace or commonspace,
ensure that Service Information Manager and Service Parts are installed.
Note
Refer to the Windchill Help Center under Specialized User Capabilities ▶ Service
Information Manager for more information.

Creo Illustrate Dynamic Document Information Page
Creo Illustrate dynamic document objects contain Creo Illustrate graphics stored
on your PTC Server.
The Creo Illustrate information page is a collection point for information
related to Creo Illustrate dynamic document objects. The information page of a
Creo Illustrate dynamic document object is accessed by clicking the information
icon.
From the information page, you can perform actions on a Creo Illustrate dynamic
document object, as well as view the object attributes and any related information.
For an overview of information page functionality, see “About Information Pages”
and “Customizing Your Information Page Tabs” in the Windchill Help Center.
Actions
Information pages contain a list of applicable actions in a menu just below the
object identification line. See “Common Actions” for a list of common actions
available in Windchill. The availability of these actions depends on the status of
the Creo Illustrate dynamic document object, as well as your access to it. For
more information about status indicators, see “Status Indicators” in the Windchill
Help Center.
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Tabs
The following tabs are viewable on the Creo Illustrate dynamic document
information page. You can customize the tabs that appear on each object
information page to display the information most useful to you. For more
information, see “Customizing Your Information Page Tabs” in the Windchill
Help Center.
Note
Administrators may have modified the tabs that are viewable to you. Additional
tabs may appear depending on the solutions deployed at your site.
Tab
Details

Related Objects

History

Description
The Details tab lists the primary attributes
associated with the object, along with a Where
Used information table, showing where the
object is used.
If there is a default representation, a
visualization of the graphic will display. See
“About Visualization” in the Windchill Help
Center.
The Related Object tab allows you to view
representations of the graphic.
If this object was created from a PVZ graphic
dynamic document, than a Source and Image
table will show its source PVZ object as well.
The History tab contains a version history and
time line of the object.

Creating a Workspace
Use the Windchill ribbon to access the Server Manager window to create a new
workspace on the primary server. The new workspace automatically becomes
your active workspace.
Note
The Windchill ribbon is accessible when Creo Illustrate is connected to
Windchill Workgroup Manager.
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To create a new workspace:
1. From Creo Illustrate, select Windchill Workgoup Manager
icon from the
Windchill ribbon. Select the Tools ▶ Server Management utility to open the
Server Management window. The Server Management window displays all
the registered servers.
2. From the Servers list, select the server on which you want to create the new
workspace.
3. Select Workspace ▶ New, or from the Server Active Workspace section,
right-click any workspace and select New. The Create New Workspace window
opens.
4. Enter a name for the new workspace and select a context from the Context list.
5. Select OK. The new workspace appears in the Server Active Workspace section
and in the Folder navigator. It automatically is set to primary and becomes
the active workspace.

Open In Creo Illustrate
You can open a Creo Illustrate file from the following Windchill locations into
your active Creo Illustrate session:
•

Active workspace on the primary server.

•

Workspace on the primary server.

•

Windchill Workgroup Manager client.

•

Information System Manager with Service Parts (if installed)
○ Information Structure
○ Folders
○ Structure
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○ Workspaces
Note
For more information about Service Information Manager and Service
Parts, refer to Accessing Service Information Manager and Service Parts
on page 53 in the “Getting Started with Windchill Workgroup Manager”
section.
1. Select the illustration you want to edit and click
Check Out in the active
workspace Object List table, or from the Parts List Editor ribbon.
Note
Depending on your preference, you can check out the illustration from the
active workspace or from within an active Creo Illustrate session.
2. Select the illustration to open from either File ▶ Open in ▶
Creo Illustrate,
or from in the row of the illustration you want to open, click the Actions
Open in Creo Illustrate icon.

3. If you haven’t checked out the illustration while in the active workspace, check
out the illustration if you want to edit it in Creo Illustrate. To do so, select the
Windchill ribbon check out

icon.

4. When finished viewing or editing the illustration, you can save it to the active
workspace, or check in using Checkin
from within the active workspace

from within Creo Illustrate or
.

Checking Out a File
This section describes the check out actions available from Windchill.
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In order to modify an object, you must first check it out. Check Out accomplishes
the following:
•

Creates a copy of the object in the commonspace on the server and marks it
as checked out. This signals other users that the object is being modified,
and therefore, they cannot modify it.

•

Creates a working copy of the object in your workspace that holds all your
changes until you check the object back in.

•

Reserves the object in the commonspace, preventing other users from checking
in any changes to it until you release it. You release it by checking it back
in or undoing the checkout.

Note
Windchill supports the checking out of non-latest iterations of dynamic documents,
and the subsequent checking in of those documents to become the latest iteration.
This allows you to revert to an earlier version of an illustration.
For more information on checking out non-latest iterations, see the Windchill
Help topic, “Checking Out Objects from Windchill,” which is available from the
Windchill Check Out page. You can also access this topic from the Help Center.
This example illustrates the checkout workflow for an object that is open upon
request from Windchill.

Note
During a check out operation that uses the option of adding the object content to
the workspace, data is transferred from the Windchill database to the server-side
workspace. Optionally, if you choose to open the object from the workspace, the
data is then transferred from the workspace to your authoring application.
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You can also access Check Out from three areas in Windchill. When Check
Out is performed from the workspace in Windchill, a status message displays
in Windchill.
•

Select
Check Out from the Windchill active workspace when you
right-click anywhere in a row of the selected file you want to checkout.

•

Select the Check Out
table ribbon.

•

Select the File ▶

•

From Creo Illustrate, select Check Out

on the Windchill active workspace Object List

Check Out menu in Windchill.

in the Windchill ribbon.

Undoing a Check Out
Undo Check Out reverses a checkout, and allows you to return to the model that you
originally checked in. Undo Checkout acts on the object open in the active model

and reverses any changes that were made to this object after it was checked out.
The Windchill preference Undo Checkout Overwrite Local Content, available from
Preference Management, specifies whether the model content is overwritten in
cache by default when using the Undo Checkout action. The preference default is
set to False, meaning that model content is not overwritten in cache by default.
•

Select
Undo Check Out from the Windchill active workspace when you
right-click anywhere in a row of the selected file you want to undo the checkout.

•

Select the Undo Check Out
table ribbon.

•

Select the File ▶

•

From Creo Illustrate, select Undo Check Out

icon on the active workspace Object List

Undo Check Out menu in Windchill.

in the Windchill ribbon.

Checking In a File
This section describes the Check In action available from Windchill.
Check In is not an available action if there is no primary server and primary
workspace. You must register a server from Tools ▶ Server Manager in

Windchill Workgroup Manager, and activate a workspace.
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When you are finished making changes to a file, and you are ready to publish the
changes to the shared area on the server, you must check in your objects. The
following graphic illustrates the information flow during check in.

Note
Check in transfers data from the server-side workspace to the commonspace. If you
check in an object directly from the authoring application, the data is transferred
from Creo Illustrate to the server-side workspace, and then to the Windchill server.
Check In accomplishes the following:

•

Copies the working copy of your object from your workspace to the shared
area of the server.

•

Creates a new iteration of the checked-out object in the shared area.

•

If this object was checked out by you, releases the lock on the object in the
shared area, so that others can access it.

•

Check In is initiated from Windchill when you click Check In
workspace Object List table ribbon.

•

Select the File ▶

•

From Creo Illustrate, select Check In
Windchill ribbon.

on the

Check In Custom menu in Windchill.

, or Custom Check In

in the

When you initiate check in, you can choose from two options in Windchill:
•
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When you select Check In, your object is directly copied to the commonspace.
The process follows the defaults you or your administrator has set up, and
checks in what has changed in modified objects.
•

Custom Check In

When you select Custom Check In, you check in objects with changed settings
using the Windchill HTML user interface. When you select Custom, you can
specify certain options that are applied to the object you are checking in.
Custom takes you through two pages where you can specify the following
options.
For example, use
Custom Check In when you want to associate an
illustration with an Illustration Holder during first time check in.
1. Collect Objects
The Collect Objects page allows you to select the objects you want to check
in. Select the check boxes next to the objects you don't want to be visible to
others on the Windchill server. Go to Edit menu and select Set For Check in
to deselect the selected items for check in. Select Next.
On the File menu, select Check Out Now. The object can be checked out
using the Check in option.
On the Edit menu you can select Set Location, Keep Check out, or Set For
Check in.
Note
During check in you have the option of picking a folder location, or
browsing to a product ASPS location. You can also provide an optional
check in comment.
2. Set Options
The Set Options page allows you to specify certain options for the objects
you are checking in. Select the check box next to the options you want to
set. You can choose to do the following.
○ Create a baseline.
○ Undo check out of unmodified objects.
○ Remove objects from the workspace.
○ Auto-resolve incomplete objects, either:
○ Update with objects on the server, then ignore.
○ Always ignore.
3. Press Finish to check in the file.
Working with Windchill PDM Actions
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Renaming a File
This section describes the Rename action available only on the File menu in
Windchill. It is not accessible from Creo Illustrate.
To rename a file, right-click anywhere on the row of the illustration you want
to rename and click Rename.
Or,
Click the File ▶ Rename menu in Windchill.
Rename changes a name of an object by changing the values of the Number, Name,

and Model Name attributes, if you have Modify Identity access permission. You
can also rename objects that are in another's workspace; the system notifies the
other user that they need to synchronize their workspace with updated information
on the server.
Note
Only objects that have never been checked in can be renamed from the workspace.
Once objects have been checked into the commonspace, they can no longer
be renamed from the workspace and Rename must be accessed from the
commonspace.
Note
The only supported Creo Illustrate file type for interaction with
Windchill Workgroup Manager is c3di.
Note
The only associations supported in Creo Illustrate integration with
Windchill Workgroup Manager are Content and Contribution Content associations.

Creating a New Revision
To create a new revision for an object, right-click anywhere on the row of the
illustration you want to create a new revision and click
Revise. The Revise
window opens to allow you to create a new revision for an object. To accomplish
this you assign the next revision level available in a revision scheme. The revision
scheme represents a sequence of characters identifying subsequent versions of an
object. Creating a new revision of an object results in the object, and all objects you
choose to associate with it, advancing to the set revision level. When you revise an
object, the latest version of that object is used as the content for the new revision.
The
Revise action is only available from Windchill. It is not accessible from
Creo Illustrate.
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To create a new revision for an object, right-click anywhere on the row of the
illustration you want to create a new revision and click

Revise.

Or,
Select the File ▶

Revise menu in Windchill.

Uploading a File
This section describes the Upload action which is only available from the
user interface in Windchill Workgroup Manager. It is not accessible from
Creo Illustrate.
Upload stores working copies of the files you are editing in your registered

Creo Illustrateapplication to your personal folder location on the Windchill server,
without making your changes visible to other users. Upload is only valid for new
or modified files that are checked out to this workspace by you.
Upload local contents to server

is available on the Windchill ribbon, as shown

in the next graphic.

To upload an illustration, click Upload local contents to server
of the illustration you want to upload.

on the row

Or,
Click the File ▶

Upload menu in Windchill.

Synchronizing a File
This section describes the Synchronize action, which is only available from the
HTML user interface in Windchill Workgroup Manager. It is not accessible from
Creo Illustrate.
Synchronize ensures that the contents of the cache are in sync with the contents

of the server-side workspace. The cache can become out of sync when you are
working on workstation "A" for a day, then you upload all data in the workspace to
work on workstation "B" the following day. If you activate that same workspace
on Workstation "A" at a later time, the cache is out-of-date. This data needs to be
synchronized so that the object contains updated data. Data can also become out of
sync when the connection to the server is lost, and you keep working on cached
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workspace data. In this case, the data in the cache is more up-to-date than what is
in the server-side workspace. Click the Tools ▶ Synchronize menu in Windchill to
resolve out of sync data.

Working with Information System
Manager and Service Parts
You can work in Information System Manager and Service Parts in Windchill when
Creo Illustrate is integrated with Windchill Workgroup Manager, is registered
and connected to the Windchill Server, and when Service Information Manager
and Service Parts are installed.
Note
For more information about Service Information Manager and Service Parts,
refer to Accessing Service Information Manager and Service Parts on page in the
“Getting Started with Windchill Workgroup Manager” section.
Detailed information about Service Information Manager and Service Parts can
be found in the Windchill Help Center under:
•

Specialized User Capabilities ▶ Service Information Management ▶ Service
Information Management ▶ Windchill Service Parts ▶ Working with Windchill
Service Parts

and from,
•

Specialized User Capabilities ▶ Service Information Management ▶ Service
Information Management ▶ Windchill Service Parts ▶ Working with Windchill
Service Parts

Managing Illustrations in a Parts List
A typical use scenario is that a Parts List author who has created a Parts List for a
Service Manual or a Parts Catalog wishes to add, edit and delete illustrations to
a Parts List.
Use the Parts List Editor to manage Creo Illustrate illustrations in Windchill
Service Information Manager and Service Parts.

Adding Illustrations
Once you have created a Parts List you can add Creo Illustrate illustrations to the
Parts List using the Parts List Editor.
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Add illustrations to a parts list using the following steps:
1. From Windchill, select Information Structure, or Folders from the Navigator
pane.
2. In the Information Structure or Folders window you can either:
•

Insert a New Parts List by selecting Insert New ▶ Insert New Parts List. Enter
the product name for the new Parts List, select the folder, and click OK.

•

Select an existing Parts List.

3. Right-click the Parts List product name you want to add one or more
illustrations and select Open In ▶ Open Content in Parts List Editor.
4. In the Parts List Editor Structure tab, click
List Editor ribbon.

Add Illustration in the Parts

5. The Add Illustration window opens to allow you to search for and associate
illustrations to the parts list so they can be associated with individual parts.
After you have entered the search criteria, click Search.
Field
Search On

Number
Name

Description
The type of documents that you can search
on. In this case, only EPM Document is
applicable.
The number assigned to the illustration type.
The name of the illustration type.

For example, select EPM Document and the wildcard *.c3di, and click Search
to search for a Creo Illustrate illustration.
Note
To select a new search criteria, remove the existing search criteria by clicking
Clear. Renter the search criteria to view the new search results in the New
Illustration window table.
6. The search results are displayed in the New Illustration window table.
7. Select the illustration to add to the Parts List and click OK. The system
saves the illustration to the Parts List and when finished, opens the Parts List
Structure tab.
8. To add additional illustrations to the Parts List, repeat steps 3 — 7.
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Editing Illustrations
Edit illustrations to a parts list using the following steps:
1. From Windchill, select Information Structure, or Folders from the Navigator
pane.
2. In the Information Structure or Folders window, right-click the Parts List
product name you want to edit one or more illustrations and select Open
In ▶ Open Content in Parts List Editor.
3. In the Parts List Editor Structure tab, select the illustration you want to edit and
click

Check Out in the Parts List Editor ribbon.

Note
Depending on your preference, you can check out the illustration from the
active workspace or from within an active Creo Illustrate session.
4. Right-click the illustration and click
illustration in Creo Illustrate.

Open in Creo Illustrate to open the

5. If you haven’t checked out the illustration while in the active workspace, check
out the illustration if you want to edit it in Creo Illustrate. To do so, select
Check Out

in the Windchill ribbon.

6. When finished editing the illustration, you can save it to the active workspace,
or check in using the check in options in Creo Illustrate or from the Windchill
active workspace check in options.

Deleting Illustrations
Delete illustrations to a parts list using the following steps:
1. From Windchill, select Information Structure, or Folders from the Navigator
pane.
2. In the Information Structure or Folders window, right-click the Parts List
product name you want to delete one or more illustrations and select Open
In ▶ Open Content in Parts List Editor.
3. In the Parts List Editor Structure tab, select one or more illustrations you
want to delete from the product name content holder and click
Remove in
the Parts List Editor ribbon.
Note
If an illustration is checked out, it cannot be deleted until it is checked back in.
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This chapter discusses advanced usage of Windchill Workgroup Manager. It
covers basic information about:
•

Thumbnail Generation and Thumbnail Worker.

•

Viewing Relationships.

•

Conflict Management.

•

Cache Management.
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Thumbnail Generation and Thumbnail
Worker
You are able to see thumbnails of Creo Illustrate illustrations in
Windchill Workgroup Manager.
The documentation concerning thumbnail generation and thumbnail worker can be
found in the ProductView™ Adapters Installation and Configuration Guide.

Viewing Relationships
You are able to see the related drawings on a Windchill part’s information page by
selecting the Related objects ▶ Related CAD/Dynamic Documents report.
Similarly, you are able to see the Windchill parts related to an illustration’s details
page by selecting the Related Parts report.
The Related Objects reports for dynamic documents do not have a configuration
control; by default you are shown the latest configuration.

Conflict Management
The term conflict management refers to addressing or resolving the restrictions
that your PDM system can place on your retrieval, modification, and storage
activities in order to maintain the integrity of the database. Typically, with
Windchill Workgroup Manager, you encounter two types of conflicts, as follows.
•

Conflict upon an attempt to modify an object.

•

Conflict upon attempting to perform a PDM transaction (referred to as an
event) such as check in, check out, and so forth.

Conflict upon Attempt to Modify
If you attempt to modify a workspace object that is not checked out (and also not
locked), then upon attempting a checkin, the system presents the Conflicts window,
informing you that the object is read-only because it is not checked out. You can
choose to resolve the conflict by using one of the following options.
•

Check out now – Perform an immediate check out on the object (within a

version), enabling you to modify the object and later check in the modifications.
When checked in, the modifications are shown as an iteration of the current
object version.
•

Revise and Check out – Perform an immediate check out on the object (for

a new version), enabling you to modify the object and later check in the
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modifications. When checked in, the modifications are shown as a new version
of the object.
•

Continue – Continue with modifications without checking out (modifications

will not be eligible for checking in, and may be lost.)
If your attempt at modification involves several checked-in objects, you can
specify different resolutions of the conflict for each object, or you can use the Set
All menu to apply the same resolution to all.

Conflicts Involving a PDM Event
PDM events may cause conflicts with the database that need to be resolved. Event
Management provides a way for you to check and act on log messages generated
in Creo Illustrate or Windchill sessions. It can be accessed in the following ways.
•

From the Windchill ribbon in Creo Illustrate, select Event Management

.

Note
From Creo Illustrate, only information about transactions with the primary
server is available. In the Creo Illustrate message area, a graphical status
indicator provides status information.
•

From a workspace, select Event Management from the workspace actions
drop-down list.

•

Select the Event Management link in the banner at the top of a Windchill page.

•

From Windchill Workgroup Manager, select the Console Status icon in the
status bar.

•

In Windchill Workgroup Manager, select Tools ▶ Event Management.

•

In Windchill, select Home ▶ Quick Links ▶ Event Management.

On the Event Manager page you can see the PDM events for the named server
listed chronologically in the Events table. You can access detailed information
about a particular event by clicking in the event's Actions column, and access the
Conflict Management page by clicking icons displayed in the Actions column for
viewing or resolving conflicts.
The event type icons used by Event Management are described in the following
table.
Event Management Icons
Icon
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Description
Overridable type conflict
Non-overridable type conflict (Failed)
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Event Management Icons (continued)

Icon

Description
Warning
In Progress
Pending
Retried
On Hold

The icons for actions that may be available in the Actions columns are described
in the following table.
Actions Column Icons

Icon

Description
View event information
View Warnings/Conflicts
Resolve Conflicts

The Event Information page is accessed from the Event Manager by clicking the
information icon
in the Actions column for the event in the Event List, or by
selecting the hyperlink in the event name. The Event Information page lists the
objects that have been processed for a given event. At the top of the page is a
hyperlink that returns you to the Event List. Below the hyperlink is the event title.
Next to the event title are icons for the Delete action and, if warnings or conflicts
occurred, one of the following actions, as applicable to the type of event:
•

View Warning

– If the event type is a warning

•

View Conflicts

– If the event type is a non-overridable conflict

•

Resolve Conflicts

– If the event type is an overridable conflict

The area immediately below the event title lists the event attributes, as follows:
•

Event Name – The name of the event.

•

Workspace – The workspace from which the event originated.

•

Status – The status of the event, if completed, or a progress bar indicating
how close the event is to completion.

•

Start Date – The date and time the event began.
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• End Date – The date and time the event was completed.
• Elapsed Time – The total time required to complete the event (if completed).
Below the attributes area is a table listing the Affected Objects in the event.
The Conflict Management page assists you in viewing and resolving conflicts that
arise from database events. It is accessed from Event Management or the Event
or the resolve conflicts
Information page by clicking the view conflicts icon
icon .
The next graphic displays the Conflict Management page.
Objects that experienced one or more conflicts during an event are listed in the
Conflicts table, which by default has the columns described in the following table.
Conflicts Table Columns
Column
(Selection)
(Conflict type)
Name
Retry Option
Description

Number
File Name

Description
Select check boxes to select or deselect rows. Clicking the
header check box selects/deselects all rows.
Displays an icon identifying the type of conflict.
Displays the name of the affected object, if applicable.
Displays the default or currently applied user-selected retry
option for the conflict, if one is available.
Displays an explanation of the conflict.
Note
If the explanation exceeds character limits for the column,
an ellipsis (...) followed by a link "view full text below..."
appears at the end of the truncated description. Clicking the
link displays the full text of the description in the Description
field below the Conflicts table
Displays the number of the affected object, if applicable.
Displays the file name of the affected object, if applicable.

Note
You can customize your Current View of the Conflicts table; however, setting (row)
filters is not allowed for this table. For more information, see the help available
from the Customize View List page, which appears when you select Customize
from the current view drop-down list.
In the ribbon of the Conflicts table is a drop-down menu that lists any Retry Options
common to all of the selected conflicts.
Advanced Techniques
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To resolve an overridable conflict, perform the following procedure.
1. Select one or more rows containing an overridable conflict.
2. Select an option from the Retry Options drop-down list in the table ribbon.
3. Select Set. The Conflicts table refreshes to display the new value in the Retry
Option column for the selected row(s).
4. Select Retry. The action is retried and a new entry is created in the Event List.
The original event's status changes to Retried. Further access to the original
event in Conflict Management is read-only.

Managing Cache
Windchill Workgroup Manager cache is a local repository for third-party authoring
applications contained in a specific workspace, and is used only when uploading
or downloading files to and from the server. Using cache improves performance
because Windchill Workgroup Manager only downloads files if the content on the
server is more recent than the content in the cache; and only uploads files when
you direct it to do so.
By default, when you register Windchill servers and authoring applications, a
.vfs directory is created for cache. It is located under your user profile on your
local computer. For every server location listed in the .vfs directory, there are
subdirectories for each workspace.
Note
Working directly in cache is discouraged so that data is not accidentally corrupted.
To help avoid directly working in cache, a component on the client, called the
Workspace Local Directory, is available. It is recommended you use this, rather
than browsing to or saving from Arbortext IsoDraw to the cache directly. Sample
default locations for the Workspace Local Directory are provided below.
The cache location is defined by the environment variable
`PTC_WF_ROOT’, which is the client connector cache. This is where
all Windchill Workgroup Manager related client side information is stored. If the
environment variable is not explicitly defined, the default location will be the
user's home directory.
By default, cache is not shared between Windchill Workgroup Manager and Creo.
If you are planning to run the Windchill Workgroup Manager and Creo on the
same system and also want to have the cache residing in a non-default location,
you must explicitly set the cache (PTC_WF_ROOT ) for both these applications to
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different locations. For example, one method of achieving this is to create a startup
batch file for each application that defines the `PTC_WF_ROOT’ environment
variable (cache location) and then start the program.
The default locations for the Windchill Workgroup Manager, Creo and
Creo Illustrate cache, and Workspace Local Directory locations, are as follows:
•

Cache location for Creo - %APPDATA%\PTC\Creo\.wf

•

Cache location for Windchill Workgroup Manager %APPDATA%\PTC\Creo\.wwgm

•

Workspace Local Directory location for Creo - %USERPROFILE%\.wf

•

Workspace Local Directory location for Creo Illustrate %USERPROFILE%\.wwgm

Although it is not recommended you directly access the .vfs directory; there
are certain PDM actions that require you to select from it. For example, Open
queries the Creo Illustrate subdirectory in the .vfs directory so you can select the
document you want to open. If desired, the location of the .vfs directory can be
changed by setting the environment PTC_VFS_ROOT to the required location.
Cache is managed from the Cache tab on the Server Management window (Tools >
Server Management). This window describes your workspace local directory/managing
directory location, cache space used (in MB), and available disk space. There is
also an option to clear the cache. The following graphic shows the Cache tab
window.

This information is also displayed on the Cache Management window.
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Select Cache Tools on the Cache tab to access the Cache Management window.
The Cache Management window provides the following:
•

Workspace local directory location of primary server's active workspace

•

Cache usage

•

Path to the .ws directory

•

Cache limit. The Target Cache Limit can be set in the wgmclient.ini
file entry cache.size, or by setting the environment variable
dm_cache_limit.

•

Amount of utilized disk space

•

The Clear Cache button clears all cache in the inactive workspace.

The next graphic displays the Cache Management window.
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This chapter is intended for all users and contains the Windchill Workgroup
Manger client and server preferences, such as preference organization and access,
and modifying preferences.
Preferences are set to enforce a company's business policies in a
consistent manner, and to ensure that the user environment meets
personal working styles. Administrators set preferences to customize
Windchill Workgroup Manager functions, user interface displays, and to provide
default behavior. Users can set client preferences to meet their personal working
styles.
There are two areas in which to set preferences:
•

The Preference Management utility on the Utilities tab on the Windchill server:
○ Allows an administrator to set server preferences.
○ Allows an administrator or a user to set client preferences.

•

wgmclient.ini file on the client:
○ Allows users to set client preferences.
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Preference Organization
The preference system is organized using a top-down design where an
administrator first sets up the commonly used server and client preferences,
followed by the user, who typically specifies client behavior.
The following list describes the preferences hierarchy:
1. Windchill Organization; the most general level. The preferences at this level
are set by an administrator on the server in the Preference Management utility.
These preferences are visible to administrators and users.
2. User; the second-most general level. The preferences at this level are
client preferences set in the Preference Management utility, and in the
wgmclient.ini file. These are visible to the user and the administrator, and
are client-only preferences. These client preferences can be customized from
what is already set by the administrator. If the same client preference is set in
the wgmclient.ini file, it overrides the client preference settings in the
Preference Management utility window.
3. wgmclient.ini file; the most specific preference level. The preferences
at this level are visible to the user, and override client preferences set on the
server in the Preference Management utility. These preferences are set to
customize the client to meet individual user working styles.
Note
Administrators can lock a preference in the Preference Management utility so that
it cannot be changed by anyone, including the settings in the wgmclient.ini
file. Administrators usually lock certain preferences to ensure certain business
policies cannot be changed.

Accessing Client Preferences on the
Server
The Manage Preferences window is accessed by a user from Windchill, using
the following path:
Windchill ▶ Home ▶ Utilities ▶ Preferences.
Client preference selections are available under the Windchill Workgroup Manager
header in the Preference Management.
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Editing Preferences
Every preference can be changed unless it is locked by the administrator. Use the
following procedure to change a preference from its current state.
1. If you are an administrator, access from Windchill, Site ▶ Utilities ▶ Preference
Management. If you are a general user, access from Windchill,
Home ▶ Utilities ▶ Preference Management.
The Preference Management utility window opens. This window lists all
preferences, and this is where you set server and client preferences.
2. Preferences display by category. Most categories have several selections.

Windchill Workgroup Manager Client and Server Preferences
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For example, The Workgroup Manager Client category lists general
and specific preferences for authoring applications integrated with
Windchill Workgroup Manager.

3. Individually, select the preferences you want to set by selecting the preference
and right-clicking to select the Set Preference
icon.

4. In the Set Preference window, enter or select the appropriate values for this
preference and select OK. The preference is set.
After a server-side preference is changed, in order to see them in the model, it
must be synchronized through Tools > Synchronize.
All client preferences have a Client: drop-down list that displays the preference
options that can be set.
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Adding a User-defined Soft Type for
Creo Illustrate
You can set a default preference for a user-defined soft type in the
Windchill Workgroup Manager for Creo Illustrate, using the Site Admin login.
1. From Windchill, navigate to Site ▶ Preference Management ▶ Windchill
Workgroup Manager ▶ Client ▶ Default soft type. Locate and select the
Creo Illustrate preference in the list of applications.
2. For the Creo Illustrate preference, the default soft type is Dynamic Document.
Click on the Edit Icon to edit the preference.
3. See the default value of the preference, “${internet_domain_name}.
DynamicDocument”. You can substitute a different user-defined soft type
if required, such as, “${internet_domain_name}.MachineDesign”, where
“${internet_domain_name}.MachineDesign is the Logical Identifier of
user-defined soft type.

Setting the Embedded Browser
Preference
Windchill Workgroup Manager allows you to set a preference for which
Internet browser you wish to use as the embedded browser for your
Windchill Workgroup Manager installation. This preference is set in the
wgmclient.ini file. Supported browsers are Internet Explorer and Mozilla.
The preference is set as follows:
•
•
•
•

The syntax for the preference is
windows.browser.type=browser_name.
To set the default embedded browser type to Internet Explorer, the syntax is
windows.browser.type=IE_In_Process.
To set the default embedded browser type to Mozilla, the syntax is
windows.browser.type=Mozilla_based_browser.
A sample entry in the wgmclient.ini file looks like this:
================================
# Sets the WWGM embedded browser type.
windows.browser.type=Mozilla_based_browser
================================

•

Out-of-the-box, the default embedded browser in the wgmclient.ini file is
set to Internet Explorer.

Note
Windchill Workgroup Manager currently supports only the 32–bit Mozilla browser.
Windchill Workgroup Manager Client and Server Preferences
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See Editing the wgmclient.ini File on page 82 for more information on how to
edit the wgmclient.ini file.

Editing the wgmclient.ini File
The default wgmclient.ini file is located in the
Windchill Workgroup Manager Home directory. You edit this file to make changes
to client preferences. Changes made in this file override client preferences set on
the server. Use the following procedure to edit the wgmclient.ini file.
1. Open wgmclient.ini in a standard text editor.
2. Change any preference as follows:
<preference name = preference value>
3. Remove the # prefix in the wgmclient.ini file to uncomment any
preference that should override the settings on the server (the preference name
= preference value pair).
4. Save the file.
5. Restart Windchill Workgroup Manager. The new client preference is available.
To add a section to Creo Illustrate, perform the following procedure.
1. Open wgmclient.ini in a standard text editor.
2. Add an explicit section [CreoIllustrate/Client Name] and define preferences
specific to Creo Illustrate below this heading. <preference name = preference
value>.
3. Save the file.
4. Restart Windchill Workgroup Manager. The new client preference specific to
Creo Illustrate is available.
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This section is intended for Administrators. It covers the information necessary for
setting up and configuring Windchill Workgroup Manager for Creo Illustrate. It
may be useful to refer to the following Windchill documents for more information.
•

Windchill Customizer’s Guide

•

Windchill System Administrator’s Guide

•

Windchill Business Administrator’s Guide

•

Creo Illustrate User's Reference

These guides are located at PTC Reference Documents.
This chapter also covers other recommendations for performance tuning, setting
up a desirable Windchill folder structure.
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Configuring Business Practices
This section describes how an administrator configures Windchill and the CAD
application to suit a company's business requirements.

Configuring Naming and Numbering
You can specify how newly-created CAD or authoring documents
(EPMDocuments) and Parts (WTParts) are named and numbered using a set
of standard policies. It is also possible to customize the CAD or authoring
document, like Creo Illustrate, naming service to address more advanced naming
and numbering requirements.

Policy-Managed Naming and Numbering
Windchill Workgroup Manager supports two policies to determine how newly
created objects are named and numbered. These policies are the following:
• Auto-numbering
• Name-driven
These policies are only utilized during the initial creation Creo Illustrate documents.
These policies are used during upload of new dynamic data (when a new dynamic
document can be created based on a model file). If the policy is changed at a
later date, existing data is not affected.
These policies can be used together to drive the naming and numbering behavior.
For example, auto numbering can be used with Custom to form a numbering
policy. The four policies can be described as follows:
•

Auto-numbering

•

○ Auto-numbering is the default naming and numbering policy.
○ The Creo Illustrate document number is provided by the document number
generator (either using the standard Windchill number generator, or through
customization).
○ In the Rename user interface, the number field can not be edited , unless
auto-numbering is disabled or the override preference is set by the
administrator that allows users to override the auto-numbering sequence
and manually enter a value in the number field.
Name-driven
○ When auto-numbering is disabled, name-driven policy comes into effect.
○ The Windchill Object Number is copied from the Creo Illustrate file name
(the file extension can be dropped and is controlled by the Windchill
preference, Upload Drop Number File Extension).
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○ The Windchill Document Name is also copied from the model file name
(the file extension can be dropped and is controlled by the Windchill
preference, Upload Drop Name File Extension).
○ If you use Workspace Rename to set the Windchill Name or Number
attribute for a new document, its value is pushed from Windchill to the
authoring environment .
○ The Creo Illustrate document and part Number field can be edited using
Rename. If parts are auto-created from dynamic documents, then the
user does not get the chance to specify a part number. If parts are created
manually, the user has the option to specify number during creation
(assuming autonumbering is disabled). If a dynamic document is created
in the Creo Illustrate application, it has no ability to define the Windchill
dynamic document number. The user must then use Rename in the
workspace to allocate a different value prior to check in.
Identifying the Current Naming and Numbering Policy
The algorithm used to understand which policy is currently set in the system (for a
particular container and class of object) is as follows:
•

If auto-numbering is set in object initialization rules, then the policy is
auto-numbering.

•

If custom behavior is implemented in rules, then the policy is custom.

•

If neither auto-numbering or custom behavior is set and the parameter-driven
properties are set in the Preference Management utility, then policy is
parameter-driven.

Windchill Preferences for Naming and Numbering
The following preferences control parameter-driven Naming & Numbering policy
when using Windchill Workgroup Manager. By default, these properties have
no value:
When set to Yes (default is No), the following properties omit file extensions from
name and number attributes for new dynamic documents during upload:
•

Upload Drop Name File Extension.

•

Upload Drop Number File Extension.
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Configuring Collection
The administrator and/or user can define default collector behavior through the
Windchill Preference Management utility (the default behavior can be changed at
run time). The following collection modes are supported:
•

Collecting all dependents at the time the collector is launched with a seed
object (up- front) such that selection actions are enabled or disabled depending
on what is selected.

•

Collecting only the required dependents of a seed object at the time the
collector is launched.

•

Collecting dependents incrementally when an object is selected and an action
clicked.

The first two listed modes can be accomplished on the Basic tab of the action page,
while the incremental selection is performed on the Advanced tab.
The system provides default settings that apply to both tabs. You can tailor the
collection process by setting one or more specific preferences that determine the
default object collection that is performed when an action is initiated.
All preferences related to the collector can be set per site, organization, or
user in the Windchill ▶ Site ▶ Utilities ▶ Preference Management. The collector
infrastructure allows each specific action (for example, Check In or Edit Attributes)
to specify a default collection for the action, as well as a default display for the
Advanced tab.
The preference is set in the Preference Management utility under a node specific to
the action. For example, the preferences for collection at Check In are found as
illustrated in the next graphic.
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The following collector preferences can be set to the values listed (note that not all
the following collection options are applicable to every action — e.g. Collector for
“Add to Baseline” has difference collection options to “Add to Workspace”):
•

Default display: All as a list, Structure, Drawings, Related Objects, Family
table, References, Change objects.

•

Configuration: Latest, As Stored, Baseline, Effectivity, Product Maturity, Use
Workspace configuration.

•

Drawings: All , Initially Selected Only, None

•

Instances: All , Initially Selected Only, None

•

Generics: All , Initially Selected Only, None

•

Parts: All , Initially Selected Only, None

•

Documents: All , Initially Selected Only, None

•

CAD Documents: All , Initially Selected Only, None

•

Affected Data : All, None

•

Change Items: All, None

•

Change Notice: All, None

•

Change Activity: All, None

•

Change Request: All, None

•

Related objects : All, Required, None

•

CAD Document Dependents: All , Initially Selected Only, None

•

Part Dependents: All, None

•

Variance: All, None

Because only a subset of these preferences might be relevant for a specific action,
not all preferences are required to exist for each action.
Note
A particular preference can be overridden by each individual user (if not locked at
the Organization or Site level by the administrator).
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Enabling As Stored Configurations
The As Stored configuration is created at checkin. When more than one CAD
document or a drawing CAD document is checked in from the workspace, the
As Stored configuration is created. The As Stored configuration is a snapshot of
the workspace at the time of check-in. You can use the As Stored configuration
in the following ways:
•

Reload the workspace the same way as the iteration is modified when the user
works with (or references) the checked-in iteration in the future.

•

Retrieve the assembly using the As Stored configuration.

By default, Create As Stored is set to Yes in the Preference Management utility.
Create As Stored specifies to create an As Stored configuration upon checkin.
As Stored is particularly useful when working with Drawings and Assemblies. It
allows the Workgroup Manager user to retrieve an assembly or drawing using
the same related components “as it was stored” with at the point of Check In
(as opposed to retrieving Latest versions of all related parts which may have
been modified independently of the parent drawing/assemblies during design
developments). This is useful in order to get back to a known configuration of
drawing or assembly. Baselines also achieve the same result of recording specific
configuration of versions/iterations. However, a baseline is a more formal method
of capturing a configuration, which is a conscious decision to create a separate
managed object that captures a particular configuration of components rather than
just “as they were stored.” Often As Stored configuration is used to generate a
baseline at a later date, e.g. to create a baseline of a set of drawings/assemblies that
need to be reviewed at a design review. You would use As Stored since Latest may
pick up some later versions of the underlying parts that have not been detailed in
the drawing yet or some that may cause assembly to fail regeneration.
Note that As Stored only considers data in the workspace at the time of Check In.
For example, if you are checking in an assembly which has 10 components and
only 5 of those components are present in the workspace, then your As Stored
configuration will contain only those 5 parts. The other 5 parts will be retrieved
according to Latest configuration.
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Configuring Revision
Administrators can configure how the system behaves during a revision operation
by setting preferences in the Windchill ▶ Site ▶ Utilities ▶ Preference Management.
These settings can determine whether to do the following:
•

Allow revision to a level other than the next in the revision scheme.

•

Create or maintain passive associations during a revision action.

•

Synchronize revision levels of CAD documents and parts during an auto
associate action.

Note
The revision level synchronization behavior described in the section, Configuring
Auto Associate Parts, also applies to Revision when the preference Auto
Associate ▶ Set Revision For Part is set to Yes.

Configuring the Ability to Set a Revision Level
A key-value pair in the Windchill preference system allows an administrator to
enable users to set a higher revision level than the next label in the revision scheme.
When set to Yes (default), the preference Set Target Revision adds a Select Revision
Label button to the New Revision user interface that allows the user to skip one
or more levels of revision during a revise operation. In addition, a revision level
can be set in the New CAD Document user interface. When set to No, the object is
revised to a default target/next revision in its series.

Configuring the Revision of Associated Items
You can configure how Content links are carried forward to new revisions
of associated (linked) objects. Using the xconf file, modify or add
<Windchill>/codebase/wt.properties, which contains the following
key-value pairing:
Key = wt.vc.struct.copyDescribeLinkOnRevise

Values: No, Yes (default)
With wt.vc.struct.copyDescribeLinkOnRevise set to the default
value, Yes, the system behaves as follows for the revision of a CAD document or
part with a Content association.
•

There is only one link; iteration-to-iteration.

•

If only the CAD document is revised, the link is not carried forward. The new
version of the CAD document does not have an association to the existing
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versions of the part (because the existing part version might be released, and
the content version of the part should not change without a check out or revise).
•

If only the part is revised, both the new and the old version of the part have a
link to the existing version of the CAD document.

•

If both the CAD document and part are revised during the same revision, the
new versions have a new Content link between them, and the old versions
maintain their existing link.

When wt.vc.struct.copyDescribeLinkOnRevise is set to No, the
system behaves the same as when it is set to Yes, with the following exception.
•

If both the CAD document and part are revised during the same revision,
then regardless of the settings in the user interface, revise acts as if the CAD
document and part are being revised alone.

Rules for New Versions
Consider these rules for new versions:.
•

By default, all new versions should be created in the same location (context
and folder) as the original.

•

If there is a user interface, the user can override the default location and choose
to place the new version somewhere else.

•

For Windchill PDMLink, the team and life cycle are determined by the object
initiation rules of the context.

•

The view of new parts defaults to the same view as the original.

Configuring Attributes
Attributes are entities that define properties of objects, such as CAD files or
Windchill business objects. They always consist of a name and value, for example,
Life Cycle State can be assigned the value, In Work.
In Windchill, there are two types of attributes: hard and soft. The system
attributes that are hard-coded into Windchill, are therefore available by default.
System attributes are typically defined for a set of characteristics that most
business objects share, such as name or number. User-defined attributes, are not
hard-coded; therefore are not available by default. The user defines soft attributes,
for example, COLOR or LENGTH, for individual objects or classes of objects.
CAD applications have analogous entities, variously called properties, parameters,
or attributes, that can be mapped to Windchill attributes so that their values are
communicated between Windchill and the CAD application, if desired.
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Note
For purposes of clarity in discussing attribute management, it is the standard
of this guide to refer to Windchill attributes as attributes and to refer to CAD
application attributes, properties, and parameters as parameters.
Administrators configure attributes and parameters so they are published
(viewable) in the CAD application and Windchill. This section describes:
•

Attribute and parameter types.

•

Configuring attributes and parameters so they are published from Windchill to
the CAD application.

•

Adding new CAD application parameters.

•

Managing system attributes and parameters.

•

Customizing existing Windchill attributes to create additional CAD parameters.

•

Ensuring that user-defined CAD application parameters are recognized in
Windchill.

•

Mapping attributes and parameters.

Attribute and Parameter Types
There are three main categories of attribute or parameters when working with
Windchill Workgroup Manager:
•

Windchill default system attributes.

•

authoring application parameters.

•

custom parameters.

Note
No authoring application parameters are exposed to Windchill through Windchill
Workgroup Manager.

Windchill Default System Attributes
The set of Windchill default system attributes are automatically published in
the authoring application when a CAD part or drawing is checked in or saved
in Windchill. These are used to support required authoring application system
parameters, such as revision. Because Windchill writes these to the authoring
application, they cannot be modified. The information on these attributes always
comes from the Windchill system, and therefore is always up-to-date (for example,
Revision reflects the Windchill revision).
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A list of the attributes provided by Windchill is listed in the following table.
Windchill Default System Attributes
Windchill Attribute
PTC_WM_REVISION

PTC_WM_PART_NAME

92

Description
• String Type
•

Initial value the first revision corresponding
to the default context of the Workspace. This
should be set to Yes whether or not the server
is online or offline.

•

Corresponds to the string used for just the
Windchill version of the CAD document. By
default this is usually, A, B, C, etc.

•

If the user modifies the value, then upon the
next retrieval or update, the value is overridden
by the system

•

Predicted upon save for new objects.

•

Should be set to the current CAD document
revision when setting upon check out for an
existing object.
String Type

•
•

Initial value: Not Applicable. This system
attribute should never be created on initial
creation of the CAD document.

•

Corresponds to the string used for the name
of the actively associated part to this model’s
CAD document.

•

May be created and set before the initial
auto-association if the naming policy is set to
use a custom parameter. Otherwise, the value
is ignored and set upon Save.

•

For new or existing CAD documents, if the user
associates, then the system parameter should
be available to be updated upon next retrieval
in or save from the authoring application.

•

When checking out an existing CAD document,
the system parameter should reflect the name
of the CAD document’s actively associated
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Windchill Default System Attributes (continued)
Windchill Attribute

PTC_WM_PART_NUMBER

PTC_WM_NUMBER

Description
part. If none exists, then the system parameter
is not created in the authoring application.
• String Type
•

Initial value: Not Applicable. This system
parameter should never be created on initial
creation of the CAD document.

•

Corresponds to the string used for the number
of the actively associated part to this model’s
CAD document.

•

May be created and set before the initial
auto-association if the naming policy is set to
use a custom parameter. Otherwise, the value
is ignored and set upon Update.

•

This attribute is not predicted. For new or
existing CAD documents, if the user associates,
then the system parameter should be available
to be updated upon next retrieval in or save
from the authoring application.

•

When checking out an existing CAD document,
the system parameter reflects the number of the
CAD document’s actively associated part. If
none exists, then the system parameter should
not be created in the authoring application.
String Type

•
•

Initial value should be set according to the
naming policies. That is, if the policy is set to:
○ CAD Model Name, then the initial value
should be based on CAD file name. The
number will contain the extension based
on a preference.
○ Auto-numbering, then the initial value
should be generated by taking a number
from the PTC auto-numbering system.
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Windchill Default System Attributes (continued)
Windchill Attribute

Description
○ CAD attribute, then the initial value should
be based on the CAD property that is
defining the number.
○ Custom naming/numbering application,
then the initial value should be generated by
taking a number from the customer-defined
auto-numbering system.
If the server is offline, and the system
cannot predict the number (due to
auto-numbering mechanisms not being
available), then the initial value is denoted
by a white space.

PTC_WM_NAME

•

Corresponds to the string used for the number
of this model’s CAD document.

•

May be created and set before the initial save
if the naming policy is set to use a custom
parameter. Otherwise, the value will be ignored
and set upon initial save or a subsequent
retrieval.

•

Predicted upon save for new objects.

•

Should be set to the current CAD document
number when setting upon check out for an
existing object.
String Type

•
•

Initial value should be set according to the
naming policies. That is, if the policy is set to:
○ CAD Model Name, then the initial value
should be based on CAD file name. The
name will contain the extension based on a
preference to keep the extension.
○ Auto-numbering, then the initial value
should be based on CAD file name. The
name will contain the extension based on a
preference to keep the extension.
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Windchill Default System Attributes (continued)
Windchill Attribute

Description
○ CAD Attribute, then the initial value
should be based on the CAD property that
is defining the name.
○ Custom naming or numbering application,
then the initial value should be based on
CAD file name. The name will contain the
extension based on a preference to keep the
extension.
○ The initial value should be able to be set
whether the server is online or offline.

PTC_WM_
ORGANIZATION_ID

•

Corresponds to the string used for the name of
this model’s CAD document

•

May be created and set before the initial save
if the naming policy is set to use a custom
parameter. Otherwise, the value will be ignored
and set upon initial save or a subsequent
retrieval.

•

Predicted upon save for new objects.

•

•

Should be set to the current CAD document
name when setting upon check out for an
existing object.
String Type

•

Initial value should be:
○ Predict: Set according to be the
organization identifier of the context of the
workspace.
○ Offline: Set according to be the
organization identifier of the context of the
workspace.

•
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Corresponds to the CAD document’s
organization identifier
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Windchill Default System Attributes (continued)

Windchill Attribute

PTC_WM_ITERATION

PTC_WM_LIFECYCLE
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Description
•

Predicted upon save for new objects

•

Should be set to the current CAD document
organization identifier when setting upon check
out for an existing object.
String Type

•
•

Initial value should be predicted and set to 1
whether the server is online or offline.

•

Corresponds to the CAD document iteration.

•

Predict for both new and existing. Upon check
out, the value should be predicted to be the
iteration after the current CAD document
iteration.
String Type

•
•

Initial value should be set according to be the
object initialization rules of the context of
the workspace. This should be Yes whether
the server is online or offline. For more
information on object initialization rules,
refer to Identifying the Current Naming and
Numbering Policy.

•

Corresponds to the name of the CAD
document’s life cycle.

•

Predicted upon save for new objects.

•

Should be set to the current CAD document
life cycle when setting upon check out for an
existing object.
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Windchill Default System Attributes (continued)

Windchill Attribute
PTC_WM_LIFECYCLE
_STATE

PTC_WM_IS_DRAWING

Description
• String Type
•

Initial value should be set according to be the
object initialization rules of the context of the
workspace. Should take the initial state of the
default life cycle. Initial value should be set
whether the server is online or offline.

•

Corresponds to the name of the CAD
document’s life cycle state.

•

Predicted upon save for new objects.

•

Should be set to the current CAD document
life cycle state when setting upon check out for
an existing object.
Boolean Type

•
•

Initial value should be set according to CAD
Adapter’s declaration of the CAD document
type or Model Descriptor. If it is set to be
a drawing, then the Boolean is set to Yes,
otherwise it is No.

•

Set to Yes if the CAD document is a drawing.

•

The value should not change once the object
is checked in.

Additional Default System Attributes for Creo Elements/Direct Drafting
The following table lists additional default Windchill system attributes
that exist for in the Windchill Workgroup Manager integration with
Creo Elements/Direct Drafting:
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Windchill Attribute
PTC_WM_PART_REVISION
_FOR_DRAWING

PTC_WM_PART_STATE
_FOR_DRAWING

PTC_WM_CREATED_BY

PTC_WM_CREATED_ON

PTC_WM_MODIFIED_BY
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Description
• String Type
•

Default: Empty string

•

Scope: Part

•

•

The revision information for the WTPart
associated with the drawing itself, or the
owning model of a drawing. If the drawing is
associated with a WTPart, this attribute has
preference.
String Type

•

Default: Empty string

•

Scope: Part

•

•

The life cycle state information for the WTPart
associated with the drawing itself, or the
owning model of a drawing. If the drawing is
associated with a WTPart, this attribute has
preference.
String Type

•

Always set

•

Scope: Content

•
•

The name of the user that created the CAD
document
Date and time (String) Type

•

Always set

•

Scope: Content

•
•

The date and time that the CAD document was
created
String Type

•

Default: Empty string

•

Scope: Content

•

The name of the user that last modified the
CAD document
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Windchill Attribute
PTC_WM_MODIFIED_ON

PTC_WM_LAST_CHANGE
_NOTE

Description
• Date and time (String) Type
•

Default: Empty string

•

Scope: Content

•
•

The date and time that the CAD document was
last modified
String Type

•

Default: Empty string

•

Scope: Content

•

The text note added to the last checkin

Custom Parameters
Custom parameters are created by the CAD administrator in the CAD application
on the Custom Product tab, and need to be mapped in Windchill using the Type
and Attribute Management utility so that they are recognized in Windchill and
published in the authoring application. For more information on mapping, refer to
Attribute and Parameter Types on page 91.
To access the CustomProduct page, go to the File menu in your authoring
application.

Configuring Attributes and Parameters
To ensure attributes and parameters are published in Windchill, they need to be
configured in Windchill and the authoring application. If a CAD drawing or
part has been checked in or saved in Windchill, the Properties page displays
the authoring application default parameters. These parameters are read-only;
however if required by your company, they can be modified. To modify these
parameters, the Windchill administrator modifies a preference in the Preference
Management utility page in Windchill, and maps it to the authoring application
preference. Mapping is performed so that the preference is recognized between
Windchill and the authoring application. For more information about mapping,
refer to Attribute and Parameter Types on page 91.
Before you have created a CAD document and before it is checked in, you can set
up attributes ahead of time in the Preference Management utility. For example, for
naming and numbering you can go to the authoring application drop-down list in
Set Preference window and set up the attributes you plan to use.
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If a user creates a authoring application parameter that conflicts in type with a
Windchill system attribute, then this user-created parameter should be deleted
and the system parameter of the correct type should be created by the Windchill
administrator. In this way, there is no conflict between the authoring application
and Windchill, and the parameter is published to the authoring application user
interface.
For example, in the Preference Management utility, locate the preference called,
PTC_WM_REVISION.
Select the set preference icon to display the Set Preference window for this
preference.
If you want to change the default Windchill preference value for your authoring
application, select it from the Client pull-down menu. For example, set
PTC_WM_REVISION=XYZ. The CAD modeled system parameter, XYZ is available
for revision in the authoring application.

Adding New Authoring Application Parameters
Default system parameters are pushed from Windchill when a CAD part or
drawing is saved or checked in, and they appear on the page discussed below. You
can keep these parameters, change them, or create new ones. Use the following
process to access the page to add a new parameter.
To add new parameters, select Custom on the iProperties page.
To add new parameters, select Custom on the Drawing Properties page.
To add new parameters, select Custom on the Properties page.
To add new parameters, select Attributes on the Properties page.
To add new parameters, select the Product tab on the Properties window
(right-click object name in the Specification Tree > Properties).
Note
Hyperlinks are not supported; therefore Hyperlink base is not valid for mapping.
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The following is a list of standard parameter names that can be mapped either
to a custom parameter name or a standard Windchill system attribute (using the
server-side preferences mapping functionality) to put the values of the Windchill
system attribute into a parameter. The labels that should be used are listed in
the next table.
AutoCAD Default Parameters
Parameter Name
MSP:AUTHOR
MSP:COMMENTS
MSP:KEYWORDS
MSP:SUBJECT
Naming Parameter=MSP:TITLE

Description
Publishes Author on Summary tab.
Publishes Comment on Summary tab.
Publishes Keywords on Summary tab.
Publishes Subject on Summary tab.
Publishes Title on Summary tab.

AutoDesk Inventor Default Parameters
Project Tab Parameter

Published Result

MSP:AUTHORITY

Authority

MSP:COSTCENTER

Cost Center

MSP:DATECHECKED

Date Checked **

MSP:DESCRIPTION

Description

MSP:DESIGNER

Designer

MSP:ENGINEER

Engineer

MSP:MATERIAL

Material

MSP:REVISIONNUMBER

Revision Number

MSP:PARTNUMBER

Part Number

MSP:PROJECT

Project
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AutoDesk Inventor Default Parameters (continued)

Project Tab Parameter

Published Result

MSP:VENDOR

Vendor

STATUS TAB PARAMETER

Published Result

MSP:CHECKEDBY

Checked By

MSP:DESIGNSTATE

Design State

MSP:ENGAPPROVEDBY

Eng. Approved By*

MSP:ENGDATEAPPROVED

Engr Date Approved **

MSP:MFGAPPROVEDBY

Mfg Approved By

MSP:MFGAPPROVEDDATE

Mfg Approved Date

SUMMARY TAB PARAMETER

Published Result

MSP:STATUS

Status

MSP:AUTHOR

Author

MSP:CATEGORY

Category

MSP:COMMENTS

Comments

MSP:COMPANY

Company

MSP:KEYWORDS

Keywords

MSP:MANAGER

Manager

MSP:SUBJECT

Subject

Naming Parameter=MSP:TITLE

Title

CATIA V5 Default Parameters
Parameter Name

Description

CAT:ACTIVE_BOM
CAT DEFINITION

Populates Definition text field.

CAT:DESCINST
CAT:DESCREF

Populates Description text field text field.

CAT:DRAW_COMMENT
CAT:DRAW_RESPON
CAT:NOMENCLATURE

Nomenclature text field

CAT:PART_NR

Populates Part Number text field.
Populates Revision text field.

CAT:REVISION
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CATIA V5 Default Parameters (continued)

Parameter Name
CAT:SOURCE

Description
Populates Source drop-down list choices (Unknown,
Made, Bought) text field.

SolidWorks Default Parameters
Parameter Name
MSP:AUTHOR
MSP:COMMENT
MSP:KEYWORDS
MSP:SUBJECT
Naming Parameter=MSP:TITLE

Description
Publishes Author on Summary tab.
Publishes Comment on Summary tab.
Publishes Keywords on Summary tab.
Publishes Subject on Summary tab.
Publishes Title on Summary tab.

When Naming Parameter=MSP:TITLE is mapped in the Preference
Manager utility, the CAD document name is published in Title field on the
File > Properties > SummaryFile > iProperties->Summary tab.
Default system parameters are created from the Product tab of the Properties
window (right-click object name in the Specification Tree > Properties).

Editing the Delegate
Windchill provides a server-side delegate that can be used to insert parameters into
a authoring application part upon download. This mechanism can be used to pass
information from the server down to the authoring application, where it can be used
like any other authoring application parameter (for example, to place information
on drawing forms). Parameters beginning with PTC or PROI are regarded as
reserved system parameters and cannot be propagated by the customization. If
they are added in the customization, they are ignored by the download service.
Note
The customized parameters are provided to the client upon download and are not
updated in the CAD application session after a Windchill operation (for example,
check in). For example, if a customized parameter is assigned the value of the
CAD document number, its value is provided to the client upon download. If the
CAD document is later renumbered, the value in the authoring application session
or the client cache is not automatically updated. The Windchill service delegate
mechanism is used to allow the customization.
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The following steps explain the customization process:
1. Create a Java class that implements the interface ModeledAttributesDelegate.
The interface definition is as follows:
package com.ptc.windchill.uwgm.proesrv.c11n;

import java.util.Collection;
import java.util.HashMap;

import wt.util.WTException;

public interface ModeledAttributesDelegate
{
// getAvailableAttributes() returns
// HashMap<String, Object> which contains
// HashMap<Attribute name, Attribute type>
HashMap getAvailableAttributes();

// getModeledAttributes(Collection docs) returns
// HashMap<input object, HashMap<Attribute name,
Attribute value>>
HashMap getModeledAttributes(Collection docs)
throws WTException;
}

Please see a sample implementation located at:
<Windchill home>/codebase/com/ptc/windchill/uwgm/proesrv/c11n/
DefaultModeledAttributesDelegate.java

2. Edit the site.xconf file (found in <Windchill>) to add the following
property to indicate availability of customization service on the server:
<Service context="default"
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name="com.ptc.windchill.uwgm.proesrv.c11n.ModeledAttributesDelegate"
targetFile="codebase/service.properties">
<Option cardinality="singleton"
requestor="java.lang.Object"
serviceClass="com.ptc.windchill.uwgm.proesrv.c11n.DefaultModeled
AttributesDelegate"/>
</Service>

Use the path of your class in place of value of serviceClass (that is, replace
com.ptc.windchill.uwgm.proesrv.c11n.Default
ModeledAttributesDelegate

with the path to your class)
3. Then use the xconfmanager tool to apply the changes to
service.properties file.
Runxconfmanager -p

4. Restart Windchill.

Customizing Existing Windchill Attributes
To create more authoring application parameters, Windchill provides a server-side
delegate that can be used to customize the system parameters added to the CAD
file upon download. This is referred to as extending the Windchill system attribute.
Upon Add to Workspace, the system queries Windchill for system parameters.
After the administrator changes the server-side delegate code by adding to it
(or commenting out what is there), the authoring application publishes the new
parameter.
Windchill provides a sample delegate that creates all the authoring application
optional system parameters. These are reserved as a convenience, so that modified
or new authoring application parameters can easily be mapped. The administrator
locates the delegate and modifies it according to company requirements. The list
of reserved Windchill attributes is listed below.
•

SP_WM_PART_REV

•

○ String Type
○ Corresponds to the string used for just the Windchill Version of the actively
associated WTPart.
SP_WM_PART_ITERATION
○ String Type
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○ Corresponds to the number used for just the Windchill Iteration of the
actively associated WTPart.
•

SP_WM_PROJECT
○ String Type
○ Corresponds to the name of the Team of the CAD document.

•

SP_WM_VIEW
○ String Type
○ Corresponds to the label of the View of the actively associated WTPart.

•

SP_WM_PART_LIFECYCLE
○ String Type
○ Corresponds to the name of the actively associated WTPart’s lifecycle.

•

SP_WM_PART_TYPE
○ String Type
○ Corresponds to the soft attribute name of the actively associated WTPart.

•

SP_WM_PART_LC_STATE
○ String Type
○ Corresponds to the name of the actively associated WTPart’s current
lifecycle state.

Editing the Delegate
Windchill provides a server-side delegate that can be used to insert parameters into
a authoring application part upon download. This mechanism can be used to pass
information from the server down to the authoring application, where it can be used
like any other authoring application parameter (for example, to place information
on drawing forms). Parameters beginning with PTC or PROI are regarded as
reserved system parameters and cannot be propagated by the customization. If
they are added in the customization, they are ignored by the download service.
Note
The customized parameters are provided to the client upon download and are not
updated in the CAD application session after a Windchill operation (for example,
check in). For example, if a customized parameter is assigned the value of the
CAD document number, its value is provided to the client upon download. If the
CAD document is later renumbered, the value in the authoring application session
or the client cache is not automatically updated. The Windchill service delegate
mechanism is used to allow the customization.
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The following steps explain the customization process:
1. Create a Java class that implements the interface ModeledAttributesDelegate.
The interface definition is as follows:
package com.ptc.windchill.uwgm.proesrv.c11n;

import java.util.Collection;
import java.util.HashMap;

import wt.util.WTException;

public interface ModeledAttributesDelegate
{
// getAvailableAttributes() returns
// HashMap<String, Object> which contains
// HashMap<Attribute name, Attribute type>
HashMap getAvailableAttributes();

// getModeledAttributes(Collection docs) returns
// HashMap<input object, HashMap<Attribute name,
Attribute value>>
HashMap getModeledAttributes(Collection docs)
throws WTException;
}

Please see a sample implementation located at:
<Windchill home>/codebase/com/ptc/windchill/uwgm/proesrv/c11n/
DefaultModeledAttributesDelegate.java

2. Edit the site.xconf file (found in <Windchill>) to add the following
property to indicate availability of customization service on the server:
<Service context="default"
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name="com.ptc.windchill.uwgm.proesrv.c11n.ModeledAttributesDelegate"
targetFile="codebase/service.properties">
<Option cardinality="singleton"
requestor="java.lang.Object"
serviceClass="com.ptc.windchill.uwgm.proesrv.c11n.DefaultModeled
AttributesDelegate"/>
</Service>

Use the path of your class in place of value of serviceClass (that is, replace
com.ptc.windchill.uwgm.proesrv.c11n.Default
ModeledAttributesDelegate

with the path to your class)
3. Then use the xconfmanager tool to apply the changes to
service.properties file.
Runxconfmanager -p

4. Restart Windchill.

Mapping User-defined Authoring Application Parameters
By default, user-defined CAD parameters are mapped to Windchill attributes with
the same name. The administrator defines the ability for authoring applications to
access parameters that are mapped to Windchill attributes. Errors and conflicts
may occur upon upload if a parameter from a CAD document is trying to be
mapped to a soft attribute in Windchill with a type mismatch or constraint
violation. Because Windchill attributes are pushed to the CAD document upon
download, only attributes that have changed since content upload are modified on
check out or download. The user may set changes to user-defined attributes into
the authoring application using Update.
AutoCAD User-defined Parameters
The type of parameter supported on this tab is String. Additionally, Block
Attributes are also only strings; therefore Windchill Workgroup Manager for
AutoCAD allows mapping to attributes of different types.
•
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Workgroup Manager CAD document, then the parameter is automatically
mapped to the Windchill soft attribute.
•

If the user has not defined a parameter with the same syntax as the Windchill
soft attribute, the parameter information is not exchanged and, therefore, not
published.

•

PTC supports mapping of soft attributes to AutoCAD parameters of types:
○ Integer
○ Number
○ String
○ Boolean
○ Date

•

As long as the value of the parameter can be populated into the Windchill soft
attribute, then values from AutoCAD are pushed to Windchill.

•

For Strings, there should never be any conflict.

•

For Boolean, the system accepts either the value of Yes or No in any case,
that is: YES, Yes, YEs, YeS, yeS, yES are interpreted to be a valid Yes for
the Boolean attributes.

•

For Integer:
○ The system accepts pure numbers, e.g. 1
○ If there is a , or a . character, then the number is not valid.
○ If there are any characters that are not numbers, then the number is not
valid.

•

For Real Numbers:
○ The system accepts pure numbers, e.g. 1 to be 1.00.
○ The system interprets any number with a . or , to be valid. That is: 1.00
or 1,00 are interpreted to be the real number 1.
○ If there is more than one . or , then the value is invalid.
○ If the number is in exponential format, it is valid.
◆ That is, 1E+06 is 1000000.00.
◆ The user can write the E character in either upper or lower case, for
example, 1e+06 and 1E+06 are both valid and equivalent.
◆ If the user is writing a positive exponential value, then he can use the +
sign, or not. Both 1E06 and 1E+06 are valid.
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◆ If there are any characters that are not numbers, then the number is
not valid.
Note
Hyperlink is not supported. AutoCAD does not support user-defined attributes
on uses links.
AutoDesk Inventor User-Defined Parameters
•

PTC supports mapping of soft attributes to attributes of the following types:
○ Real Number
○ String
○ Boolean
○ Date
○ Integer

•

If these types are not matched between AutoDesk Inventor and Windchill, the
parameter is not published.

Note
Autodesk Inventor does not support customer-defined parameters on Uses Links.
CATIA V5 User-defined Parameters
•

PTC supports mapping of soft attributes to authoring application parameters
of the following types:
○ Real Number
○ String
○ Boolean
○ Integer

•

If these types are not used, then the parameters are not published in the
authoring application.

SolidWorks User-Defined Attributes
SolidWorks and Windchill support the following types of user-defined attributes:
•

Number

•

Integer: The system accepts pure numbers, e.g. 1, If there is a , or a . character,
then the number is not valid. If there are any characters that are not numbers,
then the number is not valid.

•

Real Numbers:
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The system accepts pure numbers, e.g. 1 to be 1.00. The system interprets
any number with a . or , to be valid. That is: 1.00 or 1,00 are interpreted to
be the real number 1.
If there is more than one . or , then the value is invalid. If the number is in
exponential format, it is valid. For example,: 1E+06 is 1000000.00.
The user can write the E character in either upper or lower case. For example,
1e+06 and 1E+06 are both valid.
If the user can write a positive exponential value with or without a + sign. For
example, 1E06 and 1E+06 are valid.
If there are any characters that are not numbers, then the number is not valid.
•

Yes/No or Boolean

•

Date

•

String

•

If the authoring application parameter uses a value other than these, it will
not be published.

Note
SolidWorks does not support attributes on Uses Links.
NX, User-defined Parameters
•

The type of parameters supported:
○ Real Number
○ String
○ Integer
○ Date*
The date parameters are pushed from Windchill to the CAD application in the
format of %m/%d/%Y %H:%M where (%m - month, %d - day, %Y - 4 digits year,
%H – hours in 24-hour format, %M - minutes)
Note
NX does not support customer-defined attributes on Uses links.

Mapping Attributes and Parameters
In order to set up the parameters so that they are published in the authoring
application user interface, the administrator maps them in the Type and Attribute
Management utility. For more information on the Type and Attribute Management
utility, refer to Windchill Business Administrator's Guide located at PTC Reference
Documents.
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The following list details information about case-sensitivity when setting up
authoring application parameters that need to be recognized in Windchill:
•

Windchill is case-sensitive in its handling of attributes; but not all authoring
applications are.

•

If the authoring application does not support case-sensitive attribute names,
then they should be handled as the value in all upper case characters, regardless
of how they are shown in the authoring application.

•

Windchill soft attribute Name is case-sensitive; therefore, when creating an soft
attribute to map to a authoring application parameter that does not support
case-sensitive attributes, then the name must be in all uppercase characters
or the administrator must explicitly map the name of the soft attribute to the
name of the CAD parameter.

•

Your authoring application does not support case-sensitive parameters;
however, it does support mixed-case parameters. This means that the user
cannot create a parameter named Cost or COST, but the user can type either
COST, Cost, and cost.
Note
NX does not support mixed case parameters, and therefore should create
parameters in all uppercase.

The administrator sets up an attribute on the authoring application side in the
Properties window. Then, in Windchill, under Site > Utilities > Type and Attribute
Management, the administrator maps this attribute. Use the following process to
map attributes and parameters:
1. Check out Workgroup Manager CAD Document soft type using the next steps.
a. In the Type and Attribute Management utility, expand the EPM Document
soft type.
b. Highlight Workgroup Manager CAD Document.
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c. Select the edit icon. The Workgroup Manager CAD Document soft type is
checked out, as shown in the next graphic.

2. You can choose to create a new attribute at this point. Use the next steps to
create a new attribute.
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a. On the Attribute Definition Manager tab, select New Attribute as shown
in the next graphic.

The New Attribute window opens.
b. In the New Attribute window, type the new attribute's name in the Name
text box and select a data type from the Data Type pull-down list as shown
in the next graphic.
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c. Select OK as shown in the next graphic.

3. Map attributes. Because parameter names in the CAD file do not always match
the Windchill-defined attribute names, attribute mapping provides the ability to
define the mappings between the names of Windchill Workgroup Manager for
Autodesk Inventor Windchill Workgroup Manager for SolidWorks parameters
to the names of Windchill attributes. In order to map the CAD parameter to the
Windchill attribute, use the following procedure.
a. Navigate to the Attribute Mapping tab in the Type and Attribute Management
utility.
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b. Select Add Mapping as shown in the next graphic.

The Select Attribute window appears, showing an expandable list of
available attributes.
c. Select the attribute you want to add and click Select. The window closes,
and the Attribute Mapping tab shows the required attribute.
d. Select a authoring application from the Mapping Context pull-down list.
e. Type the CAD parameter name to which you are mapping in Mapping field
of the corresponding Windchill attribute.
Note
Block names are supported in attribute mapping. The following format is
suggested:
<block name><separator><attribute name> (The only <separator> character allowed is the /)

For example:
TitleBlock/Name

4. Check in the Workgroup Manager CAD Document. The new attribute is added
to the Attribute Mapping window.
To complete mapping this parameter in Windchill Workgroup Manager for
Autodesk Inventor Windchill Workgroup Manager for SolidWorks Windchill
Workgroup Manager for NXCreo Elements/Direct Drafting, use the following
procedure.
1. OpenWindchill Workgroup Manager for AutoCAD Windchill Workgroup
Manager for CATIA V5 Windchill Workgroup Manager for NX and navigate
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to File > Properties > CustomFile > Drawing Properties > CustomFile >
iPropertiesFile > Properties > AttributesFile > Properties > Product.
2. Create a parameter with the exact same name as the one you created in
Windchill.
3. Select Add. The Define other propertiesAdd Custom Property window opens.
4. Type in the exact same name as you did in Windchill, and give it the same
value.
5. Select OK.
6. The parameter and its corresponding value is added.
1. Set the Site or Organization level preference, Use Current Attribute Mapping, to
enumerate parameters for the current attribute definition mapping.
2. Open Creo Elements/Direct Drafting and create a new drawing.
3. Save the new drawing to the workspace.
4. Select the new drawing in the workspace and then select Edit ▶ Attributes.
5. In the Edit Attributes window, add the required attribute column and insert
the value.
6. Complete the Edit Attributes action, and then upload the drawing to Windchill.
When the drawing is opened in Creo Elements/Direct Drafting, the value added in
step 5 will be reflected with mapping. This attribute is now recognized in Windchill
with Windchill Attribute Name and in Creo Elements/Direct Drafting with Mapped
Attribute Name.
This attribute is now recognized in Windchill with the Windchill attribute name
when you upload or check in a CAD part or drawing.

Implicit Parameter-to-Attribute Mapping
Implicit mapping occurs when the authoring application parameter uses the exact
syntax as its Windchill attribute. This makes the parameter publish automatically
in the authoring application.
For example, a CAD document has a set of soft attributes that are published to the
authoring application. From this set, use the soft attribute Name and map it to the
NAME of the parameter in the authoring application. The soft-types that used in
this case are:
•

EPMDocument

•

EPMMemberLink

•

EPMReferenceLink
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If Name is the same by a case-sensitive evaluation, the two are implicitly mapped.
Other parameters are not be added to the CAD document, unless they are explicitly
mapped. For example, in the authoring application, if the administrator has created
a soft attribute with the name, Cost, then the user must also create the soft attribute
with the name Cost so it is implicitly mapped. If the authoring application user
creates COST, it will not be mapped.
If the authoring application does not support case-sensitive parameter names,
the name is treated in all uppercase characters. For example, if the authoring
application treats Cost and COST the same, then Windchill receives and handles
this attribute as COST. The Windchill soft attribute name must also be COST.
Note
Although the user may create a authoring application parameter called Cost,
it is passed to Windchill as COST. Therefore, ensure the authoring application
parameter name is in all uppercase so that it is implicitly mapped in Windchill.
Other properties are not added to the CAD document, unless they are explicitly
mapped.
If a mapped parameter is inconsistent with its corresponding soft attribute, the
following occurs.
•

Type
If the two are not the same type then a warning is given to the user upon
upload; but upload continues. The value is not pushed to the CAD document.

•

Units
If the quantity of measure is different between the attribute and the parameter,
then the CAD document receives an error upon upload. The user is notified to
check in the CAD document.

Explicit Property-to-Attribute Mapping
Explicit mapping occurs when you use Windchill to match a parameter with a soft
attribute. This is done in the Type and Attribute Management utility. The Type and
Attribute Management utility has an Attribute Mapping tab where you map the soft
attributes. You can add, modify, and remove the mappings. If you change the
mappings, it does not affect the existing CAD documents.
Similar to implicitly mapped parameters, the values from the CAD application are
added to the CAD document upon upload, and the values of soft attributes set in
Windchill are reflected in the CAD file upon download.
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Resolving Parameter/Attribute Type Conflicts
AutoCADNX doesn't have attribute types, and only allows the String type.
Windchill Workgroup Manager requires that attribute and parameter types match,
so you must ensure that this is so, or the Conflict Management utility displays this
error. Once reset to String, the conflict resolves. For more information on the
Conflict Manager utility, refer to Conflict Management on page 70.

Modifying the Properties Page
To configure a custom part-specific properties page, you have to create a properties
page or template processor. For details on how to do this refer to the Customizing
the HTML Client section in the Windchill Customization Guide located at PTC
Reference Documents Web site.

Modifying the HTML Client Item Selection Page
To enable recognition of custom parts as a sub-class of WTPart and not
just the supported type in the HTML client item selection page’s default
implementation, you must add support for the custom part in the configured
wt.query.SearchAttributeListDelegate.
In addition, you must modify the CAD application
HTML files that use the item selection page, and use the
xconfmanager modify or override the type list id entries in
com\ptc\windchill\cadx\propfiles\picker.properties.
Note
For wt.query.SearchAttributeList, which is the default configured
search attribute list, the type identifier is referred to as the query value.

Replacing WTPart
If you want your site to use only custom part and not WTParts, use the following
procedure.
1. Add custom part support to HTML Search.
2. In picker.properties, use the xconfmanager to change the type
list entries that contain a type identifier for WTPart to the custom part type
identifier you created in Step 1.
3. Restart the Method server.
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Supporting WTPart and Custom Part
If your site plans to use both WTParts and custom parts, use the following
procedure.
1. Add custom part support to HTML Search.
2. In picker.properties, use the xconfmanager to add to the type list
entries that contain a type identifier for WTPart the custom part type identifier
you created in step 1.
3. To add an All type list entry for a type list, add an entry with the ALL type
identifier used by the configured search attribute list.
4. Restart the Method server.

Enabling the Recording and Display of Rename and
Location History
When a part is renamed, Windchill records the data in a table that can be displayed
to the user. The administrator configures this display of Rename history and
Location history by modifying entries in the configAudit.xml file, located at
codebase\registry\auditing\configAudit.xml file.
Be aware that enabling auditing can adversely affect performance and consequently
choose to audit the most significant events. To enable display of the Rename
History and Location History links on the information page, put the following
entries in configAudit.xml and restart the Method server.
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE EventConfiguration SYSTEM "configAudit.dtd">
<EventConfiguration enabled="true">
<KeyEntry eventKey="*/wt.folder.FolderServiceEvent
/POST_CHANGE_FOLDER" multiObject="true"/>
<KeyEntry eventKey="*/wt.epm.EPMDocumentManagerEvent
/PRE_CHANGE_CAD_NAME" multiObject="true"/>
<ConfigEntry class="wt.epm.EPMDocumentMaster"
enabled="true">
<RenameEventEntry eventType="PRE_CHANGE_IDENTITY"
enabled="true"
handler="wt.audit.configaudit.RenameEventRecorder"/>
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<KeyedEventEntry eventKey="*/wt.epm.EPMDocumentManagerEvent
/PRE_CHANGE_CAD_NAME"
enabled="true"
handler="wt.audit.configaudit.CADNameChangeAuditEventRecorder"/>
</ConfigEntry>
<ConfigEntry class="wt.epm.EPMDocument" enabled="true">
<KeyedEventEntry eventKey="*/wt.folder.FolderServiceEvent
/POST_CHANGE_FOLDER"
enabled="true"
handler="wt.audit.configaudit.LocationChangeAuditEventRecorder"/>
</ConfigEntry> </EventConfiguration>

Note
The default configAudit.xml file comes with EventConfiguration
enabled="false", but all lower level sections enabled. Therefore, setting
EventConfiguration enabled="true" enables all auditing for the
application as a whole. To selectively audit events, you must customize which
auditing events are enabled.

Generation of Viewables
Server-side generation of viewables is enabled by setting up the Windchill
Visualization Service. For information about setting up Windchill Visualization
Service, see the Windchill Installation and Configuration Guide - Visualization
Services located on PTC Reference Documents.

Managing Secondary Content
The administrator specifies files that the system automatically attaches to a
supported model’s CAD document. The functionality assumes that the name of
these related files is not random and is based on of the main model’s CAD name.
The following file specifications are defined:
•

Extension of the file to be automatically attached

•

Existing category for the file

•

New category
○ Behavior for downloading attachments of this type
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○ Validity of the attachment after the primary content is modified is also
defined by the attachment
•

A pattern-matching string to find the name of the additional content. For
example, if CAD Name = *.prt, then attach *.JT, or if CADName = *.prt then
attach *_PRT.ans. . Valid wildcard characters are: *, and &.

By default, no automatic attachment settings are defined. These can only
be set by any user. Automatic attachment preference can be set at all levels
(User/Context/Organization/Site) from Home > Utilities > Preference Management
and the wgmclient.ini file. Use the following process to define the automatic
attachment settings:
1. In the Preference Management utility, configure the Windchill Workgroup
Manager autoattach preference, wgm.autoattach. This allows the content that is
uploaded to Windchill to be configured as additional content of a CAD model.
Note
The parameters are case sensitive. For example: to upload a PDF attachement
for Solidworks the value would be
wgm.autoattach=*.sldprt,*pdf,GENERAL

2. Set the upload.autoattach.search path. This specifies the paths
on disk, separated by ; (semi-colon), search for attachments that need to be
automatically added to a CAD document upon upload.
For more information on preferences, refer to Windchill Workgroup Manager
Client and Server Preferences.

Specifying Whether or Not to Outdate Secondary
Content
The Windchill preference system (under Preference Management ▶ Windchill
Workgroup Manager ▶ CAD Data Management ▶ Server ▶ Content Handling ▶ Mark
Out Of Date) lists the secondary content categories for your site. For each category
of file type, setting the mark-out-of-date preference to Yes (default is No) means

that upon executing various PDM operations, any secondary content of the
specified category type is marked as outdated (for example, in the Attachments
table on the CAD document information page). Setting the value to No means
that the category does not become outdated, as it is carried forward with the
CAD document.
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Users can manually override conflicts caused by outdated files (for example,
during a Check In attempt) by:
•

Terminating Check In and manually updating the attachment, thus removing
the Outdated flag.

•

Removing the attachment from the CAD document.

•

Resetting the status (removing the Outdated flag).

•

Overriding the conflict and checking the CAD document in as is, with an
Outdated status.

Setting the Automatically Download Secondary
Content Preference
The Windchill preference system (under Preference Management ▶ Windchill
Workgroup Manager ▶ CAD Data Management ▶ Server ▶ Content
Handling ▶ Download) lists the secondary content categories for your site. For each
category of file type, setting the download preference to true (default is false)

means that upon any downloading of a CAD document, any secondary content of
the specified category type is downloaded automatically along with the primary
content. Setting the value to false specifies that the secondary content is not
downloaded automatically with the primary content of CAD document.

Clean-up of Event Management
To avoid possible performance issues resulting from an accumulation
of a large number of event records in the Event Management
utility, add the following site-wide property to wt.properties:
com.ptc.core.task.purgeTasksOlderThanDays=5. Events older than the specified
number of days are automatically purged from the Event Management utility.

Configuring the Workspace User Interface
This section describes how to configure the workspace user interface including
tables, rows and automatic scrolling.

Administering Table Views
The display of information in many tables can be set by a user and administrator
using the Table View Manager. Specific views for tables can be created or edited in
the Create Table View window, described in the server online help. Administrators
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have the option of making a table view available to all users by selecting the
Publish to all users check box on the first step, Set Name, of the Create Table
View window.

Configuring Table Scrollbar Display
By default, scrollbars controlling the vertical scrolling for tables are positioned
on the right side of tables. Occasionally, the combined number and width of
table columns may make it necessary to use the horizontal scrollbar to access the
vertical scrollbar. A site-wide property allows you to change the location of table
scrollbars from the right to the left side to reduce the need for horizontal scrolling.
To position scrollbars on the left side of tables, configure the following property
in your site.xconf:
<Property name="com.ptc.core.htmlcomp.jstable.positionScrollbarLeftside"
overridable="true" targetFile="codebase/wt.properties" value="true"/>

Note
No property is necessary for default behavior. This property works for common
table components on the Windows platform (only) except for Event Management
utility tables.
For more information on the Event Management utility, refer to Conflict
Management.

Configuring the Display of Number of Workspace
Rows
The property com.ptc.windchill.uwgm.cadx.ws.sizeToWindow controls the number
of rows displayed in the workspace object list. Set to Yes (default) , the number of
rows shown is based on the height of the window. To display a fixed number of
rows (for example, 10 for Windows), set the property to No, as follows:
<Property name="com.ptc.windchill.uwgm.cadx.ws.sizeToWindow" overridable="true"
targetFile="codebase/wt.properties"value="false"/>

Configuring Automatic Scrolling in the Workspace
The property com.ptc.windchill.uwgm.cadx.ws.scrollToTable controls whether or
not the workspace page appears automatically scrolled to the beginning of the item
list table or appears scrolled to the top of the page. Set to true (default), the page
automatically scrolls to show the workspace item list.
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To disable automatic scrolling, set the property to false, as follows.
<Property name="com.ptc.windchill.uwgm.cadx.ws.scrollToTable" overridable="true"
targetFile="codebase/wt.properties" value="false"/>

Performance Considerations
The following sections describe how you can set up your system for maximum
performance.

Setting the Method Server HEAP Size
It is recommended that the default Java heap size for each method server be set to
512MB in order to cope with large CAD application data sets that are common to
the products developed by CAD users.

Data Compression
The meta data compression option is intended to improve the upload and download
performance of Windchill Workgroup Manager for users accessing Windchill
across a lower bandwidth network. This feature substantially improves the
performance of upload and download operations for large family of objects.

CAD Application Settings
In Windchill Workgroup Manager, compression is controlled by a
config.pro

setting
(
dm_http_compression_level
)

as follows.
dm_http_compression_level <an integer between 0 and 9 -0 for no compression, 9 for maximum compression>
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Maximizing the Oracle Server/Windchill Server
Connection
Due to the large number of objects and CAD documents involved in database
transactions, it is highly recommended that the connection between the Oracle
server and the Windchill method server machines is both low latency and high
bandwidth.
Note
Bulk HTTP data transfer using Apache on Windows 2000 can be restricted
by Apache's default send buffer size. It is recommended to set the property
SendBufferSize=16384 in httpd.conf to significantly improve throughput over
high latency, low bandwidth WANs.

System Configuration Recommendations
The following section discusses recommendations for configuring the Windchill
system.

Running Multiple Servers
It is recommended that Windchill and Windchill PDMLink be configured to run
multiple method servers on servers with multiple CPUs and to run Oracle on a
second server, especially when there is a single-CPU server running Windchill.

Using External File Vaulting
Content files persisted in external vaults are retrieved faster than content files stored
in Oracle as binary large objects (BLOBS). Although the use of file vaults can add
complexity to backup and recovery operations, vault management can be simplified
by using the xconfmanager to set the wt.property wt.fv.forceContentToVault =
true. This causes all content to vault to the DefaultCacheVault, keeping it
out of Oracle BLOBs, without requiring creation of a vaulting rule. In the event
that multiple vaults must be implemented at your site, a vaulting rule applied to
the User domain (where CAD documents are created) can direct content to vault
appropriately.
Note
Following a custom checkin, the user is able to see CAD documents to be vaulted
only in the default cache folder until an explicit revaulting action (executed
through the replication schedule set by the administrator) is executed.
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Using Content Replication
Content replication provides the means to copy selected content files from a master
server to remotely located replica servers for faster access by users at the remote
site, thereby significantly improving access time. The files at the replica site
remain retrievable by users at the master site.
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