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Using Pro/PROCESS for MFG 

Introduction 

About Pro/PROCESS for MFG 

Pro/PROCESS for MFG is a stand-alone Pro/ENGINEER module that defines the part 

machining process steps, material removal, fixtures, and parameter information. 

The Pro/PROCESS for MFG part machining process consists of two distinct phases: 

1. The process planner defines the process flow of machining. 

2. The user details and finalizes the process plan. 

After these two steps have been sufficiently defined, the manufacturing engineer, or 

an NC programmer, creates the NC tool path for actual material removal. The goal of 

Pro/PROCESS for MFG is to create a process plan with as much detail as desired, 

document this process, and then use it to create a manufacturing toolpath. 

About Defining the Process Plan Work Flow 

To define the part machining process plan work flow, the process planner may need 

to have access to: 

1. A library of tools, holders, workcell and available fixtures. 

One of the setup steps for process planning involves the documentation and 

inventory of all tools, fixtures, and holders for easy retrieval by the process 

planner. The library of machining tools are classified by function, size, and 

application. The process planner can create these fixtures, holders, and workcell 

as needed; that is, the database need not be complete before the work begins. 

2. The design part as provided by the design department. 

The design part is typically in the released format. The released model contains 

dimensions, tolerances—dimensional and geometric—and surface finish 

information. 

3. The workpiece geometry as available from a supplier or manufacturing 

engineer. 

The workpiece often represents an assembly of a part at some state of 

machining. It is possible that the starting workpiece for one process planner is 

the end result of a previous machining operation. Except for workpiece surfaces 

where the tolerance is sufficient to meet design requirements, the dimensional, 

surface or tolerance information associated with the design part is used by the 

process planner to decide on tools and fixtures. 
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To define the machining process plan work flow, the process planner may need to 

perform: 

• An assembly of the workpiece and design model. 

Given the workpiece and design model information, the process planner 

assembles the two parts in such a way as to provide sufficient machine allowance 

and co-locate critical features; such as an axis for a boss and reference datum 

planes. 

Sometimes, the process planner or user creates just the casting model, and then 

creates the final design model through material removal. This way, the process 

planner or user can better model the design through the manufacturing process, 

because the design model incorporates limitations of the manufacturing process. 

• An assembly of the workpiece into a relative fixture. 

The process planner, or user, needs to define how the workpiece with the 

reference model assembled inside will be assembled relative to a fixture. 

• The creation of a custom fixture. 

If there are no preexisting fixtures, then the process planner, or user, passes the 

workpiece along with manufacturing instructions to the tools department for 

creation of a custom fixture 

• A simplification of the model representation. 

The process planner, or user, often wishes to create a representation of a design 

part that is as simple as possible, yet contains all necessary details in the area to 

be machined. 

• Workcell and tool definition and selection. 

Based on process planing requirements such as material, stock allowance, 

surface finish, and tolerance, the process planner or user defines or retrieves a 

workcell and may choose a tool for each machining step or NC sequence. 

• A representation of the workpiece with material removed. 

The process planner or user needs this representation for input to the next 

machining step and also to document the process. 

• Modifications to the machining steps. 

After defining all steps, the process planner may reorder the machining steps, 

add or insert more steps, or delete some of the unnecessary machining 

operations. 

To Use Pro/PROCESS for MFG 

The following procedure outlines a typical session in Pro/PROCESS for MFG.  

1. Click File > New to create a new process assembly, or click File > Open to 

open an existing assembly. 



Using Pro/PROCESS for MFG 

3 

2. Select Manufacturing as the Type. 

3. Select Process Plan as the Sub-type. 

4. Type a name for the process assembly. 

5. Click OK to open the MANUFACTURING menu. 

6. Click Mfg Sequence, Step, or New Step to create or redefine a manufacturing 

step or general step and then click Done. 

7. If no operation has been created, the operation creation user interface appears. 

8. If an operation already exists, the STEP TYPE menu appears. Click one of the 

commands: 

o Fixture—Create a typical setup [place part A in fixture B] 

o Mfg Model—Assemble Workpieces, Ref Models, General Assemblies and 

Mfg Assemblies.  

o Machine—Create milling, hole making, turning, and WEDM step types 

which can be performed at this workstation type. 

o General—Create all of the step types which can be performed at any 

workstation type. These steps include inspect, paint, debur, edge break, 

and so on. 

o Surface—Create all of the step types which are specific to surface 

workcells. These steps do not perform any changes to the component 

geometries. 

o Volume—Create all of the step types which are specific to volume 

workcells. These steps include heat treating and shrinkage. These steps do 

not perform any changes to the component geometries. 

9. Click Done to open the Step dialog box, allowing you to define elements specific 

to the step type. Select components to be assembled directly from the screen or 

from the Model Tree window. 

10. Define additional elements (such as, description of the step, a simplified 

representation, time, and cost estimates) for the step. Click OK in the dialog box 

when you are satisfied that all desired elements are defined. 

11. Define additional steps by clicking Step from the MFG SEQUENCE menu. The 

system displays the existing steps in the STEP LIST menu. The previous list 

being referred to is only for the current operation. To list steps for all operations, 

click All Operations from the SEL STEP menu. 

12. To replay the steps, click Play Steps from the MFG SEQUENCE menu. 

13. Create detail drawings of the manufacturing process by adding the process step 

model to a drawing. A Process State dialog box appears when the model is 

added to the drawing. The Process State dialog box lists the steps in the 

manufacturing process. If you want to, select the desired step and a simplified 
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representation, then click OK. The VIEW TYPE menu appears, from which you 

can place a view of the model in the specified step. 

14. Use Pro/REPORT to create a manufacturing report table for the step, which lists 

only the components assembled during the active step or a table of 

manufacturing parameters. The system lists a new set of report symbols, 

beginning with a &mfg prefix, and unique to process steps.  

15. When you create a view of another step, set the current step by clicking Views 

from the DRAWING menu, and then Dwg Models > Set State. The Set State 

command sets the current default state which will be used for the next placed 

view. Use the View and Modify View functions to change an existing Process 

State view. 

About Specific Uses for Pro/PROCESS for MFG 

Specifically, you can use Pro/PROCESS for MFG to complete the following tasks: 

• Create and manipulate manufacturing steps which may or may not generate NC 

sequences. 

• Group manufacturing steps into operations where you can define how the model 

changes with material removal, refixturing, or use of a different tool. 

• Leave a manufacturing step in a partially defined state so that the NC planner 

can complete the step; that is, define the NC tool path. 

• Examine the steps with the display of the manufacturing model accurately 

reflecting the material removal, similar to the Play Steps functionality available 

in Pro/PROCESS for ASSEMBLIES. You can easily pick a step to roll the model 

back to. Rolling back the model from step to step represents successive 

processing steps. 

• Access such features as workcell, tooling, and site parameters from the 

manufacturing step level. 

• Create process planning documentation reflecting the process planning steps and 

parameters. 

About the Part Machining Process Plan 

To define the part machining process plan, the process planner uses: 

• Legacy data from previously completed plans. 

Existing Pro/MFG data may be used as a layout skeleton. Often sections of a 

preexisting plan are used in the current definition. The planner can place text 

from existing third party data by cutting and pasting the appropriate sections of 

an old plan, using UDFs from other Pro/MFG or Pro/PROCESS for MFG models, or 

by using Pro/TOOLKIT functionality. 

• Workpiece geometry as a start condition. 
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The workpiece represents any form of raw stock; bar stock, casting, and so on 

that is going to be machined during manufacturing operations. It may easily be 

created by copying the design model and modifying the dimensions or 

deleting/suppressing features to represent the real workpiece. The benefits of 

using a workpiece include: 

o Automatic definition of extents of machining when creating manufacturing 

sequences. 

o Dynamic material removal simulation and gouge checking in Pro/MFG. 

o In-process documentation by capturing removed material. 

The workpiece geometry serves as a start condition for the part machining 

process plan. The engineer knows that by using some manufacturing techniques 

the start part can be transformed into a finished part. The workpiece, at various 

stages of machining, also defines the design and configuration of the fixture. 

• Design model as an end condition. 

The design model represents the machining target. The design part also has the 

surface finish, dimensions, and tolerances defined. No matter what approach the 

process planner takes in getting from workpiece geometry to finished geometry, 

the process goal is to achieve these surface finish, dimensions, and tolerances. 

• A basic understanding of the available processing equipment; such as tools, 

holders, fixtures, and work centers. 

To Document the Part Machining Process Plan  

In documenting the part machining process plan work flow, the user wants to: 

1. Document the process planning steps. 

2. After defining a manufacturing process plan step, the user needs to document the 

process planning step in a company accepted format. There are five classes of 

process planning steps which require specific documentation: 

o Material removal—which includes typical manufacturing steps such as 

mill, turn, drill, bore, tap, and so on. 

o Fixturing—which includes a typical setup drawing; for example, place part 

A into fixture B. 

o Manufacturing model—which includes assembly of material or the 

creation of additional workpieces. 

o Non-manufacturing—which includes inspection, packing, and deburring. 

o Non-material removal—which includes shrinkage and plating. The 

documentation is similar to the material removal step except no geometry 

simulation is performed; that is, the results of these steps are not reflected 

in part geometry. 

3. Simplify the representation of a part in all non-machined areas.  
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In some cases, the user wants to simplify the display of any part geometry which 

is non-critical to the particular machining step in order to simplify the 

manufacturing model representation. 

4. Document the material removal process. 

The user needs to document the material removal process including minimum 

sufficient dimensioning, tool and holder information, along with any necessary 

machining instructions. 

5. Create drawing views or report tables for each machining process. The end 

products of the process planning procedure include: 

o The tool selection 

o The holder 

o The fixture list which is cross-referenced to the process plan step 

o The setup drawing which contains a simplified, representative assembly of 

the workpiece and fixture assembly 

o The process plan drawing which contains the workpiece and the necessary 

dimensions, tolerances, and instructions to produce that material removal 

step 

6. Create and dimension auxiliary views. 

For some of the drawings, the user may need to create and dimension additional 

breakout sections or auxiliary views as appropriate. 

Configuring Pro/PROCESS for MFG 

About Configuring Pro/PROCESS for MFG 

Pro/Process for MFG configuration options enable you to customize your design 

environment.  

Your Pro/PROCESS for MFG configuration options, like all Pro/ENGINEER 

configuration options:  

• Are set from the Options dialog box (Tools > Options).  

• Are stored in a config.pro file.  

• Use the default value unless you manually set the configuration option.  

You can set and save multiple combinations of configuration options ( config.pro 

file), with each file containing settings unique to certain design projects.  

Pro/PROCESS for MFG Help lists the configuration options unique to sheet metal 

designs. The options are arranged in alphabetical order. Each topic contains the 

following information:  

• Configuration option name. 
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• Brief description and notes describing the configuration option. 

• Default and available variables or values. All default values are followed by an 

asterisk (*). 

To Set Pro/PROCESS for MFG Configuration Options 

1. Click Utilities > Options. The Options dialog box opens.  

2. Click the Show only options loaded from file check box to see currently 

loaded configuration options or clear this check box to see all configuration 

options. The configuration options display. 

3. Select the configuration option from the list or type the configuration option 

name in the Option box. 

4. In the Value box type or select a value.  

Note: The default value is followed by an asterisk (*). 

5. Click Add/Change. The configuration option and its value appear in the list. A 

green status icon confirms the change. 

6. When you finish configuring Pro/PROCESS for MFG, click Apply. The 

configuration options are set. 

Note: We recommend that you set your configuration options before starting a new 

sheet metal session. 

curr_proc_comp_def_color 

Specifies the default color used to display the current component in a process 

assembly. The three decimal values specify percentage of red, green and blue (in 

this order) in the resulting color. For example, 0 0 49 specifies a medium blue color. 

Defaults and available variables:  

0.000000 0.000000 0.000000*— Red=0.00, Green=0.00, Blue=0.00 

 

Note: The default value is followed by an asterisk (*). 

curr_proc_comp_def_font 

Specifies the default font used on the current component in a process assembly. 

Defaults and available variables:  

solidfont 

dotfont 

ctrlfont 

dashfont 

phantomfont 
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ctrlfont_s_l 

ctrlfont_l_l 

ctrlfont_s_s 

ctrlfont_mid_l 

dashfont_s_s 

phantomfont_s_s 

 

Note: The default value is followed by an asterisk (*). 

prev_proc_comp_def_color 

Specify the default color for components added to a process assembly in a previous 

step. The three decimal values specify percentage of red, green and blue (in this 

order) in the resulting color. For example, 0 0 49 specifies a medium blue color. 

Defaults and available variables:  

0.000000 0.000000 0.000000*— Red=0.00, Green=0.00, Blue=0.00 

 

Note: The default value is followed by an asterisk (*). 

prev_proc_comp_def_font 

Specify the default font for previously added components in a process assembly. 

Defaults and available variables:  

solidfont 

dotfont 

ctrlfont 

dashfont 

phantomfont 

ctrlfont_s_l 

ctrlfont_l_l 

ctrlfont_s_s 

ctrlfont_mid_l 

dashfont_s_s 

phantomfont_s_s 

www_add_aux_frame 

Customizes the output so you have an additional frame for each process step or for 

an assembly publication. 

Defaults and available variables:  

yes—Pro/ENGINEER creates an auxiliary aux.html file (for the assembly process-in 
each step00 directory) to be replaced by your own <filename>.html file. 
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no*—Does not create auxiliary file. 

 

Note: The default value is followed by an asterisk (*). 

www_export_geometry_as 

Specifies the output format by to one of the values 

Defaults and available variables:  

cgm_vrml—Formats ouput data to the CGM and VRML formats. 

all—Formats output data to the CGM, JPG, and VRML formats. 

jpg_vrml*—Formats output data to the JPG and VRML formats. 

vrml—Formats output data to VRML format only. 

cgm—Formats output data to the CGM and VRML format. Sets up the site to show 

only CGM. 

jpg—Formats output data to the JPG and VRML formats. Sets up the site to show 

only JPF. 

 

Note: The default value is followed by an asterisk (*). 

www_multiple_views 

Specifies what views to write to VRML files.  

Defaults and available variables:  

all—Writes all views in any component to the appropriate VRML files. 

top*—Writes only named views that reside in the assembly or process assembly to 

top-level VRML files. 

none—Does not write named views to VRML files. 

 

Note: The default value is followed by an asterisk (*). 

www_tree_location 

Specifies the location of the model tree in the browser window 

Defaults and available variables:  

out*—Opens the Model Tree in a separate window.  

in—Includes the Model Tree in the Web page, and removes the Tree checkbox from 

the control panel. 
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Note: The default value is followed by an asterisk (*). 

Process Steps 

About Process Assemblies 

A process is a Pro/ENGINEER assembly that contains the features defining the 

manufacturing steps. It follows the naming conventions process_name.asm and 
process_name.mfg. A process assembly has dependencies on one or more 

workpieces and design models. The process object has a required (for Pro/PDM 

purposes) dependency on the workpiece. 

A process allows assembly and manipulation of entire reference models relative to 

other models in the process assembly. A user can create a partially complete 

manufacturing model and then retrieve the model into manufacturing to finish 

defining the machining steps and to generate the toolpath. 

The system retrieves the process model in whatever state it exists at the end of the 

process; that is, retrieves any components and sets the last step as the active step. 

The system retrieves into memory all components required for the process model 

and displays only the components that are active from the last step. 

To Use Process Mode 

In Process mode, you can create process plans to describe manufacturing operations 

that are applied to produce a product. 

1. Click File > New. 

2. Select Manufacturing under Type and Process Plan under Sub-type. Enter a 

name for the new process assembly. 

3. Click OK to open the MANUFACTURING menu. 

4. Click one of the following commands on the MANUFACTURING: 

o Mfg Setup—Define the workcell library, tooling library, manufacturability 

database, and fixture library. Opens the MFG SETUP menu. 

o Mfg Sequence—Manipulate a process step (add, create, redefine and so 

on). Opens the MFG SEQUENCE menu. 

o Component—Performs certain assembly component operations. Displays 

the COMPONENT menu. 

o Simplfd Rep—Creates, modifies, or sets simplified representations. 

o Modify—Modifies process or process component dimensions and features. 

Opens the PROCESS MOD menu. 

o Regenerate—Updates modified part and assembly dimensions. 
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o Play Steps—Views assembly at individual steps of the process plan. Opens 

the STEP REGEN menu. 

o Relations—Adds and edits constraint equations. 

o Program—Accesses Pro/PROGRAM. 

o Integrate—Resolves differences between the source and target processes. 

MFG SETUP Menu Commands 

When you click Mfg Setup from the MANUFACTURING menu, the MFG SETUP 

menu opens with the following commands: 

• Workcell Lib—Define and activates the workcell libraries. 

• Tooling Lib—Define and activates tool libraries. 

• Param Setup—Sets up manufacturing parameters. Opens the PARAM SETUP 

menu with the following commands:  

o Site—Set up the site used by the current operation. 

o Mach DB—Set up machinability database files. 

• Mfg Geometry—Set up the manufacturing geometry. Opens the MFG 

GEOMETRY menu with the following commands: 

o Mill Volume—Create a volume to be removed during an NC sequence. 

o Mill Surface—Create a user-defined surface quilt that can be referenced by 

Surface milling NC sequences or by Mill Volumes. 

o Mill Window—Create a window for mill NC sequence.  

o Turn Profile—Create a profile for turning NC sequence. 

o Drill Group—Group axes for drilling NC sequence. 

o Datum Feats—Create datum features in the manufacturing model.  

MFG SEQUENCE Menu Commands 

When you click Mfg Sequence from the MANUFACTURING menu, the MFG 

SEQUENCE menu opens with the following commands: 

• Operation—Create and redefines operations and sets the current operation. The 

current operation is the last operation in the feature list which has not been rolled 

back. Opens the Define Operation menu with the following commands: 

o Name—Specify the operation name. 

o Workcell—Specify the workcell or machine tool. 
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You need not specify an exact workcell. The following are new types of 

workcells: 

Surface—Specify grinding machines and any other machine which doesn't 

change the geometry of a workpiece surface. 

Volume—Specify heat treating workcells and any other workcell which does 

not change the geometry of the part. 

General—Specify any workcell which does not affect the geometry of the 

workpiece. 

Mach Sys—Specify the coordinate system for CL output. 

Comments—Specify operation comments. 

Parameters—Specify operation parameters. 

From—Specify location point. 

Home—Specify location point. 

• Step—Create and redefines step features. The types of steps available depends 

upon the type of workcell defined for the operation. Opens the STEP TYPE menu 

with the following commands: 

o Fixture—Create a fixture step. 

o Mfg Model—Document the assemblies of workpieces, reference models, 

general assemblies, and manufacturing assemblies; that is, the addition of 

stock to be machined. 

o Machine—Specify all of the step types which can be performed at a 

workstation type. Opens the MACH AUX menu. The specific machining step 

type available depends upon the active operation's workcell type. 

o General—Specify all of the step types which can be performed at any 

workstation type. General step types include inspecting, painting, 

deburring, edge breaking, and so on. 

o Surface—Specify all of the step types which are specific to surface 

workcells. Surface step types do not perform any changes to the 

component geometries. 

o Volume—Specify all of the step types which are specific to volume 

workcells. Volume step types include heat treating, plating, and shrinkage. 

COMPONENT Menu Commands 

When you click Component from the MANUFACTURING menu, the COMPONENT 

menu opens with the following commands: 

• Package—Use the Package functionality to move packaged components that are 

not in the design assembly. 
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• Delete—Delete components and their children from the assembly. Process steps 

are children of components; therefore, deleting a workpiece deletes process steps 

which reference it. 

• Suppress—Suppress steps related to the workpiece to be deleted. Opens the 

DELETE/SUPP menu. 

• Resume—Resume suppressed components. Opens the RESUME menu with the 

following commands: 

o All—Resume all suppressed components. 

o Layer—Resume the components on current layer. 

o Last Set—Resume the last set of suppressed components. 

o Feat ID—Resume a component having a specified ID. 

• Redefine—Redefine one or more component constraints. 

• Reroute—Reassign component references. 

• Reorder—Reorder components. 

• Insert Mode—Activate or cancels Insert Mode. 

• Pattern—Create a pattern of a component which has not been patterned. 

• Del Pattern—Remove a pattern of a component. 

• Adv Utilities—Access advanced assembly component functionality. Opens the 

ADV COMP UTL menu with the following commands: 

o Replace—Replace an existing component with another one. 

o Copy—Copy components. 

o UDF Library—Group components together into a UDF.  

o Group—Create components from UDFs. 

o Merge—Merge components into a single part. 

o Cut Out—Subtract reference parts from other parts. 

MFG MODIFY Menu Commands 

When you click Modify from the MANUFACTURING menu, the MFG MODIFY menu 

lists the following commands: 

• Mod Part—Open the MODIFY menu to modify a part. 

• Mod Assem—Open the MODIFY menu to modify an assembly. 

• Mod Subasm—Open the MODIFY menu to modify a subassembly. 

• Mod Dim—Open the MODIFY menu to modify dimensions. 
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• Mod Mach Step—Open the STEP LIST menu to modify parameters for machine 

steps. 

• Mod Pattern—Open the SELECT FEAT menu to modify machining step pattern 

dimensions. 

STEP REGEN Menu Commands 

When you click Play Steps from the MANUFACTURING menu, the STEP REGEN 

menu lists the following commands: 

• Set Step—Select a step from the Process Window. 

• PreviousStep—Roll model back one step. 

• Next Step—Regenerate model forward one step. 

• Set Operation—Select an operation from the Process Window. 

• Previous Oper—Roll model back one operation 

• Next Oper—Regenerate model forward one operation. 

• Step Info—Display information for current step. 

• Oper Info—Display information for current operation. 

Select Step Menu 

To select steps, use the Select Step menu. This menu contains a check mark list of 

steps, showing the step number and name. 

About Tool Features  

Tool features enable you to define geometry for creating NC sequences. You can 

define tool features by selecting the required feature on the Mfg Geometry toolbar. 

The Mfg Geometry Features toolbar contains the following tool features: 

• —Create a window for a mill NC sequence. Use this feature to create mill 

windows of the type silhouette, sketch, or chain. 

• —Create a user-defined surface quilt that can be referenced by surface 

milling NC sequences or by mill volumes. 

• —Create a volume to be removed during an NC sequence. 

• —Create a profile for a turning NC sequence. 

• —Group axes for a drilling NC sequence. 

Alternatively, click Insert > Manufacturing Geometry to define the tool features. 
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Read About and Create Steps 

About Play Steps 

Play steps allow you to walk through the manufacturing process; set a specific step 

and operation, roll the model back one step or operation, and display information for 

the current step or operation. 

About Process Steps 

Process steps describe all the actions used to manufacture the product. You can only 

have one active step at any time. Process step types are: Fixture, Manufacturing 

Model, Machine, General, Surface, and Volume. 

To Create a Machine Step 

Machine steps include: milling, turning, hole making. 

1. Click MANUFACTURING > Mfg Sequence to open the MFG SEQUENCE menu. 

2. Click Mfg Sequence > Step to open the DEFINE OPER menu. 

3. The system opens the DEFINE OPER menu. The specific machining step type 

available depends upon the active operation's workcell type: 

o Name—Specify the machine step name. This is an optional field. 

o Comments—Specify machine step comments. This is an optional field. 

o Tool—Specify a tool for this machining step. This is an optional field. 

o Parameters—Specify manufacturing parameters for this machining step. 

This is an optional field. 

o References—Specify references for this machine step. This is an optional 

field. You can specify machining specific and general process references for 

this machine step. The Process Refs option allows you to select general 

component, feature, surface, edge, curve, quilt, datum, dimension or 

tolerance references to add to this machine step. These references can later 

be displayed by the manufacturing engineer when completing the machine 

step in Pro/MFG. The remaining options are specific to the type of machine 

step.  

o Simplified Rep—Specify a simplified representation for the step. This is an 

optional field. 

o Time Estimate—Specify a time estimate for the machine step. This is an 

optional field. 

o Cost Estimate—Specify a cost estimate for the machine step. This is an 

optional field. 

4. Select the feature step fields you wish to define or change and click Define. 

5. Click OK to commit and continue. 
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About Fixture Steps 

Fixture steps allow you to assemble, create, disassemble, and reassemble fixture 

components. 

To Create a Fixture Step 

1. Click Step from the MFG SEQUENCE menu. 

1. Click New Step from the STEP LIST menu. 

2. Click Fixture from the STEP TYPE menu. 

3. The system opens the FIXTURE STEP dialog box, which contains the following 

options: 

o Name—Specify the fixture name. 

o Components—Select components with which to fixture. Opens a menu 

with commands to Assemble, Create, Disassemble, Reassemble, and 

Prev State. Reassemble presents a list of previously disassembled fixture 

components. Prev State presents a list of all previous fixture steps. 

Note: Use the COMPONENT menu to delete or redefine any of the fixture 

components. 

o Comments—Specify fixture comments. This is an optional field. 

o Simplified Rep—Specify a simplified representation for the step. This is an 

optional field. 

o Time Estimate—Specify a time estimate for the fixture setup. This is an 

optional field. 

o Cost Estimate—Specify a cost estimate for the fixture setup. This is an 

optional field. 

4. Select the feature step fields you wish to define or change and click Define. 

5. Click OK to commit and continue. 

About General Steps 

General steps types handle operations which do not involve any change to the 

geometry of the workpiece. These steps include painting, burnishing, inspection, and 

so on. 

To Create a General Step 

1. Click New Step from the STEP LIST menu. 

2. Click General from the STEP TYPE menu. 
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3. The system opens the GEN STEPS menu and the STEP: General dialog box, 

which contains the following options: 

o Name—Specify the general step name. This is an optional field. 

o Type—Specify type of step. This is a required field. 

o Comments—Specify general step comments. This is an optional field. 

o References—Specify references for this general step. This is an optional 

field. Opens the GEN REFS menu which allows you to select component, 

feature, surface, edge, curve, quilt, datum, dimension or tolerance 

references to add to this general step. 

o Simplified Rep—Specify a simplified representation for the step. This is an 

optional field. 

o Time Estimate—Specify a time estimate for the general step. This is an 

optional field. 

o Cost Estimate—Specify a cost estimate for the general step. This is an 

optional field. 

o Select the feature step fields you wish to define or change and click Define. 

o Click OK to commit and continue. 

About Volume Steps 

Volume steps handle operations which involve scaling the part, such as heat treating 

and shrinkage. Volume steps do not perform any changes to the component 

geometries. 

To Create a Volume Step 

1. Click New Step from the STEP LIST menu. 

2. Click Volume from the STEP TYPE menu. 

3. The system opens the GEN STEPS menu and the STEP: Volume dialog box, 

which contains the following options: 

o Name—Specify the volume step name. This is an optional field. 

o Type—Specify type of step. This is a required field. 

o Comments—Specify volume step comments. This is an optional field. 

o References—Specify references for the volume step. This is an optional 

field, which allows you to select component, feature, surface, edge, curve, 

quilt, datum, dimension or tolerance references to add to this general step. 

o Simplified Rep—Specify a simplified representation for the step. This is an 

optional field. 
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o Time Estimate—Specify a time estimate for the volume step. This is an 

optional field. 

o Cost Estimate—Specify a cost estimate for the volume step. This is an 

optional field. 

o Select the feature step fields you wish to define or change and click Define. 

o Click OK to commit and continue. 

About Manufacturing Model Steps 

Manufacturing model steps allow you to assemble workpieces and reference models 

through several options, including general manufacturing assemblies. Assembly of 

workpieces and reference models can be performed throughout the manufacturing 

process.  

To Create a Manufacturing Model Step 

1. Click Step from the MFG SEQUENCE menu. 

2. Click New Step from the STEP LIST menu. 

3. Click Mfg Model from the STEP TYPE menu. 

4. The system opens the STEP: Mfg Model dialog box,which contains the following 

options: 

o Name—Specify the manufacturing model setup name. 

o Components—Selects components to manufacture. Opens a menu with 

options to create or assemble new components or select existing 

components from Pro/MFG. 

Use the COMPONENT menu to delete or redefine any of the manufacturing 

components. 

o Comments—Specify manufacturing model comments. This is an optional 

field. 

o Simplified Rep—Specify a simplified representation for the step. This is an 

optional field. 

o Time Estimate—Specify a time estimate for the manufacturing model 

setup. This is an optional field. 

o Cost Estimate—Specify a cost estimate for the manufacturing model 

setup. This is an optional field. 

5. Select the feature step fields you wish to define or change and click Define. 

6. Click OK to commit and continue. 



Using Pro/PROCESS for MFG 

19 

About Surface Steps 

Surface steps handle operations which involve offsetting one or more surfaces by 

some amount. Surface steps do not perform any changes to the component 

geometries. 

To Create a Surface Step 

1. Click New Step from the STEP LIST menu. 

2. Click Surface from the STEP TYPE menu. 

3. The system opens the GEN STEPS menu and the STEP: Surface dialog box, 

which contains the following options: 

o Name—Specify the surface step name. 

o Type—Specify type of step. This is a required field. 

o Comments—Specify surface step comments.  

o References—Specify references for the surface step. This is an optional 

field. You can use it to select component, feature, surface, edge, curve, 

quilt, datum, dimension or tolerance references to add to this general step. 

o Simplified Rep—Specify a simplified representation for the step.  

o Time Estimate—Specify a time estimate for the surface step.  

o Cost Estimate—Specify a cost estimate for the surface step. 

o Select the feature step fields you wish to define or change and click Define. 

o Click OK to commit and continue. 

View Steps 

To View a Process Step 

1. Click Play Steps from the MANUFACTURING menu. 

2. Click Set Step from the STEP REGEN menu. The system opens the SELECT 

STEP menu with the current active step check marked. 

3. Select the step you want to view and click Done. 

4. The system displays the current active step in the manufacturing process and 

highlights general or process references and material removals in magenta. 

Note: Highlighting is performed for all step level commands; for example Next Step, 

Prev Step, Set Step, but not for any operation level commands; for example Previous 

Oper, Next Oper, or Set Operation. 
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To View a Previous or Next Step 

1. Click Play Steps from the MANUFACTURING menu. 

2. Click Previous Step from the STEP REGEN menu to view a previous step. The 

system displays the previous step in the manufacturing and highlights general or 

process references and material removals in magenta. 

3. Click Previous Step from the STEP REGEN menu to view another previous step, 

or click Done/Return. 

4. To view the next step, click Next Step. The system displays the next step in the 

manufacturing process and highlights general or process references and material 

removals in magenta. 

To View the Process Operation 

1. Click Play Steps from the MANUFACTURING menu. 

2. Click Set Operation from the STEP REGEN menu. The system opens the 

SELECT OPER menu with the current active operation check marked. 

3. Select the operation you want to view and click Done. 

To View the Previous or Next Operation 

1. Click Play Steps from the MANUFACTURING menu. 

2. Click Previous Oper from the STEP REGEN menu. The system displays the 

model at the end of the previous operation. 

3. Click Next Oper from the STEP REGEN menu to display the model at the end of 

the next operation, or click Done/Return. 

Documenting the Process 

Create Customized Documentation 

About Drawing Mode 

You can use Drawing mode to easily create in process documents, similar to the way 

you create a view of a part or assembly, by selecting a process step from a list. The 

system creates a default view of the process component at that step. 

In Drawing mode, you can create customized documentation for the component 

process. Views of each step can be placed, component display controlled based on 

their status in the step, and report tables created using Pro/REPORT. 
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To Create Views of Process Steps 

1. Click Properties from the File menu. 

2. Click Drawing Models from the FILE PROPERTIES menu to add, remove, or 

set as current one of the drawing models. 

3. Click Set State from the DWG MODELS menu to set the process state of the 

current drawing model, and then designate the process representation. 

Using the Process State dialog box, you can select a process step and simplified 

representation. 

Process State Dialog Box Options 

The Process State dialog box contains a scrollable list that displays the process 

component steps. You can select a step to show in the view. If simplified 

representations are available, you can select one from the drop-down list. The 

system selects the representation for that process state by default. 

The Process State dialog box also contains a Final Mfg State option which appears 

at the end of the list of process states. The Final Mfg State represents the state 

which was used when creating views or repeat regions of assembly machining 

assemblies prior to Pro/ENGINEER Release 18.0. The geometry is in its final state, 

and the active fixture is the last one activated in Pro/Mfg. 

The Final Mfg State is useful in two ways: 

• It allows you to obtain the state expected prior to Pro/ENGINEER Release 18.0. 

For example, you may have a machining assembly—which you may or may not 

have previously worked on in Pro/PROCESS for MFG—which is configured with the 

expectation that the pre-Release 18.0 state is used when creating the drawing. 

Hence, this state is necessary for compatibility with legacy models and legacy 

work habits 

• If no fixture was activated in Pro/MFG, then it allows you to create views or 

repeat regions which always reference the final state of the manufacturing 

process, regardless of which steps are added, removed, or reordered in the 

future. 

To Enter an Existing Drawing 

1. Click File > Open. 

2. Click Type > Drawing from the File Open dialog box 

3. Enter the file name and click Open. 

To Open a New Drawing 

1. Click File > New. 

2. Click Type > Drawing from the New dialog box. 
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3. Enter the file name and click OK. 

4. From the New Drawing dialog box, you can specify a default model, also the 

sheet size and orientation for the drawing. 

5. Click OK. 

To Copy a Process Drawing Sheet 

1. Select Move or Copy Sheet from the DRAWING menu. 

2. From the Move Sheet dialog box, select the sheet after which you want to insert 

the moved or copied sheet. 

3. Select Copy process sheet if you want to copy the sheet as a template for 

another process step. 

4. Select a different process state from the Process State dialog box and click OK 

to continue. 

Note: For maximum performance in regenerating drawings, it is recommended that 

you create no more than one state per sheet. 

The system copies the manufacturing processes and generates a new sheet. The 

Copy process sheet function preserves the scale and orientation of the process 

component. Click Cancel from the Process State dialog box to return to the 

DRAWING menu, or select another step and click OK to create more copies. 

5. Select Go to Sheet from the Views menu and enter the new sheet number to 

view the newly generated sheet. 

Sheets Menu Commands 

If you have a license for Pro/DETAIL, you can use the Sheets command in the 

DRAWING menu to create multiple sheet drawings and move items from one sheet 

to another. You can view the sheets of a multi-sheet drawing using Pro/ENGINEER. 

The SHEETS menu displays the following options: 

• Previous—Display the previous sheet. 

• Next—Display the next sheet. 

• Set Current—Set a current sheet. This option is only available when there is 

more than one sheet. 

• Process State—Set or resets the state for the entire sheet, for both views and 

repeat regions. 

• Add—Create a new sheet at the end of the drawing. 

• Remove—Delete a specified sheet or sheets from the drawing.  

• Reorder—Move a sheet from its present position to another. If there are only 

two sheets, the system reorders them automatically. 
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• Switch Sheet—Move items (views, detail and draft items, and drawing tables) 

from one sheet to another. If the drawing has only one sheet, the system 

automatically creates a second sheet after you click items to move.  

• Format—Add a drawing format to the sheet. 

When there is more than one sheet in a drawing, an additional tag, SHEET # OF # 

displays at the bottom of the main window. When working with multi-sheet 

drawings, keep in mind the following: 

• When you switch a projection view to another sheet, it becomes independent. 

You can then move the parent view, and the projection view on another sheet 

does not update. If you switch these views again to the same sheet, the 

projection view immediately becomes a child of the parent.  

• You can change drawing scales on each sheet independently. 

• Partial views stay unchanged on one sheet when you change the scale on 

another. 

• If you erase a view on one sheet, you can resume it on any other sheet. 

Read About Process State 

To Change the Process Component State in a View 

1. Click Process State from the MODIFY VIEW menu, then select a view of a 

process component. The system displays the Process State dialog box with the 

process component state and simplified representation used in the view selected 

in the lists. 

2. Click the process component state and/or the simplified representation you want 

to change. 

3. Click OK. The system changes the view process state to the selected process 

state. The system makes this state the current process component state when 

creating new views. 

To Set Process Component State in New Views 

1. Click Set State from the DWG MODELS menu. The system opens the Process 

State dialog box with the current process component state and simplified 

representation selected in the lists. 

2. Click the process component state and/or the simplified representation you wish 

to set. 

3. Click OK. The system sets this state as the current process component state 

when creating new views. 
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Process State Dialog Box Options 

The Process State dialog box contains a scrollable list that displays the process 

component steps. You can select a step to show in the view. If simplified 

representations are available, you can select one from the drop-down list. The 

system selects the representation for that process state by default. 

The Process State dialog box also contains a Final Mfg State option which appears 

at the end of the list of process states. The Final Mfg State represents the state 

which was used when creating views or repeat regions of assembly machining 

assemblies prior to Pro/ENGINEER Release 18.0. The geometry is in its final state, 

and the active fixture is the last one activated in Pro/Mfg. 

The Final Mfg State is useful in two ways: 

• It allows you to obtain the state expected prior to Pro/ENGINEER Release 18.0. 

For example, you may have a machining assembly—which you may or may not 

have previously worked on in Pro/PROCESS for MFG—which is configured with the 

expectation that the pre-Release 18.0 state is used when creating the drawing. 

Hence, this state is necessary for compatibility with legacy models and legacy 

work habits 

• If no fixture was activated in Pro/MFG, then it allows you to create views or 

repeat regions which always reference the final state of the manufacturing 

process, regardless of which steps are added, removed, or reordered in the 

future. 

Specific Process Considerations 

About Process-Specific Considerations 

Some process-specific considerations include: adding a view or repeat region, 

modifying a view or repeat region, switching sheets of views or repeat regions, and 

the default model's process state. 

About Adding a View or Repeat Region 

When the current default model is a machining process assembly and a view or 

repeat region of the current default model exists on the current sheet, then the new 

view or repeat region's process state becomes that of the existing view or repeat 

region. The simplified representation of the view or repeat region being added 

becomes that of the current, default model. 

About Modifying a View or Repeat Region 

When you select a view of a machining process assembly using Modify View and 

ProcessState and then change the process state, this change applies to all views 

and repeat regions of this assembly on the current sheet. This change also applies to 

any sheet containing child views from the current sheet—-and so on recursively. Use 

the Model/Rep user interface to examine tables describing this behavior. 
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The system prompts you to confirm or cancel this change if it affects any view or 

repeat region which you did not originally select for modification. The simplified 

representation specified only affects the views or repeat regions which you originally 

selected. 

About Switching Sheets of Views or Repeat Regions 

When switching sheets for views or repeat regions of machining process assemblies, 

for the views or repeat regions of each of these assemblies, consider the following: 

• If there are no views or repeat regions of the assembly on the target sheet, or 

the process state of such views or repeat regions is the same as that of the view 

or repeat region being moved, then nothing changes from the current system 

behavior. This is the same as the current Pro/PROCESS for ASSEMBLIES 

behavior. 

• If there are views or repeat regions of the assembly on the target sheet, or the 

process state of such views or repeat regions is not the same as that of the view 

or repeat region being moved, each complete set of related views simply has its 

process state changed to that existing on the target sheet.  

If you select any view to move whose parent or child view you did not selected to 

move, the system prompts you to confirm or cancel changing the state of all other 

sheets upon which related views remain. 

About Machining Process Assembly as Default Model 

When the current, default model is a machining process assembly, consider the 

following: 

• The Dwg Models menu option Set State is dimmed except when the current 

sheet has no views or repeat regions of this assembly. 

• When you enter a sheet containing views or repeat regions of this assembly, the 

current, default process state changes to that of the views or repeat regions on 

the entered sheet. 

• If you use the Set Model option to switch the current model to a machining 

process assembly which appears on the current sheet, the system switches the 

process state of this newly current model to that appearing on the current sheet. 

Reports 

To Create a New Report 

1. Click File > New > Report.  

2. Enter the name of the report and click OK to open the New Report dialog box. 

3. Specify a sheet size with Set Size, or use the Retrieve Format to retrieve a 

format that you previously created.  
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4. Click an instance and click Open to display a drawing sheet in the active window, 

and the REPORT menu. 

5. Click REPORT > Table. 

6. Click Create. 

7. Define a repeat region. Click Repeat Region from the TABLE menu, and then 

click Add from the TBL REGIONS menu.  

8. Pick the cells that you want to include to repeat with model. 

9. Enter title text in a row or column outside of the repeat region (unless you want 

that text to repeat with every occurrence of model data) by using Enter Text 

and typing the desired text. 

10. The repeat region in the table must contain symbol parameter information to be 

displayed in the table. You can enter these using the keyboard by choosing Enter 

Text from the TABLE menu and Keyboard from the ENTER CELL menu; or you 

can click Report Sym from the ENTER CELL menu. 

11. Add the process model to the report by clicking Views from the REPORT menu 

and entering the name of the process. 

12. To add views of the assembly to the report, continue by adding a general view to 

the sheet. If you do not want views of the model in the report, click Quit from 

the VIEW TYPE menu and Done/Return from the VIEWS menu. The system 

still adds the model to the report, but it does not display it on the sheet. You can 

add the drawing views at any time. 

13. If necessary, click Repaint to display the contents of the table.  

14. You can add a drawing format to the report or change it by selecting Format 

from the SHEETS menu and Add/Replace from the DRAW FORMAT menu. You 

can predefine tables on these drawing formats and save them to be recalled at 

any time into a report or drawing. 

You may also add the drawing table used in the report by including it in a drawing 

format that you can retrieve. When you add a drawing format containing a table to a 

report, drawing, or layout, the table becomes independent of the format. If you 

decide to replace the format, the table highlights, and you can delete it. 

Pro/REPORT Parameters for Manufacturing Process Drawings 

Drawings of manufacturing processes are the same as drawings of any other 

Pro/ENGINEER object. However, special parameters are available using Pro/REPORT 

to create a custom table detailing the component process. An entire list of available 

system parameters appears in the following table. 

When creating a report, it is important to consider the structuring of the symbols in 

the report. Pro/REPORT parameters used in Pro/PROCESS for MFG are based upon 

either the current step or operation in the drawing or all steps and/or operations in 

the drawing. 
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Parameter Name Definition 

&mfg.actoper.actstep.comp.name Lists the names of all 

manufacturing processes in 

the currently active step 

associated with the currently 

active operation. 

&mfg.actoper.actstep.comp.type Lists the types of all 

manufacturing processes in 

the currently active step 

associated with the currently 

active operation. 

&mfg.actoper.actstep.comp.param.name Lists the names of all 

parameters for each process 

component in the currently 

active step associated with 

the currently active 

operation. 

&mfg.actoper.actstep.comp.param.value Lists the values of all 

parameters for each process 

component in the currently 

active step associated with 

the currently active 

operation. 

&mfg.actoper.actstep.name Lists the name of the 

currently active step 

associated with the currently 

active operation. 

&mfg.actoper.actstep.param.name Lists the names of all 

parameters associated with 

the current process step 

associated with the currently 

active operation. 

&mfg.actoper.actstep.param.value Lists the values of all 

parameters associated with 

the current process step 

associated with the currently 

active operation. 

&mfg.actoper.actstep.tool Lists the tool of the currently 

active step associated with 

the currently active 

operation. 
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Parameter Name Definition 

&mfg.actoper.actstep.type Lists the type of the currently 

active step associated with 

the currently active 

operation. 

&mfg.actoper.step.comp.name Lists the name for each 

component associated with 

the currently active 

operation. 

&mfg.actoper.step.comp.type Lists the types of all 

manufacturing processes for 

all steps associated with the 

currently active operation. 

&mfg.actoper.step.comp.param.name Lists the names of all 

parameters for each process 

component associated with 

the currently active 

operation. 

&mfg.actoper.step.comp.param.value Lists the values of all 

parameters for each process 

component associated with 

the currently active 

operation. 

&mfg.actoper.step.name Lists the name for each step 

associated with the currently 

active operation. 

&mfg.actoper.step.param.name Lists the names of all 

parameters for each step 

associated with the currently 

active operation. 

&mfg.actoper.step.param.value Lists the values of all 

parameters for each step 

associated with the currently 

active operation. 

&mfg.actoper.step.tool Lists the tool for each step 

associated with the currently 

active operation. 
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Parameter Name Definition 

&mfg.actoper.step.type Lists the type for each step 

associated with the currently 

active operation. 

&mfg.oper.step.comp.name Lists the names of all 

components for all 

operations. 

&mfg.oper.step.comp.param.name Lists the names of all 

parameters for each process 

component for each step 

associated with all operations. 

&mfg.oper.step.comp.param.value Lists the values of all 

parameters for each process 

component for each step 

associated with all operations. 

&mfg.oper.step.comp.type Lists the type of component 

being processed for each step 

associated with all operations. 

&mfg.oper.step.name Displays the name of each 

step associated with all 

operations. 

&mfg.oper.step.param.name Lists the names of all 

parameters associated with 

the steps associated with all 

operations. 

&mfg.oper.step.param.value Lists the values of all 

parameters associated with 

the steps associated with all 

operations. 

&mfg.oper.step.tool Displays the tool for every 

step associated with all 

operations. 

&mfg.oper.step.type Displays the type for every 

step associated with all 

operations. 
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Repeat Regions in Reports 

Repeat regions are user-defined rows, columns, or combinations of rows/columns 

(cells) that duplicate themselves to accommodate the amount of data that the model 

currently possesses. They contain the following: 

• System and user-defined parameters (such as description, time, and cost) for 

which the values are extracted from the model that is associated with the report. 

• Standard table text 

By using repeat regions, your tables that contain report data can expand and 

contract with varying quantities of data supplied by the models.  

If you have a license for Pro/REPORT, you can create a repeat region in any mode in 

which you can create a table (Drawing, Report, Layout, Diagram, or Format mode). 

You can nest repeat regions or make them two-directional. 

Other Process Functions 

About Obtaining Information 

Using the main Info menu, you can access general information concerning mass 

properties, Bill of Materials, measure etc. To obtain process-specific information such 

as cost, time estimates, and component usage lists, use the Process command on 

the Info menu.  

The Process Info menu has the following commands: 

• Sequence Info—Display an Information Window containing the textual 

information from the process sequence, including the description and type of 

each step, all attribute names, and the corresponding values. 

• Step Info—Display an Information Window containing the textual information on 

selected process steps. 

Using these options, you can access an information window that displays the 

complete process sequence. It includes information such as the step type, 

description, all attributes, and their values. The system saves this information to a 

file as it is displayed, so you can print it without actually stepping through all of the 

steps. 

About Step Information 

You can obtain information about a particular step by using the Info option in the 

Select Step dialog box, or the main Info > Process menu. If you choose one of 

these options, the system displays an Information window containing the following:  

• Step number and type 

• Machining defined 

• Abbreviated description of the step description 

• Time estimate 
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• Cost estimate 

• Simplified representation name 

• Full description 

When you show the status of components in the design assembly, you can add a 

column in the model tree called process status, which lists the current status of all 

components (that is, assembled, not assembled, assembling, and so on.) 

Simplified Representations 

About Using Simplified Representations with Large Design 
Assemblies 

Simplified representations can increase your ability to work effectively with large 

design assemblies. They improve visual clarity and performance. They are used to 

simplify the process model by excluding or substituting components for all steps or 

to simplify only the current state (that is, step). Simplified representations of the 

design model can also be used when creating process steps in the manufacturing 

process. 

Note: When dealing with simplified representations on models, be sure that 

references you have removed do not affect downstream applications. For example, if 

you place a machine coordinate system on a fixture, and then use a simplified 

representation to remove the fixture for display purposes, it is possible toolpaths will 

not compute as their references no longer exist. 

To Create Simplified Representations for a Process Model 

1. Select Simplfd Rep from the MANUFACTURING menu. 

2. Create or set the current representation. 

Components are excluded or substituted for only one step in the process assembly 

by creating or setting the current representation when defining or redefining the 

step. 

To Apply Simplified Representations to a Step  

1. Open the STEP dialog for the desired step. 

2. Click Simplfd Rep from the STEP dialog box to set or create a simplified 

representation for the step. 

You can use simplified representations of the design assembly when you create 

assemble steps in the process assembly. 

To Retrieve a Simplified Representation From a Process 

1. Create a simplified representation of the process component before adding the 

design model to the process. 
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2. Creating a simplified representation of the process component provides the 

Retrieve Rep menu selection when you add a model to the process. 

Note: Components excluded in the design model do not appear on the screen in 

phantom line font but appear in the Model Tree of the assembly where they are 

selected. 

Sample Session 

About the Sample Session 

This group of Help topics represents a sample session on a process model. The 

sample session includes retrieving the model, checking the play steps functionality, 

checking the copy process functionality, defining a new operation, and creating 

drawings; and presents some basic Pro/PROCESS for MFG features. 

To Retrieve the Process Model 

1. Select File > Open. 

2. Type the manufacturing part name. The system regenerates the process model, 

displays the last step in the process model, and displays the part's model tree.  

Example: Retrieved Process Model 

The process model is a rough out on the inside of the part. 

 

 

To Create Drawings 

1. To create a new drawing sheet click File > New. 

2. Click Type > Drawing. 
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3. Click OK to open the New Drawing dialog box. 

4. Select a default model and a template.  

5. Click Done to create the drawing and open the DRAWING menu and the 

DETAIL menu. 

6. To add or modify views and data placement on the drawing sheet, click Views > 

Add View from the DRAWING menu. 

To Use the Play Steps Functionality 

1. Select Play Steps > Set Step. The system displays the Select Step menu with 

the last step checked as the active step.  

2. Select the step you wish to set as active and click OK. 

3. To roll the model forward one step, select Next Step from the Step Regen 

menu. The system displays material removals and process references in 

magenta. 

Note: The step display allows you to interactively examine the model. 

Example: MFG Model Stock Assembled 

 

The figure below represents Step 1. 
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The following three figures represent Step 2, Step 3, and Step 4 of the 

model. 

 

Note: Rolling the model from step to step represents successive processing steps; 

that is process planning stages. 
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To Use the Copy Process Functionality 

The Copy Process functionality allows you to refer to a predefined sheet as a 

template for subsequent sheets. The process plan model is maintained within 

process plan files. It may be necessary for you to document route sheets and/or 

process plan sheets using the Pro/DETAIL function. 

1. Click File > Open. 

2. Enter the name of the drawing. The system regenerates the drawing and displays 

the first sheet in the drawing. 

3. To move to the next drawing select Insert > Sheet. The system displays the 

next drawing sheet. 

4. To copy the process select Edit > Move or Copy Sheet. The system displays the 

Process State dialog box, from which you can select the process state for the 

next sheet by clicking OK.  

5. To set the current sheet, select View > Go to Sheet. Enter the desired sheet 

number directly and click Go To. You can then navigate to the previous or next 

sheet by selecting the appropriate option. 
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Example: Copy Process Functionality 

The example drawings shown below are of the cover plan. 

Cover Plan Sheet 1 of 3 with Notes 
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Cover Plan Sheet 2 of 3 with Notes is shown below  
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Cover Plan Sheet 3 of 3 with Notes is shown below.   

 



Using Pro/PROCESS for MFG 

41 

 



Manufacturing Process Planning - Help Topic Collection 

42 

Sheet 4 is set as the current (see Copy Process Sheet 4 Set as Current.) 

 

To Define a New Operation 

1. Click File > New. 

2. Click Type > Manufacturing, and Sub-type > Process Plan to open the 

MANUFACTURING menu. 

3. Click Mfg Sequence to open the MFG SEQUENCE menu. 

4. Click Operation to open the DEFINE OPER menu from which you can define the 

new operation. 

For this example, Workcell is checked along with Done Oper, and menu 

commands Workcell > Use Prev >  OP020 are selected. This indicates that the 

workcell used for this new step is the same as the one used in a previous 

operation (OP020). 
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As shown in the dialog box below, the name of the fixture step is defined as 

SETUP_2, one fixture component is disassembled and then reassembled onto the 

part, comments are entered, no simplified representation is defined, a time 

estimate of 0.15 and a cost estimate of 5.00 are supplied. 
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