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1. SCOPE/PURPOSE
1.1 This document is to instruct the user in the creation of piping models using the Pro/PIPING™ module of Pro/ENGINEER® design software and the corresponding piping drawings.  Basic piping methodology is addressed as well as how modeling can be accomplished using the various tools of the Pro/PIPING module.   Multiple methods exist for modeling pipe assemblies, however, the modeling method chosen by the user is dependent on what type of pipe is to be modeled and design limitations.  Most pipe assemblies will be modeled using the Pro/PIPING module but simple pipes that are straight or only have one bend can be created using standard part modeling practices.  All piping models must follow the CAD standard and MPA process.
1.2 Piping Assembly. The structure of a piping assembly file contains a linestock feature, a pipeline feature and pipe centerline geometry features which are all assembly features.  Also assembled in the piping assembly are non separable items like sleeves, nuts and welded flanges.  A pipe solid model which follows the pipe centerline features is created to display the routing of the 3D solid pipe geometry.  All pipe routing location points must refer to geometry located or originated from the skeleton model in the installation assembly or through transformed coordinate systems.  Pro/PIPING resolve mode sometimes enters the part level not the assembly where the piping features were created, which makes reconstructing a failed pipe to its original geometry and location difficult without real reference geometry, such as points or curves.
1.3 Installation Assembly. To incorporate reference and location control, an upper level assembly is created to contain the piping assembly model and location geometry skeleton.  In this installation assembly, assemble the pipe mounting hardware such as standoffs, brackets, and p-clamps to the skeleton location geometry.
1.4 Pipe Solid Part. This is the actual 3D model of the pipe. The pipe solid feature in a piping assembly should not be deleted once it has been created.  Pro/PIPING creates a new part when using the “make solid” piping command.  If the pipe solid feature is deleted, the solid pipe part is deleted from the assembly and a new part file will need to be created with a different file name.  WINDCHILL will not allow the re-use of the previous filename.  The best practice is to suppress a failed piping feature, correct the problem, and then resume the pipe solid feature.
2. DEFINITIONS

· Library Fittings
Standard fittings from the library.
· Linestock
A file that specifies the pipe parameters. (Ex. Pipe outer diameter (OD), wall thickness, bend radius, etc.)

· Installation Assy
An assembly that contains the piping sub-assembly (or sub-assemblies), the pipe end fittings and the pipe mounting hardware.
· Pipeline
A Pro/PIPING feature that uses the information in the Linestock and all routing features to define the pipe.

· Piping Part
A part file that is created within the piping assembly, when the MAKE SOLID command is used.

· Piping Assembly
A stand alone design assembly model consisting of a piping skeleton, Pro/PIPING features and a solid pipe part that runs between fittings and/or components and insulation if required.

· Piping Skeleton
A skeleton file consisting of necessary features for routing the pipe(s).

· Port
A coordinate system (CSYS) in a fitting or piping component that is used to specify a start or end point for pipelines.  The Z-axis points in the direction that the pipe will run.

· Transform CSYS
A coordinate system that is created by measuring and offsetting from one CSYS to another.
3. NAMING CONVENTION

3.1 Piping models and drawings are to be named in accordance with company standards.
4. CREATION METHODOLOGY
4.1 Pipe Assembly File Structure

4.1.1 Type I: Simple piping model structure with no external supports. Pipe installation assembly and skeleton files are not required. This would be a straight or one bend pipe section.

4.1.2 Type II: Simple piping assembly file structure with skeleton for complex routing. Points, datum curves, and other geometry are recommended to locate the pipeline routing.

4.1.3 Type III:  This pipe assembly file structure contains an Installation file, skeleton, mounting hardware and piping assembly file. This type can contain items such as a "TEE" fitting and two or more pipe runs. The skeleton contains geometry such as datum curves, CSYS’s, sketches, and points to help locate the pipeline locations, mounting hardware, and also the pipe "TEE" fitting. Note: Any datum planes or datum curves created in the skeleton to locate the pipeline must be independent and not contain any external references to outside geometry.
4.2 Creating Installation Assemblies
4.2.1 Open the appropriate assembly that contains the CSYS that is to be used to locate the piping assembly.  From the top menu, select File> Open, navigate to the appropriate product and folder and select the desired assembly.

4.2.2 Create a new Installation Assembly and create a CSYS on top of the ASM_DEF_CSYS and name it to match the locating CSYS. (see Figure 1 circled in red)
4.2.3 Assemble it by the new CSYS to its locating CSYS, or if by a volume, determine the volume CSYS to be used.  If this is a simple piping model that will not be using any mounting devices, an Installation Assembly isn’t required.

4.2.4 Create a skeleton, activate it and if desired, add a shrinkwrap or copy_geom of the components that will be routed around, for visual reference only.  Referencing of any copy_geom should be avoided.  All references to copy_geom are to be deleted prior to Workgroup Approval or release.
4.2.5 If the installation assembly is simple, a transformed CSYS should be created at the mounting location for the end fittings or at the entry ports of the components to be used as the "START_CSYS" and "END_CSYS".  If the installation assembly has many piping assemblies, it is easier to keep the assemblies separate by creating the "START_CSYS" and "END_CSYS" in the individual piping assemblies. (see #8 in Figure 1, refer to Appendix A for further information)
· To create a transformed CSYS: From the top menu, select Insert> Model Datum> Coordinate System, select the CSYS at the desired location, then select the skeleton default CSYS.

4.2.6 Create any needed geometry for locating the mounting hardware. (ex. planes, CSYS's, sketch).  Repeat for every piping assembly that will be located in the Installation assembly. (see #3 in Figure 1, refer to Appendix A for further information)

4.2.7 Create a "publish_geom" feature of all CSYS's and other needed geometry for each individual piping assembly. (see #4 in Figure 1, refer to Appendix A for further information)

4.2.8 Activate the Installation assembly and assemble the required fittings (ex. tees, elbows, reducers, unions) and pipe mounting hardware to the appropriate skeleton locations.
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Figure 1
4.3 Creating the Piping Assembly
4.3.1 With the Installation Assembly active, create a new Piping Assembly and assemble it by the default CSYS.

4.3.2 Activate the Piping Assembly, create a CSYS on top of the ASM_DEF_CSYS and name it to match the Installation Assembly and the locating CSYS (see Figure 1 circled in blue), and then create an "external copy_geom" feature of the "publish_geom" from the Installation assembly skeleton, located at the default CSYS.  By using “publish_geom” and leaving it “dependent”, (until ready to release), any information in the “publish_geom” will propagate to and update the pipe routing.  The use of transformed CSYS’s requires a manual update of the CSYS’s.

4.3.3 If the "START_CSYS" and "END_CSYS" weren't created in the Installation skeleton, create transformed CSYS's from the “PORT_CSYS” of the start and end fittings and name them. (Ex. “END_CSYS”) (See Figure 2)
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Figure 2

4.3.4 Add other geometry as needed to define the pipe route.  A pipe cannot be routed through a CSYS, but can be routed offset from the CSYS.  Offset points can be created from the "external copy_geom" CSYS's and then the pipe routed through the points. (To offset a point from a CSYS, go to the create datum point command, pick on the desired CSYS, then hold the “Ctrl” button and select the correct axis, usually “Z”, then drag the location away from the CSYS.)  If routed to a CSYS, Pro/PIPING sees that as the end of a pipe and anything after that will be added as a new pipe and created as a separate piping part model.

· Transformed CSYS’s can be redefined by:

· Activating the part that it is located in

· Pick the CSYS to redefine and RMB

· Select “edit definition”

· Pick the new CSYS

· Reset the “x”, “y”, and “z” coordinates to zero

· Select the “Orientation” tab

· Reset the “About x”, “About y”, and “About z” angles to zero

· Pick the default CSYS of the active skeleton

4.3.5 Select Applications> Piping> Active Asm, then select the piping assembly in the model tree.

4.3.6 Create a Linestock.

· Select Set Up> Line Stock> and read in a linestock from the library.  If a linestock is not available, add a linestock to the library.  When creating a linestock, ensure that the fields are populated with the correct information. (See Figures 3 & 4)
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Figure 3
Figure 4

4.3.7 Create a Pipeline.

· Select Pipeline> Create/Route> and enter a name (It is good practice to name the pipeline with the same name that will be given to the solid pipe part.  See Figure 5) to create a pipeline feature, then select the linestock from the side menu.
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Figure 5
4.3.8 Route a pipe.

· The “PIPELINES” layer should be unhidden while working with Pro/PIPING.

· Select Set Start> and pick the starting CSYS.  Continue routing the pipe as needed, ending up at the “END_CSYS”.

· It is good practice to create an extend feature immediately after the start point, even if it is just a short straight pipe.  This will assist in redefining the pipe at a later date, if needed.  Do not remove this start point and extend feature, to retain the solid pipe part.
CAUTION:  The “Connect” command is less robust and more likely to fail if a fitting or component moves, due to trying to create straight segments and only 90 degree bends.

4.3.9 Adding a welded fitting.

· There are two ways to add a weld fitting:
· Assemble to the piping assembly via the correct CSYS or other mating options as a component and route the line to the fitting “PORT” CSYS, or;

· Add as an end fitting to the pipeline. (same as 4.3.10)

4.3.10 Adding a flared end.

· If a flared end is needed on the pipe, there are two ways to add it:
· Either select a flared end from the library (For example: astm-a269_tube_end.prt family table) and insert it as an end fitting (See Figure 6 through Figure 9) or if needed, create a new flared end.
[image: image6.png]ve Asm

Redefine
Replace
Done/Return




   


   
[image: image7.png]


   

Figure 6
Figure 7
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Figure 8
Figure 9
· A flared revolve feature can be created in the solid pipe part file, but this technique is not recommended:

· Open the solid pipe part.

· Datum planes may have to be created through the end of the pipe.

· Cut back the end of the pipe.

· Draw the revolve sketch so that the point of contact for the flared surface is at the correct location.  This should be measured while still in the assembly.

4.3.11 Create a solid pipe.
· Select Fabrication> Pipe Solid> click on the “+” sign beside the pipeline in the “SEGMENT” window.

· Select the pipe name in the “SOLID NAME” column and give the part the same name as the pipe assembly that it is associated to and add an “-XXX” extension. (ex. 97M28650-003.PRT)
· Select the folder browse button under the “Copy From” section and select the “pipe_startpart_std.prt” model and click “Open”.

· Click the green checkmark to apply it as the default model for the pipe.

· Select the pipe in the “SEGMENT” column and click the “Make” button.

4.4 Creating Insulation

4.4.1 While in the Installation Assembly, select Applications> Piping> Active Asm, then select the piping assembly in the model tree.  Creating the insulation at the Installation assembly level, provides the mounting hardware to be visually used as a reference for start and stop points of insulation segments.
4.4.2 Read in an insulation file from the library by clicking Set Up> Insulation> Read.
4.4.3 If the needed Insulation file is not available, add an Insulation linestock to the library.  Click Set Up> Insulation> Create, give the insulation a name, and ensure that the fields of the dialog box are populated with the correct information. (See Figure 10)
· After filling in the information, click the “Save” button and select a location to save the file (must have write access).  Then click the green checkmark.  (See Figure 10)
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Figure 10

4.4.4 Then click Fabrication> Insulation.
· The “Create Insulation” dialog box pops up by default, requesting that a pipe segment be selected for the start point location. (See Figure 11)
· Pick a pipe segment near the start end, pick near the ending end of the insulation, (pick on a different segment if necessary), select “Start” again and then choose the desired “Location Type” option. (See Figure 11)
· Specify the offset distance in the “Location Parameter” field.  The distance can be adjusted here to allow for the pipe fittings. (See Figure 11)
· Select the “End” button in the “Insulation Segment Points” option, set the “Location Type” and “Location Parameter” fields. (See Figure 12)
· Ensure that the loaded or created Insulation file is showing in the “Insulation Parameters” section and that the information is correct.  Then click the green checkmark to create the insulation. (See Figure 13)
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Figure 11
Figure 12
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   Figure 13
4.5 Solidify the Insulation

4.5.1 In order for the Insulation to have weight and to show the hatching correctly in a cross-section, the Insulation surfaces must be solidified as a separate part.  If the insulation will be a bulk item type, give the Insulation part the same name as the pipe assembly that it is associated to and add an “-BULK1” extension. (ex. 97M28650-001-BULK1.PRT) If it will be a non bulk item part, give it a dash number (ex. 97M28650-003.PRT) to the pipe assembly or a new “97Mxxxxx” number.
4.5.2 Create a new part in the piping assembly (name it as stated in 4.5.1 above) and assemble it to the default CSYS of the piping assembly.  Create a CSYS on top of the default CSYS and name it to reflect the assembly and locating CSYS that it will be associated to.
4.5.3 Create an “external_copy_geom” in the Insulation part.
· Right-click on the insulation part in the model tree and select “Open”.
· Bulk item type insulation will be represented by one part for all pieces of insulation.  If more than one bulk item type will be used in the same piping assembly, a separate part will be created for each bulk item material.

· Formed type insulation that will require a 97Mxxxxx number and a drawing, will be represented by separate parts for each piece of insulation.

· Go to the “Insert” menu, “Shared Data”, and select “Copy Geometry”.

· Select on the “Open Folder” icon to choose the reference model, click on the “In-session” icon and select the piping assembly, click the “Open” button.
· Select the default CSYS for placement.

· Select the “References” button in the dashboard and pick in the “Surface sets” area.  This will open the Piping Assembly window.

· Change the “select by” window to “Quilts”. (See Figure 14)
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Figure 14
· Pick the surface quilt of the Insulation.  If this is a bulk item insulation, hold down the “Ctrl” button and pick on every quilt surface that is being referenced by this insulation part. (See Figure 15)
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Figure 15
· Then middle-click the mouse or click the green checkmark to complete the copy geometry command.
· Pick on one quilt of the Extern Copy Geom feature and click Edit> Solidify.  Repeat for each quilt, then click the green checkmark. (See Figure 16)
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Redefining a Pipe
‘When it is necessary to modify a pipe, try rerouting before redefining.

‘When redefining a piping assembly, do not delete the original “set start point” and first
“extend” feature. If all of the features of a piping assembly are deleted, the solid pipe
will be removed and will not be re-used in the same assembly. It will then have to be
renamed in DDMS, to be able to use the name again when making anew “solid” pipe.

e Itis good practice to create an extend feature immediately after the start
point, even if it’s just a short straight pipe.

Preparing the Piping Assembly for Drawings
If not already in Piping mode, from the top menu, click Applications> Piping.

In the Menu Manager, click Info. In the “Info Type” section, select “Bend Location™.
(see Figure4.3.2.1)
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Figure 16
· Add the desired material and change the color, per company standard.

· If any of the insulation will be assembled at different stages, create simplified reps in the insulation part to show the different stages, the “Main” rep will show all of the insulation.

· When the design is ready for release, set all dependencies to “Independent”.
· Return to the piping assembly and create simplified reps to hide insulation for pipe drawings (ex. DRAWING_REP) and to show any insulation needed at the pipe installation assembly (ex. PIPE_INSTL_REP).  Reference part reps if needed.  The “Main” rep will show all insulation.

4.6 Pipe Rules checker

4.6.1 If the pipe rules have been assigned per the specifications, the Design Rules checker can be used to determine if the pipes meet the rules.
· Click the “Design Rules” icon. (See Figure 17)
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Figure 17
· Any violations will be identified in the “Design Rules Check” dialog box.  Expand the indicated sub-section in the “Design Rules Tree” section.  The violations are shown in the “Violation Details” section. (See Figure 18)
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Figure 18
4.7 Redefining a Pipe

4.7.1 When it is necessary to modify a pipe, try rerouting before redefining.

4.7.2 When redefining a piping assembly, do not delete the original “set start point” and first “extend” feature.  If all of the features of a piping assembly are deleted, the solid pipe will be removed and cannot be re-used.  It will then have to be renamed in WINDCHILL, to be able to use the name again when making a new “solid” pipe.

· It is good practice to create an extend feature immediately after the start point, even if it’s just a short straight pipe.

4.8 Preparing the Piping Assembly for Drawings

4.8.1 If not already in Piping mode, from the top pull-down menus, click Applications> Piping, then select Active Asm and pick the desired piping assembly.
4.8.2 In the Menu Manager, click Info.  In the “Info Type” section, select “Bend Location”. (See Figure 19)
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Figure 19
4.8.3 When prompted, select a segment of the pipe and the starting CSYS. (See Figure 20)
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 Figure 20
4.8.4 Select the “Designate for Report Setup” checkbox.  Under the “Saved Analyses” section, (click the arrow to expand if needed) type “bend_location” in the “Name” text box and click the Save icon. (See Figure 21)
4.8.5 In the “Info Type” section, select “Bend Machine”. (See Figure 21)
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Figure 21
4.8.6 When prompted, select a segment of the pipe. (See Figure 20)
4.8.7 Select the “Designate for Report Setup” checkbox.  Under the “Saved Analyses” section, (click the arrow to expand if needed) type “bend_machine” in the “Name” text box and click the Save icon.  Click the red “X” to close the window. (See Figure 21)
4.9 General Notes

4.9.1 Piping skeletons should contain only the features necessary to define critical boundaries and routing paths.
4.9.2 Skeletons should not contain any dependent external references and using copy_geom is strongly discouraged except for visualization.  All copy_geom features are to be deleted or set “Independent” prior to Workgroup Approval or release.
4.9.3 Creation of the skeleton can use copy_geom to establish location and orientation, but there should be no linkage from outside geometry to the skeleton.  
4.9.4 Piping models that share routing paths with other models should copy CSYS’s from the same higher level skeleton for accurate representation.

5. DRAWING METHODOLOGY
5.1 Creating a Piping Drawing

5.1.1 Create the pipe drawings using the Pro/PIPING pipe assembly in accordance with company standards.  Create any necessary views and notes.

5.1.2 Insert the piping tables into the drawing by selecting Table> Insert> Table from file.  From the WINDCHILL library, select the following tables and place them in the drawing; “pipe_bend_loc_table.tbl”, “pipe_bend_mach_table.tbl”, “pipe_stock_material.tbl”, “pipe_info_table.tbl”.
5.1.3 Insert the “pipe_bend_mach.sym” symbol from the library onto the drawing.

5.1.4 The notes should specify that the pipe ends are to be cut at least one inch longer than indicated by the 3D model, to allow for bending, flaring and/or field cut for welding.

5.1.5 Sheet one should consist of an isometric view, the piping tables, the piping symbol and the required notes.
5.2 General Notes

5.2.1 Piping drawings should contain all necessary information for construction and verification.
5.2.2 Pipe length, bend radius, and bend angle information should be displayed in a table that is pulled from the WINDCHILL library.
Installation drawings can be created from –REL companion files.

5.2.3 APPENDIX A
Figures Of A Pipe Creation
Installation Assembly. To incorporate reference and location control, an upper level assembly is created to contain the piping assembly model and location geometry skeleton.  In this installation assembly, assemble the pipe mounting hardware such as standoffs, brackets, and p-clamps to the skeleton location geometry.

Piping Assembly. The structure of a piping assembly file contains a linestock feature, a pipeline feature and pipe centerline geometry features which are all assembly features.  Also assembled in the piping assembly are non separable items like sleeves, nuts and welded flanges.  A pipe solid model which follows the pipe centerline features is created to display the routing of the 3D solid pipe geometry.  All pipe routing location points must refer to geometry located or originated from the skeleton model in the installation assembly or through transformed coordinate systems.  Pro/PIPING resolve mode sometimes enters the part level not the assembly where the piping features were created, which makes reconstructing a failed pipe to its original geometry and location difficult without real reference geometry, such as points or curves.

Pipe Solid Part. This is the actual 3D model of the pipe. The pipe solid feature in a piping assembly should not be deleted once it has been created.  Pro/PIPING creates a new part when using the “make solid” piping command.  If the pipe solid feature is deleted, the solid pipe part is deleted from the assembly and a new part file will need to be created with a different file name.  WINDCHILL will not allow the re-use of the previous filename.  The best practice is to suppress a failed piping feature, correct the problem, and then resume the pipe solid feature.
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Figure 22 (Same as Figure 1)
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Figure 23
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Figure 24
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Figure 25
Legend:
™
Pro/PIPING is a trademark of  Parametric Technology Corporation or its subsidiaries in the U.S. and in other countries.

®
Pro/ENGINEER is a registered trademark of  Parametric Technology Corporation or its subsidiaries in the U.S. and in other countries.

Weight is one inch long piece of pipe.


Bend radius is 2X, 3X, and 4X pipe Outside Diameter, specified in inches, with a space between.


The first number listed is the default, the others can be selected when modifying, or a new value can be entered.





Material name is used in Piping table.





240” = 20’


Length is per the required specification.





Select “Fitting”, “Insert”, “End”





Select the end of the pipeline.





Select the point that has been placed at the level where the face and port CSYS of the mating fitting will be when the flared surfaces are mated flush.


(“PIPE_END” in the library parts.)





Select the port CSYS at the flat end of the flare.


Must have the “Z” axis pointing away from the flare.


(“PORT1” in the library parts.)








Insulation name





Insulation material





Insulation stock number





Insulation thickness





Insulation color





Save button





This button flips the start or end point to the other end of the selected pipe segment.





Surface quilts





The number in parentheses indicates the number of violations.





Select pipe segment





Select starting CSYS
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