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Using Additional Modules 

Advanced Surface Extension 

Pro/COMPOSITE 

Basic Techniques 

About Composite Design 

The design of a composite part begins with a surface on a Pro/ENGINEER model. The 

composite part is a distinct Pro/ENGINEER entity based on the existing model 

surface. The composite part consists of plies and core material added to the surface, 

with beads and flanges to stiffen and connect the plies. Once all the material is 

added, the part can be solidified, analogous to being cured, to bind all the material 

together into one solid part. 

To document the composite part, two types of drawings can be made: drawings that 

document the design part itself, showing dimensions, a bill of materials of the plies 

involved, and so on, or a drawing that automatically shows the material added with 

each sequence. 

To Create a Composite Part 

Once you have a design part with an available base surface, you can begin your 

composite part design. If you want to use a solid surface for applying composite 

material, copy it into a surface feature prior to creating the composite part. 

1. From the Pro/ENGINEER menu bar, click File > New. The New dialog box 

appears. 

2. Select Part as the Type, and Composite as the Sub-type, then enter the name 

of the new composite part. 

3. Type or select the name of the existing design part that contains the base 

surface. If the part contains more than one surface feature, the part appears in a 

small window.  

4. Select the surface to be used as the base surface. When the surface has been 

selected, the design model appears in the main window. A merge of the design 

part into the composite part is created automatically.  

You can now add beads and flanges to the composite part. These must all be added 

before you start adding plies or cores. 

Creating the Design Part 

The design part is a regular Pro/ENGINEER part that can consist of surface features 

and solid features. However, only a single surface feature or merged surface of this 

part can be used as the basis for the composite part design. This surface forms the 
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molded surface, referred to hereafter as the base surface, giving shape to all the 

composite material to be added later. 

Use the following guidelines in creating a design part: 

• The design part surface can be a flat panel, a ruled surface, or another surface 

with a curvature. 

• The design part surface should be free of flanges and beads that are used to hold 

panels together or to stiffen the panels. These will be added in Composite mode.  

• Other surfaces and datum curves can exist in the design part. These will be 

available in the Composite part and can be used for ply and core feature 

boundaries and for creating beads and flanges.  

• Create at least one coordinate system before you begin composite feature 

creation. Coordinate systems are used as a reference for the angle of bias of the 

ply and core material. 

The following figure shows an example of a design part. 

Design Model for Composite Part 

 

To Create Beads and Flanges 

Beads and flanges are surfaces features that are added to the base surface feature. 

When all beads and flanges are added, the resulting surface forms the surface on 

which material is applied. This is called the bottom surface. Add all beads and flanges 

to the part before you add the first ply feature. Once the first ply is added, 

Bead/Flange is inaccessible. 

1. Create a surface or surfaces to form the bead or flange geometry. These surfaces 

need to intersect or join to the base surface. Flanges must be added at the edges 

of the base surface; beads can be added to the interior of the surface. 

2. Click Applications > Legacy > Feature >Create > Composite > 

Bead/Flange. The SURFACE MERGE dialog box opens. 

3. Use the SURFACE MERGE dialog box to include the bead or flange surfaces in 

the base surface. The base or bottom surface is selected automatically for 

merging. 
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4. You can create round features along the two-sided edges of the beads and 

flanges for the composite features to have a smooth transition over them. Create 

the rounds using Insert > Round. 

To Define Material During Feature Creation 

When you are creating a ply, you are prompted to select or create the ply material 

after you select the direction of the ply. 

1. Click Create from the MATERIALS menu.  

2. Enter a name for the composite material. 

3. Using the following options in the PARAMETERS menu, define the parameters 

for the material: 

o Retrieve—Uses the parameters from a saved material.  

o Save—Saves the parameters to a file with the extension .mat. Saving 

material parameters allows you to retrieve those parameters in other 

composite parts. 

o Mod Params—Edits the existing parameters using the table editor.  

o Show—Displays the current parameter values in an information window. 

Note: During ply or core feature creation, you can only define a new material. 

You cannot rename or modify an existing material. 

Composite Material Parameters 

Composite material can be defined before or during composite feature creation. It 

consists of five parameters: 

• BOTTOM_OFFSET—The bottom offset of material when overlapping other plies 

(see the figure below). 

• DENSITY—Mass density of the composite material, default equals 1. 

• FIBER_ORIENT—Whether the ply or core material has bias. Possible values are 

Yes and No. 

• THICKNESS—Thickness of the material. The default changes with respect to the 

part size (see the figure below). 

• TOP_OFFSET—The top offset of material when overlapping other plies (see the 

figure below). 
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The following figure illustrates composite material parameters. 

Composite Material 

 

Tip: Working with Composite Material Outside of Feature Creation 

To work with composite material outside of feature creation, click PART > Set Up > 

Material > Composite. The CMP MATERIAL menu appears with the following 

options: 

• Add—Adds a new composite material to the part. This option is automatically 

selected if no composite material exists in the part. Type the material name, and 

use the options on the PARAMETERS menu to retrieve, save, modify, or show 

the material parameters. 

• Remove—Removes a previously defined material. A list containing all material 

names in the part will appear. Select the material to delete and click Done Sel. 

• Modify—Modifies a material. Use the PARAMETERS menu options to retrieve, 

save, show, or modify the material parameters. 

If you want to save the material data to a file for use in other parts, click 

PARAMETERS > Save. 

Composite Features 

About Composite Features 

You can create composite plies and cores by specifying the boundaries and the 

material properties. As each feature is added, the top surface is modified to 

accommodate the contours of the new feature. The bottom surface is modified by 

having the ply boundaries projected onto it. These are characterized by curves 

appearing on the bottom surface in cyan. As you create additional features, you can 

use these curves. 

Note: The first composite feature added to the part requires that you specify the 

direction in which the composite part will be built. 

To Create a Ply 

A ply is a type of composite feature. You can create a number of different plies using 

the POSITION menu. 

1. Click Feature > Create > Composite > Ply. 

2. Use the POSITION menu to specify the type of ply. The options are: 
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o Full Body—Creates a ply that automatically covers the entire bottom 

surface. 

o Boundaries—Creates a ply that is bounded by the selected curves. 

o No Offset—Creates the ply feature using the selected boundaries.  

o Offset—Creates a ply that is offset from the selected boundary curves 

(similar to creating an offset sketch). This option is not available for full 

body plies. 

To Create a Full Body Ply 

1. Click Feature > Create > Composite > Ply > Full Body > Done. An arrow 

appears indicating the direction in which the ply will be created.  

2. Click Flip or Okay. 

3. Select or create a composite material. 

Note: Only the names of composite material that have already been added to the 

part will be displayed for selection. If you have material defined that is not in the 

name list, enter the name to add it to the part and retrieve the appropriate 

parameters. 

4. Select the reference coordinate system for aligning the material bias, and enter 

an angle for the bias. The angle is about the z-axis and with respect to the x-

axis. The top quilt of the part will be adjusted for the new ply. 

To Create a Boundaries Ply 

1. Click Feature > Create > Composite > Ply > Boundaries > Offset/No 

Offset > Done. An arrow appears indicating the direction in which the ply will be 

created.   

2. Click Flip or Okay. 

3. The composite part is placed in Sketcher so you can select existing curves by 

using Sel Curve/Edge, Sel Chain, or the "bottom" surface edges. If you have 

an open curve (it must be aligned to the bottom surface edges), the system 

automatically closes the boundary by using the bottom surface edges.  

4. Click Done. The system prompts you to select the side of the closed loop where 

the ply should be added.  

5. Click Flip or Okay. If the ply boundary is Offset, the system prompts you to 

enter the boundary offset value in the direction shown. If any edges of the 

boundary have a different offset, select them and enter their offset.  

6. Continue until all offsets have been established, then choose Done Sel. 

7. Type the name for the material or create a new one.  

8. Click PARAMETERS > Done. If the material has bias, enter a reference 

coordinate system for aligning the material bias.  
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9. Select the coordinate system and enter an angle for the bias. The angle is about 

the z-axis and with respect to the x-axis. The top surface of the part is adjusted 

for the new ply. 

Example: Creating a Ply from Boundaries 

With the Boundaries option, you can create a ply with open areas (wells) by 

selecting multiple open and closed loops to define the boundaries of the ply.  

Note: Datum curves delineating boundaries of a ply or well must be created 

before you start creating a ply. 

An example of a ply with wells appears below. Note that for ease of visualization, the 

thickness of the ply has been exaggerated. 

 

When creating a boundary ply with wells, remember that curves comprising 

boundaries of wells can be selected in any order. However, the boundary you define 

first is used by the system to determine the well location—within or outside the 

boundary. The system places an arrow at this boundary and prompts you to select 

the side where material should be added. The figure below illustrates how the 

system creates wells in a ply. 

 

Example: Creating Plies with Common Boundaries 

With the Boundaries option, you can create plies that share boundaries. An 

example of such a case appears in the following figure. Note that when you select an 

open curve aligned to surface edges, the system closes the boundary of a ply by 

using the surface boundaries; the direction of the arrow indicates where to add the 

ply.  



Using Additional Modules 

7 

 

To Add a Core 

Cores are added to the part to provide stiffness and strength to the panel. A core is 

generally a much thicker ply with beveled edges so that additional plies to 

encapsulate the core have a smooth transition over the core. The angle of the core 

can be up to 90 degrees.  

1. Click Feature > Create > Composite > Core. 

2. Choose one of these options from the POSITION menu to specify the type of 

core: 

o No Offset—Creates the core feature using the selected boundaries. 

o Offset—Creates a core that is offset from the selected boundary curves 

(similar to creating an offset sketch). 

3. Specify core boundaries, as you do for ply boundaries. 

4. Type a bevel angle for the core edges.  

5. Select the edges to which the angle applies (for every edge of the core 

boundary).  

6. Click Done Sel. 



Pro/COMPOSITE - Help Topic Collection 

8 

Example: Offset Core 

The following figure shows a composite part with an offset core. 

Composite Part 

 

To Create a Pre-Form Feature 

Pre-forms represent a composite panel already made up of one or more plies/cores. 

Every ply/core represented by the feature will use the same boundaries.  

1. Click Feature > Create > Composite > Pre-Form. 

2. Click POSITION > Full Body/Boundaries > Offset/No Offset > Done. 

3. Specify pre-form boundaries, as you do for ply boundaries. 

4. When the Pro/TABLE editor opens, enter values for every ply/core in the preform. 

The data required is: 

o Material—The name of a material existing in the part or on disk. 

o Coordinate system—The name of the reference coordinate system for 

biased plies only (material with FIBER_ORIENT = YES). 

o Angle—The angle of bias for biased plies. The angle is about the z-axis and 

with respect the x-axis of the reference coordinate system. 

o Quantity—The number of plies with the same material and bias that are 

laid up consecutively in the pre-form. 

5. The top surface of the part will be adjusted for the new ply. 

To Attach Two Composite Parts 

1. Assemble the two parts.  

2. Click Modify > Mod Part and select the first (non-solidified) component. 

3. Click Feature > Create > Composite > Attach. 

4. Select the solidified composite part to attach. 
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5. Select appropriate surfaces for attaching, first from the solidified part, and then 

from the non-solidified part.  

6. Repeat this process until all appropriate surfaces have been attached. 

Using Attached Features 

Composite parts can be attached to other composite parts using the Attach 

command. This command is available only in an assembly after the two composite 

parts have been assembled. 

To make the parts attach, remember the following: 

• The two must have similar surfaces where they attach. A flat surface can attach 

to a flat surface, a cylindrical surface to a cylindrical surface, and so on. 

• The part that is assembled first must not be solidified; the part that is being 

attached must be solidified. 

To Solidify the Composite Part 

When you have added all the plies, pre-forms, and cores that you want, you can 

solidify the part to prepare for engineering analysis and mass properties or for 

adding other solid features. Once the part is solidified, you can no longer add 

composite features to the part. 

1. Add all the composite features you want. 

2. Click Feature > Create > Composite > Solidify. 

Using Solid Features 

Part features that have the ability to join with the ply surfaces (for example, rounds, 

area offsets, and so on) can be created on the composite part. If created before 

solidifying the part, they might be used to represent a threaded insert, metal backing 

plate, and so on. These can then be covered with additional composite features. 

Once the part is solidified, you can create solid features such as cuts, slots and 

holes, cosmetic features, and user-defined features to complete the part. 

To Create a Cross Section 

You can create a cross section of a composite part with the x-section button in the 

Part or Composite menu. The resulting cross section will show all plies that are 

intersected by the cutting plane. 

This functionality is available for you if the configuration option 

allow_ply_cross_section is set to yes (default). 

1. Click X-section > Create. 

2. Enter the name for the cross section. 

3. Select or make a datum plane to be the cutting plane. 
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To Create a Core Part 

Core parts are extracted from the original composite part and flattened. These can 

then be used in drawings with dimensions added for flat patterns. 

1. With the composite model active, click PART > Flat Core. 

2. If there is more than one core, select which core to use. 

3. Type a name for the part or accept the default name. 

Modifying Composite Parts 

To Insert a Composite Feature 

1. Click FEAT > Insert Mode > Activate, and select the feature after which you 

want to insert features. Every feature after the one selected will be suppressed 

until you cancel Insert mode. 

2. Create the appropriate features. 

3. When finished, click Insert Mode. 

4. Click Cancel. The features suppressed upon entering Insert mode will be 

resumed in the appropriate order. 

Names for Selecting Composite Features 

Plies, cores, and pre-forms are automatically given the following names: 

• Ply—PLY_# 

• Core—CORE_# 

• Pre-form—PF_# 

where # is an incremental integer. For example, PF_1, PLY_2, PLY_3, PF_4. 

These names appear in the NAMES menu when you use the Sel By Menu option. 

Note: These names can be changed using Set Up, Name, and Feature. 

Inserting Composite Features 

It is easy with Pro/ENGINEER to add features to the composite part. However, you 

must do this by inserting the features in the following situations: 

• A ply feature has been added to the part. The Bead/Flange menu option 

becomes inaccessible. To add more beads or flanges, you must insert the 

features (surfaces, bead/flange, and round features) before the first ply. 

• The part has been solidified, which makes all composite features inaccessible. To 

add a composite feature, you must insert it before the Solidify feature. 
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Deleting a Composite Feature 

Composite features do not have the same parent and child relationships that other 

features have. You can delete most composite features without regeneration 

problems. For example, you can delete ply_2 from the part without affecting ply_8. 

The part will regenerate from the deleted feature on, adjusting the top of the 

composite part appropriately.  

You can also delete flanges and beads. Composite features will adjust themselves to 

the new boundaries as necessary.  

To Modify Dimensions 

1. Click Modify > Dimension in the PART menu.  

2. Select the feature whose dimensions you want to modify. 

3. Click Ok. The Dimension Properties dialog box opens. 

4. Modify the dimension. 

5. Click OK. The dimension is modified. 

To Modify the Design Part 

Note: The design part (the model referenced by the composite part for its design 

surface) cannot be modified when in Composite mode.  

1. Open the design model in Part mode.  

2. Make any modifications to the model. 

3. Regenerate the composite part to see the changes in Composite mode. 

To Change the Material Parameters 

Composite material can be modified for the part and also saved to disk for use by 

other parts. A different material can also be assigned to a ply or core when 

modifying the feature. 

Note: This procedure modifies the material wherever it is used. 

1. Click PART > Set Up > Material > Composite > Modify.  

2. If more than one material exists in the part, select the material to modify from 

the MOD MATERIAL menu. The PARAMETERS menu appears with the following 

options: 

o Retrieve—Retrieves a composite material file from disk to replace the 

values for the selected material. 

o Save—Saves the modified parameters to disk for use by other parts. 

o Mod Params—Modifies the current parameter values. 

o Show—Shows the current parameter values. 
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3. Select another option when done. 

To Change the Material Assigned to a Ply or Core Feature 

The composite material characteristics are assigned to a feature, but exist in the part 

for every feature to use. 

1. Click PART > Modify, then select the feature to modify. 

2. Click MOD INTF OPT > Table. The Pro/TABLE editor opens with the material 

name, feature name, reference coordinate system and angle—if the feature has 

bias—and the sequence to which the ply belongs. You can modify every value but 

the sequence. 

3. Modify the appropriate values. Remember that if you change the bias of the 

feature, you must add or delete the coordinate system name and angle.  

Note: Pro/ENGINEER checks the values against the specified material and will 

not allow invalid changes. For example, if the material has no bias, entering a 

coordinate system and angle is not allowed, and the changes won’t be kept. To 

do this, modify the material for the feature first, then modify the feature. 

4. Exit Pro/TABLE and regenerate the part. 

To Modify Sequences 

1. Click PART > Set Up > Sequences. The Pro/TABLE editor opens with the list of 

sequences and features. 

2. Modify the PLY NAMES column, specifying all the plies to be added with a specific 

sequence. The plies for a single sequence cannot overlap. Delete any unused 

sequences. 

3. Modify the sequence names if desired. 

4. Save the table. 

5. Exit Pro/TABLE to save the changes. 

Sequences 

Composite material is always added in sequence from the bottom up, that is, you 

cannot lay down a layer of composite material and then lay another underneath it. 

You can, however, for non-overlapping plies, cores, or pre-forms, build several 

composite features on the part at the same time. Pro/ENGINEER does not allow you 

to create these features all at the same time, but it does allow you to specify the 

building sequence in which the material is added. This information is used to create 

sequence drawings, in which the material added during a specific sequence is shown. 

Pro/ENGINEER establishes a sequence for each composite feature added. It starts 

with SEQ_0 for the first ply, core, or pre-form feature added, and increments for 

every feature added after. To modify the plies associated with a sequence, in the 

second column containing the ply name, enter a list of ply names with a space 

between them. 
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You can also rename the sequences without  For example, you can rename SEQ_0 to 
BASE_PLY. This does not affect the order of the sequences. 

Composite Drawings 

About Composite Drawings 

Drawings of composite parts can document the completed composite panel, or they 

can document the manufacturing sequence. Sequence drawings are a special 

application of drawings for Composite parts and views of Plies in a flattened state. 

To Create a Sequence Drawing 

Sequence drawings allow you to step through the layup sequences of composite 

material. For each sequence, Pro/ENGINEER will show the new material added, as 

you specified when you created the composite part or set up sequences in Composite 

mode. 

1. Create a new drawing. 

2. Add a view of the composite model using the Views command. 

3. When Pro/ENGINEER finds that the part is a composite model, it prompts you 

whether you want to create sequence sheets on the drawing. Answer this prompt 

with Yes. If you answer No you will create a regular drawing and will have to start 

a new drawing to get composite sequences. 

4. Add views of the model to the drawing. Every view that you add at any time will 

automatically appear in all sequences of the drawing. 

To Document the Sequences 

When you create a sequence drawing, the Sheets command in the Drawing menu 

is replaced with Sequences. The sequences all have the same number of views of 

the part, but each sequence can be annotated and dimensioned separately. 

1. Click DRAWING > Sequences. The SEQUENCES menu appears. 

2. Click one of the following options: 

o Finished—Go to the view of the finished part, where all composite material 

has been added. 

o Empty—Go to the view of the part before any composite material has been 

added. 

o Next—Go to the next sequence. 

o Previous—Go to the previous sequence. 

o Select—Go to the sequence that you select from the SEQUENCES menu. 
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3. When you have reached the desired sequence, repaint the drawing by clicking 

View > Repaint. This will regenerate the model up to the last feature in the 

selected sequence. 

4. Annotate and dimension the sequence. You can show the dimensions for the 

plies, pre-forms, and cores. Bias angles are shown at the reference coordinate 

system. 

To Create a Flat Ply View 

1. Click Add View > Of Flat Ply. 

2. Select the center for the view on the drawing. 

3. From a name list, select the ply you want to show in the view. 

4. Orient the view of the ply. You can only rotate it about the z-axis (normal to 

screen).  

5. When finished, click Done Orient. 

Flat Ply Views 

Any ply that is developable can be shown in a flattened state so that it can be 

dimensioned and used for a pattern. A flat ply view is always of a single ply, and it 

can exist in a regular drawing or in sequence drawings. When it exists in sequence 

drawings, changing the sequence and repainting does not affect a flat ply view. 

Note: The Of Flat Ply command is not available for full body plies. 

Flat views of boundary plies with bias will be shown with cross-hatching indicating 

the angle of the bias.  
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