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Introduction

Getting Started with Creo Parametric Import DataDoctor 1.0 is a tutorial-based
introduction that shows you how to repair the geometry of models imported into
Creo Parametric from external sources. If you follow the complete series of
procedures, you will learn how Import DataDoctor (IDD) handles the imported
geometry and best practices for fast and efficient repair.

These procedures introduce the basic techniques for using IDD tools. After you
are familiar with these procedures, you will be able to quickly repair, modify, and
featurize legacy and external models. The final result will fit seamlessly with
whatever Creo Parametric design you are working on.

Intended Audience

This guide is intended for designers with some experience in the use of Creo
Parametric.

Scope and Purpose

This guide is not intended to be a complete summary of IDD techniques. The goal
of the exercises is to familiarize you with the repair process so that you can use it
to streamline model repair. Many intermediate and advanced techniques are not
mentioned. Some basic techniques have been bypassed in favor of presenting the
whole workflow to a new user in a manageable way.
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After you have imported a part model (or a part from an imported assembly
model) into your Creo Parametric session, use Import DataDoctor (IDD) to correct
geometry, ensure surface consistency, add constraints, close unwanted gaps, and
adjust tangency in the imported parts.

This guide introduces you to some commonly used IDD techniques required to
repair an imported model and convert it into a Creo Parametric model. After
you have completed the exercises, you should be able to repair, modify, and use
external models in your own designs.

Note

Proficiency in Creo Parametric is assumed. Only procedures unique to IDD are
covered by this guide.



Before You Begin

Import DataDoctor is a task-based repair tool designed to repair, modify, or
featurize imported geometry. Repair tools are used to make geometry solid or
improve the quality of imported surfaces and edges. Modification tools support
moving, replacing, and manipulating existing geometry within the import feature.
Featurization tools can convert non-analytic geometry to analytic geometry and
create curves and surfaces within the import feature.

If you have not already done so, download the IDD Models. zip file and extract
the models. The link to the zip file and this guide are on the same page.

Task-based Repair

The downstream use of the imported models determines how much repair is
required. Understanding the intended purpose of the imported data can greatly
reduce repair efforts.

Imported models have the following categories of usage:

* No repairs are needed when imported models are primarily used for product
structure, model properties, or assigned mass properties information. An
imported quilt can represent a basic space claim without repair.

* Solid geometry is required to calculate mass properties or is desired for
drawing creation. You can ignore informational and warning geometry checks.

* High quality surfaces are necessary for machined, cast, or molded component
designs and other downstream application. You must address warnings and,
in certain cases, informational geometry checks.

Import Accuracy

Settings used during import can have an impact on the results. Accuracy settings
play an important role in the quality of imported geometry. Using relative
accuracy during import can produce better quality import geometry than using
company-prescribed accuracy values. Creo Parametric can match accuracy during
import to that of the third-party files for some formats. Accuracy matching
generally provides better results. Attempt imports at different accuracy settings
and choose the better quality model. Change the accuracy after import if a different
values is desired or required. Imported geometry does not regenerate and will not
suffer from the accuracy change after import.
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Learning the User Interface

Import DataDoctor is only available when a previously imported Creo Parametric
part is in session and is the active model.

To access the IDD environment:

1. Right-click the import feature on the Model Tree and click Edit Definition on
the shortcut menu or select the model and click Model » Operations » Edit
Definition.

: ,
2. Click #1] on the Import tab that opens to enter the IDD environment.
The following changes occur:

» The Geometry and Topology Structure (GTS Tree replaces the regular Creo
Parametric Model Tree.

* The Import DataDoctor ribbon tab opens.
The Import DataDoctor ribbon tab
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The Import DataDoctor ribbon tab consists of the following groups of commands:

* Analyze—Analyzes defective geometry, the quality of curves, distance, length,
and the Dihedral angle and saves the analysis with the model. Evaluates the
curvature of surfaces and the curve and surface deviations.

The geometry analysis and measurement commands for curves and surfaces
are as follows:

o @»Analyzes the curvature, radius, and the tangents of curves
o Analyzes the shaded curvature of curves

o @—Analyzes the deviations of curves and surfaces

o Saves the analysis with the model

o Measures the distance between two entities
o Measures the dihedral angle
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]
o Measures the length of curves and surfaces

o [¥ Geometry Checks—Investigates geometric defects

Structure—Allows manipulation of the topological structure of the imported
features and nodes on the Geometry and Topology Structure (GTS) Tree. You
can activate, detatch, divide, combine, merge, collapse, include, exclude,

or hide the nodes or the geometry of the nodes on the GTS Tree. Converts
regular surfaces to procedural surfaces such as extrusions, revolves, planes,
and cylinders.

The Structure tab consists of the following commands:

o |_| Activation > Activate—Activates nodes and surface sets

o |_| Activation » Deactivate—Deactivates active nodes and surface sets

o IZI Detach—Detaches a set of sub-nodes of a component or combine node
o [0 Divide—Divides component nodes

o [C] combine—Combines two or more nodes on the GTS Tree

o Merge—Merges any two nodes that represent valid quilts

o [ Collapse—Collapses a combined or merged node

o Convert » , @, , Converts to cylinder, plane, extrude,
and revolve.

O Convert To Combine—Converts a merged node to a combined node

O Include—Includes an excluded surface node

O Exclude—Excludes a surface node

Constrain—Applies tangency, wireframe, and frozen constraints to the
imported geometry. Defines gaps and slivers and add them to wireframes.
Freezes surfaces to prevent unwanted changes and reparameterization,
especially during the repair of geometry. Adds and removes tangency
constraints to wireframes.

The Constrain tab consists of the following commands:

o Gaps/Slivers—Defines gaps or slivers
o Freezing—Freezes or unfreezes surfaces
o Wireframe—Adds or removes from wireframe display

i
o Tangency—Adds or removes tangency

Heal—Finds and removes gaps and sliver surfaces. Closes gaps and removes
unwanted sliver surfaces from the imported quilts. Repairs unsatisfied
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topological connections and tangency conditions and problem surfaces.
Extends and intersects surfaces to fill boundary loops.

The Heal tab consists of the following repair geometry commands:

o @I Repair—Repairs unsatisfied topological connections and tangency
conditions

o Match—Repairs problem surfaces with more than four sides,
unsatisfied topological connections, and the associated tangency conditions

o Close—Repairs wireframes, closes gaps, and removes sliver surfaces
as a single operation

+ Edit—Edits the geometry of surfaces, edges, and curves. Moves the vertices of
surfaces, modifies and replaces surface boundaries, converts analytical surfaces
to free-form surfaces, modifies the properties of the free-form surfaces, and
expands or contracts the natural domain of a surface through extrapolation.
Manipulates the design intent of the imported data, the transformation of quilts
representing design elements, and the removal of quilts representing design
elements.

The Edit tab consists of the following commands:

o EI Move Vertex—Moves vertices
-
o Merge Curves—Merges curves and wireframes

o @ Split Curve—Splits curves and wireframes

o Replace—Replaces poor-quality one sided edges and surface
boundaries

o Properties—Edits the Math properties of surfaces
o Modify—Modifies curves and surfaces

o IE Extrapolate—Extrapolates or extends the unconstrained boundaries
of surfaces

o Align—Aligns free-form surfaces and natural and untrimmed surface
boundaries

o @ Transform—Transforms datum and surface nodes and complex nodes
and their sub-nodes on the GTS Tree

o EI Trim—Trims quilts and surfaces

o Extend—Extends one or more contiguous one-sided edges of quilts

* Create—Creates various curves, such as sketched curves, 3D curves through
points, and UV-curves by projection and intersection, through points, and from

Import DataDoctor Concepts 11



isolines. Creates boundary blend surfaces and datum entities such as datum
planes, datum axes, datum points, and datum coordinate systems.

The Create tab consists of the following commands:

o UV-Curves—Adds UV-curves by the projection or the intersection of
surfaces, through points, or from isolines

o |Z] patum Plane—Creates datum planes
o
o Boundary Blend—Creates boundary blend surfaces

o B Curve through Points—Creates 3D curves through points

“| Sketched Curves—Creates sketched curves
o ¢ Datum Axis—Creates datum axes

o ** patum Point—Creates datum points

o,

L]
0 =" Datum Csys—Creates datum coordinate systems

The Purpose of Edit Definition

The purpose of IDD is geometry definition. However, when you redefine an
imported feature, several other options for the related tasks are available on the
Import tab. You can

Reload geometry—You can click File on the Import tab and reload the source
file to update the import feature if you modified the source file after its import
or change the source file to replace the geometry of the imported features with
geometry from another file. The geometry from the new file creates a new
node on the GTS Tree. You can replace an entire import feature with geometry
from another source file, but you cannot selectively replace the geometry of the
import feature or selectively add geometry to the import feature.

Add geometry—You can click Options » Add From File on the Import tab and
click Source in the Add From File dialog box to add geometry to an import
feature from another file without changing the source file. The geometry from
the selected file creates a new node on the GTS Tree. Editing the geometry

of the new node in IDD is optional. You can delete the surfaces and other
entities of the existing geometry and move surfaces and other entities from the
newly added node to replace the deleted surfaces and entities. You can also use
IDD to edit data in the new node that you do not require and sew the newly
added surfaces to the old quilts.

Convert to solids—You can use the solid feature options on the Import tab to
solidify closed volumes and convert them to solid protrusions or surfaces. The
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options to create solid protrusions (E) and surfaces (@) are not available on
the Import tab when the imported features do not contain at least a single closed
quilt. If the existing model consists of solid features and if you accessed the

options on the Import tab to convert the imported geometry to solid protrusions

or surfaces, you can use to remove material from the existing model.

The Geometry and Topology Structure Tree

The Geometry and Topology Structure (GTS) Tree is similar to the regular Creo
Parametric Model Tree. The geometry of the imported model, such as surfaces,
datums, and other IDD geometry types, are grouped as logical collections of
member nodes. Each node is identified by an icon. Consult the IDD online help
for information about performing many common IDD operations directly on each
member node of the GTS Tree, including Hide, Activate, Merge, Exclude, Cut,
Copy, Paste, and Rename.

Display Options

The Graphics toolbar in Import DataDoctor consists of the following display
options:

Wireframe constraints
@»Frozen states of surfaces

l\_I_LI»Vertlces

lTangency constraints

In addition to the display options, the Graphics toolbar also has the pick-box

selection option (). It allows the selection of geometry inside and across a
defined box.

Tangency and wireframe constraints are determined during import based on the
resulting geometry. By default, they are not displayed on the model when you
enter Import Data Doctor, but they can be selected when required.

Tangency constraints are topologically defined connections on the boundaries
between surfaces. These constraints are automatically generated by the system
along edges that are tangent or nearly tangent after import. Satisfied tangency
constraints are represented with yellow arrows. Black arrows represent unsatisfied
tangency constraints. Tangency is not required to make a model solid but may

be desired for later use of the model.
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Frozen surfaces are displayed with a white circle containing the letter "F". Surfaces
with more than four edges are frozen by the system and cannot be unfrozen
manually. Analytic surfaces are frozen automatically by the system but you can
choose to unfreeze these surfaces. The boundaries of frozen surfaces may be
manipulated, but the surfaces themselves cannot change while frozen.

Vertices are created between the line segments of surface boundaries during import.
They are displayed as yellow dots on the model when the display option is enabled.

Wireframe constraints are topological connections between the edges of adjoined
surfaces. These connections may be defined in the source data and imported by
Creo Parametric. They may be created automatically when you enter Import
DataDoctor or they may be created manually. Satisfied topological connections
are the stitched edges between two surfaces and appear as green wireframe
curves. Black wireframe curves represent unsatisfied or disconnected topological
connections. Black wireframe identifies an unclosed hole in the model.
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In this chapter, you will import a model and learn how to use Import DataDoctor
(IDD) perform basic repairs, and save the model as a normal solid boundary
representation Creo Parametric model.

In this exercise, you will:

* Import and save a foreign or legacy model (from a STEP file).

» Activate geometry before performing repairs.

* Find and repair any gaps using the Search tool and the Define Gap tool.
» Use the Troubleshooter to check for geometric defects in the model.

* Add a boundary blend to close an opening or a missing surface.

Note

When doing the exercises in chapters 2 and 3, use a copy of the original model
file (basic probs w_slvr.stp) for each chapter. After you have used one
method to repair a gap, it cannot be repaired again using another method.
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Generic Workflow of the Repair Process

This section provides a high-level workflow of the repair process. It can help you
to address the common cases of repair although it cannot address all repair tasks.

1. Enter the IDD environment of Creo Parametric.

2. Clean up the nodes on the Geometry and Topology Structure (GTS) tree.
3. Activate a component node implicitly or explicitly.
4

Display wireframes, vertices, or the frozen status using the display options
as required.

5. Freeze the active component node.
Note

You can activate the component node, use the display options, and freeze the
component node, at any time during repair. These steps need not necessarily
be in the same order as described in this workflow.

Configure Troubleshooter and address the geometric defects you identified.
Exit IDD.
Make a solid.

Import the Model

Click File » E Open. The File Open dialog box opens.
2. Browse to the directory containing the models.

3. At the bottom right of the dialog box, select All Files (*) from the Type list. The
basic probs w_ slvr.stp file appears in the list of files.

4. Double-click the file or select it and click Open. The Import New Model
dialog box opens.

Select Part as the Type and accept the default name or enter a new one.

Click OK. The Information window opens and the model appears in the
graphics window.

Note

To disable the Information window, set the int£3d show import log
configuration option to no.

7. Close the Information window.
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Set the Model Display

1. Show or hide datum planes, datum axes, datum points, datum coordinate
system, and annotation elements as needed to unclutter the model during repair.

2. Set the model display to Wireframe to make geometric entity errors easier to
see.

Basic Repair Model

1 Gaps in the imported model

Start Import DataDoctor

1. On the Model Tree, right-click the import feature of the model (the default
name is Import Feature id xx)and click Edit Definition on the shortcut
menu or select the import feature and click Model » Operations > Edit Definition.
The Import tab opens.

=
2. Click on the Import tab. The Import DataDoctor ribbon tab opens and the
GTS Tree replaces the Model Tree. You are now in the IDD environment.

Using the GTS Tree

In the example below, the import feature contains a logical grouping of surfaces
under Component 251. This grouping is called a component and corresponds
to a quilt.

L7 Component 251
Surface 247

Performing Basic Repairs 17



Note

Each independent quilt in the import feature appears as a separate component
in the GTS Tree.

Next on the tree is surface 242, which has not been grouped. This surface is
not part of the main quilt. In this example, the single surface in the GTS Tree is a
coincident surface, a duplicate surface that lies on top of another surface. Since it
is coincident, it is not used in the model and must be removed.

Remove Coincident Surfaces

Use the Hide/Unhide technique described in steps 1 through 4 to quickly examine
the geometry of individual nodes in the GTS Tree. Follow steps 5 and 6 to remove
the coincident surface.

1. Right-click component 251 on the GTS Tree and click Hide on the shortcut
menu. Component 251 and its grouped surfaces are temporarily hidden.

2. Right-click surface 242 and click Hide on the shortcut menu. Nothing is
now visible in the graphics window.

3. Select component 251 and surface 242 on the GTS Tree. The model
appears in the graphics window as a green mesh, indicating that these surfaces
are hidden.

4. Select component 251 on the GTS Tree and spin the model to see the
surface beneath surface 242. Since you have verified that there is an actual
surface on the feature, you can now remove surface 242.

Note

You can exclude the surface node and place it in the Exclude Bin instead of
deleting it. Right-click surface 242 and click Exclude on the shortcut
menu or click Structure »Exclude on the Import DataDoctor tab to exclude and
detach surface 242 from the imported feature and place it in the exclude
component node. Though hidden in the graphics window when excluded,
surface 242 is retained in the model.

5. Right-click surface 242 onthe GTS Tree and click Delete on the shortcut
menu.
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1 Coincident surface 242 that is removed

6. Right-click component 251 on the GTS Tree and click Unhide on the
shortcut menu. The model appears in the graphics window without the extra
surface.

Activate Geometry for Repair

Before performing repairs, you must first select and activate geometry such as a
component or a set of surfaces of a component if the component is large. For
example, you can select and activate a set of surfaces of component 251.

The activation of component 251 or a set of surfaces of component 251
limits the scope of repair to the area with the defective geometry, preventing

the modification of geometry not associated with the defect. The activation of
component 251 or the surfaces within it also enables the display of wireframes,
vertices, and tangency.

Note

You cannot select and activate surfaces across components.

Activate Surfaces and Display Wireframes and
Vertices
1. Click and expand component 251 on the GTS tree.

2. Use CTRL + SHIFT to select surface 21 to surface 43, a total of
five surfaces.
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4. Click on the Graphics toolbar to display wireframes.

™

3. Right-click the selected surfaces and click Activate on the shortcut menu. The

5. Click E on the Graphics toolbar to display the vertices.
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6. Click @ on the Graphics toolbar to display the frozen surfaces. The model
displays the wirframes, vertices, and frozen surfaces of only the active surfaces,
surface 21 to surface 43, as shown.

Note

You cannot display the wireframes, vertices, or frozen states of the inactive
surfaces of component 251. You must activate these surfaces to display
their wireframes, vertices, and frozen states.

7. Select and activate another set of inactive surfaces, surface 49 to
surface 73. The recently activated surfaces, surface 49to surface
73, are added to the surfaces activated in Step 3 as follows.
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3 Impont Feature id 5

v &y Component 251
[ Surface 0
f-g Surface 21
(-4 Surface 27
b4 Surfaca 31
[-§ Surface 37
[-g Surface 43

wo

b-g Surface 4
-4 Surface 55
-3 Surfaca &
b= Surface 65
kg Surface 69
-4 Surface 73
[ Surfaca 77
=1 Surface 83

[~ Surface 87

The model displays the wireframes, vertices, and frozen surfaces as shown.
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Deactivate Geometry

You can click 2] Undo: Activate or |_| Activation > Deactivate on the Structure
tab or right-click an active surface or node and click Deactivate on the shortcut
menu to deactivate the activate surface or the component node. Similarly, you

can click T Redo: Activate or |_| Activation » Activate on the Structure tab or
right-click and click Activate on the shortcut menu to activate the deactivated

surface set or component node.

1. Select a subset of surfaces within the active set of surfaces as shown. That is,
select surface 31tosurface 65 from the active surface set, surface

21 to surface 73.

22
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¥ Impaor Featura id 5

v 57 Component 251
(A Surface 0
i3 Surface 21
g Surtaca 27
I-3 Surface 31
(-4 Surface 37
(3 Surface 43
i~ Surface 49
(4 Surface 55
(-4 Surtace 59
(-3 Surface 69
(3 Surface 73
(=) Surtace 77
(3 Surface &3
() Surface 87

2. Right-click the selected surfaces and click Deactivate on the shortcut menu.
Only the selected subset of surfaces, surface 31 to surface 65, are
deactivated while the surfaces not selected for deactivation remain active as
shown.

I Import Featura id 5

v £ Component 251

(A Surface 0

(3 Surface 21
(4 Surtace 27
(3 Surface 31
(3 Surtace 37
(=1 Surface 43
[~ Surface 49

[ Surface 55
(A Surface 59
(2 Burface 65
(=4 Surface 69
(=4 Surface 73
(= Surfaca 77
[~ Surface B3
[ Surface 87

Activate Component and Display Wireframes and
Vertices

1. Right-click the node of component 251 on the GTS tree and click Activate

on the shortcut menu.

Performing Basic Repairs
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2. Click and E on the Graphics toolbar to display wireframes and vertices
as shown. Wireframes displayed in green are satisfied wireframes while the
black wireframes are unsatisfied wireframes.

4. Click on the Graphics toolbar to display tangency as shown.

™
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Select and Activate Parent Surfaces of Wireframes

1. Right-click a wireframe in the model.

M o~
\L-/ﬁ ;'(* “’H’{ //

2. Click Select parent surfaces on the shortcut menu. The parent surfaces of the

wireframe are selected in the model and the GTS tree.
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3. Right-click and click Activate on the shortcut menu to activate the parent
surfaces of the wireframe. The selected surfaces show activation on the GTS
tree.

Set Selection Filter to Pick Wireframes

Activate the component node or the surfaces of the component. and click
on the Graphics toolbar to display wireframes. You can then set the selection
filter to pick satisfied and unsatisfied wireframes and wireframes with unsatisfied
tangency conditions.

Surfaces, edges, curves, and datums are the other geometry that you can select
with the selection filter.

When the selection filter is set to a specific geometry, click on the Graphics
toolbar to define a rectangular box and select geometry that lies within or across
the box.

Freeze the Component
1. Right-click component 251 in the GTS tree.

2. Click Freeze on the shortcut menu or select the component and click
Freezing » Freeze on the Constrain tab.

™
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Find, Define, and Repair Gaps

The edges of surfaces can coincide and yet the surfaces may not merge into a
single quilt. This is because they lack topological connections. Such topological
constraints cause gaps between surfaces that can be repaired in IDD.

Gaps between surfaces consist of pairs of one-sided boundaries of the surrounding
quilts. Each boundary has one or more one-sided edges of surfaces. Therefore,
gaps and topological connection restraints, also identified as unsatisfied topological
connections, define boundary conditions.

Black wireframes represent the disconnected edges, identified as the unsatisfied
topological connections between surfaces. If a gap is large, two pieces of
black wireframes are visible. Green wireframes represent satisfied topological
connections.

You can search for gaps automatically and select them using the Search tool or you
can select them manually from the model. Regardless of how you determine gaps
for repair, you must add the selected gaps to the wireframe to close them.

Find Gaps by Automatic Search

When you use the Search tool to find and select gaps in the model you do not have
to select them individually in the graphics window. Use the gap size attribute
value to set search rules. The Search tool returns results based on the gap distance
you provide.

Click Tools » Find in Creo Parametric. The Search Tool dialog box opens.
2. Select Gaps in the Look for list.

Set Value to 1 and click Find Now. GAP0001 and GAP0002 appear in the
items found list. These gaps have a value of 1.

Note

The Search tool does not identify any gap in the model if you retain the default
gap value.

4. Select both these items and click the arrow button to move them into the items
selected list.

5. Close the Search Tool dialog box. The selected edges appear in green in the
graphics window as shown in the following figure:
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1 Gaps selected using the search tool

Note

Make sure to display the wireframes so you can see which wireframe gaps are
satisfied (shown in green) and which gaps have been defined but not satisfied
(shown in black).

Determining Default Gaps

The Search tool does not identify any gaps in the model if you search for gaps
using the default gap distance. This is because the default gap value is used to
identify and fix all gaps during import and there are no gaps with the default gap
value in the model after import.

Therefore, to find gaps in the model, you must specify a value larger than the
default gap distance in the Search tool. If the Search tool fails to identify any

visual gap, you can use Gaps/Slivers > Define Gap on the Constrain tab
to manually define such gaps.

Closing the Gaps

After you have determined where the gaps are, by either finding them with the
Search Tool or defining them manually, use the following procedure to add
wireframe edges to repair them. When you add edges to the wireframe model, and

click @ Repair on the Heal tab, the defined wireframe gaps are closed.

1. Click Wireframe » Add to Wireframe on the Constrain tab. The green
edges appear black when you add them to the wireframe.
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2. Click Heal » @ Repair. The Repair tab opens. The surfaces that are being
repaired are highlighted in the graphics window.

3. Click . The gaps are now closed. The repaired edges appear green in color.

Define Gaps Manually

You will now define the gaps in your model by selecting them in the graphics
window. Use the figure in the procedure for reference.

1. Click Gaps/Slivers » Define Gap on the Constrain tab. The Define Gaps
dialog box opens. GAP0001 appears on the left side of the dialog box.

2. Click the Side 1 collector box and select edge A (1-sided edge id 95)
in the graphics window.

3. Click the Side 2 collector box and select edge B (1-sided edge id 191)
in the graphics window.

[ Canced

4. Click Add to Wireframe.
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5. Now click New Gap, or right-click in the graphics window and click New Gap
on the shortcut menu.

6. Select, then right-click edge C (1-sided edge id 95). It appears in the
Side 1 collector.

7. Click the Side 2 collector box and select edge D (1-sided edge id 181).
It appears in the Side 2 collector.

8. Repeat steps 5-7 for edges E (1-sided edge id 44) and F (1-sided edge id
89).

9. Click OK. The selected edges appear in green in the graphics window.

Note

Make sure to display wireframes so that you can see which wireframe gaps are
satisfied (shown in green) and which gaps have been defined but not satisfied
(shown in black).

Close the Gaps

After you have determined where the gaps are, either finding them with the Search
tool or defining them manually, use the following procedure to add wireframe

edges to repair them. When you add edges to the wireframe model, and click @
Repair on the Heal tab, the defined wireframe gaps are closed.

1. If you did not click the Add to Wireframe check box in the Define Gaps dialog
box, click . Wireframe » . Add to Wireframe on the Constrain tab.

2. Click Heal » @ Repair. The Repair tab opens. The surfaces that are being
created are highlighted in the graphics window.

3. Click . The gaps are closed.
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The closing of gaps can be sequentially dependent. That is, you may not be able to
close some gaps without closing others first. You may have to, therefore, use the
Repair tool multiple times to fix certain gaps in the model.

The Repair tool also fixes tangency while repairing topological connections.
Black arrows represent unsatisfied tangency conditions that turn yellow when
the tangency is fixed and the topological tangency is satisfied. Similarly, black
wireframes that represent unsatisfied topological connections turn green to
represent satisfied topological connections.

Although it seems intuitive to click @I Repair and globally repair the entire model,
you must be careful while using the Repair tool multiple times. Green wireframes
and surfaces may become distorted because topological tangency conditions are
also being repaired simultaneously.

You must, therefore, freeze the surfaces. However, you cannot repair tangency if
all the surfaces in the model are frozen. To prevent geometry changes that are not
required, deselect the Repair Tangency check box on the Repair tab.

Using the Close Tool

Black wireframes may not close because of poorly aligned vertices at the end of
gaps. If you cannot close a gap with the Repair tool and the surfaces of the gap are
not tangent, use the Close tool. The Close tool extends the surfaces of gaps until
they intersect the surfaces surrounding the wireframe.

1. Select the black wireframe.

2. Click Heal » Close.

Why Add Gaps to Wireframes

You must add gaps that you have identified in the model to the wireframes to define
their topological connections. The Repair tool uses the topological constraints as
input to close the gaps between the surfaces.

If you search for a gap again after you have added it to the wireframe, the Search
tool does not identify the associated one-sided boundaries as a gap because a
topological connection is established after you added the gap to the wireframe.

The wireframe stores the topological intent and allows you to use the Search and
Repair tools multiple times to satisfy the topological intent.

Note

It is good practice to inspect the wireframe before using the Search tool or defining
gaps as there may not be any gaps in the model. Instead, the model may consist of
physical holes without topological connections.
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Identifying Slivers

You can consider slivers as gaps that are closed by thin, high-aspect ratio surfaces
or contiguous chains of surfaces. High-aspect ratio surfaces are long and narrow
surfaces. They are sliver surfaces.

A sliver surface is as shown.
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Slivers can cause problems in downstream applications such as manufacturing
even if the quilts are closed. Therefore, just as you add gaps to the wireframes, you
must add the slivers to wireframes to create topological connections between the
bordering surfaces and delete the high-aspect ratio surfaces.

You can then use the Repair tool to close the physical hole resulting from the
deletion of the sliver. The Repair tool modifies the bordering surfaces to satisfy the
newly created topological constraint. If you are not planning to use downstream
applications you can leave the slivers as is in the model. This is why slivers are
not identified by default.

Check for Geometric Defects in the Model

Use the diagnostics tool to identify defective geometry and the potential problem
areas in the model. The diagnostics tool is available through the Troubleshooter
in Import DataDoctor.

To use the Troubleshooter, you must enable the geometry checks for the model
in the IDD Troubleshooter Settings dialog box. These geometric checks are the
search criteria for the diagnostics.

Set Up Diagnostics or Geometry Checks
1. Select and activate component 251 on the GTS tree.

2. Click Analyze » @ Geometry Checks on the import DataDoctor ribbon tab.
The Troubleshooter opens.

3. Click Edit » IDD Settings in the Troubleshooter. The IDD Troubleshooter
Settings dialog box opens. The Diagnostic column lists all the geometry
checks relevant to the model.

4. Select all the geometry checks to set up the diagnostics for component 251.
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Accept the default values in Threshold for certain geometry checks.

Click OK to apply the geometric check settings and the threshold values to
the model in session.

Perform Diagnostics for Geometry Checks

1.

34

Click View » Expand All in the Troubleshooter to expand the node, component
251, and its subnodes. The subnodes and items within the subnodes are
preceded by dots in colors that indicate the severity of the geometry defects as
follows:

e Red—Errors
*  Yellow—Warnings
*  Blue—Information

Select Ttem 1 of the subnode, Bad wireframe curves. Bad
wireframe curves and its items are preceded by red dots that indicate
that the defect is an error. The problem area of the model zooms in and the
defect highlights in green.

Note

Bad wireframe curves are the results of poorly defined gaps. Gaps affect
solidification of the model. You must repair bad wireframe curves if you intend
to manufacture using the model, but they can remain as is if the model is used
to convert to solid. You cannot close gaps until bad wireframe curves are
repaired or removed.

The text area of the Troubleshooter recommends the following actions:
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» Use the Remove from Wireframe tool to remove the corresponding gap
from the wireframe and convert the corresponding two-sided edge to two
one-sided edges.

» Use the Merge Curve/Wireframe tool to combine neighboring one-sided
edges of the same surface into single one-sided edges.

* Define a gap using the Search Tool or the Define Gap tool.

* Add the gap to the wireframe using the Add to Wireframe tool.

» Use gap fixing tools, such as Repair, Close, and Match, to fix the gap.
3. Select the wireframe highlighted in red, right-click, and click Remove from

Wireframe on the shortcut menu or click Wireframe » Remove from

Wireframe on the Constrain tab, as recommended by IDD in the text area of the
Troubleshooter.

Use the Match Tool to Repair Unsatisfied Wireframe

The Match tool repairs problem surfaces and the unsatisfied topological
connections of surfaces. It also fixes the associated tangency conditions.

The Match tool modifies surfaces regardless of their frozen state. It unfreezes
surfaces before it repairs them, especially surfaces that are frozen because they
are analytical, of a high order, are trimmed with more than four sides, or are
explicitly frozen. The Match tool can repair surfaces with more than four sides
because it ignores their frozen state and does not split them into four-sided patches
before their repair.

You must select the valid geometry, such as a set of surfaces or wireframe curves
of the active component or the active surface set before you use the Match tool.
1. Activate component 251.

2. Select one of the items of the subnode, Unsatisfied Wireframe.
Unsatisfied Wireframe and its items are preceded by blue dots that
indicate that the defect is of the informative type. The problem area of the
model zooms in and the wireframe highlights in green.

3. Select the wirframe highlighted in green in the model.

4. Click Heal » ﬂ Match. The Match Frozen Surfaces dialog box opens.

Click Yes in the Match Frozen Surfaces dialog box. The Match tab opens. The
model displays the new surfaces, their wireframes, and tangency by default.

6. Click the Options tab and select an option to change the display of the surfaces
to new and original surfaces or only the new surfaces.

7. Select the Repair Tangency check box.

8. Click .
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Use the Repair Tool to Repair Unsatisfied Tangency

1. Expand the subnode, Unsatisfied tangency, andselect ITtem 1. The
defective geometry highlights in green.

2. Right-click the selected item in the Troubleshooter and click Select Problem
Geometry on the shortcut menu. The defective geometry highlighted in green
is selected in the model.

3. Right-click the selected geometry in the model and click Select parent surfaces
on the shortcut menu. For Item 1, surface 87 and surface 226 of
component 251 show selection on the GTS tree.

4. Right-click and select Activate on the shortcut menu. Surface 87 and
surface 226 show activation on the GTS tree.

5. Click Heal » @ Repair. The Repair tab opens.

6. Select the Repair Tangency check box.

7. Click .

Note

Geometric defects of the informative type, such as unsatisfied wireframes and
tangency, preceded by blue dots in the Troubleshooter tree, can remain in the
model without resolution.

Add Missing Surfaces

After the gaps are closed, you must add missing surfaces. Use the Boundary Blend
tool to create a boundary blend surface between reference entities. This tool
defines the surface in one or two directions. The first and last entities selected in
each direction define the surface boundary. Use the following figures for reference.

36

1 Missing surface
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Click Create » @ Boundary Blend. The Boundary Blend tab opens. Click the
Curves tab. The First direction collector is active.

[a—y

2. Select curves A and B for the first surface direction.

Click in the Second direction collector and select curves C and D in the
graphics window.

Click . The surface is created.

[98)

s

2

|
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77

1 First direction curves
2 Second direction curves

Combine the Surfaces

The final task is to combine the new surface you have just created with the rest of
the import feature. You will use the Combine tool to connect the new boundary
blend surface to the component containing the quilt.

1. Inthe GTS Tree, select the imported feature, hold down SHIFT or CTRL,
and select the surface.

) Import Feature id 5
(A [Burface 263
v iy Component 251
[~ Suiface 0
[ Surface 21
[~ Surface 27
[~ Surface 31

[ Surface 37

[~ Surface 43

2. Click Structure » (O] Combine or right-click and click Combine on the
shortcut menu. The combined surface appears in the GTS Tree as shown:
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[ Import Feature id 5

» ¢'J Combine 272

v g Component 251
Surface 0
Surface 21
Surface 27
Surface 31
Surface 37
Surface 43

The surface and the component appear as a combine node in the GTS Tree.

You can also drag the new surface node onto the component node as follows:

Click Undo [<2]. The last operation (Combine) is undone.

2. Inthe GTS Tree, click the surface icon and drag it on top of the component icon
(be sure to hold down the left mouse button until the component auto-expands
before letting go). The surface is now a member of the component and is
attached to the rest of the quilt.

3 Import Feature id 5
v g Component 251

s
[ Surface 0

(A Surface 21
(3 Surface 27
(= Surface 31
(=l Surface 37

(1 Surface 43

Note

You can collapse the combined node to achieve the same results as a drag and drop
operation without undoing the combine task.

Set the Solid Attribute for the Import
Feature

Although you have combined the boundary blend surface with the other surfaces,
the model is a surface quilt and must be converted into a solid import feature.

™
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1. Click on the Import DataDoctor ribbon tab to exit IDD and reenter the
Import tab.

2. Click E on the Import tab. The imported model is now a solid Creo
Parametric feature.

3. Click on the Import tab.

4. Save the model to your working directory.

Summary

These are some of the basic tools and operations used in Import DataDoctor
to repair imported models. For more information, see the Creo Parametric 1.0
Resource Center available through the Creo Parametric Help Center.

Note

If you use Associative Topology Bus (ATB) to update the imported geometry, you
must repair the geometry again if the same errors persist in the updated geometry.
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Using Advanced Repair
Techniques

Repair the Side SUMace .........oooiiiiiii e 42
Replace the MiSSiNg SUMaCe ..........ooiiiiiiiii e 44
1011010 0 =1 PP 48

In the previous chapter you learned how to use some of the basic repair tools

in Import DataDoctor (IDD). In this chapter, you will learn additional ways to
repair models. These include the replacement of the trimming edges of a surface
boundary, and then copying and pasting a surface to a new location.

To begin, reimport the STEP file (basic probs w slvr.stp) from chapter
2. Now right-click the import feature on the Model Tree and click Edit Definition on
the shortcut menu. Edit Definition is also available on the Model » Operations menu.

Click on the Import tab to open the Import DataDoctor tab and enter the IDD
environment. Remove the duplicate surfaces as outlined in the procedure, Remove
Coincident Surfaces, in chapter 2. You are now ready to repair the side surface

of the imported model.
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Repair the Side Surface

In this procedure you will learn how to create a new UV curve through points that
lie on a selected surface in the imported model. You will use this new curve to
replace the existing trimming edge on the boundary of the surface highlighted

below.

1. Select the side surface in the graphics window.

2. Click Create » UV-Curves » @ UV-Curve through Points. The UV-Curve
Through Points tab opens.
3. Select vertices A and B.
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Note
Hold down the CTRL key to select both vertices at the same time.

4. Click on the UV-Curve Through Points tab. The UV surface curve is
created and is highlighted in blue.

Replace the Boundary Edge

Now you will replace the boundary edge of the surface that you selected in the
previous section with the curve that you have just created. You will then use the
Search tool to close the gaps.

1. Select the existing boundary edge (the slightly bowed edge just below the
new curve you created earlier) from the graphics window. The selected edge
appears in red on the model, as shown below.

2. Click Edit » Replace. The Replace tab opens and the Replace with collector
is active.

3. In the graphics window, select the newly created UV curve. It appears in the
Replace with collector.

4. Click on the Replace tab. The bowed surface edge is replaced by the new
curve.

5. Now use the techniques you learned in chapter 2 to define and repair any
remaining gaps in the quilt.
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Replace the Missing Surface

In the previous chapter, you used the Boundary Blend Surface tool to add a missing
surface. Now you will learn another way to repair the import model, using the
Copy and Paste Special tools to fill in the hole left by the missing surface. You
will copy an existing surface and add the copied surface using the Transform tab.
Finally, you will align the new surface. Use the following figures as references.

% |
g |

1 Missing surface
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I

1 Surface to copy
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1. Select surface 49 onthe GTS Tree, right-click, and click Copy on the
shortcut menu.

2. Right-click and click Paste Special on the shortcut menu. The copied surface is
pasted onto the model in the same place as the original and the Transform tab
opens. The Move tab and the 3D dragger are activated, as shown.

3. Select the arrow in the x-axis of the 3D dragger and transform it close to the
empty area to reposition the pasted surface in the graphics window.

1 Pasted surface

4. Click the spherical handle to rotate the copied surface and to rotate the pasted
surface in the direction of the orange arrow.
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Click the Placement tab and set the Relationship type to Coincident.

Click the Select component item collector and select Vertex Al.
Click the Select assembly item collector and select Vertex A2. Vertex Al

and Vertex A2 are aligned.

A1

\[/-
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8. Click New Constraint and set the Relationship type to Automatic.
9. Click the Select component item collector and select Vertex B1.

10. Click the Select assembly item collector and select Vertex B2. Vertex B1 and
Vertex B2 are now oriented and the surface is fully constrained.

1 Coincident
2 Oriented

11. Click on the Transform tab. The surface is replaced.

12. Finally, as you did in chapter 2, use the Combine tool to combine the surface
with the quilt component or drag the new surface into the component. The
surface does not show any gaps.
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13. Deactivate the active components to exit the IDD mode.

Hiding and Deleting UV Curves

You cannot hide UV curves independent of the surfaces on which they are defined
as the UV curves are not represented by nodes on the GTS tree. They are hidden
when you hide the surfaces on which they are defined.

However, you can delete UV curves. If you use a UV curve to replace an edge,
the UV curve aligns with the boundary of the surface and belongs to the surface.
There is no associativity between the UV curve and the edge. Therefore, after
replace, you can delete the UV curve if it is not required.

You can set the selection filter to UV Curves, and drag a bounding box across the
model to collectively select all the UV curves in the model.

Summary

In this exercise, you replaced the edge of a surface with a curve and you have
learned to close gaps using the Copy and Paste Special tool.. In the next chapters
you will learn about various other tools.
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Modifying the Top Surface
of the Model

AlIgN the TOP SUIMACE ... . 50
Move Vertex and Match the Model ..o 53
Define the Remaining Gaps.......ccuuuiiiiiiiiieei e 55

In the previous chapter you learned how to use surface boundary modifications to
help repair a model, and to use the Copy and Paste Special tools. Now you will
learn how to modify a larger surface and incorporate it in the solid component

as part of the quilt

To begin, open big gap.igs. Orient it in the graphic window so the top surface
is up, right-click it on the Model Tree and click Edit Definition on the shortcut menu.

=
Click on the Import tab to open the Import DataDoctor tab and enter the IDD
environment. You are now ready to modify the top surface of the imported model.
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Align the Top Surface

In this procedure you will learn how to delete trimming boundary edges, and then
align the surface to conform and modify the surface to match the model quilt.
Use the following figures as references.

1. Select Surface 43 on the Model Tree.

2. Select the right edge of the surface, right-click, and click Delete on the shortcut
menu or press the Delete key.

Note

Since a trimming edge cannot be incomplete or open, when you delete one
trimming edge, all trimming edges that form a closed loop for that surface are
also deleted. For example, if the surface had an internal hole through the
surface, selecting and deleting an edge of that internal loop of trimming edges
would remove the hole from the surface.
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3. Now select the surface and click Edit » Align The Align tab opens. The
bottom edge is prehighlighted. This is the surface edge to be aligned.

4. Select the corresponding boundary edge on the adjacent quilt boundary. The
surface edge is aligned to the quilt edge.
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5. Click the drag handle and drag the edge until it is the same length as the
corresponding curve on the quilt.

6. Click the Surface Sides tab. The front edge and the front curve appear as Side
1. The Tangent constraint tool is active.

7. Click inside the Side 3 collector to preselect the right edge of the surface. The
tangency constraint is also active for this edge.
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8. Select the right curve as Side 3. The surface edge aligns to the quilt boundary.
Use the drag handles to adjust the start and end points of the aligned edge.
9. Click on the Align tab. The two edges merge with the model.

Note

Only two of the four edges of the surface are aligned. You cannot align edges
2 and 4 because there are active Tangency constraints. If you change the
constraints on sides 1 and 3 to Position, you can align sides 2 and 4 (also
constrained to Position).

Move Vertex and Match the Model

Now you will modify the other sides of the surface that you selected in the
previous section with the model.

1. Change the view to Wireframe and select the surface.

2. Click Edit » EI Move Vertex.

3. Select the point of intersection of the remaining two sides. Click and drag it
until it is close to the corresponding point on the model. You may need to
move or rotate the model for better access.
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4. Click OK to exit the tool.

Move Vertex remains active until you click OK or Cancel. It is an action-object
option that allows you to select and move any vertex in the model after you select it.

When you drag a vertex to a new location, the vertex shifts and snaps to this
location. The snapped vertex moves to the closest projection of the target vertex
on the modified surface.

You can move vertices regardless of the frozen state of the relevant surfaces or
their tangency constraints. You cannot move the vertices of two-sided edges.

Detach and Add the Surface After Moving the Vertex

When you move the vertex, IDD automatically creates two-sided edges from its
associated one-sided edges and bordering one-side edges of the neighboring or

adjacent surface, if possible. This happens for each individual move; two-sided
edges are created dynamically even before you exit the Move Vertex tool.
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Additionally, you cannot move a vertex that belongs to an edge with an associated
and satisfied topological constraint. Though you cannot view the topological
constraints, this limitation is visible when the vertex you moved snaps to cause

a boundary to close. You cannot drag and drop a vertex until you remove the
topological constraint.

As a remedy to both these issues, detach the surface before using the Move Vertex
tool. You can then use unlimited drag-and-drop movements of the vertex to
fine-tune its placement before IDD attempts to create any new two-sided edges.
The detached surface is moved to the top-level node in the Geometry and Topology
Structure (GTS) Tree. After you finalize the position of the vertex, cut and paste
the surface back into the original component of the GTS Tree.

Define the Remaining Gaps

You may notice that you have placed the last two edges close to the quilt boundary
but some gaps still remain. You will repair these gaps as you have done before.

1

1 Gap 1
2 Gap 2

1. Select the new surface and click Heal » Match. This tool makes the surface
to match the edges of the original surfaces.
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2. Deactivate the component on the Model Tree and exit IDD. The model is now

repaired.

Note
If the component is not explicitly or implicitly active, the i Add to Wireframe

option is not available and you cannot add the gaps to the wireframes. You
must activate a component explicitly if there are multiple base nodes or

implicitly if there is only a single base-level component.
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Converting Surfaces to Cylinders
and Extrusions

Add the MiSSING SUIMACE .......uuiiiiiiii e 58
Convert Surfaces to a Cylinder Pseudo-Feature ..............ccoooiiiiiiiiiiiiie e 60
Convert Surfaces to an Extrude Feature.............ocooiiiiiiii e 61
REMOVE GEOMELIY ...t 65
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In the previous chapter you learned how to use surface modifications to repair a
model. In this chapter, you will learn to create pseudo-features in the imported
model. These pseudo features can later be modified, if required. You will learn to:

* Use the Boundary Blend tool to add a missing surface.

* Select surfaces and convert them to a cylinder feature, modifying the diameter
in the process.

» Select seed and boundary surface sets to create an extrude feature, and then
move the extrude node with the Transform command.

» Use the Remove tool to remove surfaces of geometry that are no longer needed.
To begin:

1. Openthed step2l14 shtmtlpartlow.stp file and save it in your
working directory.

2. Load the model, select the import feature on the Model Tree, right-click, and
click Edit Definition on the shortcut menu.

=
3. Click on the Import tab to open the Import DataDoctor ribbon tab and enter
the IDD environment.
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Add the Missing Surface

Once again you will use the Boundary Blend Surface tool to add a missing surface
and close the entire quilt.

1. Select edge A and edge B as shown in the figure below:

2. Click Create » @ Boundary Blend The Boundary Blend tab opens. The
selected edges are in the first direction chain collector.

3. Click in the second collector and choose the remaining two edges of the
missing surface.
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4. Click on the Boundary Blend tab. The boundary blend surface is created
and the missing surface is added. A new surface (surface 661) appears
on the GTS Tree.
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(-1 Surface 57

5. Select the new surface from the GTS Tree and drag it over the component
node in the tree. Hover over the node until it expands, and then drop the
surface into the component.
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Note

Remember that all surfaces in a component are logically joined together and
will connect automatically if they can. If they do not, use the techniques you
learned in chapters 1 and 2 to close any gaps.

Convert Surfaces to a Cylinder
Pseudo-Feature

You will now convert the surfaces of a hole to a Cylinder pseudo-feature. Use
the figure below as reference.

1. Activate the component on the Model Tree.
2. Select surface 353 and surface 356.

O

™ ™
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3. Click . Convert » Convert to Cylinder on the Structure tab. The Convert
to Cylinder tab opens.

4. Set the radius to 3.50.
5. Click on the Convert to Cylinder tab. The cylinder pseudo-feature is
created. The new pseudo-feature appears as the Cylinder feature, part of

the Combine node on the GTS Tree. The remaining surfaces are grouped
under Component 660.

7 Import Feature id 5
v (g Combine 633
» 7 Component 560
5} Cylinder 682

Note

You can change the radius of the cylinder pseudo-feature after you create it.
Select the cylinder node on the GTS tree, right-click, and click Modify on the
shortcut menu to access the Convert to Cylinder tab.

Convert Surfaces to an Extrude Feature

Now you will create an Extrude feature from a selected surface set.
Use the following figure as reference:

1. Select surfaces 1, 2, 3, 4, and 5.

2. When all the surfaces have been selected, click . Convert » @ Convert to
Extrude on the Structure tab. TheConvert to Extrude tab opens.

3. Click on the Convert to Extrude tab. The extrude pseudo-feature is created.

* The new pseudo-feature appears as a combine node on the GTS Tree.

» The new feature appears as an extrude feature and it is part of the Combine
693 node on the GTS Tree.
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Transform the Extrude Node

Now you will transform the location of the extrude feature. To do so, you will
create a new datum node as a permanent reference for the transformation process.

1. Select the vertical planar face of the extrude pseudo-feature, and then select
the datum plane tool from the toolbar.

.1.".-_'-

N\

2. Drag the datum plane parallel to the face of the extrude pseudo-feature.

BUNAS

3. Click OK. The Datum Plane dialog box closes.

4. Select the extrude node on the GTS Tree, right-click, and click Transform on
the shortcut menu. The Transform tab opens.

™
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5. Select the datum plane as the Motion Reference. The direction will default to
Normal.

Note

You can either drag a node to another approximate location or use a mate

or align constraint to place objects in relation to other objects. The second
method moves the component precisely.

Select the vertical face of the extrude pseudo-feature and then select the face of
the datum plane. The extrude pseudo-feature must snap to the datum reference.

7. Click on the tab. The extrude pseudo-feature and the surrounding surfaces
update and connect.

Converting Surfaces to Cylinders and Extrusions

63



Is Combine the Same As Collapse and Merge
Geometry?

The Collapse option turns a complex node into a single component node as shown.

) I pert Feature id 4
+ _ﬂ} e ponent 254

T @ Exilucke

Connections are maintained but all structure is removed. That is, no new
connections are created while the structure is simplified. The Collapse option
in IDD is not the same as the Collapse option in Creo Parametric with which
you can add geometry to an imported feature from downstream Creo Parametric
surface features.

Combine does not change the geometry when the combine node is created as
shown.

(b Import Feature i 5
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Combine only joins boundaries that match geometrically. Tasks such as attaching
a component during the conversion of surfaces to planes, cylinders, revolved,

and extruded features and dividing a component, automatically create combined
connections. Directly grouping entities with the Combine option does not establish
connections unless the boundaries of the quilts being combined already match
within the tolerance limits.
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A combine node modifies the boundaries of its quilt members to maintain
connections established between them. It extends or intersects the boundaries of the
combine members when you move or modify objects. Therefore, connections are
maintained beyond the physical limits of the original geometry that is combined.
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You can use the Combine option to connect or group any number of objects
including surfaces, components, and datums in any combination. You can use this
option to logically group and maintain connections. You can also add or remove
objects from the combined item, for example, a combined node, after its creation.

When the geometry of the members of a combine item is updated to maintain
a connection, the previous geometric state is lost. Deleting or deactivating its
connection does not restore the geometry of its constituent nodes when they are
added to the combined item or node.

If a combine connection fails, the combine node remains intact. Individual
connections within a combine node succeed or fail separately.

Merge in IDD is the same as the Merge feature in Creo Parametric. You can only
merge valid quilts that are represented by a surface, component, a combined item,
or another merge node. You cannot merge a component or a combine node if it
does not represent a continuous, valid quilt.

Merged nodes remember the original state of their merged quilts. Therefore, if a
merged component or combine node is temporarily deleted or deactivated, the
original geometry of the quilts is restored.

A merged item can only maintain its connections based on the original boundaries
of the quilts that are originally combined. If you move or modify the components
so that its members do not intersect, merge fails and is automatically removed.

To summarize,

» The Combine option permanently changes the boundaries of the members to
maintain connections.

*  Merge does not modify the boundaries of its members to maintain connections.
Instead, Merge tries to create intersections between the members based on their
original boundaries when changes are made.

* You cannot use Collapse to add geometry to a quilt or node. Instead, you can
use Collapse to simplify the structure of an existing quilt node. For example,
after merging and combining the features to get the desired shape, you can
collapse it into an unstructured, single-level component quilt.

Remove Geometry

You will now use the Close tool to remove unwanted geometry. When you remove
geometry, adjacent surfaces are extended or trimmed to converge and close the
openings. Or, as in this case, selected surfaces are deleted and internal loops on the
adjacent surfaces are removed to close the openings.
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Note

The extrude and revolve pseudo-features are based on sketches extracted from the
geometry selected at the time they are created. You can modify these sketches when
creating them or right-click and click Edit Definition on the shortcut men and, enter
the IDD environment to access the pseudo-feature’s creation tab.

Use the seed and boundary surface selection technique to select the surfaces.

1. Hold down the Ctrl key and select the eight seed surfaces as shown in green.

2. Hold down SHIFT and select surfaces 2 and 3. Surface 3 is beneath surface 2.

When you finish selecting surfaces, the seed and boundary surface set is
highlighted.

3. Click Heal » Close. The IDD Close Tool tab opens and the surface set
appears in the Collect surfaces to remove collector.

4. Click on the IDD Close Tool tab.

66 Getting Started with Creo™ Parametric Import DataDoctor™ 1.0



Note

No node is on created the GTS Tree when you select Close. However, you
can select Undo to restore the surfaces that you have removed.

Summary

You have now learned to replace a missing surface using the Boundary Blend
tool, convert surfaces to a Cylinder or Extrude pseudo-feature, and use the Close
tool to remove geometry. You have also learned to change the model to meet
new requirements.

Converting Surfaces to Cylinders and Extrusions
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The tips and techniques in this chapter show you how to close gaps. You can use
similar techniques to repair tangency between surfaces.
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Scoping the Extent of a Repair

The scope of a repair depends on how many independent, top-level component
nodes (direct children of the import feature) are in the IDD environment. If there is
only one component node, it is automatically selected for repair. If there is more
than one node, you must manually activate the component node you want to repair.
Tip

Always activate the required node in the GTS Tree before you begin working. This
is helpful. For example, you can detach a surface and make it a base node so that
you can manually recreate its trimming boundary.

If there is more than one component node immediately below the import feature,
and you have not activated the one you wish to repair, the wireframe display
disappears and the Repair tool is not available. When you activate a node in the
GTS Tree, the repair is limited to the surfaces of the active node. You can also
limit repair by activating specific surfaces on an existing component. Alternatively,
you can detach the surfaces, combine them into their own component, and then
activate and work on the component that contains the detached surfaces.

Before beginning to repair anything, examine the wireframe display. If the display
is mostly satisfied, that is, if the wireframe curves are green, with only a few
instances where they are black, do not try to repair the entire component. The
repair will take a long time to compute and some surfaces may become distorted.

Another way to make sure the repair affects only an isolated area is to freeze the
entire component. Select a component node in the GTS tree or in the graphic
display, right-click, click Select Parent Node on the shortcut menu, and click

Freeze on the shortcut menu. You can also click g Freezing » Freeze on
the Constrain tab. Unfreeze the surfaces adjacent to the black wireframe curves
to repair.

About Freezing Surfaces

Freezing drastically limits the scope of allowed changes to a surface, but does not
prevent its repair. Local changes along the boundary edges are still possible even
if the surface is frozen. Even if all the activate surfaces are frozen they can still be
repaired. When a surface is frozen, changes during repair are limited to tweaks to
a small adjacent surface or boundary. Neither the UV parameterization grid nor
the mathematical properties of the surface change. If the surface is not frozen,
however, the repair process will both tweak and change the parameterization grids
and surfaces.
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The Freeze and the Unfreeze commands are always available whenever multiple
surfaces with different freeze statuses are selected. Frozen surfaces are marked by
a unique identification icon. When you right-click and click Unfreeze, only those
surfaces that can be unfrozen are unfrozen. The rest will be marked as frozen.

About Unfreezing Surfaces

Sometimes a surface cannot be unfrozen. When this occurs, the system cannot
calculate a quadrilateral or triangular patch based on its current boundary. You
can work around the situation by merging two adjacent wireframe curves (select
the curves, right-click, and click Merge Curves) of such surfaces. This may be
sufficient to Unfreeze them.

Tip

If the above method does not work, use UV-curves to subdivide the surface (create
the UV-curves and add them to the wireframe, one subdivision at a time), and
then unfreeze each piece individually.

In general, analytical surfaces, including spheres, cylinders, and planes, are frozen
by default. When you unfreeze an analytic surface, it converts to a free-form
surface that you can modify.

Defining Gaps

You must define a gap as an input for the Repair tool in order to repair it. A gap

is displayed as a black wireframe curve. In most cases, gaps are automatically
found and defined automatically during the import process. If adjacent pairs of
one-sided edges remain that are not included in the wireframe display, you must
define new gaps and add them to it.

Tip

Carefully examine the wireframe display. Pay special attention to areas with black
wireframe curves with many vertices. Click E on the Graphics toolbar to display

vertices. Sometimes the gaps are not correctly defined. For instance, only a
portion of the one-sided edge may appear in the gap instead of the complete edge.

You can then select the incorrect wireframe curves, click l.! Wireframe *
Remove from Wireframe on the Constrain tab, and then select the Define Gaps
tool to define new, correct gaps.

In rare cases an identified gap cannot be closed. Try either of the following
methods to resolve the problem:
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» Use manual local editing tools to detach the surface, modify it and fix its
boundary, and then put it back into the component.

*  When gaps fail to add to the wireframe or do not close when the repair is done,

click Heal » Close. The input to the Close tool is the black wireframe.

Fixing Geometric Discrepancies

There are two types of geometric discrepancies: improper surface trimming
(bad edges) or corrupt surface definition (bad surfaces). These local geometric
discrepancies can prevent a successful repair operation or cause bad results. A
geometric discrepancy may also make the model unusable in downstream Creo
Parametric applications. Use the manual tools in IDD to clean up bad geometry.

Dealing with Bad Repair Results

A bad (distorted) surface is usually the result of a badly performed repair. Use
the same technique to find the bad surface either after the repair has been saved
to the model or use the Repair tool to view old and/or new geometry, and then
perform a surface analysis. The most commonly used analysis is a Compare
Surfaces analysis. You can use the options available on the Analyze tab of Import
DataDoctor.

One way to work around a bad surface after a repair is to delete it and to create a
new surface, or you can revert the component to a pre-repair state by canceling the
repair or clicking Undo. Play with the surface’s frozen status and with the tangency
constraints along its edges before attempting to repair it again.

Sometimes you can get better results by editing surface math properties (make the
number of gridlines smaller if they seem excessively dense) and/or use the Edit
Surface tool to make the control polyhedron look more regular.

Tip

Remember to check whether the surface that distorts was bad to begin with.

Using the Editing Commands

Use the options available on the Edit tab of Import DataDoctor to make changes to
both individual surfaces and curves as well as to boundary edges of surfaces.

Tip

Wherever possible, the system creates two-sided edges when you modify the edges
of a component surface. To prevent this or to work in a manner similar to that

of the Edit Boundary functionality, detach the surface, perform all necessary
operations on its edges, and drop it back into the component.
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The following tools are available:

*  The Modify tool edits a one-sided edge using control polygon manipulation.

* The Move Vertex tool moves a vertex between one-sided edges of the same
surface.

» The Merge tool merges two adjacent one-sided edges.

» The Split tool splits a one-sided edge at a selected point.
» The Delete tool deletes a one-sided edge.

Note

The system does not remember the edge control polygon. It is recreated every
time you use Modify.

Before you can create new boundary edges, you must create UV curves on the
surface. Now use the UV curve creation options from the Create tab in IDD to

replace a selected chain of existing one-sided edges by a chain of UV curves. You

can use the same editing operations for both curves and UV curves and shape
the new boundary as required.

Tips and Techniques
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Repair Procedures
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The Troubleshooter in IDD can report a series of unique geometry integrity issues.
Each issue is repairable by one or more methods.

This chapter describes each check that IDD uses as a search criteria to report
geometric defects in the model and how you can repair these defects.
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Repairs Based on Intended Use

The Troubleshooter in IDD checks and reports geometric defects in the model
that can impact its solidification and thickening, and the subsequent creation of
child features such as rounds, or the downstream use of the imported geometry
for manufacturing or mold design. The effective use of the Troubleshooter in
IDD includes understanding the intended use of the imported geometry prior to

enabling the relevant checks. Click Analyze » [ Geometry Checks on the Import
DataDoctor ribbon tab to access the Troubleshooter in IDD.

The following table lists the Troubleshooter checks, their category, and how the
relevant defects impact the use of the imported geometry.

Troubleshooter Checks and the Impact of the Geometric Defects

Troubleshooter Child Downstream
Check Type Solidify | Thicken |Features |Use
Bad surfaces Error v v v v
Bad two-sided |Error v v v v
edges

Bad wireframe |Error v v

curves

Poorly Warning v

tessellated edges

Small loops of | Warning v W

one-sided edges

Short one-sided | Warning v W

edges

Bad vertices Warning v v
Unsatisfied Information | w v

wireframes

Unsatisfied Information v

tangency

Gaps not added |Information | « v

to wireframes

Almost tangent |Information v
edges

Small surfaces |Information v v v
Narrow surfaces |Information W W v

76
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The Troubleshooter categorizes the checks as errors, warnings, or information
based on the quality of the geometry, not the intended use of the geometry.

* Errors—These are geometric defects that must be fixed. According to Creo
Parametric standards, the defective geometry, such as bad surfaces, two-sided
edges, and wireframe curves, are invalid. These defects can cause severe
problems in the downstream use of the model. Errors cause instabilities in the
geometry and can result in the abrupt termination of Creo Parametric.

*  Warnings—These are geometric defects that may or may not be bad and
depend on the circumstances that cause them. These are defects, such as edges
with poor quality tessellation, one-sides edges with small loops or one-sided
edges that are short, and vertices without coinciding edges and surfaces. You
must decide whether to fix this category of defects in the model.

* Information—These are geometric defects that do not impact the use of
the geometric data. These are defects, such as small and narrow surfaces,
unsatisfied wireframes, unsatisfied tangency, gaps not added to wireframes,
and edges that are almost tangent. These are properties of the model that may
be of interest to you that you may want to change using IDD.

Bad Surfaces

The Troubleshooter checks for surfaces with concave domains or surfaces with
parallel or almost-parallel boundaries and reports them as errors. These surfaces
are badly distorted or have bad singularities.

You cannot use bad surfaces for downstream surface operations such as thicken,
solidify, or the generation of quality tool path in manufacturing. If you use these
surfaces in merge or inheritance operations, they propagate their geometry checks
in the child model.

You can use the Troubleshooter to identify bad surfaces. Use the following
methods to analyze bad surfaces:

» Use the Troubleshooter in IDD to check for bad surfaces in the model, select the
corresponding diagnostic in the Troubleshooter, and zoom in to the bad surface.

» Check for discrepancies such as waves, bulges, and apparent holes, in the
shaded view.

* Check for discrepancies such as bad silhouette curves and wavy edges in the
wireframe view.

*  Check for surfaces that do not highlight properly. That is, check for mismatches
of the highlighted and nonhighlighted displays.

*  Check for bad surface meshes such as the following:

O A self-intersecting mesh.
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O Mesh curves passing through a point that are locally parallel to each other.
This is an indication of bad singularity as shown.

O  An unreasonable mesh for the surface shape.

O A dense or sparse mesh in a specific area of the surface. You must adjust
the mesh density to view this mesh type.

» Check for surface analysis such as curvature, slope, zebra, and so on, that
are locally shaded bad.

Resolving Bad Surfaces
You can resolve bad surfaces as follows:

* Delete the surface and use the Boundary Blend tool to recreate a good
replacement surface as follows:

1. Right-click the selected surface, and click Exclude on the shortcut menu.
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Note

PTC recommends that you do not delete any surfaces unless you are sure
that the surfaces are not required. Instead, you can exclude surfaces so
that they are hidden from display and placed in the Exclude bin. You can
recover these surfaces from the Exclude bin and use or delete them when
repairs are complete.

Ensure that the one-sided edges of the surrounding surfaces are clean and
intersect properly at the corners.

Tip

In some cases, it is easier to create the boundary blend in one direction and
replace the edges in another direction after the surface is created.

Create the boundary blend.

Note

The Boundary Blend tool creates a nonanalytical surface. If required, you
can convert the nonanalytical surface to an analytical surface, such as a
planar, extruded, cylindrical, or revolved surface.

Collapse the surface in the relevant component.

Define gaps and repair them, if necessary.

In some cases, only a portion of the surface is bad. Remove the portion of the
surface that is bad and patch the surface with a boundary blend as follows:

1.
2.

5.

Create UV-curves to isolate the bad portion of the surface.

Split the surface using the UV-curves and delete the bad portion of the
surface.

Create a boundary blend surface to fill the hole.
Collapse the surface in the relevant component.

Define gaps and repair them, if necessary.

When the general shape is similar to one of the supported procedural or
analytical types such as a bad spherical corner radius, convert the surface to
the similar supported surface type, such as a planar, extruded, cylindrical, or
revolved surface.

1.
2.
3.

Select the surface.
Select the analytic type from planar, cylindrical, extruded, and revolved.

Define the wireframe and repair the gaps.

If the edges align close to the other surfaces, define the gaps and repair
them.

If the edges do not align:

O Detach the surface.
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O Delete its boundary.

O Replace the edges of the surface to match the boundaries of the
surrounding surface.

O Define the gaps and repair them.

In some cases, you must create the relevant surface geometry outside the IDD
environment, for example, a mirrored surface, as follows:

1. Detach the relevant surface in the imported geometry and exit IDD.

2. Select and copy-paste the surface in the part mode.

Mirror the surface about a plane in the part mode.
Note

You need not exactly place the plane mid-way between the surface to
mirror and the placement location. You can transform surfaces in IDD to
align them.

Exit Import DataDoctor.

4. Select the import feature as the target for the collapse operation and
simultaneously select geometry such as surfaces, datum features, and solid
features on the Model Tree.

5. Click Model » Editing » Collapse Geometry.

Note

Model » Editing » Collapse Geometry is available only when the target
import feature is the first feature among the list of Model Tree items
selected for the collapse operation.

6. Select and right-click the import feature and click Edit Definition on the
shortcut menu.
i
7. Click [*#1] on the Import tab to open the Import DataDoctor tab and enter
the IDD environment.
Transform the surface, if necessary, to fit the relevant location.

Collapse the mirrored surface and the detached surface into the relevant
component.

10. Define gaps and repair them, if necessary.
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Note

Creo Parametric checks for self-intersections in bad mold designs, such as the
following:

» Self-intersections in the quilt—A singularity or a convergence point in the
surface. The Troubleshooter in IDD identifies this as a bad surface.

» All folds in the quilt—A surface with two of its edges joined to create
a two-sided edge. No explicit check is required for this defect in the
Troubleshooter. Folded surfaces are automatically excluded when you enter
IDD.

Bad Two-Sided Edges

Edges are defined as splines and are mathematically calculated using interpolation
points. Bad two-sided edges are created when the interpolation points of each
single-sided edge are widely spaced apart. The Troubleshooter categorizes this
defect as an error.

Profile options control the joining of surfaces by layers and the solidification of
the model. When you use these options, Creo Parametric tries to join the surfaces
by layers, close the quilts, and solidify the model. Bad two-sided edges can occur
when you significantly extrapolate surfaces to close gaps during the import of
the model.

A bad two-sided edge can visually display intermittent gaps along the edge. These
edges prevent the solidification or thickening of the geometry. Bad two-sided edges
can also indicate geometry corruption that you must address for downstream use of
the model. Troubleshooter displays these defects as errors and you must fix them.

You can fix most bad two-sided edges as follows:

1. Click Wireframe » Remove from Wireframe on the Constrain tab to
remove a green wireframe and convert the corresponding two-sided edge to
two one-sided edges.

2. Modify the edges as follows:

» For simple cases, use tools to merge and edit edges and the Move Vertex
tool to clean up the one-sided edges.

* In more complex cases, you must replace the bad edges with UV-curves.

* In some extremely complex cases, you must recreate the entire boundary
as follows:

a. Detach the surface with bad edges.

b. Select one of its edges, right-click, and click Delete on the shortcut
menu or press the Delete key.
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c. Use the UV-curves and Replace tools to create a new boundary.
d. Cut and paste or drag the new surface back into the component.
3. Recreate the wireframe.

4. Close the gap using the Repair, Match, or Close tool.

Bad Wireframe Curves

A bad wireframe occurs when a black wireframe is created on a pair of single-sided
edges of different lengths. IDD automatically creates these wireframes when you
enter IDD. They are also created when you add gaps to wireframes. The two-sided
edges displayed as green wireframes are excluded from the bad wireframe check.
Troubleshooter categorizes bad wireframes as errors.

Repair and Match tools can close bad wireframes, but the results can create
problems with future repair processes. However, not all bad wireframes close with
the use of the Match, Repair, and Close tools.

The check for bad wireframe curves identifies holes in the model that prevent
solidification or thickening of the imported geometry. You must remove these bad
wireframes that Troubleshooter identifies as errors and manipulate the underlying
edges before you create the good wireframes.

The intended results define the technique to use to fix this error. You can proceed
as follows:

1. Click Wireframe » Remove from Wireframe on the Constrain tab to
remove the gap from the wireframe and convert the corresponding two-sided
edge to two one-sided edges.

oy
» For curve segments of equal length, use Edit » Merge Curves to
combine the neighboring one-sided edges into single one-sided edges.

» For curve segments of unequal length, use Edit » Split Curve to split
the long curve at the vertex of the short curve.
Note
This can create a short edge.
2. Define a new gap using the Search Tool or the Define Gaps tool.
3. Add the new gap to the wireframe using Wireframe » Add to Wireframe
on the Constrain tab.

4. Close the remaining gap using the Repair, Match, or Close tool.
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Poorly Tessellated Edges

Edges are defined as splines and are mathematically calculated using interpolation
points. A good and clearly defined single-sided edge has an adequate density
of evenly-spaced interpolation points.

Poorly tessellated one-sided edges have too few or unevenly distributed
interpolation points. A good two-sided edge has evenly spaced interpolation points
and an equivalent density of points along each of the single-sided parent edges.
Poorly tessellated two-sided edges occur when the interpolation points of each
single-sided edge are widely spaced apart by a relatively small but significant
distance. Troubleshooter categorizes poorly tessellated edges as warnings.
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Poorly tessellated edges do not prevent the solidification of the geometry but can
create distortions or other undesired geometric results. Repairing poorly tessellated
edges improves geometric results that are not visible in most cases. If poorly
tessellated edges are left unrepaired, they can adversely impact child features and
the downstream use of the imported geometry.

Poorly tessellated two-sided edges are more likely to cause problems than poorly
tessellated one-sided edges. However, poorly tessellated two-sided edges are
created from poorly tessellated one-sided edges. Therefore, you must focus on
repairing the bad one-sided edges.

Proceed as follows to repair poorly tessellated edges:
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1. Click Wireframe » Remove from Wireframe on the Constrain tab to
convert a two-sided edge to two one-sided edges. You can encounter a problem
with one of the edges. This step is unnecessary for bad one-sided edges.

2. Right-click the diagnostic for the poorly tessellated edge in the Troubleshooter
and click Select Problem Geometry on the shortcut menu.

3. Click Edit » Modify. The Curve Modify dialog box opens.

» If'the edge has too few interpolation points, add interpolation points to the
edge and redistribute them to evenly space the points.

» If the interpolation points are clumped together, redistribute the
interpolation points to evenly space the points.

* Click OK.
4. Define a gap using the Search Tool or the Define Gaps tool.

5. Add the gap to the wireframe using Wireframe » Add to Wireframe
on the Constrain tab.

6. Use the Repair, Match, or Close tool to fix the gap.

Small Loops of One-Sided Edges

Surface quilts can contain small holes or loops of one-sided edges within a single
surface or at the intersections of two or more surfaces. The check for loops of
one-sided edges identifies these small loops. The small dimension of the loops is
quantified using a threshold value. The default threshold value is 10 times the
absolute accuracy of the model and applies to the perimeter length of the hole. The
Troubleshooter categorizes this defect as a warning.

You cannot solidify models that contain small loops of one-sided edges.

Based on their topology, you can use the following methods to repair small loops
with one-sided edges:

» If the hole is within the boundary of a single surface as shown, select one
of its perimeter edges and delete it.
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1. Click Wireframe » Remove from Wireframe on the Constrain tab to
remove the surrounding green wireframe and convert the corresponding
two-sided edge to two one-sided edges.

2. Collocate the vertices.
Recreate the wireframe.

4. Close the gap using the Repair, Match, or Close tool.

Short One-Sided Edges

Short one-sided edges are difficult to view. You can use the Troubleshooter to
zoom into them for efficient repair. The short length of the edges is quantified
using a threshold value. The default threshold value is the absolute accuracy of the
model and applies to the length of a single one-sided edge. The Troubleshooter
categorizes short one-sided edges as warnings.

You cannot solidify models containing short one-sided edges. You can add
wireframes and close gaps to solidify the model, but this can result in subsequent
feature failures or difficulties in the downstream use of the imported geometry.
Eliminating short edges or making them longer than the accuracy of the model
improves the quality of the model for downstream use.

The geometry surrounding the short one-sided edges determines the method of
repair as follows:

» If the short one-sided edge is tangent or nearly tangent to an adjacent edge as
shown:

1 Tangent or nearly-tangent short edge

1. Click Wireframe » Remove from Wireframe on the Constrain tab to
remove the wireframe from the adjacent edge.

2. Combine the segments.
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3. Recreate the wireframe.
4. Close the gap using the Repair, Match, or Close tool.

» If'the short one-sided edge must be tangent to an adjacent edge as shown:

g

1 The short one-sided edge that must be tangent

1. Use Wireframe » Remove from Wireframe on the Constrain tab to
remove the wireframe from the adjacent edge.

2. Move the common vertex so the edges are nearly tangent.
3. Combine the segments.

4. Recreate the wireframe.

5. Close the gap using the Repair, Match, or Close tool.

» If the short one-sided edge is not and must not be tangent to an adjacent edge
as shown:

1 The short edge that must not be tangent

1. Define a black wireframe for the short one-sided edge pair.
2. Close the gap using the Repair, Match, or Close tool.
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Note

The Contours check in Creo Parametric mold design looks for any and all loops
of one-sided edges. The check for the small loops of one-sided edges by the
Troubleshooter in IDD reports all loops that are difficult to view or find. However,
large open loops are visible in the model.

Bad Vertices

A bad vertex is a location at which the end points of two consecutive surface edge
segments do not coincide. The Troubleshooter in IDD categorizes this defect
as a warning.

Bad vertices do not prevent the solidification or thickening of the model, but can
affect child features and the downstream use of the imported geometry.

The repair process depends on the geometry surrounding the bad vertices.

» Ifabad vertex exists along parallel edges as shown:
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1 Edges must meet at the same point

1. Remove any wireframe from the edges of the bad vertex.

2. Click Edit » Merge Curves to combine the neighboring one-sided edges
into single one-sided edges.
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3. Recreate the wireframe.
4. Close the gap using the Repair, Match, or Close tool.

» Ifabad vertex exists at the corner of a surface as shown:
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1 Vertex is not at the intersection of edges

Detach the surface with the bad vertex from the component.

2. Right-click the relevant node in the Troubleshooter and click Select
Problem Geometry on the shortcut menu.

3. Right-click the highlighted geometry in the graphics window and click
Remove from Wireframe on the shortcut menu.

Some vertices are considered bad when the constituent surfaces do not
intersect at the same point. In complex cases, for example, when some of
these surfaces are frozen, the Repair tool does not modify the surfaces

so that they geometrically intersect, and a bad vertex is created. In some
cases, you can use the Transform or Modify shape tools to fix the problem.

O If the bad vertex disappears from the Troubleshooter, the bad vertex
is generated when closing the gap and is caused by poor surface
alignment. Repair this defect as follows:

a. Analyze the surfaces and determine which surface is not aligned
with the rest of the quilt.

b. Use the Transform tool to move the surface so that it properly aligns
with the rest of the quilt.

O If the bad vertex persists as a Troubleshooter warning, it is bad within a
single surface. Repair this defect as follows:
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a. Right-click the relevant node in the Troubleshooter and click Select
Problem Geometry on the shortcut menu.

b. Right-click the highlighted geometry in the graphics window and
click Detach on the shortcut menu.

c. Move the bad vertex such that it snaps to the existing corner of the
component. The bad vertex is repaired when it is moved.

d. Combine and collapse the surface back into the component.

4. Recreate any missing wireframe if necessary.

5. Close the gap using the Repair, Match, or Close tool.

Unsatisfied Wireframes

Satisfied wireframes represent two-sided edges and appear green. Unsatisfied
wireframes represent defined gaps added to the wireframes that are not closed and
appear black. The Troubleshooter in IDD checks and reports black wireframes in
the model as information. Unsatisfied wireframes do not include bad wireframe
geometry.

You cannot solidify or thicken models with unsatisfied wireframes. These
wireframes can automatically close and convert to satisfied wireframes when
you move vertices or use the Combine, Merge, or Collapse tool. You can use the
Match, Repair, or Close tool to interactively repair unsatisfied wireframes.

Unsatisfied Tangency

Unsatisfied tangency represents a defined tangency condition along a two-sided
edge that is not met. Tangency constraints are automatically defined based

on the angle between the adjacent surfaces of each two-sided edge when you
enter the IDD environment. The Troubleshooter categorizes this condition as
an informational check.

You do not have to repair unsatisfied tangency to solidify a model or offset a quilt,
but they can affect the downstream use of the imported geometry. Manufacturing
tool paths or a production plastic part can clearly show tangency that is not
repaired in the model.

There are several tools in IDD that you can use to repair tangency constraints

as part of other operations. Use the Repair or Match tool and select the Repair
Tangency check box on the Repair or Match tab to repair an unsatisfied tangency.
You cannot satisfy such tangency with the Repair tool when all surfaces required
for the repair task are frozen.
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The Align tool repairs tangency, but only works for free form surfaces. Use the
Align tool as follows:

1. Select the surface, right-click, and click Detach on the shortcut menu.

2. Select a boundary edge of the surface, right-click, and click Delete.

3. Select a resultant surface and click Edit » Align.
Note

Align is not available for analytical surfaces. You can change the math
properties of these surfaces to convert them to free form surfaces.

4. Align the required edge or edges using options on the Align tab.

Use the Remove Tangency tool to manually remove the not required unsatisfied
tangency.

Gaps Not Added to Wireframes

A gap is a pair of one-sided edges that are close to each other and not part of the
wireframe. One-sided edges that meet these criteria in most cases represent holes
in the imported geometry that need to be closed. The Troubleshooter categorizes
gaps not added to wireframes as an informational check.

IDD searches for gaps and automatically adds them to the wireframes when you
enter the IDD environment. The default threshold value for gaps is 7.5 times
the accuracy of the model. You can specify the default threshold value in the
Search Tool when searching for gaps and in the Troubleshooter to identify gaps
not added to wireframes. Increase the threshold value to find additional gaps not
added to wireframes.

To add gaps to wireframes:

1. Right-click the diagnostic for gap not added to wireframes in the
Troubleshooter and click Select Problem Geometry on the shortcut menu.

2. Right-click and click Add to Wireframe on the shortcut menu.

You can use the Troubleshooter to select all the gaps not added to the wireframes or
a single gap not added to a wireframe. However, you cannot use the Troubleshooter
to select a subset of gaps not added to wireframes from the identified list because
the Troubleshooter does not support multiple selection.

To identify and select a subset of gaps not added to wireframes, you can use the
following alternative approach:

1. Select the Search Tool.
2. Set the feature type to gaps.
3. Set the required default gap distance.
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4. Search for gaps.
5. Collect the required gaps in the Search Tool and click OK.

6. Click Wireframe » Add to Wireframe on the Constrain tab.

Almost Tangent Edges

Almost tangent edges are those edges for which the parent surfaces of a two-sided
edge are tangent or almost tangent within the provided angle, but do not have a
tangency constraint. The default angle is 5 degrees. To identify tangent surfaces
without a tangent constraint, set the threshold value to zero. The Troubleshooter
reports this feature as an informational check.

The almost tangent edges do not prevent the solidification or thickening of the
imported geometry. This can affect the quality of the final product such as surface
appearance and manufacturing tool paths.

You can use the Add Tangency tool to manually add tangency conditions to a
two-sided edge. Adding the tangency condition may automatically fix tangency.
You cannot repair the tangency between two frozen surfaces unless the surfaces
are already tangent. Select the Ignore check box in the Troubleshooter to hide the
almost-tangent edges that the Troubleshooter has identified when tangency is not
desired.

Small Surfaces

A small surface has a perimeter value of less than two times the threshold value.
The default threshold value is equivalent to the absolute accuracy of the model.
The Troubleshooter in IDD categorizes this defect as an informational check.

Small surfaces adversely impact model quality because of their size. They can
affect other repair operations and prevent the solidification of the model. They
often prevent the thickening of the surface quilts. Small surfaces can also impact
subsequent feature creation or the downstream use of the model. The elimination
of small surfaces from the model improves model quality.

To remove small surfaces:

1. Right-click the diagnostic for a small surface in the Troubleshooter and click
Select Problem Geometry on the shortcut menu.

2. Right-click and click Delete.

3. Close the resulting gap using the techniques described for small loops of
one-sided edges.
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Note

The check for small surfaces by mold design in Creo Parametric is the same as the
check for small surfaces by the Troubleshooter in IDD.

Narrow Surfaces

You can identify narrow surfaces by their surface area. A narrow surface has

a surface area less than the perimeter length times the threshold value divided
by two. The default threshold value is the absolute accuracy of the model.
Small surfaces are automatically excluded from this check. The Troubleshooter
categorizes narrow surfaces as an informational check.

Narrow surfaces can cause problems for subsequent feature creation or the
downstream use of the model because their relative size is equivalent to the
model's accuracy. Eliminating narrow surfaces though optional can result in
improved model quality.

Geometrically, slivers and narrow surfaces are equivalent. Topologically, a sliver
surface has two chains of black or green wireframe curves as its boundaries and

may have a few one-sided edges between these chains. This wireframe condition
is the primary difference between a sliver surface and a narrow surface as shown.

1 sliver surface
2 narrow surface

When a narrow surface meets the criteria of a sliver, you can topologically define
the narrow surface as a sliver and add it to the wireframe. The diagnostic for the
narrow surface changes to an unsatisfied wireframe node in the Troubleshooter.
You can subsequently use the Repair tool to remove the sliver surface and close
the resulting gap in a single operation.

If the model has many narrow surface nodes, it is more effective to convert narrow
surfaces into wireframes using bulk methods. The following procedure converts
most narrow surfaces into black wireframes:

1. Find and add all gaps to the wireframe.

2. Use the Search Tool to identify and collect sliver surfaces as follows:

a. Select the Search Tool.
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Set the feature type to slivers.

Set the sliver threshold as required.

Search for slivers.

Collect the required slivers in the Search Tool.
Click OK.

3. Add the slivers to the wireframe.

When the model consists of only a few narrow surfaces or when the narrow
surfaces cannot be defined as slivers, you can manually repair narrow surfaces as
follows:

*  When the narrow surfaces are in the middle of a surface quilt as shown, define
the narrow surfaces as slivers and add them to the wireframes.
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Click Gaps/Slivers » Define Sliver on the Constrain tab. The Define
Slivers dialog box opens.

Select the narrow surface from the model and close the Define Slivers
dialog box.

Click Add to Wireframe.
Note

The diagnostic for the narrow surface disappears from the Troubleshooter
when you add the narrow surface to the wireframe. It changes to an
unsatisfied wireframe node.

Repair the wireframe using the techniques described for unsatisfied
wireframes.

+ Ifa narrow surface is at the edge of a surface quilt, delete the narrow surface
and extend the remaining surfaces to close the gap.
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Note

You cannot define a narrow surface at the edge of a quilt as a sliver.
To remove such narrow surfaces:

1. Right-click the diagnostic for narrow surfaces in the Troubleshooter and
click Select Problem Geometry on the shortcut menu.
2. Right-click and click Delete.
Close the resulting gap using the techniques described for small loops
of one-sided edges.
If you delete slivers, you must manually add the resultant gaps to the wireframes
and close the gaps.

Note

The check for small surfaces by mold design in Creo Parametric is the same as the
check for small and narrow surfaces by the Troubleshooter in IDD.
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Experienced IDD users may want to use the enhanced IDD repair tools in
Pro/ENGINEER Wildfire 4.0 and later, including Creo Parametric, just as they had
used the IDD repair tools in Pro/ENGINEER Wildfire 3.0 and earlier. New users
of IDD in Pro/ENGINEER Wildfire 4.0 and later are likely to encounter difficulties
while using the repair functionality of the previous releases. Therefore, PTC has
ensured that no functionality from Pro/ENGINEER Wildfire 3.0 and earlier was
lost while enhancing the IDD repair tools in Pro/ENGINEER Wildfire 4.0 and later.

This chapter attempts to map the common IDD repair processes of Pro/ENGINEER
Wildfire 3.0 and earlier to the repair processes in Pro/ENGINEER Wildfire 4.0
and later. While the IDD functions in Pro/ENGINEER Wildfire 4.0 and later are
explained in detail, the functionality in Pro/ENGINEER Wildfire 3.0 and earlier
are briefly described.
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Move Edge to Close Wide Gaps

This guide has already described the simple “zip gaps” process of searching for
gaps, setting the maximum gap distance, adding to wireframe, and closing the gaps.

However, you cannot use “zip gaps” to zip wide gaps in the model geometry,
even if IDD has identified such gaps.

Pro/ENGINEER Wildfire 3.0 and Earlier

You can use the following techniques to zip wide gaps in the model:

* Project the good edge of another surface to replace the bad edge of a surface.

» Ifyou still cannot zip the gaps, divide the bad edge into small segments and
move them close to the edge of the other surface so that the gap is small
enough to be closed.

Pro/ENGINEER Wildfire 4.0 and Later

1. Select the bad edge of a surface to replace.
2. In the Repair mode, select the Replace tool ().

3. Select a good edge of another surface.
Note
Dividing the edge into small fragments is tedious. Instead, use the Modify

Curves and Surfaces tool )) to modify the surface edges without dividing
them into fragments.

Use the Modify Curves and Surfaces tool as follows:
1. Select the bad edge of a surface to modify.
- -
2. In the Repair mode, select the Modify Curves and Surfaces tool (L=l). The
Curve Modify dialog box opens.
3. Modify using interpolation points.

4. Add the interpolation points and drag them to the desired locations along the
edge of the other surface.

5. Click OK.
Note

In most cases, the gaps close automatically. If they do not close automatically,
you must accordingly repair the bad wireframes.
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Creo Parametric

1. Select the poor quality edge of a surface to replace.

2. Click Edit » Replace on the Import DataDoctor ribbon tab.

The Replace tab opens. The selected edge is added to the Item to be replaced
collector on the References tab.

3. Select an edge of another surface. The selected edge is added to the Replace
with collector in the References tab.

4. Click on the Replace tab to replace the poor quality edge with the edge
selected for replacement. The surface is automatically modified based on the
edge you replaced.

If you want to define the geometry of the surface edge selected for replacement,
you can modify its interpolation points as follows:

1. Select the edge of the surface that you want to modify.

2. Click Edit » =] Modify on the Import DataDoctor ribbon tab. The Curve Modify
dialog box opens.

3. Select the option to modify the surface edge using the interpolation points.

4. Add the interpolation points and drag them to the relevant locations along
the edge of the other surface.

5. Click OK on the Curve Modify dialog box.

Remove Extra Vertices

Edges between two surfaces can consist of multiple segments and unnecessary
vertices. You do not have to remove these extra vertices to make a solid. However,
removing the extra vertices can improve the quality of the edges for downstream
feature creation and their use in mold design and manufacturing.

You can combine the edge segments to eliminate the extra vertices and improve
the edge quality of surfaces.

Pro/ENGINEER Wildfire 3.0 and Earlier

You can use Geometry » Heal Geometry » Manual » Fix Quilt Boundaries » Done
to remove the extra vertices as shown.
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Extra Vertices Before their Removal

All extra vertices are not removed and you may have to manually remove the
remaining extra vertices. To remove these vertices, edit the affected boundaries
of the two surfaces and zip the repaired boundaries.

Pro/ENGINEER Wildfire 4.0 and Later

You can switch on the display of vertices in the Repair mode to visually identify
the extra vertices. The Repair tool automatically removes the extra vertices when
you close gaps and repair the two-sided edges. The extra vertices are not removed
when you cannot close a gap using the Repair tool.

Use the Repair tool on the active component as follows:

1. In the Repair mode, ensure that the surfaces are frozen and the component is
active on the Geometry and Topology Structure (GTS) tree.

2. Select the Repair tool and click on the dashboard to complete the task.

™
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Extra Vertices Before their Removal

\

The Repair tool removes the extra vertices from the one-sided and two-sided edges.
Proceed as follows to individually remove the extra vertices:

1. Select two adjoining segments from the model.

2. Select the Merge Crv/Wtm tool ().

Remaining Vertex After the Removal of Extra Vertices

Note

Not all extra vertices are removed. You may have to manually remove the
remaining extra vertices.

Remove the extra vertices as follows:

1. With a component that is active, detach one of the surfaces with an extra vertex.
2. Select the single sided-edges on either side of the vertex to remove in the
component.
Can)
3. Select the Merge Crv/Wfm tool ().
4. Activate the detached surface.

Select the single-sided edges on either side of the vertex to remove in the
surface.
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6. Select the Merge Crv/Wfm tool ().
7. Combine the surface and the component.

8. Collapse the combined node.

Model with All Extra Vertices Removed
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Creo Parametric

1. Click IEI on the In-graphics toolbar to display vertices, including the extra
vertices to be removed.

2. Select surfaces, right-click, and click Freeze on the shortcut menu to freeze
the selected surfaces.

3. Right-click the component on the GTS Tree and click Activate on the shortcut
menu to activate the component.

4. Click Heal » @ Repair. The Repair tab opens.

5. Click on the Repair tab to close gaps and remove the extra vertices.
If some extra vertices remain, remove them as follows:

1. Select a surface with an extra vertex, right-click, and click Detach on the
shortcut menu.

2. Select the single-sided surface edges on both sides of the vertex.

Cand
3. Click Edit » Merge Curves. The two one-sided edges are merged into a
single one-sided edge and the extra vertex is removed.

Fix Vertex

A bad vertex is created when the end points of two connected edge segments do
not actually meet at a point, as is evident when you zoom in close to such a vertex.

™
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Pro/ENGINEER Wildfire 3.0 and Earlier

The IDD functionality in Pro/ENGINEER Wildfire 3.0 and earlier fixes very few
classes of bad vertices. The remaining vertices appear as geometry checks that
require a manual fix.

Pro/ENGINEER Wildfire 4.0 and Later

In Pro/ENGINEER Wildfire 4.0 and later, including Creo Parametric, IDD
automatically identifies bad vertices when wireframes are automatically created
during import. It modifies this information when you edit wireframes. IDD
attempts to fix the bad vertices during a Repair or Match operation. This improved
approach repairs many more vertices than the Fix Vertex command of the earlier
releases of IDD. You can use the Troubleshooter to identify the remaining

bad vertices and manually repair them. The most common repair technique
recommended is that you remove any green wireframes and move the vertex.

Bad vertices are also created during repair operations. When the vertices of the
adjoining surfaces do not coincide at a point, the black wireframe edges may
seem to meet although they do not actually meet at the vertex. To fix this bad
vertex, transform the adjoining surfaces so that they meet at a point and close the
black wireframe.

Straighten Edge

Pro/ENGINEER Wildfire 3.0 and Earlier

The IDD functionality in Pro/ENGINEER Wildfire 3.0 and earlier has a command
with which you can straighten edges. However, this command does not exist in
the current release of IDD although you can straighten edges in Pro/ENGINEER
Wildfire 4.0 and later. The following is an edge that requires to be straightened.

Pro/ENGINEER Wildfire 4.0 and Later

1. Create a new UV curve thr%h the end points of the bad edge using the
UV-Curve through Points () tool as shown. In Creo Parametric, click
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UV-Curves » @ UV-Curve through Points on the Create tab to create a UV
curve through the end points of the edge.

Note

A UV-curve is created only in the domain of the surface. In most cases, the
surface domain extends beyond the visible boundaries of the surface and the
creation of the UV-curve is not affected. In some cases, you may have to
extend the surface domain using Edit » Extrapolate to create a UV-curve that is
continuous.

2. Highlight the distorted edge and select the Replace () tool.
3. Select the UV-curve. The edge is straightened as shown.

Note

If the UV-curve completely intersects the surface, you can add it to the
wireframe to split the surface and delete the undesired portion of the surface
instead of using the Replace tool. The UV curve (in blue) persists after the
replace operation and can be deleted if desired.

Edit Boundary

Pro/ENGINEER Wildfire 3.0 and Earlier

It takes many picks to replace the edge of a surface in the IDD
functionality of Pro/ENGINEER Wildfire 3.0 and earlier. You must use
Geometry » Heal » Manual » Edit Boundary.
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Pro/ENGINEER Wildfire 4.0 and Later

To replace a portion of a surface boundary in Pro/ENGINEER Wildfire 4.0 and
later or Creo Parametric:

1. Select the edge of a surface or a chain of edges of the surface to replace.

2. Select the Replace tool ().

3. Select the edge or chain of edges of an adjacent surface to use for the replace.

UV-curves may be manually created on the surface to trim and used to replace
edges. If the replacing edges do not align with the edges being replaced, you can
extend or trim back these manually created UV-curves.

Project and extend or trim the UV-curve as follows:
1. Select the surface where the UV-curve is to be created.

2. Select the UV-Curve by Projection tool (). In Creo Parametric, click
UV-Curves » UV-Curve by Projection on the Create tab in IDD.

3. Select the edge of another surface to project. The preview of the UV-curve
is displayed on the surface.

4. Right-click an end-point of the UV-curve represented by a white box and click
Extend To on the shortcut menu.

5. Select the surface boundary to extend.
Note

The domain of the surface is not large enough for the desired UV-curve if the
UV-curve does not extend to the relevant location or if the preview of the UV-curve
is not completely projected on the surface. Click Edit » Extrapolate to expand the
domain of the surface if it is not large enough for the extension of the UV-curve.

After the UV-curves are created, proceed as follows:
1. Select the edge segments to be replaced.

2. Select the Replace tool.

3. Select the UV-curves to define the new edge.
Note

As long as the UV-curves fully intersect the surface, this process trims back the
surface.

In some cases, it is easier to split the surface and delete the portion of the surface
that is not required as follows:
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1. Create the UV-curve to split the surface.

2. While the UV-curve is highlighted, select the Add to Wireframe tool (.) In

Creo Parametnc . Wireframe » . Add to Wireframe is available on the
Constrain tab of IDD.

3. Delete the portion of the surface that is not required.
To delete the entire surface boundary:

1. Detach the surface from the component.

2. Select the edge segments to be removed.

3. Right-click and click Delete or press the Delete key.
Note
The unbounded surface domain is displayed.

In Pro/ENGINEER Wildfire 4.0 and later, you can use the Trim tool in the
Featurize mode to modify the boundary of a surface by trimming back the surface.
In Creo Parametric, the Trim tool is available on the Edit tab of IDD.

Reverse Surface Side

Occasionally when importing a surface, the wrong portion of a periodic surface is
retained, especially for cylindrical and spherical surfaces.

Repair is easier when you can recreate the boundary of the surface from adjoining
surfaces. To correct the wrong portion of a periodic surface:

1. Detach the surface from the surrounding quilt.

2. Isolate the detached surface to remove screen clutter.
3. Delete the boundary of the visible surface.
4

Select the unbounded surface and click Edit » Extrapolate and drag the edges of
the surface to fully encompass the desired surface area.

Activate the unbounded surface.

o

Create UV-curves on the unbounded surface by projecting the edges of the
adjoining surface as follows:
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a. Select the unbounded surface and select the UV-Curve by Projection tool.

b. Hold down the CTRL key and select the visible edges of the adjoining
surfaces.

c. Click .

7. Add the UV-curves to the wireframe as follows:

a. Set the selection filter to UV-curves.
b. Drag a window across the visible UV-curves to select all of them.
c. Select the Add to Wireframe tool.

8. Select the undesired portion of the surface and delete it.

9. Drag or cut and paste the corrected surface back into the quilt.

In some cases, the surface includes loops that you cannot project from other
surfaces. To correct the wrong portion of a periodic surface in these cases:

Detach the surface from the surrounding quilt.
Isolate the detached surface to remove screen clutter.
Copy the surface and paste it as a new surface.

Hide the new surface.

Delete the boundary of the visible surface.

A o e

Select the surface and click Edit » Extrapolate and drag the edges of the surface
to fully encompass the desired surface area.

Unhide the copied surface.

%

Create UV-curves on the unbounded surface by projecting the edges of the
copied surface as follows:

a. Select the unbounded surface and select the UV-Curve by Projection tool.
b. Hold down the CTRL key and select the visible edges of the copied surface.

c. Click .

9. Delete or hide the copied surface.
10. Activate the unbounded surface.

11. Add the UV-curves to the wireframe as follows:

a. Set the selection filter to UV-curves.
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b. Drag a window across the visible UV-curves to select all of them.
c. Select the Add to Wireframe tool.
12. Select the undesired portion of the surface and delete it.

13. Drag or cut and paste the corrected surface back into the quilt.

The Overbuild Technique

Use the overbuild technique to repair bad surfaces with singularities. This
technique is also valid in Pro/ENGINEER Wildfire 4.0 and later releases and
Creo Parametric.

You can use the Troubleshooter to identify bad surfaces. You must locate the
singularity in the bad surface before you attempt repair. Refer to the the section,
Bad Surfaces, in the chapter, Troubleshooter Analysis and Repair Procedures,
of this guide.

For a singularity inside the boundary of a surface:

1. Create UV-curves through points on the bad surface to isolate the singularity.

Note

Ensure that the UV-curves create four sides with square corners. Good
surfaces have four sides. Three-sided surfaces can create new singularities.

2. Add the UV-curves to the wireframe.
3. Delete the bad portion of the surface.

4. Create a new boundary blend surface. Ensure that all four edges of the new
boundary blend surface are curvature continuous.

5. Drag or cut and paste the new surface into the quilt.

You may have to trim the surrounding surfaces when the singularity is at the corner
of the surface. In some cases, you can change the math properties of a surface to
eliminate singularities.

Final Comments

Hopefully this Import DataDoctor Getting Started Guide has shown you how to
begin using the powerful set of data repair and reuse tools in Import DataDoctor.
Remember that several different methods have been demonstrated in this getting
started guide to achieve a similar goal. Make sure to refer to the Creo Parametric
Help for more information.
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This chapter provides information about all the sources you can count on for
support in working with Creo Parametric. The three main areas of support are:

*  Creo Parametric Help Center

* Creo Parametric 1.0 Resource Center
* Technical Support

* PTC Training Services

* PTC User Community
As you become more familiar with these sources, you’ll find that they
overlap in areas of expertise. A PTC online account is required to access

PTC documentation from the Web. Register for a PTC online account at
www.ptc.com/appserver/common/account/basic.jsp.

Note

The Adobe Acrobat Reader is required to read PDF files. See
http://get.adobe.com/reader/ to download a free Acrobat Reader.

109


https://www.ptc.com/appserver/common/account/basic.jsp
http://get.adobe.com/reader/

Creo Parametric Help Center

You can access Creo Parametric context-sensitive Help and books in PDF format
by clicking Help » Help Center in Creo Parametric or through context sensitivity.
In the Help Center, see Using the Help Center for more information.

Creo Parametric Resource Center

Web-based usability tools can help when learning Creo Parametric.

Access the Creo Parametric 1.0 Resource Center from the Creo

Parametric browser, through the Creo Parametric Help Center, or at
www.ptc.com/community/landing/creo-elements-pro/start.htm. The tools include
the following:

* Web Tools and Tutorials—Step-by-step instructions and other helpful
topics. Navigate to the tutorials from the Resource Center or go directly to
www.ptc.com/appserver/mkt/products/home.jsp?k=403 and click Resource
Center » Demos, Tools & Tutorials.

* Quick Reference Card—Handy reference for toolbars, selection techniques,
dynamic viewing, and more.

* Productivity Tools—An interactive guide to new tools to increase your
productivity. Included are the selection tools, enhancements to viewing tools
(Spin, Pan, and Zoom), and the Model Tree.

* Menu Mapper—A cross-reference of menu commands from Pro/ENGINEER
2001 and Pro/ENGINEER Wildfire to latest menu commands.

PTC Technical Support

Technical support for Creo Parametric is available 24 hours a day, 7 days a week.
You can contact PTC Technical Support by phone, fax, e-mail, or FTP.

You can easily access the most current technical support contact information
from within Creo Parametric by clicking the Support link on the Creo Parametric
browser homepage.

PTC Training Services

PTC Training Services offers a multitude of solutions that embrace the
Precision Learning methodology. Precision Learning is a continuous cycle of
Learn-Assess-Improve focused toward providing the right training to the right
people and doing this at the right time using the right method.
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Learning activities, whether taught by an industry-experienced PTC certified
instructor or a PTC Web course, embrace a “tell me, show me, let me do”
philosophy to maximize understanding and retention. Visit www.ptc.com for a
wide range of instructor-led and Web courses offered by PTC Training Services
(click on Services & Training * Training Services).

PTC Training Services prides itself in the flexibility of its solutions. The flexibility
in delivery of PTC instructor-led courses includes:

*  Course Customization—Courses are tailored to the individual needs of your
company, eliminating any topics that are not relevant to your company’s
situation.

*  On-site Training—PTC sends the instructor to you and provides training
machines through our responsive traveling laptop centers.

Assessing the impact of training is key to planning the most efficient training, and
to measuring the return on your training investment. Pro/FICIENCY Evaluator
lets you gain an accurate and impartial evaluation of your personal, department,
and company skills.

Pro/FICIENCY Evaluator reveals any areas where skill improvement would prove
beneficial to your design team. Improvement activities include Web lessons,
(short, tactical how-to topics provided on the PTC customer support Web pages,)
books, mentoring, and so forth.

Creo Parametric User Community

Pro/USER provides education and communication for users of PTC software.
They offer ad-hoc yearly seminars at the Pro/USER International Conference.
Visit www.ptcuser.org for a list of training seminars.
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