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Introduction
Getting Started with Pro/ENGINEER Wildfire 4.0 Import DataDoctor is a 
tutorial-based introduction that shows you how to repair the geometry of 
models imported into Pro/ENGINEER from external sources. If you 
follow the complete series of procedures, you will learn how IDD handles 
the imported geometry and best practices for fast and efficient repair.

These procedures introduce the basic techniques for using IDD tools. 
After you are familiar with these procedures, you will be able to quickly 
repair, modify, and featurize legacy and external models. The final result 
will fit seamlessly with whatever Pro/ENGINEER design you are 
working on.

Intended Audience
This guide is intended for designers with some experience in the use of 
Pro/ENGINEER.

Scope and Purpose
This guide is not intended to be a complete summary of IDD techniques. 
The goal of the exercises is to familiarize you with the repair process so 
that you can use it to streamline model repair. Many intermediate and 
advanced techniques are not mentioned. Some basic techniques have 
been bypassed in favor of presenting the whole workflow to a new user 
in a manageable way.
iii 





Contents
Intended Audience iii
Scope and Purpose iii

Chapter 1  Import DataDoctor Concepts 

Before You Begin 1-2
Learning the User Interface 1-2

The Geometry/Topology Structure Tree 1-3
Import DataDoctor Modes 1-3

The Mode Toolbar 1-3
The Repair Toolbar 1-4
The Modify Toolbar 1-4
The Featurize Toolbar 1-5

Chapter 2  Using Repair Mode: Basic Repairs 

Import the Model 2-2
Set the Model Display 2-2

Start Import DataDoctor 2-3
Using the GTS Tree 2-3

Remove Coincident Surfaces 2-4
Find, Define, and Repair Gaps 2-5

Find Gaps by Automatic Search 2-5
Close the Gaps 2-6

Define Gaps Manually 2-6
Close the Gaps 2-7
v



Add Missing Surfaces 2-8
Combine the Surfaces 2-9

Set the Solid Attribute for the Import Feature 2-10
Summary 2-10

Chapter 3  Using Repair Mode: Advanced Repairs 

Repair the Side Surface 3-1
Replace the Boundary Edge 3-3

Replace the Missing Surface 3-4
Summary 3-6

Chapter 4  Using Modify Mode 

Align the Top Surface 4-2
Modify the Surface to Match the Model 4-5
Find the Remaining Gaps 4-6

Repair the Model 4-6

Chapter 5  Using Featurize Mode 

Add the Missing Surface 5-2
Convert Surfaces to a Cylinder Pseudo-Feature 5-3
Convert Surfaces to an Extrude Feature 5-3
Remove Geometry 5-5
Transform the Extrude Node 5-6
Summary 5-6

Chapter 6  Tips and Techniques 

Scoping the Extent of a Repair 6-1
About Freezing Surfaces 6-2
About Unfreezing Surfaces 6-2

Defining Gaps 6-3
Fixing Geometric Discrepancies 6-3

Bad Edges 6-3
Bad Surfaces 6-4

Dealing with Bad Repair Results 6-5
vi Getting Started with Pro/ENGINEER Wildfire



Modify Mode 6-5
Final Comments 6-6

Chapter 7  Getting Support 

Pro/ENGINEER Help Center 7-1
Pro/ENGINEER Resource Center 7-2
PTC Technical Support 7-2
PTC Training Services 7-2
Pro/ENGINEER User Community 7-3
vii





 1
Import DataDoctor 

Concepts
After you have imported a part model (or a part from an imported 
assembly model) into your Pro/ENGINEER session, use Import 
DataDoctor to correct geometry, ensure surface consistency, add 
constraints, close unwanted gaps, and adjust tangencies in the imported 
parts.

This guide introduces you to some commonly used IDD techniques 
required to repair an imported model and convert it into a 
Pro/ENGINEER model. After you have completed the exercises, you 
should be able to repair, modify, and use external models in your own 
designs.

Note: Proficiency in Pro/ENGINEER is assumed. Only procedures 
unique to IDD are covered by this guide.
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Before You Begin
If you have not already done so, download the IDD_Models.zip file 
and extract the models. The link to the zip file and this guide are on the 
same page.

Learning the User Interface
Import DataDoctor is only available when a previously imported 
Pro/ENGINEER part is in session and is the active model.

To access the IDD environment:

1. Right-click the Import Feature in the Model Tree and choose Edit 
Definition from the shortcut menu.

2. Click Geometry >  Import DataDoctor to enter the IDD 
environment.

The following changes occur:

• The Geometry/Topology Structure Tree (GTS) replaces the regular 
Pro/ENGINEER Model Tree

• The IDD Edit and the IDD menus are added to the menu bar.

• The IDD Mode toolbar appears in the icon area above the graphics 
window

• The IDD Tools (Repair, Modify and Featurize) toolbar appears on the 
right side of the graphics window

The IDD user interface
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The Geometry/Topology Structure Tree
The Geometry/Topology Structure Tree is similar to the regular 
Pro/ENGINEER Model Tree. The imported model’s geometry (surfaces, 
datums, and other IDD geometry types) are grouped as logical collections 
of member nodes. Each node is identified by an icon. Consult the IDD 
online help for information about performing many common IDD 
operations directly on each member node of the GTS Tree, including 
Hide, Activate, Merge, Exclude, Cut, Copy, Paste, and Rename.

Import DataDoctor Modes
There are three Import DataDoctor modes. Each mode is, essentially, a set 
of tools that perform increasingly complex analysis, conversion, and 
manipulation processes on imported external data. The modes are:

• Repair mode—Finds and removes gaps and sliver surfaces, adds UV 
curves, allows wireframe editing as well automatic repairs based on 
user-defined wireframe models.

• Modify mode—Modifies individual curves and surfaces, and replaces 
one-sided edges.

• Featurize mode—Converts static geometry to explicit procedural 
geometries with modifiable properties. Featurize mode tools convert 
existing geometry types in the imported model to IDD 
pseudo-features such as Cylinder, Plane, Extrude, or Revolve. 
Featurize mode also allows you to change pseudo features sketch or 
direction, and allows you to trim or extend, merge or intersect, close, 
or remove surfaces. Transformation by constraint or by dragging is 
also possible..

The Mode Toolbar
Use the Mode toolbar to access modes and set display options available 
for viewing the Repair wireframe:

• —Enter Repair mode

• —Enter Modify mode

• —Enter Featurize mode

• —Display tangency (Repair mode only)

• —Display frozen elements (Repair mode only)

• —Display vertices (Repair mode only)

• —Display wireframe (Repair mode only)
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The Repair Toolbar
Use the Repair toolbar to access specific repair tools:

• —Add curve by projection/intersection surface

• —Replace

• —Define gap or sliver

• —Add or remove from wireframe display

• —Combine or split curves

• —Add or remove tangency

• —Edit surface properties

• —Freeze or unfreeze

• —Repair

The Modify Toolbar
Use the Modify toolbar to access specific surface and curve modification 
tools:

• —Sketched curve

• —Merge or Split wireframe

• —Extrapolate

• —Math properties

• —Modify

• —Move vertex

• —Align

• —Transform

• —Replace
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The Featurize Toolbar
Use the Featurize toolbar to access specific repair tools:

• —Sketch curve

• —Curve Through Points

• —Boundary Blend

• —Define Gap

• , , , —Convert to (Plane, Cylinder, Revolve, Extrude)

• —Close

• —Trim

• —Extend

• —Merge

• —Detach
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 2
Using Repair Mode: 

Basic Repairs
In this chapter, you will import a model and learn how to use Import 
DataDoctor perform basic repairs and save the model as a normal solid 
boundary representation Pro/ENGINEER model.

In this exercise, you will:

• Import and save a foreign or legacy model (from a STEP file).

• Find and repair any gaps using the Search tool and the Define Gap 
tool.

• Add a boundary blend to close an opening or a missing surface.

Note:
When doing the exercises in chapters 2 and 3, use a copy of the 
original model file (basic_probs_w_slvr.stp)for each chapter. 
After you have used one method to repair a gap, it cannot be repaired 
again using another method.
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Import the Model
1. Click File > Open. The File Open dialog box opens.

2. Browse to the directory containing the models.

3. At the bottom right of the dialog box, select All Files (*) from the 
Type list. The basic_probs_w_slvr.stp file appears in the list of 
files.

4. Double-click the file or select it and click Open. The Import New 
Model dialog box opens. 

5. Select Part as the Type and accept the default name or enter a new 
one.

6. Click OK. The Information window opens and the model appears in 
the graphics window.

Note
To disable the Information window, set the 
intf3d_show_import_log configuration option to no.

7. Close the Information window.

Basic Repair Model

Set the Model Display
1. Show or hide datum planes, datum axes, datum points, datum 

coordinate system, and annotation elements as needed to unclutter 
the model during repair.

2. Set the model display to Wireframe to make geometric entity errors 
easier to see.

Gaps in the 
imported model
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Start Import DataDoctor
1. In the Model Tree, right-click the import feature of the model (the 

default name is Import Feature id xx ) and choose Edit 
Definition from the shortcut menu. The Geometry menu appears on 
the menu bar.

2. Click Geometry >  Import DataDoctor. You are now in the IDD 
environment.  The GTS Tree and the IDD menus and toolbars appear.

Using the GTS Tree
In the example below, the import feature contains a logical grouping of 
surfaces under Component 251. This grouping is called a component 
and corresponds to a quilt.

Note
Each independent quilt in the import feature appears as a separate 
component in the GTS Tree.

Next on the tree is surface 242, which has not been grouped. This is 
surface is not part of the main quilt. In this example, the single surface in 
the GTS Tree is a coincident surface—a duplicate surface that lies on top 
of another surface. Since it is coincident, it is not used in the model and 
must be removed.
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Remove Coincident Surfaces
Use the Hide/Unhide technique described in steps 1 through 4 to quickly 
examine the geometry of individual nodes in the GTS Tree. Follow steps 5 
and 6 to remove the coincident surface.

1. Right-click component 251 on the GTS Tree and choose Hide from 
the shortcut menu. Component 251 and its grouped surfaces are 
temporarily hidden.

2. Right-click surface 242 and choose Hide from the shortcut menu. 
Nothing is now visible in the graphics window.

3. Select component 251 and surface 242 on the GTS Tree. The 
model appears in the graphics window as a red mesh, indicating that 
these surfaces are hidden.

4. Select component 251 on the GTS Tree and spin the model to see 
the surface beneath surface 242. Since you have verified that there 
is an actual surface on the feature, you can now remove surface 
242.

5. Rght-click surface 242 on the GTS Tree and choose Delete from 
the shortcut menu.

6. Right-click component 251 on the GTS Tree and choose UnHide 
from the shortcut menu. The model appears in the graphics window, 
without the extra surface.

Coincident 
surface to be 
removed
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Find, Define, and Repair Gaps 
There are two ways to repair gaps. You can search for them automatically 
and select them using the Search tool, or you can select them manually 
from the model. However you determine gaps for repair, you must add 
selected gaps to the wireframe to close them.

Note
Use the Repair Mode Display icons to set the display to Wireframe for 
the section of model being repaired.

Find Gaps by Automatic Search
When you use the Search tool to find and select gaps in the model you do 
not have to select them individually in the graphics window. Use the gap 
size attribute value to set search rules:

1. Select  on the Display toolbar to enter Repair mode.

2. Click  on the Edit toolbar. The Search Tool dialog box opens. 

3. Select Gaps in the Look for list.

4. Leave the Value at the default of 0.099129 and click Find Now. 
Both the Found Items list and the Selected Items list are empty 
because the model does not contain gaps with the default value.

5. Set Value to 1 and click Find Now. GAP0001 and GAP0002 appear in 
the Found Items list. These gaps have a value of 1.

6. Select both these items and click the arrow button to move them into 
the Selected Items list.

7. Close the Search Tool dialog box. The selected edges appear in red in 
the graphics window as shown in the following figure:

Gaps selected using 
the search tool
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Note
Make sure to turn on the Wireframe display so you can see which 
Wireframe gaps are satisfied (shown in green) and which gaps have 
been defined but not satisfied (shown in black). 

Close the Gaps
After you have determined where the gaps are, by either finding them 
with the Search Tool or defining them manually, use the following 
procedure to add wireframe edges to repair them. When you add edges 
to the wireframe model, and click Repair, the defined wireframe gaps are 
closed.

1. Click  on the Repair Tools toolbar or Edit > Add to Wireframe.

2. Click  on the Repair Tools toolbar. The Repair dashboard appears. 
The surfaces that are being repaired are highlighted in the graphics 
window.

3. Click . The gaps are closed.

Define Gaps Manually
You will now define the gaps in your model by selecting them in the 
graphics window. Use the following figure for reference.

1. Click  on the Repair Tools toolbar, or click IDD > Define Gap. The 
Define Gaps dialog box opens. GAP0001 appears on the left side of 
the dialog box. 

2. Click the Side 1 collector box and select edge A (1-sided edge id 
95) in the graphics window.

3. Click the Side 2 collector box and select edge B (1-sided edge id 
181) in the graphics window.

4. Now click New Gap, or right-click in the graphics window and 
choose New Gap from the shortcut menu.

5. Select, then right-click edge C (1-sided edge id 94). It appears in 
the Side 1 collector.

6. Click the Side 2 collector box and select edge D (1-sided edge id 
191). It appears in the Side 2 collector .

7. Repeat steps 4-6 for edges E (1-sided edge id 44) and F (1-sided 
edge id 89).

8. Click OK. The selected edges appear in red in the graphics window.
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Note
Make sure to turn on the Wireframe display so you can see which 
Wireframe gaps are satisfied (shown in green) and which gaps have 
been defined but not satisfied (shown in black). 

Close the Gaps
After you have determined where the gaps are, by either finding them 
with the Search Tool or defining them manually, use the following 
procedure to add wireframe edges to repair them. When you add edges 
to the wireframe model, and click Repair, the defined wireframe gaps are 
closed.

1. Click  on the Repair Tools toolbar or Edit > Add to Wireframe.

2. Click  on the Repair Tools toolbar. The Repair dashboard appears. 
The surfaces that are being created are highlighted in the graphics 
window.

3. Click . The gaps are closed.

E, F

A, B

C, D
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Add Missing Surfaces
After the gaps are closed, you must add missing surfaces. Use the 
Boundary Blend tool to create a boundary blend surface between 
reference entities. This tool defines the surface in one or two directions. 
The first and last entities selected in each direction define the surface 
boundary. Use the following figures for reference.

1. Click  on the Display toolbar to enter Featurize mode.

Note
You must be in Featurize mode to add boundary blend surfaces.

2. Click  on the Featurize Tools toolbar or IDD > Boundary Blend 
Surface. The dashboard appears. Open the Curves slide-up panel. 
The First direction collector is active.

3. Select curves A and B for the first surface direction.

4. Click in the Second direction collector and select curves C and D in 
the graphics window.

5. Click  on the dashboard. The surface is created.

Missing 
surface

New surface
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Combine the Surfaces
The final task is to combine the new surface you have just created with 
the rest of the import feature. You will use the Combine tool to connect 
the new boundary blend surface to the component containing the quilt. 

1. In the GTS Tree, select the imported feature, hold down SHIFT or 
CTRL, and select the surface.

2. Click Edit > Combine or right-click and choose Combine from the 
shortcut menu.

3. The combined surface appears in the GTS Tree as shown below:

4. Click . The surface and the component appear as a combine node 
in the GTS Tree.

You can also drag the new surface node onto the component node:

1. Click Undo . The last operation (Combine) is undone.

2. In the GTS Tree, click the surface icon and drag it on top of the 
component icon (be sure to hold down the left mouse button until the 
component auto-expands before letting go). The surface is now a 
member of the component and is attached to the rest of the quilt.
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Set the Solid Attribute for the Import Feature
Although you have combined the boundary blend surface with the other 
surfaces, the model is a surface quilt and must be converted into a solid 
import feature. 

1. Click  in the feature toolbar to exit IDD and reenter Edit Definition 
mode.

2. Click Edit > Feature Properties. The Properties dialog box opens.

3. Select the Make Solid check box.

4. Click OK. The imported model is now a solid Pro/ENGINEER 
feature.

5. Click  in the feature toolbar.

6. Save the model to your working directory.

Summary
These are some of the basic tools and operations used in Import 
DataDoctor to repair imported models. For more complete information, 
see the Pro/ENGINEER Wildfire 4.0 Resource Center available through 
the Pro/ENGINEER Help Center.
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 3
Using Repair Mode: 

Advanced Repairs
In the previous chapter you learned how to use some of the basic repair 
tools in Import DataDoctor. In this chapter, you will learn additional 
ways to repair models. These include the replacement of the trimming 
edges of a surface boundary, and then copying and pasting a surface to a 
new location. 

To begin, reimport the STEP file from chapter 2. Now right-click the 
model feature in the Model Tree and choose Edit Definition from the 
shortcut menu. Click Geometry >  Import DataDoctor to enter the 
IDD environment.

Repeat the procedure under Remove Coincident Surfaces from chapter 2. 
You are now ready to repair the side surface of the imported model.

Repair the Side Surface
In this procedure you will learn how to create a new UV curve through 
points that lie on a selected surface in the imported model. You will use 
this new curve to replace the existing trimming edge on the boundary of 
the surface highlighted below.
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1. Select  on the Display toolbar to enter Repair mode.

2. Select the side surface in the graphics window.

3. Click  Insert curve through points on a surface from the  
Insert curve by projection fly-out menu on the Repair Tools toolbar. 
The dashboard appears.

4. Select vertices A and B. 

Note
Remember to hold down CTRL to select both vertices at the same 
time.

5. Click  on the dashboard. The UV surface curve is created and is 
highlighted in blue.
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Replace the Boundary Edge
Now you will replace the boundary edge of the surface that you selected 
in the previous section with the curve that you have just created. You will 
then use the Search tool to close the gaps.

1. Select the existing boundary edge (the slightly bowed edge just below 
the new curve you created earlier) from the graphics window. The 
selected edge appears in red on the model, as shown below.

2. Click  on the Repair Tools toolbar. The dashboard appears and the 
Replace with collector is active.

Note
The Replace tool is available only if you select an existing boundary 
edge to replace.

3. In the graphics window, select the newly created UV curve. It 
appears in the Replace with collector.

4. Click  on the dashboard. The bowed surface edge is replaced by 
the new curve.

Now use the techniques you learned in chapter 2 to define and repair any 
gaps in the quilt.
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Replace the Missing Surface
In the previous chapter, you used the Boundary Blend Surface tool to add 
a missing surface. Now you will learn another way to repair the import 
model, using the Copy and Paste Special tools to fill in the hole left by the 
missing surface. You will copy an existing surface and add the copied 
surface using the Paste dashboard. Finally, you will align the new surface. 
Use the following figures as references.

1. Select surface 49 on the GTS Tree and click Edit > Copy. 

2. Click Paste Special on the Edit toolbar or click Edit > Paste Special. 
The copied surface is pasted onto the model in the same place as the 
original and the Transform dashboard appears.

3. Click the Move slide-up panel and make sure the Motion Type is 
Translate.

4. Select the pasted surface in the graphics window and move it to the 
empty area.

Missing surface

Surface to copy
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5. Click the Move slide-up panel, change the Motion Type to Rotate, 
and rotate the pasted surface as shown.

6. Click the Placement slide-up panel and set the Constraint Type to 
Align. 

7. Click the Select component item collector and select Vertex A. 

8. Click the Select assembly item collector and select Vertex A1. 
Vertex A and Vertex A1 are aligned.

9. Click New Constraint.

10. Click the Select component item collector and select Vertex B.

11. Click the Select assembly item collector and select Vertex B1. 
Vertex B and Vertex B1 are now aligned.

12. Click New Constraint to define another constraint and align Vertex 
C and Vertex C1

13. Click  on the dashboard. The surface is replaced.

14. Finally, as you did in chapter 2, use the Combine tool to combine the 
surface with the quilt component or drag the new surface into the 
component. 

Pasted surface

A, A1

B, B1

C, C1
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Summary
So far, you have learned to close gaps using the Copy and Paste Special 
tool and using the Search tool. You have replaced the edge of a surface 
with a curve. In the next chapters you will learn about various Modify 
and Featurize Mode tools.
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 4
Using Modify Mode
In the previous chapter you learned how to use surface boundary 
modifications to help repair a model, and to use the Copy and Paste 
Special tools. Now you will learn how to modify a larger surface and 
incorporate it in the solid component as part of the quilt

To begin, open big_gap.prt. Orient it in the graphic window so the top 
surface is up, right-click it in the Model Tree and choose Edit Definition 
from the shortcut menu. Click Geometry >  Import DataDoctor to 
enter the IDD environment.

You are now ready to modify the top surface of the imported model.
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Align the Top Surface
In this procedure you will learn how to delete trimming boundary edges, 
and then align the surface to conform and modify the surface to match 
the model quilt. Use the following figures as references.

1. Select Surface 43 from the Model Tree.

2. Select  on the Display toolbar to enter Modify mode.

3. Select the right edge of the surface, and then click Edit > Delete. 

Note
Since a trimming edge cannot be incomplete or open, when you 
delete one trimming edge, all trimming edges that form a closed loop 
for that surface are also deleted. For example, if the surface had an 
internal hole through the surface, selecting and deleting an edge of 
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that internal loop of trimming edges would remove the hole from the 
surface. 

4. Now select the surface and click  Connect and align. The 
dashboard appears. The bottom edge is prehighlighted. This is the 
surface edge to be aligned.

5. Select the corresponding boundary edge on the adjacent quilt 
boundary. The surface edge is aligned to the quilt edge. 

6. Click and drag the edge until it is the same length as the 
corresponding curve on the quilt (the drag handles will turn white).
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7. Open the Surface Sides slide up panel. The front edge and the front 
curve appear as Side 1. The Tangent Constraint tool is active.

8. Click inside the Side 3 collector to preselect the right edge of the 
surface. The Tangency constraint is also active for this edge.

9. Select the right curve as Side 3. The surface edge aligns to the quilt 
boundary. Use the drag handles to adjust the start and end points of 
the aligned edge.

10. Click  on the dashboard. The two edges merge with the model.

Note
Only two of the four edges of the surface are aligned. You cannot 
align edges 2 and 4 because there are active Tangency constraints. If 
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you change the constraints on sides 1 and 3 to Position, you can align 
sides 2 and 4 (also constrained to Position).
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Modify the Surface to Match the Model
Now you will modify the other sides of the surface that you selected in 
the previous section with the model.

1. Change the view to Wireframe and select the surface. Click  Move 
Vertex.

2. Select the point of intersection of the remaining two sides. Click and 
drag it until it is close to the corresponding point on the model. You 
may need to move or rotate the model for better access.

3. Click OK to exit the tool.

4. Select the surface, and then click  Modify. The mathematical mesh 
that defines the surface appears.

5. Click and drag points on the surface mesh until the remaining sides 
correspond with the curves on the model.

6. Click  on the dashboard.
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Find the Remaining Gaps
You may notice that you’ve gotten the last two edges close to the quilt 
boundary but some gaps still remain. You will use the Search tool to find 
and repair these gaps as you have done before.

1. On the Model Tree, click and drag Surface 43 so that it appears 
under Component 52.

2. Select  on the Display toolbar to enter Repair mode.

3. Click  on the Edit toolbar. The Search Tool dialog box opens. 

4. Select Gaps in the Look for list.

5. Set the Value to 2.0 and click Find Now. Gap 0001 and Gap 0002 
appear in the Items Found list.

6. Select the gaps and click  to add them to the Selected Items 
list.

7. Click CLOSE to close the Search tool.

8. Now click  Add to Wireframe. The remaining sides of the surface 
highlight in black.

Repair the Model
1. Click  Repair. The model is displayed as a quilt. 

2. Click  on the Options dashboard and then  on the toolbar to 
accept.

3. Click Edit > Repaint. 
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 5
Using Featurize Mode
In the previous chapter you learned how to use surface modifications to 
repair a model. In this chapter, you will learn to create pseudo-features in 
the imported model using Featurize mode. These pseudo features can 
later be modified, if desired. You will learn to:

• Use the Boundary Blend tool to add a missing surface. 

• Select surfaces and convert them to a Cylinder feature, modifying the 
diameter in the process.

• Select seed and boundary surface sets to create an Extrude feature, 
and then move the Extrude node with the Transform command.

• Use the Remove tool to remove surfaces of geometry that are no 
longer needed.

To begin:

1. Open the d_step214_shtmtlpartlow.prt file and save it in your 
working directory.

2. Load the model, then right-click it in the Model Tree and choose Edit 
Definition from the shortcut menu.

3. Click Geometry >  Import DataDoctor to enter the IDD 
environment.
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Add the Missing Surface
Once again you will use the Boundary Blend Surface tool to add a 
missing surface and close the entire quilt. 

1. Select edge A and edge B as shown in the figure below:

2. Click  on the Featurize Tools toolbar or IDD > Boundary Blend 
Surface. The dashboard appears. The selected edges are in the first 
direction chain collector.

3. Click  on the dashboard. The boundary blend surface is created 
and the missing surface is added. A new surface (surface 661) 
appears on the GTS Tree.

4. Select the new surface from the GTS Tree and drag it over the 
component node in the tree.  Hover over the node until it expands, 
and then drop the surface into the component.

Note
Remember that all surfaces in a component are logically joined 
together and will connect automatically if they can. If they do not, use 
the techniques you learned in chapters 1 and 2 to close any gaps.

Select edges A and B
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Convert Surfaces to a Cylinder Pseudo-Feature
You will now convert the surfaces of a hole to a Cylinder pseudo-feature. 
Use the figure below as reference.

1. Select surface 353 and surface 356.

2. Click Convert to Cylinder  from the Convert to Plane menu on 
the Featurize Tools toolbar. The dashboard appears. 

3. Set the radius to 3.50.

4. Click  on the dashboard. The Cylinder pseudo-feature is created. 
The new pseudo-feature appears as the Cylinder 682 node, part of 
the Combine 693 node on the GTS Tree. The remaining surfaces are 
grouped under Component 660.

Note
You can change the radius of the Cylinder pseudo-feature after you 
create it. Select the Cylinder node in the GTS tree, and then right-click 
and choose Modify from the shortcut menu to access the Cylinder 
dashboard.

Convert Surfaces to an Extrude Feature
Now you will create an Extrude feature from a selected surface set.

Use the following figureas reference:
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1. Select surfaces 1,2, 3, 4, and 5..

2. When all the surfaces have been selected, click Convert to Extrude 
 from the Convert to … menu on the Featurize Tools toolbar. The 

dashboard appears.

3. Click  on the dashboard. The Extrude pseudo-feature is created. 

4. The new pseudo-feature appears as a combine node on the GTS Tree. 

5. The new feature appears as Extrude 793, part of the Combine 693 
node on the GTS Tree.

1

2

3

4

5
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Remove Geometry
You will now use the Close tool to remove unwanted geometry. When 
you remove geometry, adjacent surfaces are extended or trimmed to 
converge and close the openings. Or, as in this case, selected surfaces are 
deleted and internal loops on the adjacent surfaces are removed to close 
the openings.

Note
The Extrude (and Revolve) pseudo-features are based on sketches 
extracted from the geometry selected at the time they are created.  
You can modify these sketches when creating them or right-click and 
choose Edit Definition from the shortcut menu to access the 
pseudo-feature’s dashboard. 

Use the seed and boundary surface selection technique to select the 
surfaces. Use the following figures as reference.

1. Select the seed surface (1).

2. Hold down CTRL and select surfaces 2 and 3. Surface 3 is beneath 
surface 2.

3. When you finish selecting surfaces, the seed and boundary surface 
set is highlighted.

4. Click Close  on the Featurize Tools toolbar. The dashboard 
appears and the surface set appears in the Collect surfaces to remove 
collector.

5. Click  on the dashboard.

Note
No node is created the GTS Tree when you select Close. However, 
you can select Undo to restore the surfaces that you have removed.

1

2

3
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Transform the Extrude Node
Now you will transform the location of the extrude. To do so, you will 
create a new Datum node as a permanent reference for the 
Transformation process.

1. Select the vertical planar face of the Extrude pseudo-feature, and then 
select the datum plane tool from the toolbar.

2. Drag the datum plane parallel to the face of the Extrude 
pseudo-feature face. 

3. Click OK. The Datum Plane dialog box closes.

4. Select the Extrude node on the GTS Tree, right-click and choose 
Transform from the shortcut menu. The Transformation dashboard 
opens. 

Note
You can either drag a node to another approximate location or use a 
Mate or Align constraint to place objects in relation to other objects. 
The second method moves the component precisely.

5. Select the vertical face of the Extrude pseudo-feature and then select 
the face of the datum plane.  The Extrude pseudo-feature should snap 
to the datum reference. 

6. Click  on the dashboard. The Extrude pseudo-feature and the 
surrounding  surfaces update and connect.

7. Exit IDD.

8. Select Edit > Feature Properties. The Redefine Feature dialog box 
opens.

9. Select the Make Solid check box.

10. Click OK.

Summary
You have now learned to replace a missing surface using the Boundary 
Blend tool, convert surfaces to a Cylinder or Extrude pseudo-feature, and 
use the Close tool to remove geometry. You have also learned to change 
the model to meet new requirements.
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 6
Tips and Techniques
The tips and techniques in this chapter show you how to close gaps in 
Repair mode. You can use similar techniques to repair tangencies 
between surfaces. 

Scoping the Extent of a Repair
The scope of a repair depends on how many independent, top-level 
component nodes (direct children of the import feature) are in the IDD 
environment. If there is only one component node, it will automatically 
be selected for repair. If there is more than one node, you must manually 
activate the component node you want to repair.

Tip
Always activate the required node in the GTS Tree before you begin 
working. This is helpful whenever you need, for example, to detach a 
surface (making it a base node) so that you can manually recreate its 
trimming boundary.

If there is more than one component node immediately below the import 
feature, and you have not activated the one you wish to repair, the 
wireframe display disappears and the Repair tool is not available. When 
you activate a node in the GTS Tree, the repair is limited to the surfaces of 
the active node. You can also limit a repair by activating specific surfaces 
on an existing component. Alternatively, you can detach the surfaces, 
combine them into their own component, and then activate and work on 
the component (which contains the detached surfaces) by itself. 

Before beginning to repair anything, examine the wireframe display. If 
the display is mostly satisfied (the wireframe curves are green) with only 
a few instances where they are black, do not try to repair the entire 
component. The repair will take a long time to compute, and some 
surfaces may become distorted (we'll discuss later how to work around 
such distortions). 
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Another way to make sure the repair affects only an isolated area is to 
freeze the entire component. Select a component node in the GTS tree or 
in the graphic display, right-click and choose Select Parent Node from the 
shortcut menu, and then click Freeze. Unfreeze the surfaces adjacent to 
the black wireframe curves to repair.

About Freezing Surfaces
Freezing drastically limits the scope of allowed changes to a surface, but 
does not prevent its repair. Local changes along the boundary edges are 
still possible even if the surface is frozen. Even if all the activate surfaces 
are frozen they can still be repaired. When a surface is frozen, changes 
during repair are limited to tweaks to a small adjacent surface or 
boundary. Neither the UV parameterization grid nor the mathematical 
properties of the surface change. If the surface is not frozen, however, the 
repair process will both tweak and change the parameterization grids and 
surfaces.

The Freeze and Unfreeze commands are always available whenever 
multiple surfaces with different Freeze statuses are selected. Frozen 
surfaces are marked by a unique identification icon. When you select 
Unfreeze, only those surfaces that can be unfrozen are unfrozen. The rest 
will be marked as frozen.

About Unfreezing Surfaces
Sometimes a surface cannot be unfrozen. When this occurs, the system 
cannot calculate a quadrilateral or triangular patch based on its current 
boundary. You work around the situation by merging two adjacent 
wireframe curves (select the curves, and then click Merge Curves) of such 
surfaces. This may be sufficient to Unfreeze them.

Tip
If the above method does not work, use UV curves to subdivide the 
surface (create the UV curves and add them to the wireframe, one 
subdivision at a time), and then unfreeze each piece individually.

In general, analytical surfaces (including spheres, cylinders, and planes) 
are frozen by default. When you unfreeze an analytic surface, it converts 
to a modifiable free-form surface.
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Defining Gaps
You must define a gap as an input for the Repair tool in order to repair it. 
A gap is displayed as a black wireframe curve. In most cases, gaps are 
automatically found and defined automatically during the import 
process. If adjacent pairs of one-sided edges remain that are not included 
in the wireframe display, you must define new gaps and add them to it.

Tip
Carefully examine the wireframe display. Pay special attention to 
areas with black wireframe curves with many vertices (click Display 
Vertices to show vertices). Sometimes the gaps are not correctly 
defined (only a portion of the one-sided edge may appear in the gap, 
when the whole edge should be, for instance). Select the incorrect 
wireframe curves, click Remove from Wireframe, and then select the 
Define Gaps tool to define new, correct gaps. 

In rare cases an identified gap cannot be closed. Try either of the 
following methods to resolve the problem:

• Use manual local editing tools (available mostly in Modify mode) to 
detach the surface, modify it and fix its boundary, and then put it 
back into the component. 

• When gaps fail to add to the wireframe or do not close when the 
repair is done, click Close in Repair mode. In this mode, unlike in 
Featurize mode, the input (and only one allowable) to the Close tool 
is the selected black wireframe.

Fixing Geometric Discrepancies
There are two types of geometric discrepancies: improper surface 
trimming (bad edges) or corrupt surface definition (bad surfaces). These 
local geometric discrepancies can prevent a successful Repair operation 
or cause bad results. A geometric discrepancy may also make the model 
unusable in downstream Pro/ENGINEER applications. Use the manual 
tools in Modify mode to clean up bad geometry. 

Bad Edges
Use a Geometry check to locate bad edges, especially overlapping 
geometry, short edges, and misaligned vertices. Click Remove from 
Wireframe to convert two-sided bad edges into one-sided in Repair 
mode. Use the Merge Edges, Edit Edge, and Move Vertex tools for 
simple cases.

In more complex cases, you must replace the bad edges with UV curves. 
In some extremely complex cases you must recreate the entire boundary. 
To do this, detach the surface with bad edges, select one of its edges and 
click Delete. Use the UV Curves and Replace Edges tools to create a new 
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boundary, and then cut and paste or drag the new surface back into the 
component. If the new boundary matches that of its neighbors, the 
two-sided edges are automatically created. If not, define new gaps and 
click Repair.

Bad Surfaces
Bad surfaces are either badly distorted or have bad singularities. Use the 
following techniques to find bad surfaces:

• Run a geometry check to find bad surfaces. Since a bad surface often 
has bad edges, a bad surface usually indicates a bad edge.

• Check for visible discrepancies in Shaded view: waves, bulges, and 
apparent holes.

• Check for visible discrepancies in Wireframe view: bad silhouette 
curves, wavy edges.

• Selected surface does not highlight properly: visibly mismatched 
highlighted and non-highlighted displays.

• Bad surface mesh: self-intersecting mesh; points where all mesh 
curves passing through it are locally parallel to each other (an 
indication of a bad singularity); unreasonable mesh for the surface 
shape; dense or sparse mesh in a specific area of the surface (adjust 
mesh density to see this). Notice the bad surface singularity in the 
figure shown below.

• Locally bad shaded surface analysis (curvature, slope, zebra, and so 
forth).
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Delete these surfaces, and then use the Boundary Blend tool to recreate 
them. In some cases, when the general shape is similar to one of the 
supported procedural or analytical types, you can use Featurize mode to 
convert the surface to the similar supported surface type.

Dealing with Bad Repair Results
A bad (distorted) surface is usually the result of a badly performed repair. 
Use the same technique to find the bad surface either after the repair has 
been saved to the model or use the Repair dashboard to view old and/or 
new geometry, and then perform a surface analysis. The most commonly 
used analysis is a Compare Surfaces analysis. Click Curvature Analysis > 
Compare Surfaces. 

One way to work around a bad surface after a repair is to delete it and to 
create a new surface, or you can revert the component to a pre-repair state 
by canceling the repair or clicking Undo. Play with the surface’s frozen 
status and with the tangency constraints along its edges before 
attempting to repair it again.

Sometimes you can get better results by editing surface math properties 
(make the number of gridlines smaller if they seem excessively dense) 
and/or use the Edit Surface tool to make the control polyhedron look 
more regular.

Tip
Remember to check whether the surface that distorts was bad to 
begin with. 

Modify Mode
Use Modify mode to make changes to both individual surfaces and 
curves as well as to boundary edges of surfaces.

Tip
Wherever possible, the system creates two-sided edges when you 
modify the edges of a component surface. To prevent this or to work 
in a manner similar to that of the Edit Boundary functionality, detach 
the surface, perform all necessary operations on its edges, and drop it 
back into the component.

The following tools are available:

• The Edit tool edits a one-sided edge using control polygon 
manipulation.

• The Move Vertex tool moves a vertex between one-sided edges of the 
same surface.

• The Merge tool merges two adjacent one-sided edges.
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• The Split tool splits a one-sided edge at a selected point.

• The Delete tool deletes a one-sided edge.

Note
The system does not remember the edge control polygon. It is 
recreated every time you enter Edit.

Before you can create new boundary edges, you must create UV curves 
on the surface. Now use the UV curve creation options from the IDD 
menu or Repair mode toolbar to replace a selected chain of existing 
one-sided edges by a chain of UV curves. You can use the same editing 
operations for both curves and UV curves and shape the new boundary 
as required.

Final Comments
Hopefully this Import DataDoctor Getting Started Guide has shown you 
how to begin using the powerful set of data repair and reuse tools in 
Import DataDoctor. Remember that several different methods have been 
demonstrated in this getting started guide to achieve a similar goal. Make 
sure to refer to the Pro/ENGINEER Help for more information.
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Getting Support
This chapter provides information about all the sources you can count on 
for support in working with Pro/ENGINEER. The three main areas of 
support are:

• Pro/ENGINEER Help Center

• Pro/ENGINEER Wildfire 4.0 Resource Center

• Technical Support

• PTC Training Services

• PTC User Community

As you become more familiar with these sources, you’ll find that they 
overlap in areas of expertise. A PTC online account is required to access 
PTC documentation from the Web. Register for a PTC online account at 
www.ptc.com/appserver/common/account/basic.jsp.

Note
The Adobe Acrobat Reader is required to read PDF files. See 
www.adobe.com/supportservice/custsupport/download.html to 
download a free Acrobat Reader.

Pro/ENGINEER Help Center
You can access Pro/ENGINEER context-sensitive Help and books in PDF 
format by clicking Help > Help Center in Pro/ENGINEER or through 
context sensitivity. In the Help Center, see Using the Help Center for 
more information.
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Pro/ENGINEER Resource Center
Web-based usability tools can help when learning Pro/ENGINEER. 
Access the Pro/ENGINEER Wildfire 4.0 Resource Center from the 
Pro/ENGINEER browser, through the Pro/ENGINEER Help Center, or 
at www.ptc.com/community/proewf3/newtools/index.htm. The tools 
include the following:

• Web Tools and Tutorials—Step-by-step instructions and other 
helpful topics. Navigate to the tutorials from the Resource Center or 
go directly to www.ptc.com/go/wildfire/get/index.htm and click 
Online Tutorials.

• Quick Reference Card—Handy reference for toolbars, selection 
techniques, dynamic viewing, and more.

• Productivity Tools–An interactive guide to new tools to increase 
your productivity. Included are the selection tools, enhancements to 
viewing tools (Spin, Pan, and Zoom), and the Model Tree.

• Menu Mapper—A cross-reference of menu commands from 
Pro/ENGINEER 2001 and Pro/ENGINEER Wildfire to latest menu 
commands.

PTC Technical Support
Technical support for Pro/ENGINEER is available 24 hours a day, 7 days 
a week. You can contact them by phone, fax, e-mail, or FTP.

You can easily access the most current technical support contact 
information from within Pro/ENGINEER by clicking the Support link on 
the Pro/ENGINEER browser homepage. 

PTC Training Services
PTC Training Services offers a multitude of solutions that embrace the 
Precision Learning methodology. Precision Learning is a continuous cycle 
of Learn-Assess-Improve focused toward providing the right training to 
the right people and doing this at the right time using the right method.

Learning activities, whether taught by an industry-experienced PTC 
certified instructor or a PTC Web course, embrace a “tell me, show me, let 
me do” philosophy to maximize understanding and retention. Visit 
www.ptc.com for a wide range of instructor-led and Web courses offered 
by PTC Training Services (click on Services & Training > Training 
Services).
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PTC Training Services prides itself in the flexibility of its solutions. The 
flexibility in delivery of PTC instructor-led courses includes:

• Course Customization—Courses are tailored to the individual needs 
of your company, eliminating any topics that are not relevant to your 
company’s situation.

• On-site Training—PTC sends the instructor to you and provides 
training machines through our responsive traveling laptop centers.

Assessing the impact of training is key to planning the most efficient 
training, and to measuring the return on your training investment. 
Pro/FICIENCY Evaluator lets you gain an accurate and impartial 
evaluation of your personal, department, and company skills. 

Pro/FICIENCY Evaluator reveals any areas where skill improvement 
would prove beneficial to your design team. Improvement activities 
include Web lessons, (short, tactical how-to topics provided on the PTC 
customer support Web pages,) books, mentoring, and so forth.

Pro/ENGINEER User Community
Pro/USER provides education and communication for users of PTC 
software. They offer ad-hoc yearly seminars at the Pro/USER 
International Conference. Visit http://www.ptcuser.org for a list of 
training seminars.
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