cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Can you change the line style of an annotation?

ulaengin
1-Newbie

Can you change the line style of an annotation?

Is there a way to change the line style of this annotation to solid?

Capture.PNG

17 REPLIES 17

Hi Ulaengin...

How did you make this? This type of annotation usually is solid. I'm curious as to how you created it with a dashed line.

Thanks...

-Brian

I think this is the same picture that was in the hide datum planes discussion that Antonius had the video showing how to make those a different way - annotations.

It is. Antonius showed me how to make those annotations - which I did, but mine came out with a dashed line instead of solid and I'm trying to figure out how to change it. Antonius didn't know - so I started a new discussion.

Hi,

you can create custom symbol for this example

Regards,

Vladimir

Best Regards,
Vladimir Palffy

I know I could "fake" in the datums but I want them to come from the model.

Sorry but for Gtol system symbol and for Reference plane it is not possible set custom line style

Regards,

Vladimir

Best Regards,
Vladimir Palffy

True Vladimir, but why is ulaengin's extension line dashed where mine come in solid? Is this a bug, graphics driver, or release version issue?

If you attach the datum tag either tangent or normal to a surface (can't recall which), I think it affects the line style of the leader. I have to go back and play with it but maybe that has something to do with it?

The orientation in the model is controlled by annotation planes. By default, the annotation is on the selected surface. I moved the orientation to be normal from the placement plane. When I showed it in the drawing, it behaved as expected.

If the view is set up to where the datum plane is facing you, the annotation does not have the triangle. It simply sits there on the face where it is placed and cannot be moved. It has a small hash type arrow in this case but only when it is hilighted.

Good thing is, playing with this has not caused a crash in Creo 2.0 M040. I'll keep trying though

Hi folks

I think we need to start from beginning: Main question is - why do you need to change line style standard for Standard (ANSI, DIN, ISO etc.) GTOL and Reference plane? Do you use different Standard? Why do you need to customize this?

Regards,

Vladimir

Best Regards,
Vladimir Palffy

Are you saying there is a standard that is changing ulaengin's line style?

No, I am sorry - I am saying ... Why do "you" (ulaengin) want to change the standard (for GTOL and reference plane) - it is necessary for your engineering design?

Best Regards,
Vladimir Palffy

I'm not sure I understand you. I'm not trying to change the standard? The standard drawings we use have the datum leader as a solid line as opposed to a dashed line as seen in the picture above...

that is good , the solid line is fine ...

Note: For default configuration of ProE/Creo is it same (datum leader as a solid line).

Try to load your company standard of *dtl file

Best Regards,
Vladimir Palffy

Hi ulaengin,

Did you come to know how to change it ?

Thanks,
Sumanth

I too have the same problem. It seems that if we add the datum symbol from Show model annotations, we get this dotted line, whereas if we add it manually in the drawing, we get a solid line. Does anybody have any solution to this?

Yes you can change the leader line extension. In the drawing go to File, Prepare, Drawing properties. In the configuration file look for "leader_extension_font". Set the option in the value window by typing "solidfont". Hit apply

Good Luck

Announcements