cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Contact tolerance in Creo 2C

gfraulini
17-Peridot

Contact tolerance in Creo 2C

Hi all,

when you start a non linear analysis, the default tolerance at which each step the program tends, is 1e-14.

iterazioni.JPG


In WF5 you could modify this parameter inserting a windows environment variable called "MSE_CONTACT_TOLERANCE_FACTOR", as you can see at page 22 in the attached pdf.
This thing does not work with creo 2.
I don't find anything in the help.

Thanks.
Regards


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

Hello Giulio,

a quick check in the TS database with MSE_CONTACT_TOLERANCE_FACTOR as keyword revealed that setting this environment variable was used a workaround in Creo Elements/Pro 5.0 to counter an issue where thin surfaces have been falsely recognized as interpenetrating, causing endless processing. Since this error has been fixed with Creo Parametric 1.0, the environemnt variable probably has been removed.

See CS6933 : A static analysis is not completed as expected in Creo Elements/Pro Mechanica

http://support.ptc.com/appserver/cs/view/solution.jsp?n=CS6933

Gunter

View solution in original post

6 REPLIES 6
346gnu
12-Amethyst
(To:gfraulini)

Hi Giulio,

You may have done this, but did you restart the software after defining the variable?

Regards

Charles

gfraulini
17-Peridot
(To:346gnu)

Nuova+immagine.bmp

Hi Charles,

yes I've restarted the software, the computer, all. If I use WF5 it works. Only with Creo 2 I've problems.

Dale_Rosema
22-Sapphire I
(To:gfraulini)

Are they reading the same files. If not, did you change it is both places.

Thanks, Dale

Hi Dale,

it's not a file, it's a windows environment variable.

Hello Giulio,

a quick check in the TS database with MSE_CONTACT_TOLERANCE_FACTOR as keyword revealed that setting this environment variable was used a workaround in Creo Elements/Pro 5.0 to counter an issue where thin surfaces have been falsely recognized as interpenetrating, causing endless processing. Since this error has been fixed with Creo Parametric 1.0, the environemnt variable probably has been removed.

See CS6933 : A static analysis is not completed as expected in Creo Elements/Pro Mechanica

http://support.ptc.com/appserver/cs/view/solution.jsp?n=CS6933

Gunter

View solution in original post

achavan
5-Regular Member
(To:gfraulini)

Hi Giulio,

You can try setting it from GUI: File->Options->Configuration Editor. See following pic for rest of the steps.

sim_contact_tolerance_factor.jpg

Announcements