cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - When posting, your subject should be specific and summarize your question. Here are some additional tips on asking a great question. X

Creo 2 drawing dimension tolerance

ungarata
1-Newbie

Creo 2 drawing dimension tolerance

I want to set the tolerances of individual dimensions on a drawing. I have the following two lines set in my config.pro:

 

tol_display yes

tol_mode nominal

 

Two items:

 

1. Creo doesn't like the "tol_mode nominal" entry; it marks it as an error and probably just ignores it.

2. If I right-click a dimension and open the dimension properties dialoge, the "Tolerance Model" dropdown is greyed out.

 

Any ideas how I can change a specific dimension to show tolerances and leave all the others alone?

 

-eric

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Folks

You need to do 2 things here.

1. File -> prepare-> drawing properties->options->change

Type in Tol_dis in the find box and swith to yes.

2. You need to do the same in your config file.

I had this problem and when I switched tol_display in both above options it worked.

View solution in original post

19 REPLIES 19
Dale_Rosema
23-Emerald III
(To:ungarata)

While in the drawing, go to File, Drawing Options, and see if you have tol_display set to yes. It is different than the Tools, Options tol_display.

Thanks, Dale

Yes; I went File -> Options -> Entity Display -> "Show Dimension Tolerances" is checked.

I have no menu selections that will allow me to go "Tools -> Options -> tol_display". I'm using Creo 2.0.

Anything else to double-check?

thanks,

-eric

Dale_Rosema
23-Emerald III
(To:ungarata)

There is one option in the part file (.prt) and another option in the drawings file (.drw). You'll need to set both.

Okay, I opened the .prt file, and went to the same location, and it's also checked to allow tolerances.

???

-eric

Dale_Rosema
23-Emerald III
(To:ungarata)

Highlight the dimesnion that you want to show the tolerances. Right click and go to properties. Select the type of dimension that you want (i.e. nominal - no tolerances, limits, symmetrical, ......).

Hope this helps. If not, I'll have to respond tomorrow.

Thanks, Dale

Yep, that's what I'm doing. Here's a screenshot of the Properties window for a dimension:

dimension+dialogue+box.gif

-eric

I am having the same issue. Hopefully somone finds a solution to this soon.

What version are you using? I see no issue once the options are set in both the config files.

Can you upload your model and drawing ?

Martin Hanak


Martin Hanák
karthik3
6-Contributor
(To:ungarata)

how did you get that dimension properties? I am using creo 4.0, Let me know where can i find that option.

Inoram
13-Aquamarine
(To:ungarata)

Did you change it in your prodetail.dtl? Which is the same as going to attached picture then on Detail Options hit Change.

menu1.JPG

Hi Folks

You need to do 2 things here.

1. File -> prepare-> drawing properties->options->change

Type in Tol_dis in the find box and swith to yes.

2. You need to do the same in your config file.

I had this problem and when I switched tol_display in both above options it worked.

Actually, I have "tol_display" set to "no" in my config.pro file because I don't like seeing the tolerances in the model, but I have it set to "yes" in my .dtl file, and it works fine for me. It doesn't have to be set to "yes" in both.

It's stupid that the list of config options does not mention that this exists in 2 different places.

I am having the same problem. Tolerance Mode is not selectable.

File >options >entity display > show dimension tolerances is not a solution.

What kind of drafting package has an option which prevents tolerancing?

Oh... ...Mark... Did someone mistakenly refer to Creo as having a drafting package?

Just kidding. But yes, out of the box, Creo Detailing is something -very- different than one would expect.

Hello everytone!

 

I've just faced the same issue with my colleague.

He had forgotten to change default units settings from Inches to milimeters in model, and afterwards he had created drafting using template with metric dimensioning. We have struggled for a few minutes, final solution was changing model units to mm and starting new drawing.

 

Hope it works for all.

 

J.V.Madhavan
4-Participant
(To:ungarata)

Please refer to below video. you may get an idea. https://www.youtube.com/watch?v=B2O9pb-Y_ys

How do you set drawing tolerances when you have an imported model where you cannot set the tolerance in the model definition?

Good day all,

I see there are some solutions on the table and would like to inquire if any have worked or if your problem still exists.

Thank you to everyone who has offered solutions.

Best,

Toby

Top Tags