cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Have a PTC product question you need answered fast? Chances are someone has asked it before. Learn about the community search. X

Driving Sketch Not Updating

Chirs33
6-Contributor

Driving Sketch Not Updating

Hey all, I hope I find you well on this fine Friday!

 

I'm working on a model which is driven by a simple sketch brought in via a copy geom. The copy geom is directly below the coor sys in the feature tree and I bring the driving sketch into session before opening my model. Problem is, for some reason the sketch that the model is bringing in via the copy geom is not updating. I have to edit the copy geom, apply changes and then the sketch will update. FYI the copy geom is set to automatic update in the options. 

 

Any help greatly appreciated. 

3 REPLIES 3
KenFarley
21-Topaz I
(To:Chirs33)

From the description of External Copy Geometry:

 

"An independent external Copy Geometry feature remains frozen in its original state, whether or not its external reference model is in session and its geometry has been updated."

 

This *seems* to imply that the part that was copied from can be modified, but it's not reflected in the part that is copied to. Seems odd - why keep a link between the two if they're not going to update?

As another poster suggested, maybe the copy geom feature has been made "independent".  Examine your model and see if this option is unchecked:

ECG.png

Chirs33
6-Contributor
(To:pausob)

Thank you for the replies. Please see below for what I see when I edit the copy geom. I don't have the same options as shown in your screenshot. FYI we are running Creo 4 M080.

 

When I right click on the copy geom and check out the feature information, I can see that the feature externally references the correct file. Dependency is set to automatic update.

Top Tags