cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Erase Graphics / Show graphics

StephenWilliams
22-Sapphire III

Erase Graphics / Show graphics

So I was lamenting the fact that I had several set datums on my drawing that I couldn't layer off and I decided to see what parts these datums were coming from.

As I clicked around the part, I right-clicked and noticed a RMB menu I had never seen before.

ERASE GRAPHICS

So I tried it, it made the datum go away in the model

I reselected the datum in the model tree and right clicked again and I get another menu option I haven't seen

SHOW GRAPHICS

So I tried it, the datum comes back.

Best as I can tell, this doesn't affect my drawing whatsoever but I'm baffled that I had never seen those options before.

Anyone have any insight?

 

show graphics.jpg

erase graphics.jpg


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

So PTC support says its there to hide set datums in the part/assembly. Hmmm, is this a fix for model datum that couldn't be set to a layer?

I'll have to give this a whirl on parts that I have control over. I can't fix those I don't have control over though so I don't think its a real fix but might be a help.

ptcsupport.jpg

View solution in original post

8 REPLIES 8

It's also in the Datum properties dialog box.

dialog.jpg

TomU
23-Emerald II
(To:StephenWilliams)

It's locked on my version and I don't see those menu options.  This is with Creo 3.0 M070.  What version and build are you running?

StephenWilliams
22-Sapphire III
(To:TomU)

Creo 2 M170.

I think its when you click the other datum style, the one that looks like the 1994 datum instead of the 1982 datum even though it really means annotation feature and not annotation feature.

StephenWilliams
22-Sapphire III
(To:TomU)

If you use the 1982 version, you can add the datum to a layer and turn it off.

If you use the 1994 version, you have no layer abilities.

TomU
23-Emerald II
(To:StephenWilliams)

Nope, no dice.  When I first create the other style, the box is unchecked, but it won't let me check it.  If I go back into properties after creation it suddenly is checked and can't be unchecked.  Guess I'll have to call PTC....

TomU
23-Emerald II
(To:StephenWilliams)

PTC got back with me.  The problem was due to the placement type.  "On Datum" placement locks the "Display Datum Graphics" to on.

From the Creo 2.0 documentation:

  • For On Datum, the set datum tag is placed on the datum in a default position. The Display Datum Graphics box is selected by default and unavailable.
  • For In Dim, select a dimension in the graphics window. The set datum tag is placed on the dimension. The selected dimension determines the annotation plane of the set datum tag annotation. The set datum tag is placed in the dimension. If required, select the  Display Datum Graphics box to display the datum graphics.
  • For In Gtol, select a GTOL in the graphics window. The set datum tag is placed on the GTOL. The selected GTOL determines the annotation plane of the set datum tag annotation. The set datum tag is placed in the dimension. If required, select the Display Datum Graphics box to display the datum graphics.
  • For On Geometry, select a geometry. The set datum tag is placed on the geometry at the selected location. The set datum tag is placed in the dimension. If required, select the Display Datum Graphics box to display the datum graphics.

From the Creo 3.0 documentation:

  • Set datums are assigned to the active combination state at the time they are set and the display status of set datum tags is shown. However, the accompanying datum geometry is not displayed unless the placement of the set datum tag is On Datum or you define the datum graphic to be shown by selecting the Display Datum Graphics box.
  • For On Datum, the Display Datum Graphics box is selected by default and unavailable.

So PTC support says its there to hide set datums in the part/assembly. Hmmm, is this a fix for model datum that couldn't be set to a layer?

I'll have to give this a whirl on parts that I have control over. I can't fix those I don't have control over though so I don't think its a real fix but might be a help.

ptcsupport.jpg

View solution in original post

Apple has survived changing the OS to make it incompatible with previously written software and the microprocessor has also changed.

One of these days PTC will stop hurting the vast majority of its set-datum using customers and FIX the SET DATUMS to ONLY SHOW at the related DOCUMENT LEVEL, even though both users who depend on the current BROKEN approach will complain and the 99,99% will be happier.

Announcements