cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Exclude parts in repeat regions by parameter

MK_8566483
2-Guest

Exclude parts in repeat regions by parameter

Hi,

I have a drawing of a sheet metal part that has two instances that differ by one dimension. These instances create two flat patterns. I want to display the instances in a table in the drawing. I want to display the part in flat pattern state, and I want the table to only contain flat instances. In other words, I need to filter (exclude) bent instances (they are identical except that one flat pattern feature is Y and N, i.e. suppressed and not suppressed).
How can I achieve this? I tried various filters, but I can't figure out how to filter by this suppressed state.

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions


@MK_8566483 wrote:

See attached.


Hi,

I added following line to all your filter definitions

&fam.inst.name == *VYKRES

See drawing in attached data set.

 

I also added table containing 2D repeat region.


Martin Hanák

View solution in original post

5 REPLIES 5

Don't know if this will work in your case, but in our BOM table, we have a filter to exclude components based on a part level parameter:

&asm.mbr.ORDER_CODE != ZZ

In this case, the parameter is ORDER_CODE.  If the component has a value of ZZ, it is excluded from the table.


@MK_8566483 wrote:

Hi,

I have a drawing of a sheet metal part that has two instances that differ by one dimension. These instances create two flat patterns. I want to display the instances in a table in the drawing. I want to display the part in flat pattern state, and I want the table to only contain flat instances. In other words, I need to filter (exclude) bent instances (they are identical except that one flat pattern feature is Y and N, i.e. suppressed and not suppressed).
How can I achieve this? I tried various filters, but I can't figure out how to filter by this suppressed state.

Thanks.


Hi,

please upload your data.


Martin Hanák

See attached.


@MK_8566483 wrote:

See attached.


Hi,

I added following line to all your filter definitions

&fam.inst.name == *VYKRES

See drawing in attached data set.

 

I also added table containing 2D repeat region.


Martin Hanák

View solution in original post

Thank you, Martin

 

Marek

Announcements