cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Insert Symbol pulls in old symbol

BenLoosli
Sapphire II

Insert Symbol pulls in old symbol

We have revised some old symbols that used to be Upper/lower case lettering to be all Upper case lettering. The old symbols are relocated to another directory, not under the current pro_symbol_dir defined in config.pro. When we go to select the symbol, the preview window shows it like we expect, all upper case. When it is dropped onto the drawing, it becomes the old Upper/lower case symbol. Using Windchill, no other drawings in the workspace or loaded in memory as the user erases all not displayed between drawings. We are on Creo 4 m080.

 

What would cause the system to grab a symbol from another directory that is not even a sub-folder of the main directory defined by pro_symbol_dir.

The really confusing part is that sometimes we will get the all uppercase symbol.

 

Tags (1)
9 REPLIES 9

Re: Insert Symbol pulls in old symbol

Are there old versions of the symbol on the drawing, maybe erased/hidden not deleted?


There is always more to learn in Creo.

Re: Insert Symbol pulls in old symbol

I will check with the users and be sure they look for any hidden symbols and delete them.

Re: Insert Symbol pulls in old symbol

Been using it since Pro/E 2000 and Windchill since 6.2..6 DSU11.

I was on Unigraphics for 18 years, some times supporting both at the same company as we transitioned.

Always something new and then PTC changes it!

 

Re: Insert Symbol pulls in old symbol

Ben,

 

Are the symbols named the same? Did you erase the old symbol from the drawing first?

Re: Insert Symbol pulls in old symbol

They are named the same.

Other symbols when selected from the folder ask if we want to update it, not this one.

 

Re: Insert Symbol pulls in old symbol

It is Creo, not everything works the same. LOL
You will have to delete the symbol from the drawing and then re-add the new desired one.

Re: Insert Symbol pulls in old symbol

The symbol is not on the drawing.

Selecting it from the symbol library, shows it all capitals in the preview but upper/lower case when placed on the drawing.

I am going to include the latest versions of the 2 symbols that give my users problems as default on a new set of drawing templates I am building to incorporate some other changes. They can then delete the one they do not need.

 

Re: Insert Symbol pulls in old symbol


@BenLoosli wrote:

The symbol is not on the drawing.

Selecting it from the symbol library, shows it all capitals in the preview but upper/lower case when placed on the drawing.

I am going to include the latest versions of the 2 symbols that give my users problems as default on a new set of drawing templates I am building to incorporate some other changes. They can then delete the one they do not need.

 


Hi,

I am sure that you know that symbol is copied into a drawing during its first placement. Even if you delete it from a sheet, it is still included in a drawing.

drw_symbol.png

 


Martin Hanák

Re: Insert Symbol pulls in old symbol

We see that with some symbols, and Creo asks if it should update the old symbol. Not sure what criteria Creo uses to determine if a symbol is old. I have resaved all of the symbols that have been giving us problems last week. I would expect that the new symbol would ask if it want to update, but it doesn't. Some of the other symbols do ask if they should update.

Announcements