cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Learn all about the Community Ranking System, a fun gamification element of the PTC Community. X

Parts not combined in BOM

Paul6
8-Gravel

Parts not combined in BOM

Hi All,

I am experiencing a strange issue relating to parts showing in a BOM in Creo 4 M140.

I have 1 part (screw.prt) with 2 family table members. (2 lengths, screw_L1 & screw_L2).

I have Sub-Assembly A with 4 x screw_L1 and 2 x screw_L2 within and Sub-Assembly B with 2 x screw_L1 and 2 x screw_L2 within.

I have both Sub-Assembly A & Sub-Assembly B in a Master.ASM.

The Master.ASM and the screw.PRT resides in the same folder as Sub-Assembly A ,but Sub-Assembly B resides in a different folder.

Both folders are called out in the search.pro config file.

When I create a drawing of Master.ASM with BOM table. screw_L1 is listed twice, with the quantities from Sub-Assembly A and Sub-Assembly B separately, whilst screw_L2 is listed only once with the combined quantities of Sub Assembly A & B. 

 

What I am trying to achieve is to have screw_L1 to show the combined quantity, like screw_L2 is being recorded in the BOM.

 

Anyone any ideas on why the BOM is recording it differently and how I may resolve this.

 

Thanks for any suggestions in advance.

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Martin,

Thanks for the offer of assistance.

However I have found the reason why, Screw_L1 appeared to be reported twice in the BOM.

It appears that in Sub-Assembly A, the generic of screw.prt was being used and reported instead of Screw_L1.

Screw_L1 was used in Sub Assembly B.

It just so happened the generic screw.prt has the same ID and part description as screw_L1 in the family table.

View solution in original post

2 REPLIES 2
MartinHanak
24-Ruby II
(To:Paul6)


@Paul6 wrote:

Hi All,

I am experiencing a strange issue relating to parts showing in a BOM in Creo 4 M140.

I have 1 part (screw.prt) with 2 family table members. (2 lengths, screw_L1 & screw_L2).

I have Sub-Assembly A with 4 x screw_L1 and 2 x screw_L2 within and Sub-Assembly B with 2 x screw_L1 and 2 x screw_L2 within.

I have both Sub-Assembly A & Sub-Assembly B in a Master.ASM.

The Master.ASM and the screw.PRT resides in the same folder as Sub-Assembly A ,but Sub-Assembly B resides in a different folder.

Both folders are called out in the search.pro config file.

When I create a drawing of Master.ASM with BOM table. screw_L1 is listed twice, with the quantities from Sub-Assembly A and Sub-Assembly B separately, whilst screw_L2 is listed only once with the combined quantities of Sub Assembly A & B. 

 

What I am trying to achieve is to have screw_L1 to show the combined quantity, like screw_L2 is being recorded in the BOM.

 

Anyone any ideas on why the BOM is recording it differently and how I may resolve this.

 

Thanks for any suggestions in advance.

 


Hi,

if it is possible please put all Creo files into single zip file and upload zip file. I can investigate your data and give you some advice.


Martin Hanák

Hi Martin,

Thanks for the offer of assistance.

However I have found the reason why, Screw_L1 appeared to be reported twice in the BOM.

It appears that in Sub-Assembly A, the generic of screw.prt was being used and reported instead of Screw_L1.

Screw_L1 was used in Sub Assembly B.

It just so happened the generic screw.prt has the same ID and part description as screw_L1 in the family table.

Top Tags