cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem opening flat file in Creo 3.

MikeMarcoux
11-Garnet

Problem opening flat file in Creo 3.

Has anyone received the following error trying to open a flat cable file in Creo 3?

"Cabling harness cannot be opened in isolation. Please open the cabling assembly which contains the harness."

We are currently working in Creo2 and M200 w/WC.  A client asked us to modify a cable, but we were missing some of the cable files (MFG).  The sent us the missing files, but they were all in Creo 3.  Unbeknownst to us, they migrated to Creo 3.  We installed a single seat of Creo 3 to modify this on cable, but we keep on receiving the error above.  We've never run into this error in Creo 2, and it has us a bit perplexed.  We're pretty green at the cabling extension, and was hoping some one could shed some light on what we're missing or doing wrong. 


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
1 ACCEPTED SOLUTION

Accepted Solutions

Alright, I have now successfully opened the flat cable files. The issue was not with missing files or the steps I was doing, but with Creo/Windchill itself.

Even after first bringing the cable assembly (XXXX.asm) into session, I was never able to open the flat cable file (XXXX_FLAT.asm) while I was working in Creo3 with the files locally.

I sucked the files into Windchill, and with the cable assembly open I tried opening the flat cable file by using the open folder icon in the tool bar in Creo3. It would still continue to give me this cannot open cable in isolation error each time.

With the cable assembly in session, if I select the flat cable file through the Windchill window, then click on the open in Creo icon, the flat cable would open every time.

So it appears the flat cable files are only opening through the Windchill window. This was observed on the two cable files I was working with.

View solution in original post

6 REPLIES 6

I think this is why we pay maintenance... to submit the files to PTC in a support case and to have them solve the problem.  There will be some legwork, obviously, but it seems you are at that point.  Just submit a support case and have them look over the files.  they can drag info out of there like nobody's business.

Normally, I would go this route immediately, but due to the nature of the work, these files can't be sent out.  We seem to be at an impasse.

It's just really odd that we have zero issues with Creo2, and this error occurs for Creo3. We've been wracking our collective brain to determine if it a config or setting issue, but it doesn't seem to be an issue. 

ykhessin
5-Regular Member
(To:MikeMarcoux)

Mike,

Each flat harness contain two assemblies (3 for the old versions), this error is usually shown when you try to retrieve not the top one. Retrieving the top assembly may fix the issue.

I'm working on these cable files with Mike, so I might be able to expand on the issue.

Antonius Dirriwachter,

The issue here is that we can't share these files with PTC for a support case unfortunately. They are our client's files and are confidential.

Yakov Khessin‌,

I have the XXXX_MFG.ASM file, the XXXX_FLAT.ASM file, the XXXX.ASM file. With the files in Creo2, I can open the XXXX.ASM file and then open the XXXX_FLAT.ASM file and have it open successfully, otherwise it gives me the error saying it cannot be opened in isolation. With the files in Creo3, even if I have the XXXX.ASM file opened first, it still returns the isolation error and will not open the XXXX_FLAT.ASM file. I can see the flat structure in the XXXX_MFG.ASM file, and the drawing displays it properly. But that file will not open alone.

I fully appreciate the confidential nature of your files.  I assumed as much and that is why I didn't suggest posting them here.

However, when submitting a support case, there is a "confidentiality" requirement that you can place on the case.  PTC service would know more, but if it comes to it, it might be worth understanding their process for protecting sensitive data.  At that point, you client can review the process of submission.

That is, if the wonderful minds of this forum doesn't beat you to it

Alright, I have now successfully opened the flat cable files. The issue was not with missing files or the steps I was doing, but with Creo/Windchill itself.

Even after first bringing the cable assembly (XXXX.asm) into session, I was never able to open the flat cable file (XXXX_FLAT.asm) while I was working in Creo3 with the files locally.

I sucked the files into Windchill, and with the cable assembly open I tried opening the flat cable file by using the open folder icon in the tool bar in Creo3. It would still continue to give me this cannot open cable in isolation error each time.

With the cable assembly in session, if I select the flat cable file through the Windchill window, then click on the open in Creo icon, the flat cable would open every time.

So it appears the flat cable files are only opening through the Windchill window. This was observed on the two cable files I was working with.

Announcements