cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Relations from an earlier release?

dgschaefer
21-Topaz II

Relations from an earlier release?

Creo 2, M160

When adding a relation to a part this morning, I got this message:

Capture.JPG

"You are about to edit a set of relations that was evaluated in a release prior to PTC Creo."

On one hand, I understand this, our start part was built in WF5, this is Creo 2.  On the other hand, I've been working with these models all week (and with these start parts for months) and I've never seen this error before.  This particular part was created in Creo 2 and regenerated in Creo 2 many times.

Likely not an issue, but I wonder what changed that triggered this now.  Anyone have any insight?


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
1 ACCEPTED SOLUTION

Accepted Solutions
JLG
1-Newbie
1-Newbie
(To:dgschaefer)

There was a bug with angle dimensions that was identified and fixed.  As I recall, a relations_to_verify.log file gets generated identifying potential problems.  When I checked my .log file, I saw that all the dimensions it was flagging were angular.  I just verified that all the values were correct and went on my way.

View solution in original post

4 REPLIES 4
JLG
1-Newbie
1-Newbie
(To:dgschaefer)

There was a bug with angle dimensions that was identified and fixed.  As I recall, a relations_to_verify.log file gets generated identifying potential problems.  When I checked my .log file, I saw that all the dimensions it was flagging were angular.  I just verified that all the values were correct and went on my way.

View solution in original post

dgschaefer
21-Topaz II
(To:JLG)

That makes sense, I had just added a relation on an angular dim by typing in a parameter name while editing the dim. and saying yes when it asked if I wanted to add a relation.

Do you know what build of Creo 2 fixed it?

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
JLG
1-Newbie
1-Newbie
(To:dgschaefer)
dgschaefer
21-Topaz II
(To:JLG)

Hmm, that applies to tolerancing being incorrect and it says it was fixed in M110.  This model was created in M160 and has only been worked on in M160 (although the template was made in WF5).

I searched the KB for that error message and came up empty.

Not a big deal, my model is correct and the message has not returned.

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Announcements