cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - When posting, your subject should be specific and summarize your question. Here are some additional tips on asking a great question. X

Save as PDF, hidden lines are very short dashed lines, not scaled

TB_7118605
11-Garnet

Save as PDF, hidden lines are very short dashed lines, not scaled

I'm in Creo 7 & Adobe Acrobat X.  I do a Save As/Save a Copy/PDF and the PDF I get has really short dashed lines that are supposed to represent hidden lines, there not scaled to the size of the part.  This wasn't a problem in Creo 6?  Is there a solution?

 

tbuffington_0-1596210251604.png

 

8 REPLIES 8

Are you using a PEN File?  That would be my first thing to check...  if not, you should probably define one and play with the settings.

 

http://support.ptc.com/help/creo/creo_pma/usascii/index.html#page/fundamentals%2Ffundamentals%2Ffund...


Dave

@TB_7118605 

 

Try setting config intf2d_out_pdf_scale_line_fonts as no and export to PDF. I hope this will help.

I could not find that config at all. I also have a similar issue.  We are going from Creo 4 to Creo 7.  All the configs, pentable, etc....are the exact same.  The PDF export on Creo 4 is different than Creo 7 and I cannot figure out why.  I also did some testing and all the older drawings we use dont have this issue (when I say older these drawing started like 5 years ago).  Any new drawings or even a drawing created back in 2017 has this line style issue when doing an export with Creo 7.  Its a very weird situation.  See attached pictorial.  the phantom line style is normal in Creo 4 and in Creo 7 it much tighter/looks like solid.  Hope someone can help.

rbreyette-2_0-1598379479517.png

 

I could not find that config at all. I also have a similar issue.  We are going from Creo 4 to Creo 7.  All the configs, pentable, etc....are the exact same.  The PDF export on Creo 4 is different than Creo 7 and I cannot figure out why.  I also did some trails and all the older drawings we use dont have this issue (when I say older these drawing started like 5 years ago).  Any new drawings or even a drawing created back in 2017 has this line style issue when doing an export with Creo 7.  Its a very weird situation.  See attached pictorial.  the phantom line style is normal in Creo 4 and in Creo 7 it much tighter/looks like solid.  Hope someone can help.

Untitled.jpg

 
 
 

 

BenLoosli
23-Emerald II
(To:rbreyette-2)

It is a hidden option that you need to enter into your config.pro manually.

 

To check out ALL config.pro options, look at www.creosite.com. Olaf has done a great job of listing all the config.pro options, both visible and hidden.

Perfect! I applied that config and it fixed the issue.  Now I do have another issue and this has been going on forever with G-size sheets.  The phantom line style never looked like B-size see attached pic.  The spacing is always larger so at times when you have smaller boxes that are phantom they will not show up phantom because the spacing.  Before I applied your hidden config fix to the B-size the export on a G-size on Creo 7 was much better than Creo 4.  But with the hidden config applied it reverts it back to were the phanton line style on G-size sheets are terrible.  Any ideas how to fix this?

B-size vs G-size.jpg

Thanks in advance 


@rbreyette-2 wrote:

Perfect! I applied that config and it fixed the issue.  Now I do have another issue and this has been going on forever with G-size sheets.  The phantom line style never looked like B-size see attached pic.  The spacing is always larger so at times when you have smaller boxes that are phantom they will not show up phantom because the spacing.  Before I applied your hidden config fix to the B-size the export on a G-size on Creo 7 was much better than Creo 4.  But with the hidden config applied it reverts it back to were the phanton line style on G-size sheets are terrible.  Any ideas how to fix this?

B-size vs G-size.jpg

Thanks in advance 


Hi,

please read old discussion ... https://community.ptc.com/t5/Data-Exchange/Line-Style-change-due-to-Format/m-p/485584#M1720 ... maybe it helps you to solve G-size problem.


Martin Hanák
kdirth
19-Tanzanite
(To:TB_7118605)

Look at Article - CS321071 for the resolution.  In a nut shell there is a hidden config setting intf2d_out_pdf_scale_line_fonts that needs to be set to no.  go to File / Options / Configuration Editor and select "Add..." button. enter the config name, set it to no and select Ok.


There is always more to learn in Creo.
Announcements
NEW Creo+ Topics: Real-time Collaboration