cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Surfaces in drawings slowing me down.

ptc-4278446
Newbie

Surfaces in drawings slowing me down.

Hi all,

We get imported data (iges/STEP) of components which we insert into larger assemblies. These models generally upon import become surface models.

My problems begin when I have to start creating drawings, views take a lot longer to be generated and regenerated.

It becomes hugely frustrating.

has anyone else encountered this?? I have worked on several different pc's running various versions of proe and the problem seems to persist! Have I got something in my config that is causing this, or is there something I can add to stop it!!!!

Any help at all would be fantastic


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.
7 REPLIES 7

Re: Surfaces in drawings slowing me down.

Hello Paul,

try to solidify the imported data with the import data doctor.

regards,

Michael

Re: Surfaces in drawings slowing me down.

Hi Michael,

I have included a couple a screengrabs to show the issue, the second image shows how many open surfaces are in the model. (this is the largest - igs size 13Mb)

If you like I can send one on for you to look at? (will require some kind of contact detail)

Cheers

Paul

pump.JPGpump_wire.JPG

Re: Surfaces in drawings slowing me down.

Hello Paul,

i can estimate that it is a lot of work to repair and solidify every part.

But to get drawings, sections, weights i think it is the only way.

regards,

Michael

Re: Surfaces in drawings slowing me down.

Hi Paul,

The key is to import them as solids instead of surfaces. But importing these kind of large assemblies as solids gives missing information, small surfaces get ignored.

I had this issue also in the past and could solve it by using an external IGES/STEP convertor and then import the new file. This improved the amount of holes and missing surfaces a lot.

Another solution that you can try is making a shrinkwrap of the received product, there is a chance that PRO/E can close the gaps for you.

cheers,

Alain

Re: Surfaces in drawings slowing me down.

Gents,

Thanks for your responses.

Please note the image above is importing as one part, no sub assemblies.

Im presently trying to get the supplier to export as solids, but it seems to be falling on deaf ears

So are there any settings I can use when detailing as this is my main problem??

Re: Surfaces in drawings slowing me down.

Turn down your graphics quality in options. I have noticed that this -really- dogs the application in drawings. No line smoothing, low graphics quality... etc. You can also turn off colors and textures if they're used.

Re: Surfaces in drawings slowing me down.

It may be a part but if it has multiple bodies you can still import it as assembly. Do you get this option in import dialog?

You'd then be able to fix all the volumes one by one.

Also check IDD if there are is not a bunch of different components when you load it in.

Announcements