cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unexpected spin centre position when using filled plane display

pwalton
4-Participant

Unexpected spin centre position when using filled plane display

I am using Creo Parametric 8.0 8.0.0.0

Actually Using Creo 8.0.1.0 - Normally, when spinning a model the spin centre latches to a face/edge/etc.. of the model under the current cursor position.
I've noticed that when the new 'filled plane display' is switched on and there is a plane in front of the model, the spin centre latches onto the plane instead on the model - even if the model edge/surface/etc. itself is highlighted.
Switching the filled plane display off stops this happening.
Is this intentional?
Is it possible to stop this with some configuration option.
8 REPLIES 8
Patriot_1776
22-Sapphire I
(To:pwalton)

I've turned off the spin center, and prefer spinning it around any point I choose instead of the model center, which changes.

pwalton
4-Participant
(To:Patriot_1776)

Hi Patriot, thanks, but the problem only occurs with the spin centre turned off. 

Patriot_1776
22-Sapphire I
(To:pwalton)

Bummer!  But, I'm stuck on Creo 4 so I haven't had any issues.  Good luck getting it resolved!

dpalakkandy
15-Moonstone
(To:pwalton)

@pwalton,

 

I am not sure if i understood the issue correctly. I tried reproducing the issue in Creo Parametric 8.0.1.0 however, couldn't reproduce the issue.

Can you please help me out with some snapshots or some data with which i could reproduce the issue?

 

I think the below information would give you a better understanding on Spin Center:

 

To Set the Spin Center for an Object

The default orientation for an object is set to trimetric but can be modified to be isometric or user-defined. The default spin center of a model is the model center. Use the following procedure to modify it to be any point on the screen.

 

* You cannot set the spin center for an object in the Drawing mode.

1. Click View >  Reorient.

2. From the Type list in the Orientation tab, choose Preferences.

3. From the Spin Center option buttons in the Options section, select one of the following:

Model center

Screen center

Pointorvertex—Select a point or vertex on the object.

Edge or axis—Select an edge or axis on the object.

Coordinate system—Select a coordinate system on the object.

4. Under Default Orientation, select the type of default orientation you want to create (Isometric, Trimetric, or User Defined), and set the angular position of the user-defined default orientation in the X and Y directions.

5. To name, set, save, or delete the view, click the arrow triangle to the left of the Saved Orientations section, and use one of the following:

Save—Type a name for the current view in the Name text box and click Save to save the current view.

Set—Select a name from the list and click Set to display the selected view.

Delete—Select a name from the list and click Delete to delete the selected view.

6. Click OK to accept the orientation changes and remove the dialog box, Undo to undo your orientation changes and start over, or Cancel to abort spin center changes and remove the dialog box.

You can also set orientation using the configuration file option orientation.

 

 

pwalton
4-Participant
(To:dpalakkandy)

Hi dpalakkandy,

This is a test model - a simple block with a datum plane offset in front of it.

pwalton_4-1628932952755.png

With Filled Planes:

pwalton_5-1628933037345.png

 

With filled planes spinning the model becomes more difficult.

I noticed this when working on a small simplified rep of an assembly where the parts I was working on were behind the main datum plane – of course the work around is easy – switch off the filled planes – but I quite like them so am just looking for a way to stop this happening.

Not sure if it was intended like this or just an oversight…

 

 

dpalakkandy
15-Moonstone
(To:pwalton)

Hi @pwalton,

 

Thanks for the images and this really helped me to reproduce the issue.

I think this is working as designed. When the datum plane is not filled, the cursor sticks to the highlighted surface and when datum plane is filled, the cursor sticks to the filled datum plane and not on to the highlighted surface.

Yet another observation made while testing the issue is that the behavior is reproducible only when the Spin Center is hidden. If you show the Spin Center, I see that that cursor sticks to the Spin Center of the model and not anywhere else. So, i would suggest try reproducing the issue with the Spin Center On and let me know your observation.

Looking forward to hearing from you.

 

Regards,

Deepak

As a user, we would expect the the "fill" to be a visual aid only, not an actual surface. If we wanted an actual surface, we would create an actual surface, at least that is my opinion. A user typically turns off the spin center because they prefer to NOT spin around the default spin center.

Well put! - I agree.

Announcements