cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Add option in Creo Parametric to import DWG files without hidden layers (to have right sizes)

Add option in Creo Parametric to import DWG files without hidden layers (to have right sizes)

I opened a case in the ptc customer support site (C13519222) because I have some dwg files that if imported in Creo Parametric have wrong size.

Investigating ptc told me that wrong size are caused by hidden layers in the original dwg files.

Observing Creo View or DWG True View there isn't this behavior and size are correct. Then I asked to ptc if is there an option to avoid import of hidden layers to solve my issue.

They answered that it is not possible, solution for them is to clean the original files, but I can't, it isn't for me a solution. I can't ask to my suppliers to clean drawings because Creo Parametric doesn't have the option to see files like Autocad or Creo View.

 

This is the original conversation:

PTC: Behavior is caused because of the items placed outside the format in original file. Dwg file is having many views scattered outside the format in original file. These scattered items are      hidden in layer and exported with that condition. Creo drawing format size automatically get increased to accommodate these hidden items. Opened this file in AutoCAD 2013 & deleted all      items outside the format - Saved the file. Retrieving this will resolve the issue.

ME: Is possible to use some option (config.pro or dwg_import...) to avoid hidden layers import? If yes I can set it and I will have the same behavior of Creo View or Dwg True View.

PTC: I found this Config.pro in order for the hidden layers not to be exported: Set configuration file option intf_out_blanked_entities to no And also: Refer to Suggested Technique for      Filtering Imported and Exported IGES Data with Layers : http://support.ptc.com/cs/cs_23/howto/idt620/idt620.htm . I will close the case , as the issue has been solved ( via a      workaround ).I wish that the explanations was helpfull.

ME: I tried to set in my config.pro: intf_in_blanked_entities no. Then I imported the affected dwg and I see hidden layers yet. What is wrong please?

PTC: If Hidden layer items are available in AutoCAD file, they will be imported as hidden in Creo automatically. Can’t avoid them. They will stay as hidden in Creo also, but increase the drawing      format size. There is no currently such option any settings to avoid it. We can use “WBLOCK” command in AutoCAD to select the needed objects & save to new file. Import this new file, so      we will be knowing what we are importing in Creo.

ME: Idea Created (but for me it is a bug)

 

 

 

1 Comment
Community Manager
Status changed to: Acknowledged