cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you get an answer that solved your problem? Please mark it as an Accepted Solution so others with the same problem can find the answer easily. X

Creo won't start with WorkerDaemon as a service

BenLoosli
23-Emerald II

Creo won't start with WorkerDaemon as a service

When we switched from WF4 to Creo last week, we also upgraded the settings for the publishing machine and put a local copy of Creo on it. Went through the Adapter.pvi and the Workder.rcp files and updated them to work with Creo2. We were already running the CreoView Adapters, so the only change was Creo2 from WF4. When we start the GS Worker as a service creo will not launch. The GS Worker is calling WorkerDaemon.exe. If I open a command prompt and run WorkerDaemon manually, then I can get Creo2 to start from the Worker Agent Administration window.


Has anyone else had this issue with Creo2 or CreoView? PTC seems stumped on my open call.


Going to cross post this to other groups for better coverage.

3 REPLIES 3

Hi,

Can you be more specific as to what was done, when you mentioned :
"Went through the Adapter.pvi and the Workder.rcp files and updated them
to work with Creo2" ?

What is the current adapter version being used ? I guess you have to refer
to CreoView adapter compatibility matrix and check if its supported with
the version of Windchill & Creo.

-Vaibhav


On Fri, Aug 29, 2014 at 11:45 PM, Ben Loosli <->
wrote:

> When we switched from WF4 to Creo last week, we also upgraded the settings
> for the publishing machine and put a local copy of Creo on it. Went through
> the Adapter.pvi and the Workder.rcp files and updated them to work with
> Creo2. We were already running the CreoView Adapters, so the only change
> was Creo2 from WF4. When we start the GS Worker as a service creo will not
> launch. The GS Worker is calling WorkerDaemon.exe. If I open a command
> prompt and run WorkerDaemon manually, then I can get Creo2 to start from
> the Worker Agent Administration window.
>
> Has anyone else had this issue with Creo2 or CreoView? PTC seems stumped
> on my open call.
>
> Going to cross post this to other groups for better coverage.
>

Here are some helpful articles:

 

BenLoosli
23-Emerald II
(To:BenLoosli)

This issue has never been resolved, even with a rehosting to different servers,

I do not have this issue with my other 2 Windchill systems where we publish on the Windchill server and not a separate workstation. When this system gets upgraded o Windchill 11.1 in December, I will move the CreoView publishing to the server and hope it works there.

Top Tags