Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Make UNDO actually undo across all of Creo


Make UNDO actually undo across all of Creo

I just want to be able to undo anything I just did in any area of Creo (like every other program I have ever used). 



Currently it works really well (as it is supposed to) in Sketcher mode but other than that it is closer to a joke.  First day I train a new person to ProE/Creo I tell them save often and don't expect the undo command to work (when it does work it is like winning the lotto).


I go to move multiple draft entities but because it may be a short line I selected Creo assumes that I wanted the endpoint and it ends up extending the line in an impossible way to undo (even when I still have it selected I cannot unselect is too late)...I cannot undo!  I think we could all add our own examples of not being able to undo in various areas of Creo, so feel free to add some more in the comments area.



Please make undo work in all areas of Creo. 

"When you reward an activity, you get more of it!"

5-Regular Member

And also it would be good if you were able to run a J-Link action listener in the background of your Creo session and not have it automatically kill the undo functionality.

Similarly when editing a drawing "symbol", nothing can be undone in that interface.  NOTHING!

"When you reward an activity, you get more of it!"

My user's example below - Creo 2 Parametric M140


We would like to use UNDO for change the COLOR of model. (Appearance Gallery)

This is the best "product idea" ever. I wonder if they have actually not considered making functionality that works before. If that thought never occurred to them before I doubt that suggesting it now will all of a sudden make sense to them. This is the perfect example of how the PTC coding work is implemented. more than 3 points = do it

1 pt would spamming this new feature in online marketing materials trick someone into buying our product? yes = 1 pt

1 pt do we need to actually finish the idea to include it in a release? no = 1 pt

1 pt is this idea something we have previously coded but isn't included in the current release?

yes = 1pt

-2 pt would this require us removing or fixing existing code that wasn't in the last update? yes = -2 pt

Undo is the first functionality that programmers learn how to build in app development. If they aren't willing/able to do that correctly in this program then that shows that their code complexity and lack of organization has increased beyond their control. Any new updates will mostly need to be additional code in order to coexist in their management model.

The general trick I learned in Creo 3 is that Undo (CTRL-Z)  and Redo (CTRL-Y) often works well inside of feature creation/edit but will reset as soon as you change screens (e.g. accept the feature). I used to think the Undo-Redo system didn't work at all but that's not the case.

If it didn't work at all there were be little confusion of what was undoable and what was not undoable.  Because it is mixed I tell users pretend that it doesn't exist and don't depend on it.  If you need it and it works thank God.  Otherwise have the habit of saving frequently and if you are using PDMLink than check the time and use the Workspace frames.

Undo feature would be VERY useful, like it is in some features,  Creo2 did seem to take a step in the right direction (even if a baby step), because when upgrading from WF4 to Creo2 I was pleasantly surprised to find that there was more actions that were undoable, though I could not list them now.

"When you reward an activity, you get more of it!"

More undo-redo would be helpful but I trying to help people understand how to maximize their current situation by understanding the general logic that PTC has employed. Let's take a scenario of creating an extrude:

  • Create a plane - undo-redo works while defining the references
  • Click Ok - Resets undo-redo
  • Click on the extrude button with plane selected - goes directly into sketching
  • Create sketch - redo-undo generally works within the sketcher
  • Click Ok - Resets undo-redo
  • Change depth of the extrude - undo-redo works although I found it was a little glitchy with some of the other options in Creo 3 M060. Likely should be reported as a bug to PTC.
  • Click Ok - Resets undo-redo

Works the same for rounds:

  • Click round button
  • Select edges, add sets, change round types, change transitions, or any other options. Undo-redo generally works like a charm while playing with these settings. Can be really useful if you accidentally selected something you didn't want on a complicated round.
  • Click Ok - Resets undo-redo

I cannot imagine expecting users to be able to remember this with enough certainty to be able to depend on.  But if this works for you and others on this forum, I am glad that it helps..

"When you reward an activity, you get more of it!"
23-Emerald III

Just noticed this article today from PTC:

Hello everyone,

we have the same problems with no chance to use Redo/Undo in modeling features. We have found out that features which are controlled by an IF-Relation in ProProgram (to surpress them) cause this wrong behavior.

Just for notice:

  • the config option "general_undo_stack_limit" has been set to value 50.
  • the old mass calculation called "MASSPROP" has been corrected.

Unfortunately we can't understand why Creo is not able to let the user go some steps foward or back ?! As mentioned in every other program. When I see that this "idea" (sorry...that's not an idea...that's a big error within the core functionality in Creo) has been puplished in 2014 and we still have no improvement in this case but answers from PTC like "that's an normal bevior...that's not an error because it didn't work never before" then I am really wondering about this software quality.

We just want to make live easier for our users but that's not possible I think...

Are you using Teamcenter IPEMS?

If so there was a earlier release of ipems that turned off the undo functionality in Creo Paremetric.

Hope this helps,


I'm surprised that PLM software such as Teamcenter could have any effect on something like undo functionality in Creo, However we do not use it.  Creo is bad (at undoing) whether it is connected to Windchill or just stand alone.  Like Maximilian Hauck‌ said it is a problem with the core functionality.

I also agree with Maximilian Hauck that this request is more of a fix than an "idea", but unfortunately whether a bug fix, updating the software, or a genuine idea PTC wants us to throw it all together on this "Idea" forum.

Hey, I got an idea! Let's update Creo to the 21st century!    I understand the challenge of updating the core functionality in all areas of Creo, however that understanding doesn't make it any less painful for the user when they go from modern software to Creo (which actually has perfect undo functionality in model sketcher mode, just not good anywhere else) and then back again.  The contrast is painful.

"When you reward an activity, you get more of it!"

Hi Don,

thanks for your comment but we don't use Teamcenter as PLM software. Our models are managed in Windchill (& SAP).

I am with Lawrence Scheeler in this case - i don't think that the problem is caused by an PLM software. In my first job I worked as an designer for a small company and had to handle several customer Creo-environments with different PDM/PLM-softwares in the backround. There was no difference...if there is logic within the part brought into by an IF-Relation redo/undo was not useable any more. Same problem with the MASSPROP-Relation although that can be solved by deleting it.

Hi Don,

I have determined that IPEM is causing my issues with undo.

Do you know how to resolve it?


Hi Dan,

You will need to upgrade Ipem to Hotfix 4

You should not have any issues after that.



We are at Teamcenter Integration for Creo version 11.2.0.

I've been told that version 11.3.1 fixes it but have no idea when we'll upgrade.

There currently is no hotfix for this version either.

Thank you for your reply!


The Undo functionality can sometimes be "deactivated" when a J-Link function is active (Auxiliary Applications).  Stopping or turning off the J-Link function will restore full Undo


Are there any plans, in which Creo release this will be fixed?


I'm especially interested that Undo/Redo is affected by certain customization functions and do not understand the logic of CS143895 "However since Pro/ENGINEER Wildfire 2.0, a Pro/TOOLKIT functions called within command access functions (uiCmdAccess) will not clear Undo/Redo buffer. It is a practical requirement that the Pro/TOOLKIT functions which can modify models should not be called while these callbacks are active, in order to prevent instability in the models." .. why it's made such difference between command access functions and other listener functions? This is maybe an easy to change behaviour that would help in many cases (see also this message thread).

I did also opened a case on that topic.

@_marc, once try the creo default template as a starting part or assembly.

  • When you open new part/assembly window, use uncheck option and proceed to pick the template part / assembly from install dir (or browse to $pro_directory).

In the part or assembly created from default template you may check that undo/redo functions should work properly. In my experience, company sometimes sets a start template with problematic PLM parameters which caused this issue in every part and assembly created from them. Let me know if you find it useful, if so I can cover and share this issue in more detail for others. Thanks.