cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mechanism Animation- Base Part won't stop twirling around

bpenza
5-Regular Member

Mechanism Animation- Base Part won't stop twirling around

I've got an assembly. A conveyor belt with baffle.  The parts all move properly, but the base structure keeps twirling around.  I can't get the base part to stay fixed.    I have created this assembly successfully and then unsuccessfully. Can anyone give advise on this?    Basically, how do we get a part to remain stationary while other parts are moving about?

 

4 REPLIES 4
TomD.inPDX
17-Peridot
(To:bpenza)

Fully constraining your grounded elements -should- solve your problem.

 

However, I've seen some bazar things out of mechanism.

All I can say is to start from scratch and follow all the logic you impart to the assembly.

 

If this is Creo 2 or 3 full version, I can look at it if you post it. 

 

bpenza
5-Regular Member
(To:TomD.inPDX)

Thanks, 

I have done it a few times and sometimes it works fine and others, strange results.   I have noted that if I create some of the moving parts as separate items outside the assembly, I get much better results.   The making of parts within the assembly often causes me strange side effects on the animation side. 

Thanks. for help. 

 

TomD.inPDX
17-Peridot
(To:bpenza)

The only animation artifact I was not able to get around was the zoom factor.

For some reason I couldn't keep the camera "fixed" and it kept adjusting camera's axial position.

 

mbonka
15-Moonstone
(To:bpenza)

Hello @bpenza

 

 first what l got on my mind are external references. If you create parts from assembly level (activate part), then it´s easy to create external reference. This external reference can create a mess during mechanism motion.

Check if problematic part got external references.

 

Regards

@mbonka

Announcements