cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

fail to select objects

swen
1-Newbie

fail to select objects

I fail to select the objects in creo parametric 2.0 almost half of the time and a warning message will pop out saying that"to select the object, hold down Alt key to temporarily disable the selection filters"

Just like this one.

03152223_Y69V.jpg

I don't know what does this mean and what I should do.

Can anybody help me fix this problem?

13 REPLIES 13
MartinHanak
23-Emerald V
(To:swen)

Hi,

to prevent displaying the message, please activate tab related to object you want to select. This method has to be used especially in Drawing mode. For example: If you want to select sketched 2D geometry, then you have to activate Sketch tab.

MH


Martin Hanák

Do you mean to select objects from the model tree on the left? That will work but I'm having problem with directly selecting them in the graphics. After all, selecting objects from the model tree is not as convenient as direct selection.

MartinHanak
23-Emerald V
(To:swen)

Hi,

I mean selecting objects in graphics window. Please describe, what are you selecting and attach picture of your situation.

MH


Martin Hanák

Well, everything here will usually take me 3 or 5 times of clicking before I can successfully select anything. Then it becomes normal for several clicks. After that I cannot select objects with only one click again. It is repeatedly happening like this.

QQ截图20160919215528.bmpw

MartinHanak
23-Emerald V
(To:swen)

Hi,

you picture tells me that you have opened an assembly.

What do you want to select ? Is it some datum plane ? Please attach a picture with arrow pointing to reference you want to select.

What tab in ribbon user interface is active ? Please attach a picture of ribbon interface.

MH


Martin Hanák

Do you mean the menu for modeling on the top? Actually none of the taps is active now since I haven't started anything yet.

I first discover this problem because I wanted to make a sketch, which requires me to select a datum plane before I active the sketch.

Then I realized that I'm having problem selecting planes at once. So I check the stuff I mad before and find that I have the same problem with not only datum planes but also surfaces, lines and extrudes...

I'm not activating anything yet, I just open/create a file and try to select what has already been there.

MartinHanak
23-Emerald V
(To:swen)

Hi,

please start with simple test - create new part using default template. When you finish this step you will see three datum planes in graphic window.

Now put cursor on datum plane outline and select it using:

  1. mouse
  2. laptop touchpad

What is the result in case 1. and 2. ?

If both test are unsuccessful, then open Creo2_loadpoint\Creo 2.0\Common Files\Mxxx\text\config.pro file in Wordpad and add following line at the end of file. Then repeat above mentioned tests.

graphics win32_gdi

MH


Martin Hanák
JamesAvis
12-Amethyst
(To:swen)

What kind of workstation are you using?  I've had some reports of this problem, but only from users on Surface tablets, or using an HDMI connected TV as a monitor.

JamesAvis
12-Amethyst
(To:swen)

Almost forgot to mention that all the users reporting this to me were using Windows 10.  What OS are you using?

swen
1-Newbie
(To:JamesAvis)

I'm just using a laptop with Windows 10.

JamesAvis
12-Amethyst
(To:swen)

Check to see if your laptop and graphics card is on the list of supported laptops.  Also, what build of Creo 2 is it?  Windows 10 support was added in M190.

If you're not on, or similar to, the list of supported configurations, this may just be a hardware limitation.  In my experience, with two people using two identical Surface tablets with Windows 10, one had the issue you are having, the other did not.  However, this was all back on M150.

rkassmeyer
4-Participant
(To:swen)

I know this is kind of an old thread, but we just ran into this same issue where I work and for us, it turns out to be caused by a changed feature of Windows 10 to "scale" certain display items.

Open the Settings of the display by right clicking on the Desktop and choosing "Display Settings"

On the Display settings page, there is a slider labeled "Change the size of text, apps, and other items:"

When not set to 100%, we see this exact issue you are reporting.  It must be due to the setting not mapping the new percentage properly to mouse clicks, pre-highlighting works fine, but selection is hit and miss.capture.gif

tgriffin
4-Participant
(To:swen)

The selection filter is in the bottom right of the screen.

selection filter.jpg

Make sure it is set to smart, all, or whatever it is you are trying to select.  "Alt" just allows you to disregard the selection filter and select anything.

Announcements