cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can Bookmark boards, posts or articles that you'd like to access again easily! X

Add attributes to atict

ptc-3063012
1-Newbie

Add attributes to atict

Hello,

I have attributes called desktop, cycle, show etc., in my atict tags. These are currently fed into the XML file through an external transform program. When I try to open the xml file in ArborText after running this transform it shows the following error:

*** Error on line 22 in file Q:\NextGen_3A\Cycle_1\01 For XPP Composition\01 Clean\10-1111-20.xml:
[A11053] Unrecognized attribute "desktop" for tag "atict:add"

*** Error on line 22 in file Q:\NextGen_3A\Cycle_1\01 For XPP Composition\01 Clean\10-1111-20.xml:
[A11053] Unrecognized attribute "cycle" for tag "atict:add"

Since these attributes are not defined in atict it throws up the error. Can someone advise which file should I modify to add these attributes.

Karthik

8 REPLIES 8

I forget where that file is, but atict supports attr1 attr2 attr3 attr4 etc.
(not sure how far up that goes). It might be easier (and less fragile in the
long run) to use those than to add your own. Some, especially attr1, might
be "reserved" for stuff Editor does out of the box.

On Wed, Feb 10, 2010 at 8:41 AM, Karthik Kumar <
karthik.kumar@merrillcorp.com> wrote:

> Hello,
>
> I have attributes called desktop, cycle, show etc., in my atict tags. These
> are currently fed into the XML file through an external transform program.
> When I try to open the xml file in ArborText after running this transform it
> shows the following error:
>
>
>
> *** Error on line 22 in file Q:\NextGen_3A\Cycle_1\01 For XPP
> Composition\01 Clean\10-1111-20.xml:
> [A11053] Unrecognized attribute "desktop" for tag "atict:add"
>
>
>
> *** Error on line 22 in file Q:\NextGen_3A\Cycle_1\01 For XPP
> Composition\01 Clean\10-1111-20.xml:
> [A11053] Unrecognized attribute "cycle" for tag "atict:add"
>
>
>
> Since these attributes are not defined in atict it throws up the error. Can
> someone advise which file should I modify to add these attributes.
>
>
>
> Karthik
>

Hi Karthik--



The file Paul's referring to is $EDITOR/lib/dtgen/atitag.cf. The atict:
tag definitions begin around line 1051 (for 5.3 anyway). It looks like
attr1 through attr9 are predefined, so you might be able to coopt those,
but it also looks like it wouldn't be hard to add your own (though I
haven't done this myself, so I can't say for sure that it works).



Please let us know what you decide to do with this and how it works for
you. Good luck!



--Clay


I tried to add my attributes into the atitag file but it does not work. However on the atitag.cf file there are note on how to add the new element but all I need is just add attributes. I did not change attr1 to attr9 rather I created new attributes. I am still getting the error.

I have attached what original atitag.cf and the one that I modified. If you can guide me it would be helpful.

Karthik

Hi Karthik-



Unfortunately, it looks like you did exactly what I would have tried.
Since that didn't work, I'm afraid I don't really have any more
suggestions for you. Might be worth filing a support request to see if
one of the PTC engineers can help you sort it out.



--Clay


It has been my experience that changes to the atitag.cf and/or
atiattr.cf require compilation of the doctype to take effect. Does
anyone know for sure if that is still true with XML doctypes?



Allen


When I've done things like that, I put the custom attributes in the atict namespace:

<atict:add atict:extra_info="information">added text</atict:add>

I don't know if that's technically kosher, but Arbortext doesn't complain about it.

-James

Thanks James,

I did the same thing and added custom attributes to my atict tag and I am getting unrecoginzed tag error in AT. Upload the screenshot.

Karthik

Hi Karthik,

Sorry for the delayed response. I tried doing:

<atict:add user="mschleicher" time="1254431917" atict:hello="goodbye">

and Arbortext accepts it without complaint. But if I try:

<atict:add user="mschleicher" time="1254431917" hello="goodbye">

Then Arbortext gives the same error that you posted. If you use the atict namespace prefix, do you get the error? I'm using Arbortext 5.3 M040, so they might have locked it down more in recent versions.

-James


Top Tags