cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Adept 8.1 fails to show (update) changes in a graphic element.

Newbie

Adept 8.1 fails to show (update) changes in a graphic element.

I´m having some difficulties with graphic elements in Adept 8.1.

We have made some customizations in ACL that enables the user to edit a
graphic element (CGM) in an external editor (Visio) when double-clicking on
it. Upon exit from the external editor, the old CGM-file is replaced by the
new one, that is, the old file is deleted and replaced by the new file with
the same name.

In order to get Adept to display the content of the new CGM-file the ACL
code modifies the "name="-attribute in the graphic-tag (oid_modify_attr).
This works just fine in Adept 5.4.1, the graphic element is reloaded and the
content of the new CGM-file is displayed. This approach does not work in
Adept 8.1.

The only workaround I have found so far, is to to modify the
"name="-attribute to a different CGM-file (that exists), and then modify the
"name"-attribute again to the new CGM-file. This is not a desirable
solution.

Deleting the whole figure-tag set and reinserting it does not solve the
problem. The same thing goes for "redisplay" and "set graphics=off|on".

Does anybody have a solution?

I read Anita Nagari's message regarding "Problem with redisplay";

>We are facing some problem with the display.
>In our customized application whenver the caret moves >inside the table ,
we run our own ACL scripts in which >we invoke different toolbars and
menu's.
>
>After the toolbars and menu's appear the edit window >gets blank which
means it doesnt get refreshed. We tried >using the redisplay command but it
doesnt solve the >problem.
>
>However if we put the response command instead of >redisplay , it works
fine.
>
>Similarly when the caret moves outside the table , same >thing happens.

We are experiencing the same problem, just by inserting a new table (without
any customizations). The user has to move the caret outside the table in
order to see the table. Could this possible be a flaw in the Adept 8.1 code?

Ulrik Salde
Sorona Innovation AB
ulrik.salde@sorona.se
Tags (2)
1 REPLY 1

Adept 8.1 fails to show (update) changes in a graphic element.

I´m having some difficulties with graphic elements in Adept 8.1.

We have made some customizations in ACL that enables the user to edit a
graphic element (CGM) in an external editor (Visio) when double-clicking on
it. Upon exit from the external editor, the old CGM-file is replaced by the
new one, that is, the old file is deleted and replaced by the new file with
the same name.

In order to get Adept to display the content of the new CGM-file the ACL
code modifies the "name="-attribute in the graphic-tag (oid_modify_attr).
This works just fine in Adept 5.4.1, the graphic element is reloaded and the
content of the new CGM-file is displayed. This approach does not work in
Adept 8.1.

The only workaround I have found so far, is to to modify the
"name="-attribute to a different CGM-file (that exists), and then modify the
"name"-attribute again to the new CGM-file. This is not a desirable
solution.

Deleting the whole figure-tag set and reinserting it does not solve the
problem. The same thing goes for "redisplay" and "set graphics=off|on".

Does anybody have a solution?

I read Anita Nagari's message regarding "Problem with redisplay";

>We are facing some problem with the display.
>In our customized application whenver the caret moves >inside the table ,
we run our own ACL scripts in which >we invoke different toolbars and
menu's.
>
>After the toolbars and menu's appear the edit window >gets blank which
means it doesnt get refreshed. We tried >using the redisplay command but it
doesnt solve the >problem.
>
>However if we put the response command instead of >redisplay , it works
fine.
>
>Similarly when the caret moves outside the table , same >thing happens.

We are experiencing the same problem, just by inserting a new table (without
any customizations). The user has to move the caret outside the table in
order to see the table. Could this possible be a flaw in the Adept 8.1 code?

Ulrik Salde
Sorona Innovation AB
ulrik.salde@sorona.se