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Arbortext Editor not displaying CGMs in the Editor's View

SarahPrice
7-Bedrock

Arbortext Editor not displaying CGMs in the Editor's View

When inserting .CGM graphics within an XML they do not display in the Editor's view. They display as a graphic icon with a red X however when I print preview the graphics display as expected. I have all the preferences set to display graphics. I believe it may have something to do with the IsoViewer within Editor. Previously when in Editor and I click on a graphic I would get the IsoView icon but now I'm not.

We are currently on Arbortext Editor 7.0 m010.

Any thoughts would be greatly appreciated.

Sarah Price

1 ACCEPTED SOLUTION

Accepted Solutions

We have seen this in the past when renistalling programs.


First I would check that graphics are set to display in editor.  View graphics should have a check mark beside it


Second, see support document CS188158

Primary workaround

  1. Uninstall PTC Arbortext Editor, PTC Arbortext IsoView and PTC CreoView
  2. Install IsoDraw if necessary (prior to installing Arbortext Editor)
  3. Install PTC Arbortext Editor

Bryon

View solution in original post

2 REPLIES 2

We have seen this in the past when renistalling programs.


First I would check that graphics are set to display in editor.  View graphics should have a check mark beside it


Second, see support document CS188158

Primary workaround

  1. Uninstall PTC Arbortext Editor, PTC Arbortext IsoView and PTC CreoView
  2. Install IsoDraw if necessary (prior to installing Arbortext Editor)
  3. Install PTC Arbortext Editor

Bryon

This is from a PTC iquiry. This worked for us and it might work for you if your Isoview is 32 bit and your Arbortext editor is 64 bit. I put their response into a Procedures guide I maintain for our staff.

                      Make CGM Files Appear in Arbortext

Document Details

Title

Cannot see the .CGM illustrations in Arbortext Editor

Description

·         Open a document in Arbortext Editor

·         .cgm graphics do not display in the Arbortext Editor window

Cause

·         registry conflicts

Resolution

·         First workaround (may not be required)

1.    Uninstall PTC Arbortext Editor, PTC Arbortext IsoView and PTC CreoView

2.    Install IsoDraw if necessary (prior to installing Arbortext Editor) not required for most users

3.    Install PTC Arbortext Editor

·         Second workaround (used most of the time for Navistar users)

1.    Run the dos command prompt, but run as administrator

·         Hover over the icon on your desk top or the program name in your programs directory, press right mouse button and select “run as administrator”

·         The instructions below will not work if not run as administrator

2.    Set the default directory in Dos window using the following:

cd “c:\Program Files (x86)\PTC\PTC Arbortext IsoView 7.3”

3.    Register the two .ocx files

·         run  regsvr32 IsoViewX73.ocx

·         run  regsvr32 IsoViewX73_x64.ocx

If this does not work then try running from 4 down in the dos prompt. Note the directory changes and make sure for Arbortext you have the right directory

4.    run c:\Program Files\PTC\Arbortext Editor\bin\x64\editor.exe -UnregAnyServer (This undoes the current registration)

5.    run c:\Program Files\PTC\Arbortext Editor\bin\x64\editor.exe -RegServer  (This redoes registration)

6.    cd to the directory where the IsoViewX73.ocx and IsoViewX73_x64.ocx files are located

7.    Register the two .ocx files

1.    run  regsvr32 IsoViewX73.ocx

2.    run  regsvr32 IsoViewX73_x64.ocx

Changing Directories

·         cd “c:\”

·         cd “c:\Program Files (x86)\PTC\PTC Arbortext IsoView 7.3”

·         And so forth for the other levels you may need to go to.

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