cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Visit the PTCooler (the community lounge) to get to know your fellow community members and check out some of Dale's Friday Humor posts! X

Associate a stylesheet to ditamaps / topics

bfriesen
16-Pearl

Associate a stylesheet to ditamaps / topics

We have multiple stylesheets and I would like the default one to be selected when publishing. Currently if I publish a topic by itself it chooses the correct stylesheet. When I publish a map it chooses a different one.

 

The goal is to have the same stylesheet selected when publishing a topic or a map. I did find a help topic about adding a stylesheet PI https://support.ptc.com/help/arbortext/r8.1.2.0/en/index.html#page/admin%2Fadmin%2Fhelp1394.html  I do not think that is what I want. I also found this one https://www.ptc.com/en/support/article/CS269879?source=search and it does not seem to work. 

 

Currently if I go to format, select stylesheets the editor/default  path is correct to the techinfo stylesheet, but the print/pdf is empty with no association. My guess is that it should be set to the default techinfo stylesheet also. Is that the correct thought? Is there a way to make the setting global for all the users.

 

Thanks

Bryon

 

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks to Tim P  @ptc support. This setting is driven by the instance.acl file located in the doctypes directory. I had the instance.acl techinfo file set correctly, but was unaware that the same file existed in the techinfo map folder. Once I modified that file also it worked as expected.

 

Add the following lines to the instance.acl file. Change the techinfo.style to whatever stylesheet you want to be the default.

 

set stylesheet=techinfo.style
set printstylesheet=techinfo.style

 

Bryon

View solution in original post

1 REPLY 1

Thanks to Tim P  @ptc support. This setting is driven by the instance.acl file located in the doctypes directory. I had the instance.acl techinfo file set correctly, but was unaware that the same file existed in the techinfo map folder. Once I modified that file also it worked as expected.

 

Add the following lines to the instance.acl file. Change the techinfo.style to whatever stylesheet you want to be the default.

 

set stylesheet=techinfo.style
set printstylesheet=techinfo.style

 

Bryon

Top Tags