cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Forcing insertion of default attributes values

Highlighted

Forcing insertion of default attributes values

Hi,

I'm using Epic 5.1.

I defined some default values for some attributes in my DTD.
When I insert a tag containing one of these attributes, the attribute is not
inserted.

1) Is it the expected behaviour of Epic?
2) Is there an option to force the insertion of attributes having default
values?

Thanks a lot,
Benoît
Tags (2)
1 REPLY 1
Highlighted

Re: Forcing insertion of default attributes values

Hi Benoît,

When you say 'the attribute is not inserted' do you mean it isn't showing up in the Edit window? For attributes taking their default values, this is normal behaviour. Even though the attribute is not shown on-screen, it is being read from the DTD. You can see it in the Modify Attributes panel. If the attribute value is a default, the attribute name will be black text on the panel and the default value will be shown. If the attribute value has been set to a value other than the default, the attribute name will be blue text and the selected value shown.

Note that to restore an attribute to its default value (and remove it from the element on-screen) you must Delete any existing value, not just select the default.

This is how it works on Epic 4.3.1.

Hope this helps.

David

David S. Taylor

Structured Information Specialist
Institute for Research in Construction
National Research Council Canada
Bldg. M-23A, Room 239
1200 Montreal Road, Ottawa, ON K1A 0R6
Announcements