cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

IsoView: CGM graphics, raster content is "shuffled"

SOLVED
Newbie

IsoView: CGM graphics, raster content is "shuffled"

When viewing CGMs in IsoView, at the default size, which sizes the graphic to the viewport, the raster portions of the image is all shuffled. Horizontal portions of the image is "shuffled". If you zoom out to about 50% of the viewport size the graphic looks correct, but none of the text is legible because the graphic is zoomed out too far.

here is how the image is displayed:

screenshot_1.jpg

Here is a similar portion of the image, how it is supposed to look:

(the drawing of the plane is a raster image imported into the CGM, while the black arrows are vector elements in the CGM.)

screenshot_3.jpg

All the vector elements are positioned correctly, but the raster portions get shuffled depending on the zoom level.

This is using the 7.2 evaluation copy of IsoView and being used in IE7. The problem also occurs in IE8.

This problem only to select computers, but all running the same OS (Windows XP).

The graphic will look correct on some computers, whereas on others it will be incorrect.

The presence of IsoDraw does not affect the outcome either. Two computers running IsoDraw both have different outputs.

Has anyone encountered this problem before?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: IsoView: CGM graphics, raster content is "shuffled"

here is the response received from PTC:

I found a case with an SPR reported for a similar issue regarding using of ATI Radeon Graphics. The symptoms shown in that specific case mentioned of distorted or blank images when using the ATI graphics. Please try the following workaround and let me know if this resolve the issue.

The following work around was created by R&D:

The user must manually edit the file IsoView 7.2 Preferences.prf. It can be found in %APPDATA%\PTC\IsoDraw\Preferences.

Use Notepad to open the file. Navigate to the entry " Use OpenGL for 2D:" and set this value from 1 to 0. If the entry isn't in the file it can be added.

The result should look like this:

############################################################################

# Display Preferences:

Use Anti-Aliasing: 1

Use OpenGL for 2D: 0

############################################################################

Before changing the file IsoView 7.2 Preferences.prf please make sure, the IsoEngine72.exe process has been suspended (this can be done using the Windows Task Manager).

works perfectly.

Thanks goes out to Hoa Mai@PTC for the quick response.

11 REPLIES 11

Re: IsoView: CGM graphics, raster content is "shuffled"

Hello!

Why do not you convert raster images into vector and then work with them?

Re: IsoView: CGM graphics, raster content is "shuffled"

unfortunately there are too many graphics at this time for that to be a viable option.

Are there any solutions for this error?

Re: IsoView: CGM graphics, raster content is "shuffled"

Could you attach this CGM file?

Re: IsoView: CGM graphics, raster content is "shuffled"

happens with all graphics that contain raster images, here is one. Not the one that was shown above, but behaves the same way when viewed in IsoView.

I've also tried numerous export versions. All with the WebCGM 4 profile though, but different compressions and binary and text versions, and they all behave the same way.

Re: IsoView: CGM graphics, raster content is "shuffled"

Has opened your file in IsoView 7.2 (by using Internet Explorer 9) and I do not see any problems with graphics (try it on different zoom level). I use Windows Vista Business 32-bit.

Pic_1.png

P.S. Сould you record a demo video from your window screen (in WinXP) to see how this issue looks like?

Re: IsoView: CGM graphics, raster content is "shuffled"

calvin.l wrote:

...This problem only to select computers, but all running the same OS (Windows XP).

With Service Pack 3?

Highlighted

Re: IsoView: CGM graphics, raster content is "shuffled"

Yes, Windows XP SP3.

here is a video of the graphic in action. I am zooming out first. You can see the graphic revert to the correct view. But when you zoom in, the raster portion of the graphic becomes distorted.

Re: IsoView: CGM graphics, raster content is "shuffled"

Try to do the following:

1. Update drivers for your video adapter.

2. Create a new "Case" of this issue for PTC's technical support, here: http://www.ptc.com/appserver/cs/case/case_logger.jsp

Re: IsoView: CGM graphics, raster content is "shuffled"

I've narrowed it down to the use of the video driver. If I switch to a generic video driver, the graphic will appear as it should. As soon as I use the manufacturer's video driver the error occurs.

The video driver causing this error is the ATI/Radeon video driver.

Another peculiar behaviour is that the graphic will appear as it should when viewed in the Magnifier Window and Global View windows.

I've started a new Case with Arbortext, and I am awaiting their response.