cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Keep the content of a table on a same page

SOLVED
Highlighted
Newbie

Keep the content of a table on a same page

Hello every one,

I am having a difficulty on Arbortext, I would like to keep the content of a table together but when I generate the PDF if the table is at the bottom of a page it splits the content. I already tried some modification on the stylesheet (keep, indivisibility) but even when I change the different levels of priority to set new rules for keeping content together, it does not change anything.

Do you have any clue to solve this little issue?

Thanks,

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Keep the content of a table on a same page

Hi Camille,

Sure thing.  Anytime a poster or the Help Center refer to an 'Advanced Preference', you can find it by using the following:

Menu option "Tools -> Preferences"

Once the dialog is open, look for the button labelled 'Advanced' on the bottom left of the dialog.

This opens a very long list of preferences listed by their internal names.  If you know what you're looking for, you can scroll through it quickly by typing the first few letters of the setting (in this case 'dee' should be sufficient).

Highlight the setting and click the 'Edit' button (or just double-click the setting) if you want to change the setting

View solution in original post

4 REPLIES 4
Highlighted

Re: Keep the content of a table on a same page

Hi Camille,

Keeping a large object like this together can sometimes come down to some tricky settings in the keeps are you were attempting.  However, there is also a advanced preference called deepcontentsplitting.  What is your currently set to?

set http://support.ptc.com/cs/help/arbortext_hc/ae61_hc/aeAcl/help10103.html?queryId=14fbe380538deepcontentsplitting={ on | off | never}

This set option is used to enable and disable deep content splitting, which allows page breaks in table rows, algroups, and boxed regions. Deep content splitting is enabled using on, disabled using off. The default setting is on.

You can insert a _deepsplit tag pair to circumvent the off setting for set http://support.ptc.com/cs/help/arbortext_hc/ae61_hc/aeAcl/help10103.html?queryId=14fbe380538deepcontentsplitting using Format Touchup Deepsplit Region. To prevent deep content splitting overrides, set this command to never.

Note

Using line numbering with http://support.ptc.com/cs/help/arbortext_hc/ae61_hc/aeAcl/help10103.html?queryId=14fbe380538deepcontentsplitting may produce unexpected results. It is recommended that you do not use line numbering with http://support.ptc.com/cs/help/arbortext_hc/ae61_hc/aeAcl/help10103.html?queryId=14fbe380538deepcontentsplitting.

To disable deep content splitting in your document:

set http://support.ptc.com/cs/help/arbortext_hc/ae61_hc/aeAcl/help10103.html?queryId=14fbe380538deepcontentsplitting=off
Highlighted

Re: Keep the content of a table on a same page

Thank you for your support but you are quoting the Arbortext Styler Help chapter about deepcontentsplit...

I do not know what is my current setting for this feature, because I do not know where I can find it.

Please can you tell me where I can modify the setting of the deepcontentsplit in Arbortext Styler?

Highlighted

Re: Keep the content of a table on a same page

Hi Camille,

Sure thing.  Anytime a poster or the Help Center refer to an 'Advanced Preference', you can find it by using the following:

Menu option "Tools -> Preferences"

Once the dialog is open, look for the button labelled 'Advanced' on the bottom left of the dialog.

This opens a very long list of preferences listed by their internal names.  If you know what you're looking for, you can scroll through it quickly by typing the first few letters of the setting (in this case 'dee' should be sufficient).

Highlight the setting and click the 'Edit' button (or just double-click the setting) if you want to change the setting

View solution in original post

Highlighted

Re: Keep the content of a table on a same page

OK thank you for this answer. I get lost between the settings to be modified by the styler or directly in the preferences. I will try and see if it solves my problem.

Announcements