cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Prevent a row from breaking across pages?

SOLVED
mbarron
1-Newbie

Prevent a row from breaking across pages?

Is there a setting or attribute that can be used to keep a table row from splitting between pages when the table crosses page boundaries?  I've got a table of technical manuals, some with ridiculously long names, and it just looks so ugly when it breaks across a page.  All of the information in the entire row is on the first page -- with no bottom border, mind you -- and the remaining portion of the row at the beginning of the next page contains only the remainder of the title, with all other cells blank, of course.  But I can't make any sense whatsoever of the available table attributes or their options.  And needless to say, Help is worthless.

Thanks,

Mic

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Mic,

It sounds like you need to change the setting for deepcontentsplitting. I've attached the relevant section from my book.

Good luck!

Suzanne Napoleon

www.FOSIexpert.com

"WYSIWYG is last-century technology!"

View solution in original post

6 REPLIES 6

Hi Mic,

It sounds like you need to change the setting for deepcontentsplitting. I've attached the relevant section from my book.

Good luck!

Suzanne Napoleon

www.FOSIexpert.com

"WYSIWYG is last-century technology!"

View solution in original post

Thank you, Suzanne, that was very generous of you!

I did get it to work with the deepcontentsplitting tags, but I'm not sure I did it entirely correctly.  However, the rest of the document seems to be fine.

Keeping in mind that I'm entirely new to Arbortext (within the last couple of months)...

I didn't know what was meant by "selecting it [a particular section of the document] and inserting a <_deepcontentsplitting> tag pair", but I edited the SGML with the "edit -current -untagged" command and inserted "<?Pub _deepcontentsplitting=off>" just inside the <para0> tag that contains the table in question, and then I inserted "<?Pub _deepcontentsplitting=on>" just before the closing </para0> tag.  (We do need it "on" for other tables.)  It was the second row that was breaking across the page, so in doing this I expected row 2 and following to be moved to the next page; however, the entire table moved to the next page.  It's only a 3-row table, so that's not a problem, but I wouldn't want that with longer tables.  I guess I'd just have to insert a manual break in that case?

Thanks,

Mic

Hi Mic,

When formatting a table that breaks across pages, Arbortext Editor tries to keep the first two rows together on the first page and the last two rows together on the last page. If you want the page to break after the first row, highlight the second row in the Edit window and select Tables>Table Properties...>Row. Under Published Output Options, change the Page Break Before Row setting from Default to Force. Other settings are Allow and Inhibit.

HTH.

Good luck!

Suzanne

Awesome, Suzanne, thanks so much!

-- Mic

TimPhelps
5-Regular Member
(To:mbarron)

Did setting the deepcontentsplitting variable to a value of "off" resolve your problem?

Please note, that there is a side affect to doing this.

If the row happens to have enough text in it to make the row deeper than the depth of the page, then text of the offending row will flow off the bottom of the page.

Tim,

Thanks for the heads-up!  That definitely happened to some other tables, so I made sure to turn deepcontentsplitting back on.

Thanks,

Mic

Announcements