cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with Adding a user-defined character set

Newbie

Problems with Adding a user-defined character set

We are upgrading adept apps from 5.4.1 to 8.x (8.1), I have problems with a
user defined character set we use. This worked fine in ver. 5.4.1, but not
in 8.1 .

I follow the documentation (or am i missing something, here goes:

OS: Windows 98
Adept Editor ver. 8.1
name of font to map user defined character entities to: SILDoulos IPA93
(phonetic characters).

1. The following entities will be mapped to the IPA font:

lys-a-oe -> 195
schwa -> 171
aapen-e -> 69
stemt-sj -> 90
slapp-g -> 196
ustemt-sj -> 83
slapp-b-v -> 66
aapen-o -> 141
trykkprikk -> 39

2. I make a *new* file, called 'fonetisk.cf' with content:

charset:fonetisk

lys-a-oe char fonetisk 195
schwa char fonetisk 171
aapen-e char fonetisk 69
stemt-sj char fonetisk 90
slapp-g char fonetisk 196
ustemt-sj char fonetisk 83
slapp-b-v char fonetisk 66
aapen-o char fonetisk 141
trykkprikk char fonetisk 39

and saves it at i:\mydir\fonetisk.cf

3. Copying the file c:\adept\lib\wcharset.cf to i:\mydir\wcharset.cf,
and adds the following line:

fonetisk=SILDoulos IPA93

4. Following env.-variables is set in autoexec.bat:

set APTCSFILE=i:\mydir\wcharset.cf
set APTCHENPATH=i:\mydir\fonetisk.cf;%%D



When I start Adept Editor I get the following error msg:

'Invalid character set "fonetisk" at line 20 file i:\mydir\wcharset.cf'

Anyone got any ideas?

Morten

Morten Gresby (+47 22021682)
STEP Infotek AS (+47 22021680)
morteng@infotek.no, http://www.infotek.no/
Tags (2)
Announcements