cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - You can change your system assigned username to something more personal in your community settings. X

Table FOSI formatting?

ptc-953343
1-Newbie

Table FOSI formatting?

I thought CALS table properties were "automatically" recognized. Within
the editor, I have changed the width of my table to less than a page wide.
This displays as expected in the editor. I then test the composed view and
the table fills the column width. It seems I can change the proportion of
the columns, but I can't get the overal table width to change.

I've set/unset the pgwide value to see if this affected anything - no
difference. I've alos used the table properties which inserts a PI - this
had no chnage.

Any idea what is going on?

..dan
4 REPLIES 4

I think you may have found a bug that affects authored tables and well as
FOSI-generated tables.

In the Table Properties dialog, there is a check box for Use Default (100%),
which if checked means the table will be as wide as the Edit window and will
fill the page width in composed output. If the check box is not checked, the
Display Width property is un-grayed so you can enter the desired width of the
table. This is recorded as a PI such as the following:



I expected this PI to work in a gentable. However, when I tested it in a
one-column table in 5.3, the table was as wide as the page width and did not
honor indent settings.

When I specified the colwidth as 20pi, the table was 20pi wide in the Edit
window and in composed output.

Then I tested specifying the width for an authored table and leaving the column
widths proportional, and the table had the correct width in the Edit window, but
in Preview, it was margin to margin. As with the gentable, specifying the column
widths worked in the Edit window and in Preview.

Hopefully this is fixed in 5.4, which I don't have so I can't test it. If anyone
determines it is not fixed in 5.4, would you please do everyone a favor and
bugreport it to Arbortext technical support?

Thanks!
Suzanne Napoleon
www.FOSIexpert.com
"WYSIWYG is last-century technology!"




-----End Original Message-----

At 07:19 PM 9/16/2010, you wrote:
>Hopefully this is fixed in 5.4, which I don't have so I can't test
>it. If anyone determines it is not fixed in 5.4, would you please do
>everyone a favor and bugreport it to Arbortext technical support?


I'll check on Monday, I'm currently working in 5.2

..dan


---------------------------------------------------------------------------
Danny Vint

Panoramic Photography



In Reply to Suzanne Napoleon:


Then I tested specifying the width for an authored table and leaving the column
widths proportional, and the table had the correct width in the Edit window, but
in Preview, it was margin to margin. As with the gentable, specifying the column
widths worked in the Edit window and in Preview.

Hopefully this is fixed in 5.4, which I don't have so I can't test it. If anyone
determines it is not fixed in 5.4, would you please do everyone a favor and
bugreport it to Arbortext technical support?

Thanks!
Suzanne Napoleon
www.FOSIexpert.com
"WYSIWYG is last-century technology!"



First reponse back from PTC is that this is as intended. If you drag the
column markers and outer edge of the table you are setting propertional
values and even with "Full width" set to off, it is going to make the
table the full width.

If you edit the column properties and set them to a fixed width (3in
instead of 3*) then the table does respect the sizing information.

I indicated that if nothing else this was counter intuitive when
everything about he editor interface indicates that the table will be
smaller than the width of the page. For instance, the editor view shows it
less than the width of text on the screen, table rules shows it as 3
inches, and properties says use a specific width and not full.

I'll let you know how this plays out.

..dan

>
>
> In Reply to Suzanne Napoleon:
> Then I tested specifying the width for an authored table and leaving the
> column
> widths proportional, and the table had the correct width in the Edit
> window, but
> in Preview, it was margin to margin. As with the gentable, specifying the
> column
> widths worked in the Edit window and in Preview.
>
> Hopefully this is fixed in 5.4, which I don't have so I can't test it. If
> anyone
> determines it is not fixed in 5.4, would you please do everyone a favor
> and
> bugreport it to Arbortext technical support?
>
> Thanks!
> Suzanne Napoleon
> www.FOSIexpert.com
> "WYSIWYG is last-century technology!"
>
>
>
>
Announcements