cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Version 5 <?APT PI's

Highlighted

Version 5 <?APT PI's

When I first open most of my SGML documents using Epic version 5.1A,
Windows XP, SP2, I find that Epic has inserted a bunch of processing
instructions.

Example:
Element gi="prtitle">gi="contractno">gi="discl">gi="expcont">gi="downgrd">Element gi="item">gi="step">Element gi="person" attrs="afsc quantity">Element gi="name">Element gi="partno">gi="consum">gi="defhd">Element gi="taskref" empty="yes" attrs="name packetid">gi="reqcond">gi="input">gi="title">external-ptr">attrs="namest nameend align valign morerows">gi="row">gi="colspec" empty="yes" attrs="colname colwidth">gi="tgroup" attrs="cols">Element gi="step-seq">gi="outstd">version iicnum iicdate copytype type">

I tried "save -nopi" but that doesn't get rid of them.

Highlight and delete seems to work, but I am wondering why they are
there in the first place and if they will come back.

Does anyone know?
Thanks,

-Andy

\ / Andy Esslinger - Lockheed Martin Aeronautics Company
_____-/\-_____ (817) 777 3047 LM Aero Ft. Worth F/A-22 TOD
Integration
\_\/_/ Box 748 Mail Zone 4285 Ft. Worth, TX
76101


Tags (2)
2 REPLIES 2
Highlighted

Re: Version 5 <?APT PI's

Andy,

These are the "freeform PIs" that are added only
for freeform (dtd-less) XML documents. You can
turn off the generation of these PIs using
set freeformpis=off
(it defaults to 'on').

See help 2095.

When I do save -nopi, I don't get these PIs
(though the next time I save without the -nopi
flag, they are emitted again).

paul
Highlighted

Re: Version 5 <?APT PI's

I believe the "Somewhere along the way, Epic has thought or still thinks that this is a
free-form XML document. Perhaps if this is an SGML document, then the
doctype was compiled somewhere along the way as XML?
Announcements