cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

We are working to address an issue with subscription email notifications. In the meantime, be sure to check your favorite boards for new topics.

Windows Update Changed File Assoc and Icons - Restore?

RobertWilliams
1-Newbie

Windows Update Changed File Assoc and Icons - Restore?

Not sure if it was a windows, java, or acrobat update, but one of the ones today changed my file associations and icons (which I previously had all of my XML / SGML file associations and icons pointing to Arbortext). XML opened some microsoft xml edit window instead.


So, I changed (at least) my XML file association back to Arbortext, but the icon is still some generic 'page' or something.


My question is, short of reinstalling Arbortext, (happily running 6.0 build M010 with NO - repeat NO issues or problems), is there any other way or trick to reassociate the XML related files (and the icons) back to the Arbortext software family? I loathe the thought of having to reinstall the Arbortext, as (to me, a basic user in a standalone shop) that's just asking for aggravation.


Thoughts? Thanks for reading.


Bob Williams


Bristol RI, US

2 REPLIES 2

I haven't tried this, so it's just a shot in the dark, but you could
run the M010 installer again and select the "Modify" option.  The
resulting sequence of dialogs should include the one to select which
file types to associate.  Following through should restore the
associations (or, so goes the theory, anyway...).

-Brandon 🙂


On Wed, Apr 11, 2012 at 4:41 AM, Bob Williams
<robert.williams@techresearchgroup.com> wrote:
> Not sure if it was a windows, java, or acrobat update, but one of the ones
> today changed my file associations and icons (which I previously had all of
> my XML / SGML file associations and icons pointing to Arbortext).  XML
> opened some microsoft xml edit window instead.
>
> So, I changed (at least) my XML file association back to Arbortext, but the
> icon is still some generic 'page' or something.
>
> My question is, short of reinstalling Arbortext, (happily running 6.0 build
> M010 with NO - repeat NO issues or problems), is there any other way or
> trick to reassociate the XML related files (and the icons) back to the
> Arbortext software family? I loathe the thought of having to reinstall the
> Arbortext, as (to me, a basic user in a standalone shop) that's just asking
> for aggravation.
>
> Thoughts?  Thanks for reading.
>
> Bob Williams
>
> Bristol RI, US
>
>
> ----------

Hi Bob,
We ran into this earlier on 5.3 m110 on Windows XP. It is a greedy
Microsoft file extension grab that repeatedly "stole" the .xml associations
(and icons) as you describe. Our response is to run the following code in
our batch files that we use to launch Editor. We force (using a big fat
sledge hammer) the extensions and icons to our will. Conceivably these
could be set from a scheduled batch file run, too, if you are not launching
Editor from a batch file.

Take special care with respect to registry entries if you run these on an
OS other than Windows XP and assume all registry editing warnings apply!
(And of course, update the Editor installation location to match your
environment.)

assoc .xml=xmlfile
reg add HKEY_CLASSES_ROOT\xmlfile\DefaultIcon /ve /d "C:\Program
Files\Arbortext\Editor53\bin\epic.exe,0" /f
reg delete HKEY_CLASSES_ROOT\xmlfile\shell\Open /f
ftype xmlfile="
ftype xmlfile="C:\Program Files\Arbortext\Editor53\bin\epic.exe" "%%1"



On Wed, Apr 11, 2012 at 1:41 AM, Bob Williams <
robert.williams@techresearchgroup.com> wrote:

> Not sure if it was a windows, java, or acrobat update, but one of the ones
> today changed my file associations and icons (which I previously had all of
> my XML / SGML file associations and icons pointing to Arbortext). XML
> opened some microsoft xml edit window instead.
>
> So, I changed (at least) my XML file association back to Arbortext, but
> the icon is still some generic 'page' or something.
>
> My question is, short of reinstalling Arbortext, (happily running 6.0
> build M010 with NO - repeat NO issues or problems), is there any other way
> or trick to reassociate the XML related files (and the icons) back to the
> Arbortext software family? I loathe the thought of having to reinstall the
> Arbortext, as (to me, a basic user in a standalone shop) that's just asking
> for aggravation.
>
> Thoughts? Thanks for reading.
>
> Bob Williams
>
> Bristol RI, US
>
Top Tags