cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't "place" part in assembly

SOLVED
Highlighted
Visitor

Can't "place" part in assembly

I am trying to import a part into an assembly, and usually, I am prompted to identify the "placement" of the part in the assembly. I do not get this option at all when importing the part. I import the part, it just appears in the window as it does in the model, and there are no other options available. When changing the orientation of the model, the only options are "standard orientation" and "default orientation," although the model itself is able to be oriented from front, top, and back like normal. When I try to right-click on the part in the assembly to edit the placement, the icon for editing the part is not available. 

 

Trouble shooting completed:

- Deleted everything in the model's prt file and tried to import it into an assembly. Still gave no "placement" options. 

- Saved the prt file as an iges file, tried to import into an assembly, and it DID allow me to choose "placement" options. 

 

So I think something is wrong with my prt file. Any suggestions on how to fix this? 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Can't "place" part in assembly

It sounds like you are starting with a completely empty assembly - no datums, no pre-defined views, etc.  When an assy is completely empty, there is nothing to assemble it to so it comes in at the "default" location, essentially aligning the origins.  Also, an empty assy will have no orientations other than standard and default.

 

When creating your assembly make sure that you are using the assembly template that you or your company has pre-defined in order to have the default planes and saved orientations.

--
Doug Schaefer | Engineering Manager
Crow Works
2 REPLIES 2

Re: Can't "place" part in assembly

It sounds like you are starting with a completely empty assembly - no datums, no pre-defined views, etc.  When an assy is completely empty, there is nothing to assemble it to so it comes in at the "default" location, essentially aligning the origins.  Also, an empty assy will have no orientations other than standard and default.

 

When creating your assembly make sure that you are using the assembly template that you or your company has pre-defined in order to have the default planes and saved orientations.

--
Doug Schaefer | Engineering Manager
Crow Works

Re: Can't "place" part in assembly

Ahhh. That is exactly what was happening. Thank you so much!