cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Choppy and laggy rotation of 3D assemblies

Highlighted
Level 1

Choppy and laggy rotation of 3D assemblies

Hello PTC Community!

Hopefully this is the correct place to ask this question, but if it is not, please don't hesitate to let me know where a better place to post this might be.

Anyways, to the problem! My computer is currently having a very difficult time rotating assemblies. Parts disappear while rotating, and the model rotate lags behind my mouse move by almost two seconds (very frustrating!). I am currently working on a computer with 24GB of ram, an NVIDIA quadro 5000 graphics card, and a 8 core 3.07 GHz CPU. Other computers in my office have the exact same specs, but have no trouble flying around assmblies that are 100 times as complex as mine.

Please let me know if you have any ideas as to why my computer is so slow! Or if you need more information about my computers specs.

Kind Regards,

John

6 REPLIES 6

Re: Choppy and laggy rotation of 3D assemblies

Compare these settings between your computer and others in the office.

13.PNG

14.PNG

Re: Choppy and laggy rotation of 3D assemblies

Another possible reason is config option "Graphics" which might be set to win32_gdi. If exists, set as opengl (default)

Re: Choppy and laggy rotation of 3D assemblies

Thanks for the quick reply Tom!

My PTC settings are the same as other computers in the office. These are the following values.

Shade quality: 3

Shade small surfaces: checked

Edge Display Quality: Medium

I am thinking that the issue is related to the driver software that is currently on my computer. I've found things mentioning OpenGL but have not been able to follow their instructions.

Re: Choppy and laggy rotation of 3D assemblies

Hello Mahesh!

Where do I access the config option "graphics"?

Re: Choppy and laggy rotation of 3D assemblies

File > Options > Configuration Editor and check for graphics in the list.

Just to double check: Select File > Help > System Information > Check for "Creo Parametric Graphics Type" OpenGL or Win32_gdi ???

Sys.jpg

Re: Choppy and laggy rotation of 3D assemblies

John,

Was the option provided by Mahesh helpful?

Note that this option will require a restart of the software to take effect. Also note that in newer releases, I think this option is no longer searchable; just add it manually.