cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Components moving in assembly

SOLVED
Highlighted
Newbie

Components moving in assembly


Hi Friends,

I had created a small assembly consisting of 10 cables and some conduits. In the drawing I had saved the support frames as draft entities.

But later, I did not need one of those cables. So I deleted it. But when I did that, the rest of the cables move from their respective co-ordinates and position themselves at the wrong place.

I assembled the model by co-ordinate systems (not by normal mates).

Can anyone give me an idea why this is happening and how to rectify this?

Thanks

Mahesh

Tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Components moving in assembly

Hello Gunter,

Yes you are right. By the title, since the cables are the sole components in my assembly i mentioned so. Sorry for the confusion.

I figured out the problem. The problem was, the moment i delete some cables, the overall view size is altered to a smaller size in the drawing view. Since the skeleton is in draft entities, it seems as if the cables are moved to a wrong position. But in reality, we just have to unrelate both the views and manually move it according to the current view size.

Thanks

Mahesh

View solution in original post

4 REPLIES 4
Highlighted

Re: Components moving in assembly

Hello Mahesh,

from your description I understand that cables change their location - to some extend this can be expected, since cabling features affect each other not in a sequential way as you are used to from other features in the model tree. Later cables may affect those created earlier. And in return removing cables might have an effect, too.

But what confuses me: Your title says "Components moving in assembly". You actually mean cables moving, not the components, right? Cable routing is created by features from the harness model (which would be a component of the assembly).

Regards,

Gunter

Highlighted

Re: Components moving in assembly

Hello Gunter,

Yes you are right. By the title, since the cables are the sole components in my assembly i mentioned so. Sorry for the confusion.

I figured out the problem. The problem was, the moment i delete some cables, the overall view size is altered to a smaller size in the drawing view. Since the skeleton is in draft entities, it seems as if the cables are moved to a wrong position. But in reality, we just have to unrelate both the views and manually move it according to the current view size.

Thanks

Mahesh

View solution in original post

Highlighted

Re: Components moving in assembly

Thank you for letting us know, Mahesh!

So a rescaling of the view with the cables tricked you into believing the cables have moved, because you were viewing them with respect to another, related view.

In reality they were not, just the layout of the drawing got slightly disarranged and had to be corrected.

I am marking your post as Correct Answer, to signal that this question/issue has been resolved.

Regards,

Gunter

Highlighted

Re: Components moving in assembly

You are welcome. And thank you for your suggestions as well.

Regards

Mahesh C

Announcements