cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mechanism Errors

SOLVED
Level 6

Mechanism Errors

I'm teaching a Creo course. I am not able to replicate my students errors, but it has happened enough times, I'd like to find out answers for them.

The assembly is a geneva wheel with liftoff enabled cams. The assembly is relation driven to allow modification to the number of stations.

Several students are getting "The mechanism constraints could not be satisfied. The mechanism could not be assembled." The issue warning on failure button is checked.

If they un check the button, how do they get that option back?

Any thoughts on whats causing the failure? Failures tend to occur more with higher frame rates for the position analysis.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Mechanism Errors

I think I found it.

In model properties, under Assembly, mechanism, user defined settings.

You can re-enable the warning and set the relative tolerance to be a lower value.

6 REPLIES 6

Re: Mechanism Errors

I don't know the answer to all your questions but there was a recent discussion that helped my mechanism error rate... save snapshots!

The idea is that any time you drag things, the regeneration turns yellow. Somehow, you cannot get a successful regeneration with the components in a dragged position. The same is true if you play the analysis and the end positions are not the same as the original condition. Again, the regeneration fails. Restoring snapshots created at good regeneration states resolves both these issue.

Re: Mechanism Errors

I think I found it.

In model properties, under Assembly, mechanism, user defined settings.

You can re-enable the warning and set the relative tolerance to be a lower value.

Highlighted

Re: Mechanism Errors

Nice find

Re: Mechanism Errors

If that fixes it, don't forget to mark you answer as correct for those who may come behind and search for the same answer.

Re: Mechanism Errors

I also get this error when i try to drag components, but for me this was not the solution, after some time i found what was the problem, so maybe if anyone gets this error it might help.

I have higher assembly where i have all assemblies and lower assemblies where are parts

Higher assembly is made of more lower assemblies, which means that higher assembly is the final assembly.

I made this error because i moved the part in lower ass. that contains mechanism in higher ass., but i moved it out of mechanism range - PIN like (0° - 180°) - mechanism range, but i moved it in lower assembly over 180 degrees and left it in that position.

I was geeting this error because my mechanism was no longer connected, if you get this error just simply delete the mechanism (cam), it might help.

My english is not wery good, i hope you understand me what am i trying to say

Re: Mechanism Errors

Being diligent about creating snapshots and keeping snapshots up to date is the easiest solution to recovering disconnected errors.