cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Missing Cosmetic Threads on drawings - Pattern Leader only.

SOLVED
Highlighted
Level 1

Missing Cosmetic Threads on drawings - Pattern Leader only.

Hello,

I created a part with a number of patterns of tapped holes. When I made a drawing, the pattern instances showed up as I expected, but the pattern leader had no sign of a cosmetic thread. So, I have tapped holes that look good, but I can't show their dimensions, and a tapped hole that doesn't look tapped, but which has all the dimensions I could ever wish for. Plus a drawing view that is just plain wrong.

Have I made some mistake here? Or is this a feature/bug?

 

WF2 M220

 

 

 

Thanks,

 

 

 

John

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Missing Cosmetic Threads on drawings - Pattern Leader only.

Thank you, Brian.

Extraordinarily, when I opened the drawing afresh this morning, all the cosmetic threads showed up correctly. I had restarted Pro/E before I wrote the original post - If in doubt, Reboot! - but it didn't go away.

 

Weird.

 

 

Anyway, problem solved - until the next time standard holes play up, I suppose.

 

 

Regards,

 

 

John

3 REPLIES 3

Re: Missing Cosmetic Threads on drawings - Pattern Leader only.

HI John...

I'm assuming from your post that you used the Hole Feature with the Tapped Hole option. Is this correct? If so... choose a small pattern and delete it LEAVING the original hole. Does the tap show up now? What I mean is... does the tap show up correctly on the drawing when there's no pattern? If so... once you pattern it, does the hole tap disappear on the leader again? Just wondering... this might help us come up with a solution.

At Planet PTC in Orlando, we had quite a lively discussion on the benefits and limitations of the Standartd Hole Feature. This is where you can pick from a list of standard hole sizes, taps, etc. My contention is that it has some limitations that regular holes do not have... so I do not use the standard holes at all. I've never seen this happen to a standard hole before- but then again, as I said, I don't use them for just this type of reason.

In a pinch, if we cannot figure out how to solve this problem, you can always create a regular hole, pattern it, then create a cosmetic thread as a separate feature and ref pattern it to follow the hole. This definitely works at WF2 and will get you passed the problem.

One side note... whenever you pattern a cosmetic thread, it seems that the PARENT thread maintains all the correct thread data (form, pitch, etc). The instances do NOT maintain this data. This has been a problem all the way back to at least Pro/E 2000i^2 which goes back at least 12 years.

Thanks!

-Brian

Re: Missing Cosmetic Threads on drawings - Pattern Leader only.

Thank you, Brian.

Extraordinarily, when I opened the drawing afresh this morning, all the cosmetic threads showed up correctly. I had restarted Pro/E before I wrote the original post - If in doubt, Reboot! - but it didn't go away.

 

Weird.

 

 

Anyway, problem solved - until the next time standard holes play up, I suppose.

 

 

Regards,

 

 

John

Re: Missing Cosmetic Threads on drawings - Pattern Leader only.

Strange! At least everything's working again as it should!

I'm always amazed at how many problems crop up and then mystically go away again! It happens often enough to make you wonder if there's not a ghost in the machine somewhere.