cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Stop part from moving when placing constraints

Highlighted
Regular Member

Stop part from moving when placing constraints

When placing a constraint the part moves.  How can I stop this behavior?  Thanks.

6 REPLIES 6
Highlighted

Re: Stop part from moving when placing constraints

Don't know of any way to set constraints without the part moving in compliance with those constraints.

Also no way to keep offset values for a constraint when you change one of the references - it always makes the updated constraint "coincident".

Highlighted

Re: Stop part from moving when placing constraints

It doesn't always do this for me, so it must be some sort of function of distance between the parts when the part is added and the overall size of the assembly.

Highlighted

Re: Stop part from moving when placing constraints

If you go into the Placement box and uncheck the constraint enabled box, the part will not move as you are setting the constraints.

 

PLACEMENT.JPG

Highlighted

Re: Stop part from moving when placing constraints

The problem with that is I'll need to go back and check that box again.  Old Pro/E had a checkbox called Preview that could be unchecked.

Highlighted

Re: Stop part from moving when placing constraints

A couple of different solutions come to mind.

  • Unchecking the "Constraint enabled" box as suggested by someone.
  • Setting a Fix constraint before adding the other constraints.
  • Using the separate window to pick your references, rather than picking them in the main graphics window, if this is the problem (i.e. the part moving makes it harder to select the references you want). You can even turn off displaying the part in the main graphics window if it tends to hide the geometry you want to select in the assembly.
  • If the issue is that the part moves to "coincident" when it should be "distance", try setting the constraint to "distance" before adding it (i.e. not using the "automatic" constraint).
  • If you want this as the default behavior, the following settings control the behavior of the "Automatic" constraint:
    • auto_constr_always_use_offset
    • comp_angle_offset_eps
    • comp_normal_offset_eps
    • auto_constr_offset_tolerance

 

If none of these are solutions, could you explain how you would like Creo to behave? I.e. describe more in detail why the behavior is an issue.

Highlighted

Re: Stop part from moving when placing constraints

I'll try using the separate window.  I remember this option back in Pro/E.

Announcements
Business Continuity with Creo: Learn more about it here.