cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Why do sketches show up in no hidden view

Highlighted
Newbie

Why do sketches show up in no hidden view

Surely someone has asked this question, I just cannot find it.

 

Environment: Creo 3.0, part or assembly, No Hidden display style

 

I have a part that I have written text on using a sketch and that sketch can be seen no matter the orientation of the part in any of the hidden line modes. See Capture.png, text should not be visible from that angle.

 

I know I can just hide the sketch but this becomes problematic in an assembly with many items with many sketches. Besides I really dont want to hide the sketch because it represents marking on the item that's really there.

 

I have found that if I turn Fast HRL off then the sketches hide properly but then all the cosmetic threads show up. See Capture2.png, thread should not be visible from that angle.

 

I might be able to get around this if I were to make a drawing of the assembly, but this to becomes problematic when I need many images in different orientations.

 

All I want is a real No Hidden line view for illustrations.

 

Does anyone have a workaround or can you direct me to where this question has already been answered?

18 REPLIES 18

Re: Why do sketches show up in no hidden view

Brian,

just info for you ... I was not able to reproduce the problem in Creo Parametric 3.0 M030 (simple brick model with one sketch and one cosmetic thread.

Martin Hanak


Martin Hanák

Re: Why do sketches show up in no hidden view

Well that's odd. I just confirmed it does it for me on both 2.0 and 3.0. And other users here have had the same problem. There workaround is to set up layers and turn everything on and off accordingly.

But that's interesting that it doesn't do it for you, you think it could be a graphics issue?

Re: Why do sketches show up in no hidden view

Martin,

Would you be willing to share your config settings? Maybe we have some kind of odd combination of settings causing the issue.

Thanks

Brian

Re: Why do sketches show up in no hidden view

Brian,

I uploaded my test model + drawing. It was created in Creo Parametric 2.0 M070 using default settings (this means without any config.pro). You can open my drawing and test it. Also you can use the same "procedure" as me.

Martin Hanak


Martin Hanák

Re: Why do sketches show up in no hidden view

I started up Creo with out my normal config.pro and opened the part and it seems to do the same thing.

Are you looking at the drawing or the part? My difficulty is that I don't want to have to make a drawing because reorienting in a a drawing is a pain.

If you open the part and set the Display State to No hidden you should see either the cosmetic thread or the sketch through the back of the part. Then when you turn off or on the Fast Hidden lines removal you should see the opposite.

Can you (or anyone else) confirm that this doesn't (or does) happen to you when viewing the part?Capture3.PNG

Capture4.PNG

Re: Why do sketches show up in no hidden view

I can confirm that on Creo 2 M120, I get the same results as you. I either see the cosmetic thd or the sketch.


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: Why do sketches show up in no hidden view

Great thanks Stephen!

That tells me it is less likely to be a video card or config option stack up issue.

Now if anyone could just tell us how to fix it!

Re: Why do sketches show up in no hidden view

I don't know if there is a "fix". My work-around would be to add the cosmetic threads to a layer and turn that layer off, simply because I suspect you may want to see your sketch occasionally.

Depending on your setup, you may already have a layering scheme that will do that for you.

It's just a work-around, but I agree, a fix would be in order.


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: Why do sketches show up in no hidden view

To the best of my knowledge, it has been this way ever since Wildfire 2, and maybe before. Cosmetic sketches have always shown through the solid. It's like they're perpetually in wireframe mode.

Like Steve said, the only workaround was to add them to a layer and then hide them.

Announcements