cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Why is drawing rep displayed different than model rep?

Level 15

Why is drawing rep displayed different than model rep?

I have an assembly that includes sub-assemblies. In the assembly mode I created a simplified rep showing a variety of parts. When I use that simplified rep in a drawing many parts don't appear. It seems like the drawing evaluation of a simplified rep is different than the assembly mode evaluation of the same rep.

 

The problem seems to be that if I mark a sub-assembly as Exclude the drawing evaluation considers all its components Excluded, even though in the assembly many of the pieces are MasterRep.

 

It looks like I'll have to MasterRep the affected sub-assembly and then manually select and Exclude the hundreds of parts that I don't need to see.

 

Creo 2 M070.

8 REPLIES

Re: Why is drawing rep displayed different than model rep?

I was surprised to hear that, so attempted to reproduce it myself, and it did not occur.  The parts in Master Rep under a subassembly with Exclude showed up fine in both assembly and drawing mode.  I'm not sure what would be special about your circumstances that would make it different.  Could you perhaps file a case with Tech Support?

Re: Why is drawing rep displayed different than model rep?

Probably not. Too many CND or will be fixed in 2 years, sort of answers and I'M definitely not interested in 'performs to requirements.'

I expect a code review would be required to see why the drawing mode evaluates the simplified rep with different code than the assembly mode code does; but then there should only be one module to do that evaluation, in which case the results would be identical.

I noticed a similar problem with explode lines being trimmed differently between the assembly mode view and the drawing mode.

Re: Why is drawing rep displayed different than model rep?

I agree with Matthew. I use simplified reps all the time on large assemblies, just finished up a drawing with several different reps portrayed and haven't ever seen this issue.

Things to check:

1. Make sure you save your rep in the model. Depending on how you created or modified it, you may need to save the rep.

2. check layers to make sure you don't have components on layers

3. make sure your drawing views are actually using the simp rep you think they are using by checking the view properties in the view states tab.

Re: Why is drawing rep displayed different than model rep?

Good thoughts, especially the one about layers.  Without being able to see it, one other thing that springs to mind is File>Prepare>Drawing Properties, then issue the detail setup command update_drawing all (by putting 'update_drawing' in the name field, 'all' in the value field).  If the drawing appearance is improved after regen or retrieval after the update, it would signify the problem was previously fixed, but the fix protected by versioning to avoid modifying released drawings.

Re: Why is drawing rep displayed different than model rep?

Done, done, done. Simp rep user since like rev 18.

I do love having to detour to make the save. Imagine that UI element getting added elsewhere. Change a dim, regen, and then have to 'Save' the change in order to be able to Save the change in the model file.

If it was layers, changing the rep status wouldn't change the visibility

If it was the wrong rep changing the rep status wouldn't change the visibility.

I think the PTC developers found a fork in the code and took it so that the drawing evaluation doesn't match the assembly evaluation for some case that has nothing to do with user-side actions. There is likely a setting being stored that the drawing evaluation section takes as a signal to skip part of the evaluation.

Re: Why is drawing rep displayed different than model rep?

Is it repeatable? So specifically, in your top level assembly, you exclude a sub-assembly but you set sub-components as master rep, correct?

I created a new assembly with some a couple of subassemblies and couldn't reproduce your results as I understand them.


Re: Why is drawing rep displayed different than model rep?

I suspect you won't be able to. There is probably a setting that is software managed in the model/drawing data that is interpreted differently between the assembly and drawing modes. This is a setting that is not user accessible.

My complaint is that PTC did not use exactly the same software to interpret Simplified Reps in the assembly and drawing modes.

I would love to take credit for the whole thing, but I am updating, including -new- simplified reps and -new- views, models and drawings that go back to 1997. As such it's unlikely I'd be able to figure out when the failure was introduced or how and it really doesn't matter, because it is a problem that should not exist at all.

Highlighted

Re: Why is drawing rep displayed different than model rep?

Does the same thing happen on another users's PC?