cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

context menu bug in Creo 2.0

SOLVED
Highlighted
Bedrock

context menu bug in Creo 2.0

Hi there,

 

it happens occasionally, that context menus (right - click dialogues) do not work any more.

The video shows that scenario when editing transitions. Strangely, the menu suddenly disappears only on entries below "Pick from List".

 

The video shows this bug with Creo 2.0 M060, but it happens from time to time also in later versions.

Updating drivers (Nvidia) seems to have no influence on that issue.

 

System:Quadro 4000; Win7 64bit

 

Does someone spotted the same or similar graphics problem?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: context menu bug in Creo 2.0

Hello,

i have the same Problem since some Versions of Wildfire and Creo (actual Creo 3.0 M060).

After some Test i figuered out, that the reason seams to be an additional 3D mouse. I had the Space Navigator from 3d Connextion and now also tried the one from Space Control. With both i had the effect, that after a while the problem with the right mouse Menu appeared. When not working with the 3D mouse (not pluged in and driver dissabled) the effect does not appear. So for me its pretty shure, that this must somehow be the reason (dont' have an idea why exaclty). I also figured out together wiht the service of SpaceController, that the the RefreshingButton (STRG R) in an Assembly causes sometimes that the problem is "healed" and the right mouse menu is working properly again for a while. So it seems to has to do also with refreshing of the screen (maybe screen is refreshed without the menue and so it disappears). Hope this helps you and maybe somebody else a little. Would be interested if you also work with a 3D mouse and you can confirm what i observed.

My System: AMD FirePro W7000, Win7 64Bit

View solution in original post

20 REPLIES 20
Highlighted

Re: context menu bug in Creo 2.0

It seems more like a mouse (or input) issue then a graphics issue. Like something is canceling the menu.

Highlighted

Re: context menu bug in Creo 2.0

Matthias,

As Matt mentioned this seems to be a mouse/graphics problem. Did you get a chance to test this with a different mouse?

Highlighted

Re: context menu bug in Creo 2.0

Hello,

i have the same Problem since some Versions of Wildfire and Creo (actual Creo 3.0 M060).

After some Test i figuered out, that the reason seams to be an additional 3D mouse. I had the Space Navigator from 3d Connextion and now also tried the one from Space Control. With both i had the effect, that after a while the problem with the right mouse Menu appeared. When not working with the 3D mouse (not pluged in and driver dissabled) the effect does not appear. So for me its pretty shure, that this must somehow be the reason (dont' have an idea why exaclty). I also figured out together wiht the service of SpaceController, that the the RefreshingButton (STRG R) in an Assembly causes sometimes that the problem is "healed" and the right mouse menu is working properly again for a while. So it seems to has to do also with refreshing of the screen (maybe screen is refreshed without the menue and so it disappears). Hope this helps you and maybe somebody else a little. Would be interested if you also work with a 3D mouse and you can confirm what i observed.

My System: AMD FirePro W7000, Win7 64Bit

View solution in original post

Highlighted

Re: context menu bug in Creo 2.0

Hi Stefan,

meanwhile we switched to Creo 3.0 and this bug still occurs from time to time.

And indeed, all CAD - Workstations are equipped with a SpaceMouse Pro.

I will try Your STRG R (CTRL R ) trick the next time and let You know if it helped.

Highlighted

Re: context menu bug in Creo 2.0

Hi there,

i probably found the reason for the context menu bug. When Preselection (Options -> Selection -> preselection) is deaktivated the Problem sems not to appear. Even when Preselection is aktivated and the Problem accures i can deaktivate preselection and the context menue works.

So i would be interested if somewone can confirm this. Although this can just be a workarround (to disable preselection for a short time -> i did make a mapkey for that). In my opinion one can not work effektively without preselection.

Hope this helps someone with the same (annoying) problem.

Stefan

PS meanwhile i also tried out another 3D mouse (besides my SpaceNavigator) and it had the same Problem...

Highlighted

Re: context menu bug in Creo 2.0

Hi Stefan,

thank You for evaluating another 3D Mouse (from another vendor, right?). So 3Dconnexion seems not to be the one to blame.

I will check Your "preselection" workaround the next time this problem occurs.

Matthias

Highlighted

Re: context menu bug in Creo 2.0

That fixed it!  Thanks!

Highlighted

Re: context menu bug in Creo 2.0

Right this morning I had this issue again while working in a drawing.

"Repaint" (not using STRG R, but the according button) solved it for the moment.

As soon as the problem occurs in 3D - mode, I will try "Repaint" again.

Highlighted

Re: context menu bug in Creo 2.0

I checked Your "Repaint" method several times.

It works when the odd menu bug occurs and also when preselection highlighting is not working properly.

Thanks for Your solution.

Highlighted

Re: context menu bug in Creo 2.0

I'm having the same issue for awhile now. Plus I'm the only member using a Space Mouse Pro (or any 3D device) and I saw issue on mid-releases of Creo 2.0 and 3.0.

System:

Win7 64-bit on Lenovo laptop. NVIDIA Quadro K2100M (latest driver). Currently running Creo 3.0 M060 connected to Windchill PDM Essentials.

I tried the Ctrl + R but it did not resolve the disappearing menu.

Highlighted

Re: context menu bug in Creo 2.0

Same issue here.

Using an older 3D connection space pilot with Creo 3.0  M060.

I agree sometimes when I would repaint the screen the issue would resolve.  But now I am working in a drawing and the repaint does not solve it.  Tried unplugging the space pilot but nothing changes.

PTC  please try to duplicate this on your systems. 

Highlighted

Re: context menu bug in Creo 2.0

Hello everybody,

any news here?

We have the same issue in Creo3 M090/M100 and we use SpaceMousePro too.

Jochen

Highlighted

Re: context menu bug in Creo 2.0

I don't have one, but have you tried new SpaceMouse drivers? Looks like they put up new ones today.

Highlighted

Re: context menu bug in Creo 2.0

We have updated our space mouse driver to the latest version but the problem still exists. After working a while in Creo context menu does not appear anymore.

It seems happening mostly in drawing mode.

Any new ideas? Thanks.

Highlighted

Re: context menu bug in Creo 2.0

Huh ... I have been using the brand new Spacemouse Enterprise for 4 months now with Creo 3.0 problem free. But this week, I now have this problem too.

I shall try the Repaint solution now... I have no idea what STRG R means.

Highlighted

Re: context menu bug in Creo 2.0

STRG R is the german keyboard equivalent to CTRL + R


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)
Highlighted

Re: context menu bug in Creo 2.0

Ah! Thank you.

Highlighted

Re: context menu bug in Creo 2.0

Figures ... this hasn't occurred again since finding this potential solution. Curse you Murphy!

Highlighted

Re: context menu bug in Creo 2.0

Ctrl-R worked for me, but only from the model file, not from the drawing itself. Thanks!

Highlighted
Regular Member
(in response to Mat)

Re: context menu bug in Creo 2.0

I found my way here because I have the same issue with a SpaceExplorer. I found that this was happening in drawing mode with an assembly open in another window. When I close the assembly the problem goes away. Great to find out about the CTRL R, it works!

Thanks

Rick

Announcements