cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

corrupt workspace sending my models back in time

bp
Regular Member

corrupt workspace sending my models back in time

Ive been working on a compicated creo (2) assembly for weeks (in the same workspace, Im forced to work with Windchill) and I was really looking forward to finally finishing this project. This morning I opened my assembly, completely wrecked. Appearantly my local cache got corrupted which caused Creo to forget any changes made to random models in my assembly including (of course) the main skeleton model.

I got very upset and contacted our reseller. They said this is a known problem and is not even solved in Creo 4.

How on earth is this posibble?! This means working with Creo and Windchill is working with a timebomb. I would like to know if anyone else ever had this problem. For me its the second time this happened this year.

5 REPLIES 5

Re: corrupt workspace sending my models back in time

Did your reseller not offer to help you recover (assuming you are on current maintenance)? Just becuase there is a corrupted workspace or corrupted data doesn't necessarily mean that all is lost. There are tools that can be used to attempt to recover data. Sometimes files and data need to be sent to PTC to fix the issues. Most can be recovered.

 

As far as what you can do to prevent or reduce these instances, you need to check in your data regularly. You need to make sure you have automatic upload turned on so your data isn't only on your local cache.

When I think there is a chance of corruption (for whatever reason) i will even back up my files outside of windchill as an extra level of safety.

 

On occasion, you will also need to check in all your work and delete your .wf folder to clean out lingering issues.


Steve Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: corrupt workspace sending my models back in time

I use creo (4.0 M020) standalone.  Occasionally, a single corrupted part, assembly, or drawing file can cause the dump of many hours of work.  I created  and scheduled a custom DOS Batch file that backs up my workspace nightly to two separate locations, so that in the worst case, I only lose 10 hours of work, and I can even step back to work from up to 30 days ago.  It happens less often than in previous releases, but I know from experience that this "timebomb" is going to happen eventually (whether it's creo or the Operating System that is the cause).

 

If PTC can repair corrupt files sent to them, why don't they provide a repair tool (something like using scanpst.exe to repair an Outlook data file).  I can't send native model or drawing files outside of my internal network as a matter of proprietary and intellectual property policies.  I also don't have the time to wait for PTC to return a repaired file.

Re: corrupt workspace sending my models back in time

Typically, if a vendor can repair the damage they will instead change the software to avoid creating the problem in the first place. If they don't know what is wrong they need to have someone look at the data and spend time figuring it out.

 

Outlook is a straight forward file format. I'm sure that they 'repair' the file by recreating the index on the single file of sequential delimited messages which is generally readable with notepad if you like.

 

If one is working stand-alone, is that file system? Each save should generate a new version so one should lose no more than time to the previous save. If it is a Workspace, then you can use Frames to get to the previous saved file versions.

Highlighted

Re: corrupt workspace sending my models back in time

Thats what im looking for, Trough experience i've learned to save Creo files after every relevant change, lets say every second minute (even though every save action takes a relative long time thanks to modelcheck). So how do I access my lokal earlier saved versions in my workspace?

Re: corrupt workspace sending my models back in time

For one, you need to have Frames turned on. This is under Windchill options. Your system admin should be able to help you with that.

 

I forget where in the interface you access frames - there's a Windchill segment of the forum to post a question about Windchill to, so I would recommend chasing it over there. Once you know that you are looking for them they should be easy to find.