cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

protk_wf4.dat configuration error

SOLVED
Newbie

protk_wf4.dat configuration error

Dear PTC users

I prepared a new configuration.pro for new project, i am facing the new error while opening creo/elements pro 5.0.

I have attached some screen shots below, Kindly view it and help me.

1.while startup showing this error

2. How to fix this?config+error.JPGprotkdat.JPG

Actually it says misssing some protk file,

We are using creo/elements pro 5.0 and with inbuild EFX 7.0.

Please give me a solution and define what's the problem.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: protk_wf4.dat configuration error

I am happy it now works.

The config.pro option was one that someone had created or provided in the startup folder when you had WF4 on the system. Somewhere along the timelines of the updates, the location and the toolkit dat file was deleted. By removing the option from config.pro, the toolkit will look at the default toolkit dat information provided by PTC.

Not knowing what was in the original dat file, it is difficult to know what the difference will be. You might want to have a conversation with an administrator to find out what was special about the WF4 installation with regard to ProToolkit.

View solution in original post

6 REPLIES 6

Re: protk_wf4.dat configuration error

if you want to use proe 5 then efx 7 separately to be installed. I have faced the problem, al you need to go to that file, open with text editor and change the path for right file of wf5. For creo 2 it is now advanced assembly extension, u need not to install seprately.

Regards

Jayanta Sarkar

Highlighted

Re: protk_wf4.dat configuration error

Dear jayanta

which file i have to edit?

And i searched the file protk_wf4.dat and protk_wf5.dat is not available

Please tell how to proceed furthuer.

forget to attach this image on discussion starting

startup.JPG

Re: protk_wf4.dat configuration error

Just to be sure; did you install the toolkit during the install screens? I have not loaded WF4 or WF5 but I think the install interface is the same. It is easy to forget to install something.

Otherwise, yes, make sure the file the error complains about exists, and if it is not the right place, correct the path.

What if you remove the option "protkdat" from config.pro?

What has happened to me before is that when I updated the software from one version to the next datecode, all the files in the old version were deleted never to be recovered. The only thing that is saved is the files outside from the install directory.

Re: protk_wf4.dat configuration error

dear Antonius Dirriwachter

As you said i have installed creo/element pro with all option only i am sure about that.

Then i removed the option ''protkdat'' from config.pro, now no error was displayed.

I removed from config.pro, because of that we have to face any problem in design?

But may i know why it's dispalying? Why that file was not available? in that place?

Thanks and regargss

Viswanathan.K

Re: protk_wf4.dat configuration error

I am happy it now works.

The config.pro option was one that someone had created or provided in the startup folder when you had WF4 on the system. Somewhere along the timelines of the updates, the location and the toolkit dat file was deleted. By removing the option from config.pro, the toolkit will look at the default toolkit dat information provided by PTC.

Not knowing what was in the original dat file, it is difficult to know what the difference will be. You might want to have a conversation with an administrator to find out what was special about the WF4 installation with regard to ProToolkit.

View solution in original post

Re: protk_wf4.dat configuration error

Hi Viswanathan...

I think all you really need in your config.pro is:

efx_enabled yes

I haven't had to use the protk line to start up EFX since WF3. So I think Antonius' solution to just remove it was the right one.

Are you having any other startup issues? I got your email and I'm just trying to make sure you're on the right track. There's not much difference between WF3 and WF4 so your config.pro should be okay except for minor issues like the one you mentioned.

Even if you do see some weird error messages, chances are it will not impact you ability to work in Pro/ENGINEER successfully. If you see anything else, please let us know.

Thanks!

-Brian