cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo View 3 doesn't load on a particular computer for a single user

SOLVED
Highlighted
Newbie

Creo View 3 doesn't load on a particular computer for a single user

Hi all,

 

I will be more precise. We have many computers that run Creo Elements 5 M250 and Creo View 3. On a single computer and for a single user it fails to start. If launched as a standalone program from start, programs, etc, it only runs for 1-3 seconds before crashing. It can only be monitored shortly from the task manager, as nothing actually appears. If launched as a plugin of IE or Chrome, I only get a white empty page without anything in it.

 

The weird thing is that on the same computer, if we logged in as different users, the program works fine. At the same time, if the user logs in on another computer the program works as well.

 

Unfortunaltely, I have been autorizhed to rebuild his profile on his machine, which I think could help us, so I would like to know if someone has any idea of what I could do to help the user.

 

I have already unistalled and installed "everything", creo view, creo elements, java, desktop integration, etc. but with no results. The issue is not related to any particular drawing.

 

Thank you very much in advance for your help.

Tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Creo View 3 doesn't load on a particular computer for a single user

Hello Davide,

have you been able to make progress with the issue?

According to this article on the PTC web site, when getting rid of the user configuration and loading a default one, the issue should actually be solved:

CS197408 : Creo View can't open any representation with error reported "productview.exe has stopped working"

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS197408

Gunter

5 REPLIES 5

Re: Creo View 3 doesn't load on a particular computer for a single user

Try going to the appdata folder for the user and look in the ptc subfolder for a user_prefs.xml file. Rename it and then launch CV3 to create a new one. I have seen this preference file get corrupted and cause problems in the past.

Re: Creo View 3 doesn't load on a particular computer for a single user

Thank you very much Bill, this has been a big step forward, as after I renamed the xml file, I have been able to get a proper crash and something logged on the Windows Event Viewer.

I got as application error:

Faulting application name: productview.exe, version: 10.2.20.23, time stamp: 0x536bd7b3

Faulting module name: uitoolspv.dll, version: 0.0.0.0, time stamp: 0x534545bc

Exception code: 0xc0000005

Fault offset: 0x000000000017a55a

Faulting process id: 0x23e4

Faulting application start time: 0x01d03b12f063184f

Faulting application path: C:\Program Files\PTC\Creo 3.0\View\x86e_win64\obj\productview.exe

Faulting module path: C:\Program Files\PTC\Creo 3.0\View\x86e_win64\obj\uitoolspv.dll

and under .NET errors:

Application: productview.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: exception code c0000005, exception address 000007FED5B1A55A

any suggestion?

Re: Creo View 3 doesn't load on a particular computer for a single user

Try to start with TRACE variable, to get more information:

set PVIEW_TRACE="c:\.....\Creoview.log"

or type the variable in the pview.cfg (installation\bin)

ralf

Re: Creo View 3 doesn't load on a particular computer for a single user

Hello Davide,

have you been able to make progress with the issue?

According to this article on the PTC web site, when getting rid of the user configuration and loading a default one, the issue should actually be solved:

CS197408 : Creo View can't open any representation with error reported "productview.exe has stopped working"

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS197408

Gunter

Re: Creo View 3 doesn't load on a particular computer for a single user

Hello Gunter,

sorry about the delay in my reply, but I haven't upgraded my account, and I was not able to see the document. The one you pointed me out is the correct one and the solution worked perfectly.

Thanks to everyone.